ATI radeon 9200 open source drivers - no direct rendering

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

ATI radeon 9200 open source drivers - no direct rendering

bn-5
Hi,

I have an ATI radeon 9200 graphic card. I use the 6.8.2 Xorg (latest x86
stable) with the "radeon" driver. My xorg.conf (here attached) seems OK
to me, it loads dri, glx and has the 0666 permissions set in section
DRI. But I have no direct rendering... I managed to live with it for a
while, but now I'd like to see what's wrong and fix it.

I checked the logs (attached here too) and what concerns me is the
following section:

[...]
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
[drm] failed to load kernel module "radeon"
(II) RADEON(0): [drm] drmOpen failed
(EE) RADEON(0): [dri] DRIScreenInit failed.  Disabling DRI.
[...]

I had a look in /dev and the logs are right...I have no /dev/dri/card0
device (my /dev/dri/ folder is empty). I have the latest udev, kernel
2.6.12-gentoo-r9, but I remember I had no direct rendering before the
devfs-->udev switch too.

I'm quite puzzled. What do I have to do?

Thank you,

Max
--
[hidden email] mailing list

Reply | Threaded
Open this post in threaded view
|

Re: ATI radeon 9200 open source drivers - no direct rendering

Peter Gordon-2
On Sun, 2005-11-06 at 21:35 +0000, b.n. wrote:

> [...]
> drmOpenDevice: node name is /dev/dri/card0
> drmOpenDevice: open result is -1, (No such device)
> drmOpenDevice: open result is -1, (No such device)
> drmOpenDevice: Open failed
> drmOpenDevice: node name is /dev/dri/card0
> drmOpenDevice: open result is -1, (No such device)
> drmOpenDevice: open result is -1, (No such device)
> drmOpenDevice: Open failed
> [drm] failed to load kernel module "radeon"
> (II) RADEON(0): [drm] drmOpen failed
> (EE) RADEON(0): [dri] DRIScreenInit failed.  Disabling DRI.
> [...]
Did you enable the ATi Radeon direct rendering manager and any needed
AGP support in your kernel configuration?

It's under the Device Drivers --> Character Devices option.

Hope that helps.

--Peter

signature.asc (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: ATI radeon 9200 open source drivers - no direct rendering

bn-5
> Did you enable the ATi Radeon direct rendering manager and any needed
> AGP support in your kernel configuration?
>
> It's under the Device Drivers --> Character Devices option.

Hmmm... my .config says so:

CONFIG_AGP=y
# CONFIG_AGP_ALI is not set
# CONFIG_AGP_ATI is not set
# CONFIG_AGP_AMD is not set
# CONFIG_AGP_AMD64 is not set
CONFIG_AGP_INTEL=y
# CONFIG_AGP_NVIDIA is not set
# CONFIG_AGP_SIS is not set
# CONFIG_AGP_SWORKS is not set
# CONFIG_AGP_VIA is not set
# CONFIG_AGP_EFFICEON is not set

I guess CONFIG_AGP_ATI should be set to yes?

m.
--
[hidden email] mailing list

Reply | Threaded
Open this post in threaded view
|

Re: ATI radeon 9200 open source drivers - no direct rendering

Peter Gordon-2
On Sun, 2005-11-06 at 22:25 +0000, b.n. wrote:

> > Did you enable the ATi Radeon direct rendering manager and any needed
> > AGP support in your kernel configuration?
> >
> > It's under the Device Drivers --> Character Devices option.
>
> Hmmm... my .config says so:
>
> CONFIG_AGP=y
> # CONFIG_AGP_ALI is not set
> # CONFIG_AGP_ATI is not set
> # CONFIG_AGP_AMD is not set
> # CONFIG_AGP_AMD64 is not set
> CONFIG_AGP_INTEL=y
> # CONFIG_AGP_NVIDIA is not set
> # CONFIG_AGP_SIS is not set
> # CONFIG_AGP_SWORKS is not set
> # CONFIG_AGP_VIA is not set
> # CONFIG_AGP_EFFICEON is not set
>
> I guess CONFIG_AGP_ATI should be set to yes?
>
> m.
Well, that's for your AGP chipset. Now you need to enable the direct
rendering manager:

CONFIG_DRM=y
CONFIG_DRM_RADEON=y

--Peter

signature.asc (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: ATI radeon 9200 open source drivers - no direct rendering

bn-5

>>I guess CONFIG_AGP_ATI should be set to yes?
>>
>
>
> Well, that's for your AGP chipset. Now you need to enable the direct
> rendering manager:
>
> CONFIG_DRM=y
> CONFIG_DRM_RADEON=y

Ok. Seems I just need a healthy kernel recompile in the next days...
Thank you very much.

M.
--
[hidden email] mailing list