Bug while compiling xorg-server-1.1.1

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug while compiling xorg-server-1.1.1

Bugzilla from brauliobo@gmail.com
Bug report:

While compiling xorg-server-1.1.1 (with emerge) I got the following error:

 sparc-unknown-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I.
-I../../../include -I../../../include -I../../../include
-I../../../include -I../../../include -I../../../include
-I../../../include -I../../../include -I../../../hw/xfree86
-I../../../hw/xfree86/include -I../../../hw/xfree86/common
-I../../../hw/xfree86/os-support -I../../../hw/xfree86/os-support/bus
-I../../../os -I./../ddc -I./../i2c -I./../loader -I./../rac
-I./../parser -I./../scanpci -I./../vbe -I./../int10 -I./../vgahw
-I./../dixmods/extmod -DHAVE_XORG_CONFIG_H -DXF86PM -DXFree86Server
-DXFree86LOADER -Wall -Wpointer-arith -Wstrict-prototypes
-Wmissing-prototypes -Wmissing-declarations -Wnested-externs
-fno-strict-aliasing -D_BSD_SOURCE -DHAS_FCHOWN -DHAS_STICKY_DIR_BIT
-I../../../include -I../../../include -I../../../Xext
-I../../../composite -I../../../damageext -I../../../xfixes
-I../../../Xi -I../../../mi -I../../../miext/shadow
-I../../../miext/damage -I../../../render -I../../../randr
-I../../../fb -O2 -mcpu=ultrasparc3 -mtune=ultrasparc3 -pipe -mvis -MT
xf86KbdLnx.lo -MD -MP -MF .deps/xf86KbdLnx.Tpo -c xf86KbdLnx.c  -fPIC
-DPIC -o .libs/xf86KbdLnx.o
In file included from /usr/include/asm/bitops.h:4,
                 from /usr/include/linux/bitops.h:77,
                 from /usr/include/linux/thread_info.h:20,
                 from /usr/include/asm-sparc/system.h:10,
                 from /usr/include/asm/system.h:4,
                 from /usr/include/linux/list.h:6,
                 from /usr/include/linux/wait.h:21,
                 from /usr/include/linux/keyboard.h:20,
                 from xf86KbdLnx.c:169:
/usr/include/asm-sparc/bitops.h:288: error: static declaration of
'ffs' follows non-static declaration

I corrected the bug by removing the static declaration on the bitops.h
file. I guess that the problem is with the ebuild
linux-headers-2.6.11-r6 (which I'm using)

That it. Any questions, just ask.

Thanks
bráulio

--
[hidden email] mailing list

Reply | Threaded
Open this post in threaded view
|

Re: Bug while compiling xorg-server-1.1.1

Bugzilla from brauliobo@gmail.com
actually the bugfix is change is change /usr/include/asm/bitopt.h

from:
/* Autogenerated by create_ml_includes() in multilib.eclass */

#ifndef __arch64__
# include <asm-sparc/bitops.h>
#endif /* !__arch64__ */

#ifdef __arch64__
# include <asm-sparc64/bitops.h>
#endif /* __arch64__ */

to:
* Autogenerated by create_ml_includes() in multilib.eclass */

#ifndef __arch64__
# include <asm-sparc64/bitops.h>
#endif /* !__arch64__ */

#ifndef __arch64__
# include <asm-sparc64/bitops.h>
#endif /* __arch64__ */

Note: I'm using gcc 4.1.1

On 8/31/06, Bráulio Oliveira <[hidden email]> wrote:

> Bug report:
>
> While compiling xorg-server-1.1.1 (with emerge) I got the following error:
>
>  sparc-unknown-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I.
> -I../../../include -I../../../include -I../../../include
> -I../../../include -I../../../include -I../../../include
> -I../../../include -I../../../include -I../../../hw/xfree86
> -I../../../hw/xfree86/include -I../../../hw/xfree86/common
> -I../../../hw/xfree86/os-support -I../../../hw/xfree86/os-support/bus
> -I../../../os -I./../ddc -I./../i2c -I./../loader -I./../rac
> -I./../parser -I./../scanpci -I./../vbe -I./../int10 -I./../vgahw
> -I./../dixmods/extmod -DHAVE_XORG_CONFIG_H -DXF86PM -DXFree86Server
> -DXFree86LOADER -Wall -Wpointer-arith -Wstrict-prototypes
> -Wmissing-prototypes -Wmissing-declarations -Wnested-externs
> -fno-strict-aliasing -D_BSD_SOURCE -DHAS_FCHOWN -DHAS_STICKY_DIR_BIT
> -I../../../include -I../../../include -I../../../Xext
> -I../../../composite -I../../../damageext -I../../../xfixes
> -I../../../Xi -I../../../mi -I../../../miext/shadow
> -I../../../miext/damage -I../../../render -I../../../randr
> -I../../../fb -O2 -mcpu=ultrasparc3 -mtune=ultrasparc3 -pipe -mvis -MT
> xf86KbdLnx.lo -MD -MP -MF .deps/xf86KbdLnx.Tpo -c xf86KbdLnx.c  -fPIC
> -DPIC -o .libs/xf86KbdLnx.o
> In file included from /usr/include/asm/bitops.h:4,
>                  from /usr/include/linux/bitops.h:77,
>                  from /usr/include/linux/thread_info.h:20,
>                  from /usr/include/asm-sparc/system.h:10,
>                  from /usr/include/asm/system.h:4,
>                  from /usr/include/linux/list.h:6,
>                  from /usr/include/linux/wait.h:21,
>                  from /usr/include/linux/keyboard.h:20,
>                  from xf86KbdLnx.c:169:
> /usr/include/asm-sparc/bitops.h:288: error: static declaration of
> 'ffs' follows non-static declaration
>
> I corrected the bug by removing the static declaration on the bitops.h
> file. I guess that the problem is with the ebuild
> linux-headers-2.6.11-r6 (which I'm using)
>
> That it. Any questions, just ask.
>
> Thanks
> bráulio
>

--
[hidden email] mailing list