Compiling ronn: Missing an already installed item

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Compiling ronn: Missing an already installed item

tuxic
Hi,

While trying to install app-text/ronn, I got this interesting
problem:

ronn misses hpricot, which was installed in beforehand.
(The '=====================' are added by me)

Does anyone else installed ronn successfully ?
How can I acchieve this?

Thanks a lot for any help in advance!
Cheers
Meino



>eix  hpricot
[I] dev-ruby/hpricot
     Available versions:  0.8.6-r5 {doc test ELIBC="FreeBSD" RUBY_TARGETS="ruby22 ruby23 ruby24"}
     Installed versions:  0.8.6-r5(06:16:04 AM 10/01/2017)(-doc -test ELIBC="-FreeBSD" RUBY_TARGETS="ruby22 -ruby23 -ruby24")
     Homepage:            https://wiki.github.com/hpricot/hpricot
     Description:         A fast and liberal HTML parser for Ruby
==========================================================================================

>emerge ronn                
Calculating dependencies... done!
>>> Verifying ebuild manifests
>>> Emerging (1 of 1) app-text/ronn-0.7.3-r3::gentoo
>>> Failed to emerge app-text/ronn-0.7.3-r3, Log file:
>>>  '/var/tmp/portage/app-text/ronn-0.7.3-r3/temp/build.log'
>>> Jobs: 0 of 1 complete, 1 failed                 Load avg: 1.84, 1.47, 1.27
 * Package:    app-text/ronn-0.7.3-r3
 * Repository: gentoo
 * Maintainer: [hidden email]
 * USE:        abi_x86_64 amd64 elibc_glibc kernel_linux ruby_targets_ruby22 userland_GNU
 * FEATURES:   preserve-libs sandbox userpriv usersandbox
>>> cfg-update-1.8.2-r1: Creating checksum index...
>>> Unpacking source...
 * Running unpack phase for all ...
 * Unpacking .gem file... ...
 [ ok ]
 * Uncompressing metadata ...
 [ ok ]
 * Unpacking data.tar.gz ...
 [ ok ]
>>> Source unpacked in /var/tmp/portage/app-text/ronn-0.7.3-r3/work
>>> Preparing source in /var/tmp/portage/app-text/ronn-0.7.3-r3/work ...
 * Running prepare phase for all ...
 * Running source copy phase for ruby22 ...
 * Running prepare phase for ruby22 ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/app-text/ronn-0.7.3-r3/work ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/app-text/ronn-0.7.3-r3/work ...
 * Running compile phase for all ...
fatal: the 'hpricot' library is required (gem install hpricot)
===============================================================
 * ERROR: app-text/ronn-0.7.3-r3::gentoo failed (compile phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line  124:  Called src_compile
 *   environment, line 4446:  Called ruby-ng_src_compile
 *   environment, line 4140:  Called _ruby_invoke_environment 'all' 'all_ruby_compile'
 *   environment, line  618:  Called all_ruby_compile
 *   environment, line  701:  Called die
 * The specific snippet of code:
 *       PATH="${S}/bin:${PATH}" rake man || die
 *
 * If you need support, post the output of `emerge --info '=app-text/ronn-0.7.3-r3::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=app-text/ronn-0.7.3-r3::gentoo'`.
!!! When you file a bug report, please include the following information:
GENTOO_VM=  CLASSPATH="" JAVA_HOME=""
JAVACFLAGS="" COMPILER=""
and of course, the output of emerge --info =ronn-0.7.3
 * The complete build log is located at '/var/tmp/portage/app-text/ronn-0.7.3-r3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-text/ronn-0.7.3-r3/temp/environment'.
 * Working directory: '/var/tmp/portage/app-text/ronn-0.7.3-r3/work/all/ronn-0.7.3'
 * S: '/var/tmp/portage/app-text/ronn-0.7.3-r3/work/all/ronn-0.7.3'
[1]    18461 exit 1     emerge ronn





Reply | Threaded
Open this post in threaded view
|

Re: Compiling ronn: Missing an already installed item

Hans de Graaff-2
On Sun, 01 Oct 2017 06:25:27 +0200, tuxic wrote:

>>>> Compiling source in /var/tmp/portage/app-text/ronn-0.7.3-r3/work ...
>  * Running compile phase for all ...
> fatal: the 'hpricot' library is required (gem install hpricot)

The compile phase for all uses the currently eselected ruby. Perhaps you
have a mismatch between your RUBY_TARGETS and the eselected version?

Hans


Reply | Threaded
Open this post in threaded view
|

Re: Compiling ronn: Missing an already installed item

tuxic
On 10/01 06:11, Hans de Graaff wrote:

> On Sun, 01 Oct 2017 06:25:27 +0200, tuxic wrote:
>
> >>>> Compiling source in /var/tmp/portage/app-text/ronn-0.7.3-r3/work ...
> >  * Running compile phase for all ...
> > fatal: the 'hpricot' library is required (gem install hpricot)
>
> The compile phase for all uses the currently eselected ruby. Perhaps you
> have a mismatch between your RUBY_TARGETS and the eselected version?
>
> Hans
>
>

Hi Hans,

thanks for the hint! That fixed it!
Cheers
Meino