Contradictionary reports from eix/emerge

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Contradictionary reports from eix/emerge

tuxic
Hi,

after updateing I have run (beside others) this command:

    eclean-dist -C -d -v

and got:


   The following unavailable installed packages were found
             sys-devel/autoconf-2.13


Running

    eix sys-devel/autoconf

and got

[U] sys-devel/autoconf
     Available versions:  
     (2.1)  2.13-r1
     (2.64) 2.64-r1
     (2.69) 2.69-r4
     (9999) **9999
       {emacs USERLAND="BSD"}
     Installed versions:  2.13(2.1)(01:46:26 PM 09/15/2018)(USERLAND="-BSD") 2.69-r4(2.69)(09:29:15 PM 01/02/2019)(-emacs)
     Homepage:            https://www.gnu.org/software/autoconf/autoconf.html
     Description:         Used to create autoconfiguration files

which is in sync wth the abouve.

But when I do

    emerge --selective=n -va sys-devel/autoconf

I get

    These are the packages that would be merged, in order:

    Calculating dependencies... done!
    [ebuild   R    ] sys-devel/autoconf-2.69-r4:2.69::gentoo  USE="-emacs" 0 KiB

    Total: 1 package (1 reinstall), Size of downloads: 0 KiB


Why will autoconf be RE-installed. This version isn't installed at
all. Why do I get '[ebuild   R    ]' instead of an update?
How often do I need to reinstall autoconf until it will not be
reported back as being old and no longer in the database.
(I checked it...it is not masked.)? ;)

Thank you very much in advance for any help!

Cheers!
Meino



Reply | Threaded
Open this post in threaded view
|

Re: Contradictionary reports from eix/emerge

Nikos Chantziaras-2
On 03/01/2019 07:37, [hidden email] wrote:

> Hi,
>
> after updateing I have run (beside others) this command:
>
>      eclean-dist -C -d -v
>
> and got:
>
>     The following unavailable installed packages were found
>               sys-devel/autoconf-2.13
>
> Running
>
>      eix sys-devel/autoconf
>
> and got
>
> [U] sys-devel/autoconf
>       Available versions:
>       (2.1)  2.13-r1

Portage is telling the truth. You have 2.13 installed, which doesn't
exist anymore. Note the "-r1" in "2.13-r1".


> Installed versions:  2.13(2.1)(01:46:26 PM 09/15/2018)(USERLAND="-BSD") 2.69-r4(2.69)(09:29:15 PM 01/02/2019)(-emacs)

So you have 2.13 and 2.69-r4 installed. It seems you missed the
"2.69-r4" in the above line?


Reply | Threaded
Open this post in threaded view
|

Re: Contradictionary reports from eix/emerge

tuxic
On 01/03 08:15, Nikos Chantziaras wrote:

> On 03/01/2019 07:37, [hidden email] wrote:
> > Hi,
> >
> > after updateing I have run (beside others) this command:
> >
> >      eclean-dist -C -d -v
> >
> > and got:
> >
> >     The following unavailable installed packages were found
> >               sys-devel/autoconf-2.13
> >
> > Running
> >
> >      eix sys-devel/autoconf
> >
> > and got
> >
> > [U] sys-devel/autoconf
> >       Available versions:
> >       (2.1)  2.13-r1
>
> Portage is telling the truth. You have 2.13 installed, which doesn't exist
> anymore. Note the "-r1" in "2.13-r1".
>
>
> > Installed versions:  2.13(2.1)(01:46:26 PM 09/15/2018)(USERLAND="-BSD") 2.69-r4(2.69)(09:29:15 PM 01/02/2019)(-emacs)
>
> So you have 2.13 and 2.69-r4 installed. It seems you missed the "2.69-r4" in
> the above line?
>
>

oh! yes, I missed it...sorry.

Thanks ! :)

Cheers
Meino