HD externo NTFS e Charset

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

HD externo NTFS e Charset

Raphael MD
Faz algum tempo que uso um hd externo formatado em NTFS.

Percebi no entanto, que um problema entre o charset do NTFS ISO e o UTF-8 do linux faz com que alguns arquivos não sejem gravados no HD externo.

Lembro que a certo tempo este tema foi discutido:


http://gentoo.2317880.n4.nabble.com/Problema-de-charset-ao-montar-particao-automaticamente-td220416.html

Tentei o camihno de criar uma regra pro udev, não da erro algum, mas não resolve o problema.

Percebi que na internet muito se fala sobre a regra do udev mas nenhuma surtiu efeito no meu caso.

Percebi que há o problema de identificar o dispositivo, criei a regra só pro meu hd então para facilitar e nada.


Vou de fstab?

Alguém já implementou algo que funcione?

Obrigado.


Reply | Threaded
Open this post in threaded view
|

Re: HD externo NTFS e Charset

João Matos-2
Raphael,

Enfrentei esse problema em duas (de duas) instalações do Gentoo. Ele se corrigiu automaticamente em ambas, e eu não faço ideia do que quer que tenha mudado para a escrita de caracteres especiais em NTFS/FAT passasse a funcionar.

Uma solução paliativa que me ajudava a quebrar o galho enquanto o problema persistia era montar o dispositivo USB na mão, como root. Abria o gerenciador de arquivos como root e copiava os arquivos normalmente. Talvez isso funcione pra você.

Att,


Em 6 de novembro de 2013 22:09, Raphael MD <[hidden email]> escreveu:
Faz algum tempo que uso um hd externo formatado em NTFS.

Percebi no entanto, que um problema entre o charset do NTFS ISO e o UTF-8 do linux faz com que alguns arquivos não sejem gravados no HD externo.

Lembro que a certo tempo este tema foi discutido:


http://gentoo.2317880.n4.nabble.com/Problema-de-charset-ao-montar-particao-automaticamente-td220416.html

Tentei o camihno de criar uma regra pro udev, não da erro algum, mas não resolve o problema.

Percebi que na internet muito se fala sobre a regra do udev mas nenhuma surtiu efeito no meu caso.

Percebi que há o problema de identificar o dispositivo, criei a regra só pro meu hd então para facilitar e nada.


Vou de fstab?

Alguém já implementou algo que funcione?

Obrigado.





--