I am trying to install app-editors/atom...and portage talks to me in tongues...or so...

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

I am trying to install app-editors/atom...and portage talks to me in tongues...or so...

tuxic
Hi,

Its decoding time ... again... :)

Happy new year !

I am trying to install the editor 'atom'...and got this instead from
portage/emerge (I am on unstable...):

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/openssl:0

  (dev-libs/openssl-1.0.2u:0/0::gentoo, ebuild scheduled for merge) USE="asm sslv3 tls-heartbeat zlib -bindist -gmp -kerberos -rfc3779 -sctp -sslv2 -static-libs -test -vanilla" CPU_FLAGS_X86="(sse2)" pulled in by
    <dev-libs/openssl-1.1:= required by (dev-util/electron-2.0.17-r2:2.0/2.0::gentoo, ebuild scheduled for merge) USE="proprietary-codecs system-ffmpeg system-libvpx system-ssl tcmalloc -cups -custom-cflags -gconf -gnome-keyring -kerberos -lto (-neon) -pic -pulseaudio (-selinux) -test" L10N="am ar bg bn ca cs da de el en-GB es es-419 et fa fi fil fr gu he hi hr hu id it ja kn ko lt lv ml mr ms nb nl pl pt-BR pt-PT ro ru sk sl sr sv sw ta te th tr uk vi zh-CN zh-TW"
    ^                                 ^^^ ^                                                                                                                                                                                                                                                                                                                                                                                                                                                          

  (dev-libs/openssl-1.1.1d-r3:0/1.1::gentoo, installed) USE="asm zlib -bindist -rfc3779 -sctp -sslv3 -static-libs -test -tls-heartbeat -vanilla" CPU_FLAGS_X86="(sse2)" pulled in by
    >=dev-libs/openssl-1.1.1:0= required by (net-libs/nodejs-13.5.0:0/0::gentoo, ebuild scheduled for merge) USE="npm snapshot ssl -debug -doc -icu -inspector -pax_kernel -systemtap -test" CPU_FLAGS_X86="sse2"
    ^^                 ^^^^^^^^                                                                                                                                                                                  
    dev-libs/openssl:0/1.1= required by (app-admin/rsyslog-8.1911.0-r1:0/0::gentoo, installed) USE="gcrypt openssl ssl uuid -clickhouse -curl -dbi -debug -doc -elasticsearch -gnutls -jemalloc -kafka -kerberos -kubernetes -libressl -mdblookup -mongodb -mysql -normalize -omhttp -omhttpfs -omudpspoof -postgres -rabbitmq -redis -relp -rfc3195 -rfc5424hmac -snmp -systemd -test -usertools -xxhash -zeromq"
                    ^^^^^^^

As far as my knowledge of portagese goes it means: Man, decide what
you want: This software or that software...you cannot get both.

So I have to decide, whether I want atpm or nodejs...

These little funny '^', which are positioned below that lines, are
offsetted in dependance to the width of my terminal, which render them
pretty useless as it seems to me.

Is there any way to get atom installed?
Any hope?

;) :)

Cheers!
Meino



Reply | Threaded
Open this post in threaded view
|

Re: I am trying to install app-editors/atom...and portage talks to me in tongues...or so...

Franz Fellner


Am So., 5. Jan. 2020 um 19:11 Uhr schrieb <[hidden email]>:

As far as my knowledge of portagese goes it means: Man, decide what
you want: This software or that software...you cannot get both.

So I have to decide, whether I want atpm or nodejs...

Portagese is funny, but sometimes Ebuildian is more usefull.
Get the basics and dive into the tree of tears.
Look at the opposing crumbs of knowledge and - find a third solution!

Have fun
Franz
Reply | Threaded
Open this post in threaded view
|

Re: I am trying to install app-editors/atom...and portage talks to me in tongues...or so...

tuxic
On 01/05 07:22, Franz Fellner wrote:

> Am So., 5. Jan. 2020 um 19:11 Uhr schrieb <[hidden email]>:
>
> >
> > As far as my knowledge of portagese goes it means: Man, decide what
> > you want: This software or that software...you cannot get both.
> >
> > So I have to decide, whether I want atpm or nodejs...
> >
>
> Portagese is funny, but sometimes Ebuildian is more usefull.
> Get the basics and dive into the tree of tears.
> Look at the opposing crumbs of knowledge and - find a third solution!
>
> Have fun
> Franz

Ok, I skip atom.

Cheers
Meino



Reply | Threaded
Open this post in threaded view
|

Re: I am trying to install app-editors/atom...and portage talks to me in tongues...or so...

Franz Fellner


Am So., 5. Jan. 2020 um 19:52 Uhr schrieb <[hidden email]>:
On 01/05 07:22, Franz Fellner wrote:
> Am So., 5. Jan. 2020 um 19:11 Uhr schrieb <[hidden email]>:
>
> >
> > As far as my knowledge of portagese goes it means: Man, decide what
> > you want: This software or that software...you cannot get both.
> >
> > So I have to decide, whether I want atpm or nodejs...
> >
>
> Portagese is funny, but sometimes Ebuildian is more usefull.
> Get the basics and dive into the tree of tears.
> Look at the opposing crumbs of knowledge and - find a third solution!
>
> Have fun
> Franz

Ok, I skip atom.

Huh?!? That's not the solution I envisioned.
Just look at the ebuilds, especially the electron. Search for openssl. Adjust. Profit.
 

Cheers
Meino



Reply | Threaded
Open this post in threaded view
|

Re: I am trying to install app-editors/atom...and portage talks to me in tongues...or so...

Neil Bothwick
In reply to this post by tuxic
On Sun, 5 Jan 2020 18:10:54 +0100, [hidden email] wrote:

> I am trying to install the editor 'atom'...and got this instead from
> portage/emerge (I am on unstable...):
>
> !!! Multiple package instances within a single package slot have been
> pulled !!! into the dependency graph, resulting in a slot conflict:
>
> dev-libs/openssl:0
>
>   (dev-libs/openssl-1.0.2u:0/0::gentoo, ebuild scheduled for merge)
> USE="asm sslv3 tls-heartbeat zlib -bindist -gmp -kerberos -rfc3779
> -sctp -sslv2 -static-libs -test -vanilla" CPU_FLAGS_X86="(sse2)" pulled
> in by <dev-libs/openssl-1.1:= required by
> (dev-util/electron-2.0.17-r2:2.0/2.0::gentoo, ebuild scheduled for
> merge) USE="proprietary-codecs system-ffmpeg system-libvpx system-ssl
> tcmalloc -cups -custom-cflags -gconf -gnome-keyring -kerberos -lto
> (-neon) -pic -pulseaudio (-selinux) -test" L10N="am ar bg bn ca cs da
> de el en-GB es es-419 et fa fi fil fr gu he hi hr hu id it ja kn ko lt
> lv ml mr ms nb nl pl pt-BR pt-PT ro ru sk sl sr sv sw ta te th tr uk vi
> zh-CN zh-TW" ^                                 ^^^ ^
>                                                                
Try emerging electron with USE="-system-ssl"


--
Neil Bothwick

Grow your own dope, plant a politician!

attachment0 (849 bytes) Download Attachment