Installing i2p

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Installing i2p

Pavel Volkov
I'm trying to install net-p2p/i2p from powerman overlay.

It's said on the i2p website that i2p supports IcedTea7:
http://www.i2p2.de/download

But net-p2p/i2p::powerman depends on dev-java/jrobin which is restricted to
Java 1.6:
https://bugs.gentoo.org/show_bug.cgi?id=402485

The result is that "emerge i2p" pulls both icedtea-bin 1.7 and 1.6 and I have
to mask 1.7.

How do other distros manage to use i2p with Java 1.7 then?