LAMP - Apache no arranca al inciar

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

LAMP - Apache no arranca al inciar

Carlos Sura
Hola, 

Recientemente instalaba LAMP en mi maquina, y después de instalar Apache, me dijo que había fallado al iniciar, no le tome caso, y lo añadí a los servicios de arranque, y note que cada vez que reiniciaba el ordenador, tomaba varios seguros más en terminar de iniciar, debido a que intentaba arrancar Apache, pero este fallaba.

No tengo ni la menor idea de porque este falla al quererlo arrancar desde el inicio, pero cuando entro y lo inicio desde la consola como usuario ROOT, me lo inicia, demora un poco, pero lo inicia.

A continuación les dejo unos enlaces, donde pueden encontrar la información de mi ordenador y de los registros que me genera apache:

/var/log/apache2/error_log  http://tinypaste.com/e3fff

 tail /var/log/apache2/startuperror.log
Syntax OK
Syntax OK
Syntax OK


----
Y bueno, supongo que eso es lo necesario, ya luego de eso, no le veo nada así como que me indique donde puede residir el error.

¿Alguna idea?

Éxitos,
--
Carlos Sura.-

Reply | Threaded
Open this post in threaded view
|

Re: LAMP - Apache no arranca al inciar

Canek Peláez Valdés
2011/9/1 Carlos Sura <[hidden email]>:

> Hola,
> Recientemente instalaba LAMP en mi maquina, y después de instalar Apache, me
> dijo que había fallado al iniciar, no le tome caso, y lo añadí a los
> servicios de arranque, y note que cada vez que reiniciaba el ordenador,
> tomaba varios seguros más en terminar de iniciar, debido a que intentaba
> arrancar Apache, pero este fallaba.
> No tengo ni la menor idea de porque este falla al quererlo arrancar desde el
> inicio, pero cuando entro y lo inicio desde la consola como usuario ROOT, me
> lo inicia, demora un poco, pero lo inicia.
> A continuación les dejo unos enlaces, donde pueden encontrar la información
> de mi ordenador y de los registros que me genera apache:
> emerge --info: http://tinypaste.com/3ed6bd
> /var/log/apache2/error_log  http://tinypaste.com/e3fff
>  tail /var/log/apache2/startuperror.log
> Syntax OK
> Syntax OK
> Syntax OK
>
> ----
> Y bueno, supongo que eso es lo necesario, ya luego de eso, no le veo nada
> así como que me indique donde puede residir el error.
> ¿Alguna idea?
> Éxitos,

¿Estás instalando Apache en una máquina de escritorio o laptop? El
único error en los logs es que el DNS no puede resolver el nombre
gentoo-b0x; eso podría explicar el retraso del servidor (se atora
esperando que se resuelva dicho nombre).

Trata de agregar

127.0.0.1 localhost gentoo-b0x

en /etc/hosts, a ver si de algo ayuda.

Saludos.
--
Canek Peláez Valdés
Posgrado en Ciencia e Ingeniería de la Computación
Universidad Nacional Autónoma de México

Reply | Threaded
Open this post in threaded view
|

Re: LAMP - Apache no arranca al inciar

Carlos Sura


2011/9/1 Canek Peláez Valdés <[hidden email]>
2011/9/1 Carlos Sura <[hidden email]>:
> Hola,
> Recientemente instalaba LAMP en mi maquina, y después de instalar Apache, me
> dijo que había fallado al iniciar, no le tome caso, y lo añadí a los
> servicios de arranque, y note que cada vez que reiniciaba el ordenador,
> tomaba varios seguros más en terminar de iniciar, debido a que intentaba
> arrancar Apache, pero este fallaba.
> No tengo ni la menor idea de porque este falla al quererlo arrancar desde el
> inicio, pero cuando entro y lo inicio desde la consola como usuario ROOT, me
> lo inicia, demora un poco, pero lo inicia.
> A continuación les dejo unos enlaces, donde pueden encontrar la información
> de mi ordenador y de los registros que me genera apache:
> emerge --info: http://tinypaste.com/3ed6bd
> /var/log/apache2/error_log  http://tinypaste.com/e3fff
>  tail /var/log/apache2/startuperror.log
> Syntax OK
> Syntax OK
> Syntax OK
>
> ----
> Y bueno, supongo que eso es lo necesario, ya luego de eso, no le veo nada
> así como que me indique donde puede residir el error.
> ¿Alguna idea?
> Éxitos,

¿Estás instalando Apache en una máquina de escritorio o laptop? El
único error en los logs es que el DNS no puede resolver el nombre
gentoo-b0x; eso podría explicar el retraso del servidor (se atora
esperando que se resuelva dicho nombre).

Trata de agregar

127.0.0.1       localhost gentoo-b0x

en /etc/hosts, a ver si de algo ayuda.

Saludos.
--
Canek Peláez Valdés
Posgrado en Ciencia e Ingeniería de la Computación
Universidad Nacional Autónoma de México


Excelente pregunta la que me has hecho, pensé que eso podría tener algo que ver, pero no lo tomaba en cuenta, lo estoy instalando en una LAPTOP ¿tiene algo que ver? ¿que cosa?

Voy a probar con la linea en /etc/hosts 

A ver si eso me funciona.

Agradezco tu respuesta.


--
Carlos Sura.-

Reply | Threaded
Open this post in threaded view
|

Re: LAMP - Apache no arranca al inciar

Santiago López Denazis
On 09/01/2011 05:48 PM, Carlos Sura wrote:

> 2011/9/1 Canek Peláez Valdés<[hidden email]>
>
>> 2011/9/1 Carlos Sura<[hidden email]>:
>>> Hola,
>>> Recientemente instalaba LAMP en mi maquina, y después de instalar Apache,
>> me
>>> dijo que había fallado al iniciar, no le tome caso, y lo añadí a los
>>> servicios de arranque, y note que cada vez que reiniciaba el ordenador,
>>> tomaba varios seguros más en terminar de iniciar, debido a que intentaba
>>> arrancar Apache, pero este fallaba.
>>> No tengo ni la menor idea de porque este falla al quererlo arrancar desde
>> el
>>> inicio, pero cuando entro y lo inicio desde la consola como usuario ROOT,
>> me
>>> lo inicia, demora un poco, pero lo inicia.
>>> A continuación les dejo unos enlaces, donde pueden encontrar la
>> información
>>> de mi ordenador y de los registros que me genera apache:
>>> emerge --info: http://tinypaste.com/3ed6bd
>>> /var/log/apache2/error_log  http://tinypaste.com/e3fff
>>>   tail /var/log/apache2/startuperror.log
>>> Syntax OK
>>> Syntax OK
>>> Syntax OK
>>>
>>> ----
>>> Y bueno, supongo que eso es lo necesario, ya luego de eso, no le veo nada
>>> así como que me indique donde puede residir el error.
>>> ¿Alguna idea?
>>> Éxitos,
>>
>> ¿Estás instalando Apache en una máquina de escritorio o laptop? El
>> único error en los logs es que el DNS no puede resolver el nombre
>> gentoo-b0x; eso podría explicar el retraso del servidor (se atora
>> esperando que se resuelva dicho nombre).
>>
>> Trata de agregar
>>
>> 127.0.0.1       localhost gentoo-b0x
>>
>> en /etc/hosts, a ver si de algo ayuda.
>>
>> Saludos.
>> --
>> Canek Peláez Valdés
>> Posgrado en Ciencia e Ingeniería de la Computación
>> Universidad Nacional Autónoma de México
>>
>>
> Excelente pregunta la que me has hecho, pensé que eso podría tener algo que
> ver, pero no lo tomaba en cuenta, lo estoy instalando en una LAPTOP ¿tiene
> algo que ver? ¿que cosa?
>
> Voy a probar con la linea en /etc/hosts
>
> A ver si eso me funciona.
>
> Agradezco tu respuesta.
>
>
   Yo lo tengo instalado en una laptop (con el profile desktop/gnome) y
cero problemas. Iba a sugerirte lo mismo que Canek, así que prueba y nos
cuentas.
   Saludos.

--
Santiago López Denazis
Open your source, open your mind.

Reply | Threaded
Open this post in threaded view
|

Re: LAMP - Apache no arranca al inciar

Canek Peláez Valdés
In reply to this post by Carlos Sura
2011/9/1 Carlos Sura <[hidden email]>:

>
>
> 2011/9/1 Canek Peláez Valdés <[hidden email]>
>>
>> 2011/9/1 Carlos Sura <[hidden email]>:
>> > Hola,
>> > Recientemente instalaba LAMP en mi maquina, y después de instalar
>> > Apache, me
>> > dijo que había fallado al iniciar, no le tome caso, y lo añadí a los
>> > servicios de arranque, y note que cada vez que reiniciaba el ordenador,
>> > tomaba varios seguros más en terminar de iniciar, debido a que intentaba
>> > arrancar Apache, pero este fallaba.
>> > No tengo ni la menor idea de porque este falla al quererlo arrancar
>> > desde el
>> > inicio, pero cuando entro y lo inicio desde la consola como usuario
>> > ROOT, me
>> > lo inicia, demora un poco, pero lo inicia.
>> > A continuación les dejo unos enlaces, donde pueden encontrar la
>> > información
>> > de mi ordenador y de los registros que me genera apache:
>> > emerge --info: http://tinypaste.com/3ed6bd
>> > /var/log/apache2/error_log  http://tinypaste.com/e3fff
>> >  tail /var/log/apache2/startuperror.log
>> > Syntax OK
>> > Syntax OK
>> > Syntax OK
>> >
>> > ----
>> > Y bueno, supongo que eso es lo necesario, ya luego de eso, no le veo
>> > nada
>> > así como que me indique donde puede residir el error.
>> > ¿Alguna idea?
>> > Éxitos,
>>
>> ¿Estás instalando Apache en una máquina de escritorio o laptop? El
>> único error en los logs es que el DNS no puede resolver el nombre
>> gentoo-b0x; eso podría explicar el retraso del servidor (se atora
>> esperando que se resuelva dicho nombre).
>>
>> Trata de agregar
>>
>> 127.0.0.1       localhost gentoo-b0x
>>
>> en /etc/hosts, a ver si de algo ayuda.
>>
>> Saludos.
>> --
>> Canek Peláez Valdés
>> Posgrado en Ciencia e Ingeniería de la Computación
>> Universidad Nacional Autónoma de México
>>
>
> Excelente pregunta la que me has hecho, pensé que eso podría tener algo que
> ver, pero no lo tomaba en cuenta, lo estoy instalando en una LAPTOP ¿tiene
> algo que ver? ¿que cosa?

Nada en particular, debería funcionar, como le funciona a Santiango,
pero generalmente cuando se instala en un escritorio (o laptop) no
ponemos mucha atención al nombre (hostname) de la máquina.

> Voy a probar con la linea en /etc/hosts
> A ver si eso me funciona.

Suerte.
--
Canek Peláez Valdés
Posgrado en Ciencia e Ingeniería de la Computación
Universidad Nacional Autónoma de México

Reply | Threaded
Open this post in threaded view
|

Re: LAMP - Apache no arranca al inciar

Carlos Sura
In reply to this post by Santiago López Denazis


2011/9/1 López Denazis Santiago <[hidden email]>
On 09/01/2011 05:48 PM, Carlos Sura wrote:
2011/9/1 Canek Peláez Valdés<[hidden email]>

2011/9/1 Carlos Sura<[hidden email]>:
Hola,
Recientemente instalaba LAMP en mi maquina, y después de instalar Apache,
me
dijo que había fallado al iniciar, no le tome caso, y lo añadí a los
servicios de arranque, y note que cada vez que reiniciaba el ordenador,
tomaba varios seguros más en terminar de iniciar, debido a que intentaba
arrancar Apache, pero este fallaba.
No tengo ni la menor idea de porque este falla al quererlo arrancar desde
el
inicio, pero cuando entro y lo inicio desde la consola como usuario ROOT,
me
lo inicia, demora un poco, pero lo inicia.
A continuación les dejo unos enlaces, donde pueden encontrar la
información
de mi ordenador y de los registros que me genera apache:
emerge --info: http://tinypaste.com/3ed6bd
/var/log/apache2/error_log  http://tinypaste.com/e3fff
 tail /var/log/apache2/startuperror.log
Syntax OK
Syntax OK
Syntax OK

----
Y bueno, supongo que eso es lo necesario, ya luego de eso, no le veo nada
así como que me indique donde puede residir el error.
¿Alguna idea?
Éxitos,

¿Estás instalando Apache en una máquina de escritorio o laptop? El
único error en los logs es que el DNS no puede resolver el nombre
gentoo-b0x; eso podría explicar el retraso del servidor (se atora
esperando que se resuelva dicho nombre).

Trata de agregar

127.0.0.1       localhost gentoo-b0x

en /etc/hosts, a ver si de algo ayuda.

Saludos.
--
Canek Peláez Valdés
Posgrado en Ciencia e Ingeniería de la Computación
Universidad Nacional Autónoma de México


Excelente pregunta la que me has hecho, pensé que eso podría tener algo que
ver, pero no lo tomaba en cuenta, lo estoy instalando en una LAPTOP ¿tiene
algo que ver? ¿que cosa?

Voy a probar con la linea en /etc/hosts

A ver si eso me funciona.

Agradezco tu respuesta.


 Yo lo tengo instalado en una laptop (con el profile desktop/gnome) y cero problemas. Iba a sugerirte lo mismo que Canek, así que prueba y nos cuentas.
 Saludos.

--
Santiago López Denazis
Open your source, open your mind.

Efectivamente Canek Peláez, estabas en lo correcto, no me había percatado de la linea, y ahora ya inicia y no marca ningún error.

Agradezco la ayuda y la respuesta de los dos.

Descuido de mi parte,

Éxitos,

--
Carlos Sura.-