Lost "middle click opens links" in KDE/Firefox combo - anyone else?

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Lost "middle click opens links" in KDE/Firefox combo - anyone else?

Andrew Lowe-2
Hi all,
        Yesterday afternoon, and for the last ??? years, I could be using
Firefox, within KDE and with a Logitech M560[1] mouse, middle click on a
link and a new tab would open containing the link.

        I did an "emerge world", which included some KDE stuff, but not
Firefox, last night and this morning, this functionality is now gone.
Has anyone else got this problem or come across it being mentioning in
their wanderings of the web?

        Any thoughts greatly appreciated,

                Andrew






[1] https://tinyurl.com/u9vxqdy

Reply | Threaded
Open this post in threaded view
|

Re: Lost "middle click opens links" in KDE/Firefox combo - anyone else?

Mick-10
On Thursday, 30 January 2020 05:41:34 GMT Andrew Lowe wrote:
> Hi all,
> Yesterday afternoon, and for the last ??? years, I could be using
> Firefox, within KDE and with a Logitech M560[1] mouse, middle click on a
> link and a new tab would open containing the link.

Yes, middle-click would paste a URL and FF would load it.  This has been the
behaviour of FF for as long as I can think on different desktops, not just
Plasma/KDE.


> I did an "emerge world", which included some KDE stuff, but not
> Firefox, last night and this morning, this functionality is now gone.
> Has anyone else got this problem or come across it being mentioning in
> their wanderings of the web?
>
> Any thoughts greatly appreciated,
>
> Andrew
>
>
>
>
>
>
> [1] https://tinyurl.com/u9vxqdy
I can confirm I can't paste with the middle button and navigate to a URL in FF
or Falkon, but I don't know what has caused this.  From what I recall Chromium
never worked, while FF always did.
--
Regards,

Mick

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Lost "middle click opens links" in KDE/Firefox combo - anyone else?

Neil Bothwick
On Thu, 30 Jan 2020 09:07:00 +0000, Mick wrote:

> On Thursday, 30 January 2020 05:41:34 GMT Andrew Lowe wrote:

> > Yesterday afternoon, and for the last ??? years, I could be
> > using Firefox, within KDE and with a Logitech M560[1] mouse, middle
> > click on a link and a new tab would open containing the link.  
>
> Yes, middle-click would paste a URL and FF would load it.  This has
> been the behaviour of FF for as long as I can think on different
> desktops, not just Plasma/KDE.
>
 
> > I did an "emerge world", which included some KDE stuff, but
> > not Firefox, last night and this morning, this functionality is now
> > gone. Has anyone else got this problem or come across it being
> > mentioning in their wanderings of the web?

> I can confirm I can't paste with the middle button and navigate to a
> URL in FF or Falkon, but I don't know what has caused this.  From what
> I recall Chromium never worked, while FF always did.

Chromium still behaves as it always did here, with a middle-click opening
the link in a new tab.


--
Neil Bothwick

Computer apathy error: don't bother striking any key.


attachment0 (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Lost "middle click opens links" in KDE/Firefox combo - anyone else?

Mick-10
On Thursday, 30 January 2020 09:28:56 GMT Neil Bothwick wrote:

> On Thu, 30 Jan 2020 09:07:00 +0000, Mick wrote:
> > On Thursday, 30 January 2020 05:41:34 GMT Andrew Lowe wrote:
> > > Yesterday afternoon, and for the last ??? years, I could be
> > >
> > > using Firefox, within KDE and with a Logitech M560[1] mouse, middle
> > > click on a link and a new tab would open containing the link.
> >
> > Yes, middle-click would paste a URL and FF would load it.  This has
> > been the behaviour of FF for as long as I can think on different
> > desktops, not just Plasma/KDE.
> >
> > > I did an "emerge world", which included some KDE stuff, but
> > >
> > > not Firefox, last night and this morning, this functionality is now
> > > gone. Has anyone else got this problem or come across it being
> > > mentioning in their wanderings of the web?
> >
> > I can confirm I can't paste with the middle button and navigate to a
> > URL in FF or Falkon, but I don't know what has caused this.  From what
> > I recall Chromium never worked, while FF always did.
>
> Chromium still behaves as it always did here, with a middle-click opening
> the link in a new tab.
Hmm ... I just checked again.  It doesn't do so on two different systems.  I
wonder if some setting is responsible for it not working here.  :-/

--
Regards,

Mick

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Lost "middle click opens links" in KDE/Firefox combo - anyone else?

Dale-46
Mick wrote:

> On Thursday, 30 January 2020 09:28:56 GMT Neil Bothwick wrote:
>> On Thu, 30 Jan 2020 09:07:00 +0000, Mick wrote:
>>> On Thursday, 30 January 2020 05:41:34 GMT Andrew Lowe wrote:
>>>> Yesterday afternoon, and for the last ??? years, I could be
>>>>
>>>> using Firefox, within KDE and with a Logitech M560[1] mouse, middle
>>>> click on a link and a new tab would open containing the link.
>>> Yes, middle-click would paste a URL and FF would load it.  This has
>>> been the behaviour of FF for as long as I can think on different
>>> desktops, not just Plasma/KDE.
>>>
>>>> I did an "emerge world", which included some KDE stuff, but
>>>>
>>>> not Firefox, last night and this morning, this functionality is now
>>>> gone. Has anyone else got this problem or come across it being
>>>> mentioning in their wanderings of the web?
>>> I can confirm I can't paste with the middle button and navigate to a
>>> URL in FF or Falkon, but I don't know what has caused this.  From what
>>> I recall Chromium never worked, while FF always did.
>> Chromium still behaves as it always did here, with a middle-click opening
>> the link in a new tab.
> Hmm ... I just checked again.  It doesn't do so on two different systems.  I
> wonder if some setting is responsible for it not working here.  :-/
>


Just to add to this.  In Firefox, it worked in the past, I sort of found
it annoying when I would accidentally middle click and off it went.  It
no longer works now.  It does however work in Seamonkey.  It worked in
the past as well.  I did upgrade Firefox as well as a small number of
KDE packages the other day, Monday USA time. 

Dale

:-)  :-) 

Reply | Threaded
Open this post in threaded view
|

Re: Lost "middle click opens links" in KDE/Firefox combo - anyone else?

Arve Barsnes
In reply to this post by Mick-10
On Thu, 30 Jan 2020 at 12:26, Mick <[hidden email]> wrote:
> Hmm ... I just checked again.  It doesn't do so on two different systems.  I
> wonder if some setting is responsible for it not working here.  :-/

There is a setting for this in about:config, but I find it hard to
believe that an update to something outside of firefox would change
this setting...

browser.tabs.opentabfor.middleclick

Regards,
Arve

Reply | Threaded
Open this post in threaded view
|

Re: Lost "middle click opens links" in KDE/Firefox combo - anyone else?

Peter Humphrey-3
In reply to this post by Dale-46
On Thursday, 30 January 2020 11:42:52 GMT Dale wrote:

> Just to add to this.  In Firefox, it worked in the past, I sort of found
> it annoying when I would accidentally middle click and off it went.  It
> no longer works now.  It does however work in Seamonkey.  It worked in
> the past as well.  I did upgrade Firefox as well as a small number of
> KDE packages the other day, Monday USA time.

I never knew it did this, so I tried it just now. It works for me. Versions as
in .sig.

--
Regards,
Peter.

Gentoo stable system, openrc-0.41.1
gcc 9.2.0, sys-kernel/gentoo-sources 4.19.97
QT 5.13.2, KDE frameworks 5.64.0, KDE plasma 5.17.4
KDE apps 19.08.3 incl KMail 19.08.3 (5.11.3), akonadi 19.08.3
dev-db/mariadb-10.2.29, net-libs/webkit-gtk-2.24.2
x11-drivers/xf86-video-amdgpu 19.0.1
dev-libs/amdgpu-pro-opencl-19.30.838629



Reply | Threaded
Open this post in threaded view
|

Re: Lost "middle click opens links" in KDE/Firefox combo - anyone else?

Andrew Lowe-2
In reply to this post by Andrew Lowe-2
On 30/1/20 1:41 pm, Andrew Lowe wrote:

> Hi all,
>      Yesterday afternoon, and for the last ??? years, I could be using
> Firefox, within KDE and with a Logitech M560[1] mouse, middle click on a
> link and a new tab would open containing the link.
>
>      I did an "emerge world", which included some KDE stuff, but not
> Firefox, last night and this morning, this functionality is now gone.
> Has anyone else got this problem or come across it being mentioning in
> their wanderings of the web?
>
>      Any thoughts greatly appreciated,
>
>          Andrew
>
>
>
>
>
>
> [1] https://tinyurl.com/u9vxqdy
>

        Well it appears it's the kernel.... Boot into my environment with the
5.4.14 kernel, bring up FF and then happily go "middle button clicking"
on links. Tabs with the appropriate links start popping up everywhere,
as expected.

        Shutdown then restart using the 5.5.0 kernel and try "middle button
clicking" and it fails. I'll have to do some more checking but it looks
like that is the problem.

        Andrew