Lots of big updates...

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Lots of big updates...

tanstaafl-2
Hi everyone,

I haven't updated in a little while, and am seeing a lot of big updates...

The main ones that concern me are:

perl (5.16 > 5.18)
&
mariadb (5.5.37 > 10.0.12)

and of course, I always worry about:

glib (2.38.2-r1 > 2.40.0-r1)
&
glibc (2.17 > 2.19-r1)

Anyone have any warnings/caveats about these updates?

Especially the mariadb update? I'm thinking about masking that one for a
while, just to be safe...

Thanks

Reply | Threaded
Open this post in threaded view
|

Re: Lots of big updates...

tanstaafl-2
On 8/10/2014 11:45 AM, Tanstaafl <[hidden email]> wrote:
> I haven't updated in a little while, and am seeing a lot of big updates...
>
> The main ones that concern me are:
>
> perl (5.16 > 5.18)

Ok, a little experimenting to see if I can stage these updates and just
update perl first, I get:

>  # emerge -pvuDN perl
>
> These are the packages that would be merged, in order:
>
> Calculating dependencies... done!
> [ebuild     U  ] virtual/libintl-0-r1 [0] ABI_X86="(64%*) -32% (-x32)" 0 kB
> [ebuild     U  ] sys-devel/gnuconfig-20140212 [20131128] 44 kB
> [ebuild     U  ] app-admin/perl-cleaner-2.16 [2.15] 6 kB
> [ebuild     U  ] sys-libs/db-4.8.30-r1:4.8 [4.8.30:4.8] USE="cxx -doc -examples -java -tcl {-test}" ABI_X86="(64%*) (-32) (-x32)" 22,351 kB
> [ebuild     U  ] dev-lang/perl-5.18.2-r1:0/5.18 [5.16.3:0/5.16] USE="berkdb gdbm -debug -doc -ithreads" 13,746 kB
>
> Total: 5 packages (5 upgrades), Size of downloads: 36,147 kB
>
> !!! Multiple package instances within a single package slot have been pulled
> !!! into the dependency graph, resulting in a slot conflict:
>
> dev-lang/perl:0
>
>   (dev-lang/perl-5.16.3::gentoo, installed) pulled in by
>     =dev-lang/perl-5.16* required by (virtual/perl-Attribute-Handlers-0.930.0-r1::gentoo, installed)
>     dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-SSLeay-1.550::gentoo, installed)
>     dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/IO-Socket-SSL-1.953.0::gentoo, installed)
>     dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Sub-Exporter-0.986.0::gentoo, installed)
>     dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/PlRPC-0.202.0-r2::gentoo, installed)
>     dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-Daemon-0.480.0-r1::gentoo, installed)
>     dev-lang/perl:0/5.16=[-build(-)] required by (dev-vcs/git-1.8.5.5::gentoo, installed)
>     dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/log-dispatch-2.410.0::gentoo, installed)
>     dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Try-Tiny-0.180.0::gentoo, installed)
>     dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Error-0.170.210::gentoo, installed)
>     dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Package-Stash-XS-0.280.0::gentoo, installed)
>     dev-lang/perl:0/5.16=[-build(-)] required by (net-analyzer/net-snmp-5.7.3_pre3::gentoo, installed)
>     dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Package-Stash-0.360.0::gentoo, installed)
>     (and 1 more with the same problems)
>
>   (dev-lang/perl-5.18.2-r1::gentoo, ebuild scheduled for merge) pulled in by
>     =dev-lang/perl-5.18* required by (virtual/perl-MIME-Base64-3.130.0-r3::gentoo, installed)
>     (and 3 more with the same problem)

A little googling suggests that I could resolve this by a simple:

emerge -C virtual/perl-Attribute-Handlers-0.930.0-r1
&
emerge -C virtual/perl-MIME-Base64-3.130.0-r3

But even if this does resolve the conflicts, what would break
(temporarily) if I removed those? They're virtuals, so... maybe...
nothing? Any way to check?

Reply | Threaded
Open this post in threaded view
|

Re: Lots of big updates...

Alan McKinnon-2
On 10/08/2014 18:04, Tanstaafl wrote:

> On 8/10/2014 11:45 AM, Tanstaafl <[hidden email]> wrote:
>> I haven't updated in a little while, and am seeing a lot of big
>> updates...
>>
>> The main ones that concern me are:
>>
>> perl (5.16 > 5.18)
>
> Ok, a little experimenting to see if I can stage these updates and just
> update perl first, I get:
>
>>  # emerge -pvuDN perl
>>
>> These are the packages that would be merged, in order:
>>
>> Calculating dependencies... done!
>> [ebuild     U  ] virtual/libintl-0-r1 [0] ABI_X86="(64%*) -32% (-x32)"
>> 0 kB
>> [ebuild     U  ] sys-devel/gnuconfig-20140212 [20131128] 44 kB
>> [ebuild     U  ] app-admin/perl-cleaner-2.16 [2.15] 6 kB
>> [ebuild     U  ] sys-libs/db-4.8.30-r1:4.8 [4.8.30:4.8] USE="cxx -doc
>> -examples -java -tcl {-test}" ABI_X86="(64%*) (-32) (-x32)" 22,351 kB
>> [ebuild     U  ] dev-lang/perl-5.18.2-r1:0/5.18 [5.16.3:0/5.16]
>> USE="berkdb gdbm -debug -doc -ithreads" 13,746 kB
>>
>> Total: 5 packages (5 upgrades), Size of downloads: 36,147 kB
>>
>> !!! Multiple package instances within a single package slot have been
>> pulled
>> !!! into the dependency graph, resulting in a slot conflict:
>>
>> dev-lang/perl:0
>>
>>   (dev-lang/perl-5.16.3::gentoo, installed) pulled in by
>>     =dev-lang/perl-5.16* required by
>> (virtual/perl-Attribute-Handlers-0.930.0-r1::gentoo, installed)
>>     dev-lang/perl:0/5.16=[-build(-)] required by
>> (dev-perl/Net-SSLeay-1.550::gentoo, installed)
>>     dev-lang/perl:0/5.16=[-build(-)] required by
>> (dev-perl/IO-Socket-SSL-1.953.0::gentoo, installed)
>>     dev-lang/perl:0/5.16=[-build(-)] required by
>> (dev-perl/Sub-Exporter-0.986.0::gentoo, installed)
>>     dev-lang/perl:0/5.16=[-build(-)] required by
>> (dev-perl/PlRPC-0.202.0-r2::gentoo, installed)
>>     dev-lang/perl:0/5.16=[-build(-)] required by
>> (dev-perl/Net-Daemon-0.480.0-r1::gentoo, installed)
>>     dev-lang/perl:0/5.16=[-build(-)] required by
>> (dev-vcs/git-1.8.5.5::gentoo, installed)
>>     dev-lang/perl:0/5.16=[-build(-)] required by
>> (dev-perl/log-dispatch-2.410.0::gentoo, installed)
>>     dev-lang/perl:0/5.16=[-build(-)] required by
>> (dev-perl/Try-Tiny-0.180.0::gentoo, installed)
>>     dev-lang/perl:0/5.16=[-build(-)] required by
>> (dev-perl/Error-0.170.210::gentoo, installed)
>>     dev-lang/perl:0/5.16=[-build(-)] required by
>> (dev-perl/Package-Stash-XS-0.280.0::gentoo, installed)
>>     dev-lang/perl:0/5.16=[-build(-)] required by
>> (net-analyzer/net-snmp-5.7.3_pre3::gentoo, installed)
>>     dev-lang/perl:0/5.16=[-build(-)] required by
>> (dev-perl/Package-Stash-0.360.0::gentoo, installed)
>>     (and 1 more with the same problems)
>>
>>   (dev-lang/perl-5.18.2-r1::gentoo, ebuild scheduled for merge) pulled
>> in by
>>     =dev-lang/perl-5.18* required by
>> (virtual/perl-MIME-Base64-3.130.0-r3::gentoo, installed)
>>     (and 3 more with the same problem)
>
> A little googling suggests that I could resolve this by a simple:
>
> emerge -C virtual/perl-Attribute-Handlers-0.930.0-r1
> &
> emerge -C virtual/perl-MIME-Base64-3.130.0-r3
>
> But even if this does resolve the conflicts, what would break
> (temporarily) if I removed those? They're virtuals, so... maybe...
> nothing? Any way to check?


Nothing will break. Like you say they are virtual and contain no code
and deploy nothing. So your system will continue to function as it
currently does, and Portage will sort itself out when you next emerge world.

Unless of course portage wants to unmerge any of the providers that
satisfy the virtuals, and you say "yes" ... :-)



--
Alan McKinnon
[hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: Lots of big updates...

Jouni Kosonen
In reply to this post by tanstaafl-2
Tanstaafl wrote:

> mariadb (5.5.37 > 10.0.12)
> Thanks

I went from mariadb-5.5.38-r1 to 10.0.12 here on Aug 5 and didn't manage
to break anything, even akonadi-server.
There shouldn't be anythong a revdep-rebuild won't handle.

Jouni




Reply | Threaded
Open this post in threaded view
|

Re: Lots of big updates...

Alan McKinnon-2
In reply to this post by tanstaafl-2
On 10/08/2014 17:45, Tanstaafl wrote:
> Hi everyone,
>
> I haven't updated in a little while, and am seeing a lot of big updates...
>
> The main ones that concern me are:
>
> perl (5.16 > 5.18)

No problem other than you might have a bunch of blockers to resolve and
of course perl-cleaner to run. Just keep cycling through it till it
completes; preserved-rebuild will keep your system intact.

All regular Gentoo stuff, nothing to be concerned about. Besides, if it
breaks you know what to do (and no-one can really tell you about
breakage in advance)

> &
> mariadb (5.5.37 > 10.0.12)

No info


>
> and of course, I always worry about:
>
> glib (2.38.2-r1 > 2.40.0-r1)

This is not a problem, but you keep raising it. glib is a bunch of
helper functions and in no way related at all to glibc (an entirely
different kettle of fish)


> &
> glibc (2.17 > 2.19-r1)

No problem. There were no ABI changes to glibc for ages now

>
> Anyone have any warnings/caveats about these updates?
>
> Especially the mariadb update? I'm thinking about masking that one for a
> while, just to be safe...


Run it in your test environment and satisfy yourself first




--
Alan McKinnon
[hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: Lots of big updates...

William Kenworthy
In reply to this post by tanstaafl-2
I would follow that path - I did and it worked out fine.

Unmerge all conflicting perl modules

emerge world -1NuDv

Dont forget perl-cleaner --all immediately afterwards

and with the python updates that are probably there too - python-updater

enjoy ...

Note that some perl modules have disappeared in 5.18 but it didn't cause
me any grief I know of.

BillK

On 11/08/14 00:04, Tanstaafl wrote:

> On 8/10/2014 11:45 AM, Tanstaafl <[hidden email]> wrote:
>> I haven't updated in a little while, and am seeing a lot of big
>> updates...
>>
>> The main ones that concern me are:
>>
>> perl (5.16 > 5.18)
>
> Ok, a little experimenting to see if I can stage these updates and just
> update perl first, I get:
>
>>  # emerge -pvuDN perl
>>
>> These are the packages that would be merged, in order:
>>
>> Calculating dependencies... done!
>> [ebuild     U  ] virtual/libintl-0-r1 [0] ABI_X86="(64%*) -32% (-x32)"
>> 0 kB
>> [ebuild     U  ] sys-devel/gnuconfig-20140212 [20131128] 44 kB
>> [ebuild     U  ] app-admin/perl-cleaner-2.16 [2.15] 6 kB
>> [ebuild     U  ] sys-libs/db-4.8.30-r1:4.8 [4.8.30:4.8] USE="cxx -doc
>> -examples -java -tcl {-test}" ABI_X86="(64%*) (-32) (-x32)" 22,351 kB
>> [ebuild     U  ] dev-lang/perl-5.18.2-r1:0/5.18 [5.16.3:0/5.16]
>> USE="berkdb gdbm -debug -doc -ithreads" 13,746 kB
>>
>> Total: 5 packages (5 upgrades), Size of downloads: 36,147 kB
>>
>> !!! Multiple package instances within a single package slot have been
>> pulled
>> !!! into the dependency graph, resulting in a slot conflict:
>>
>> dev-lang/perl:0
>>
>>   (dev-lang/perl-5.16.3::gentoo, installed) pulled in by
>>     =dev-lang/perl-5.16* required by
>> (virtual/perl-Attribute-Handlers-0.930.0-r1::gentoo, installed)
>>     dev-lang/perl:0/5.16=[-build(-)] required by
>> (dev-perl/Net-SSLeay-1.550::gentoo, installed)
>>     dev-lang/perl:0/5.16=[-build(-)] required by
>> (dev-perl/IO-Socket-SSL-1.953.0::gentoo, installed)
>>     dev-lang/perl:0/5.16=[-build(-)] required by
>> (dev-perl/Sub-Exporter-0.986.0::gentoo, installed)
>>     dev-lang/perl:0/5.16=[-build(-)] required by
>> (dev-perl/PlRPC-0.202.0-r2::gentoo, installed)
>>     dev-lang/perl:0/5.16=[-build(-)] required by
>> (dev-perl/Net-Daemon-0.480.0-r1::gentoo, installed)
>>     dev-lang/perl:0/5.16=[-build(-)] required by
>> (dev-vcs/git-1.8.5.5::gentoo, installed)
>>     dev-lang/perl:0/5.16=[-build(-)] required by
>> (dev-perl/log-dispatch-2.410.0::gentoo, installed)
>>     dev-lang/perl:0/5.16=[-build(-)] required by
>> (dev-perl/Try-Tiny-0.180.0::gentoo, installed)
>>     dev-lang/perl:0/5.16=[-build(-)] required by
>> (dev-perl/Error-0.170.210::gentoo, installed)
>>     dev-lang/perl:0/5.16=[-build(-)] required by
>> (dev-perl/Package-Stash-XS-0.280.0::gentoo, installed)
>>     dev-lang/perl:0/5.16=[-build(-)] required by
>> (net-analyzer/net-snmp-5.7.3_pre3::gentoo, installed)
>>     dev-lang/perl:0/5.16=[-build(-)] required by
>> (dev-perl/Package-Stash-0.360.0::gentoo, installed)
>>     (and 1 more with the same problems)
>>
>>   (dev-lang/perl-5.18.2-r1::gentoo, ebuild scheduled for merge) pulled
>> in by
>>     =dev-lang/perl-5.18* required by
>> (virtual/perl-MIME-Base64-3.130.0-r3::gentoo, installed)
>>     (and 3 more with the same problem)
>
> A little googling suggests that I could resolve this by a simple:
>
> emerge -C virtual/perl-Attribute-Handlers-0.930.0-r1
> &
> emerge -C virtual/perl-MIME-Base64-3.130.0-r3
>
> But even if this does resolve the conflicts, what would break
> (temporarily) if I removed those? They're virtuals, so... maybe...
> nothing? Any way to check?
>


Reply | Threaded
Open this post in threaded view
|

Re: Lots of big updates...

Neil Bothwick
On Tue, 12 Aug 2014 06:32:08 +0800, Bill Kenworthy wrote:

> Note that some perl modules have disappeared in 5.18 but it didn't cause
> me any grief I know of.

They haven't disappeared, they are now part of the core Perl installation
and not needed as separate ebuilds.

http://dilfridge.blogspot.co.uk/2014/07/perl-in-gentoo-dev-langperl-virtuals.html


--
Neil Bothwick

Become a computer programmer and never see the the world.

signature.asc (188 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Lots of big updates...

William Kenworthy
On 12/08/14 06:37, Neil Bothwick wrote:

> On Tue, 12 Aug 2014 06:32:08 +0800, Bill Kenworthy wrote:
>
>> Note that some perl modules have disappeared in 5.18 but it didn't cause
>> me any grief I know of.
>
> They haven't disappeared, they are now part of the core Perl installation
> and not needed as separate ebuilds.
>
> http://dilfridge.blogspot.co.uk/2014/07/perl-in-gentoo-dev-langperl-virtuals.html
>
>

Yes, I should have been clearer.

BillK