Making use of webapp optional

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Making use of webapp optional

Dirk Tilger-2
Hi guys,

I'm trying to enhance the mapserver ebuild to support building no CGI at
all. The software can be built as extension for many programming
languages and a CGI is not strictly necessary.

It was suggested in #gentoo-web on freenode that I should use the 'cgi'
USE flag for this purpose. I wrapped all calls to webapp functionality
with `if use cgi` or an equivalent, but then I'm getting at the very end
of the build process:

| >>> Original instance of package unmerged safely.
|  *
|  * This ebuild did not call webapp_src_install() at the end
|  * of the src_install() function
|  *
|  * Please log a bug on http://bugs.gentoo.org
|  *
|  * You should use emerge -C to remove this package, as the
|  * installation is incomplete
|  *
|
| !!! ERROR: sci-geosciences/mapserver-4.10.0 failed.
| Call stack:
|   ebuild.sh, line 1595:   Called qa_call 'pkg_postinst'
|   environment, line 4827:   Called pkg_postinst
|   ebuild.sh, line 1304:   Called webapp_pkg_postinst
|   webapp.eclass, line 462:   Called die
|
| !!! Ebuild did not call webapp_src_install() - report to http://bugs.gentoo.org
| !!! If you need support, post the topmost build error, and the call stack if relevant.
| !!! A complete build log is located at '/var/tmp/portage/sci-geosciences/mapserver-4.10.0/temp/build.log'.
|
| !!! FAILED postinst: 1
| !!! This ebuild is from an overlay: '/home/dirk/overlay'

When I do run the webapp_src_install() function, I get at the end:

|  * Running //usr/sbin/webapp-config -I -h localhost -u root -d /mapserver mapserver 4.10.0
|  * Fatal error: Your configuration file sets the server type "Apache"
|  * Fatal error: but the corresponding package does not seem to be installed!
|  * Fatal error: Please "emerge >=net-www/apache-1.3" or correct your settings.
|  * Fatal error(s) - aborting
|
|   * Running //usr/sbin/webapp-cleaner -p -C mapserver

The only solution I have found so far is to wrap 'inherit webapp' with
`use cgi` everything works, but then my ebuild gets rejected, because
that would prevent metacaching as was pointed out to me at bugzilla.

Any suggestions would be highly appreciated.
Thanks in advance,
Dirk.
--
[hidden email] mailing list

Reply | Threaded
Open this post in threaded view
|

Re: Making use of webapp optional

Renat Lumpau
On Sun, 2007-03-04 at 11:56 +0400, Dirk Tilger wrote:

> Hi guys,
>
> I'm trying to enhance the mapserver ebuild to support building no CGI at
> all. The software can be built as extension for many programming
> languages and a CGI is not strictly necessary.
>
> It was suggested in #gentoo-web on freenode that I should use the 'cgi'
> USE flag for this purpose. I wrapped all calls to webapp functionality
> with `if use cgi` or an equivalent, but then I'm getting at the very end
> of the build process:
Could you attach or pastebin your ebuild?

Best,
--
Renat Lumpau       all things web-apps
C6A838DA           04AF B5EE 17CB 1000 DDA5  D3FC 1338 ADC2 C6A8 38DA

signature.asc (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Making use of webapp optional

Dirk Tilger-2
On Sun, Mar 04, 2007 at 10:03:09AM -0500, Renat Lumpau wrote:

> On Sun, 2007-03-04 at 11:56 +0400, Dirk Tilger wrote:
> > Hi guys,
> >
> > I'm trying to enhance the mapserver ebuild to support building no CGI at
> > all. The software can be built as extension for many programming
> > languages and a CGI is not strictly necessary.
> >
> > It was suggested in #gentoo-web on freenode that I should use the 'cgi'
> > USE flag for this purpose. I wrapped all calls to webapp functionality
> > with `if use cgi` or an equivalent, but then I'm getting at the very end
> > of the build process:
>
> Could you attach or pastebin your ebuild?

That was the version that ended compilation in:
| * Fatal error: Your configuration file sets the server type "Apache"
| * Fatal error: but the corresponding package does not seem to be installed!
| * Fatal error: Please "emerge >=net-www/apache-1.3" or correct your settings.
| * Fatal error(s) - aborting

http://pastebin.com/893768

The other try had line 302 and line 305 wrapped in `if use cgi`.

Dirk.
--
[hidden email] mailing list

Reply | Threaded
Open this post in threaded view
|

Re: Making use of webapp optional

Renat Lumpau
On Mon, 2007-03-05 at 11:00 +0400, Dirk wrote:

> On Sun, Mar 04, 2007 at 10:03:09AM -0500, Renat Lumpau wrote:
> > On Sun, 2007-03-04 at 11:56 +0400, Dirk Tilger wrote:
> > > Hi guys,
> > >
> > > I'm trying to enhance the mapserver ebuild to support building no CGI at
> > > all. The software can be built as extension for many programming
> > > languages and a CGI is not strictly necessary.
> > >
> > > It was suggested in #gentoo-web on freenode that I should use the 'cgi'
> > > USE flag for this purpose. I wrapped all calls to webapp functionality
> > > with `if use cgi` or an equivalent, but then I'm getting at the very end
> > > of the build process:
> >
> > Could you attach or pastebin your ebuild?
>
> That was the version that ended compilation in:
> | * Fatal error: Your configuration file sets the server type "Apache"
> | * Fatal error: but the corresponding package does not seem to be installed!
> | * Fatal error: Please "emerge >=net-www/apache-1.3" or correct your settings.
> | * Fatal error(s) - aborting
>
> http://pastebin.com/893768
>
pastebin.com doesn't seem to work too well. Could you try elsewhere?

Best,
--
Renat Lumpau       all things web-apps
C6A838DA           04AF B5EE 17CB 1000 DDA5  D3FC 1338 ADC2 C6A8 38DA

signature.asc (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Making use of webapp optional

Dirk Tilger-2
On Mon, Mar 05, 2007 at 10:11:36AM -0500, Renat Lumpau wrote:
> pastebin.com doesn't seem to work too well. Could you try elsewhere?

http://ostec.org/~dirk/mapserver-4.10.0.ebuild

Dirk.
--
[hidden email] mailing list

Reply | Threaded
Open this post in threaded view
|

Re: Making use of webapp optional

Renat Lumpau
On Tue, 2007-03-06 at 14:51 +0400, Dirk wrote:
> On Mon, Mar 05, 2007 at 10:11:36AM -0500, Renat Lumpau wrote:
> > pastebin.com doesn't seem to work too well. Could you try elsewhere?
>
> http://ostec.org/~dirk/mapserver-4.10.0.ebuild

I'm not sure I see what the problem is. Have you tried wrapping _all_
calls to webapp.eclass functions in use cgi && {} blocks?

Best,
--
Renat Lumpau       all things web-apps
C6A838DA           04AF B5EE 17CB 1000 DDA5  D3FC 1338 ADC2 C6A8 38DA

signature.asc (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Making use of webapp optional

Dirk Tilger-2
On Tue, Mar 13, 2007 at 06:34:18PM -0400, Renat Lumpau wrote:
> On Tue, 2007-03-06 at 14:51 +0400, Dirk wrote:
> > On Mon, Mar 05, 2007 at 10:11:36AM -0500, Renat Lumpau wrote:
> > > pastebin.com doesn't seem to work too well. Could you try elsewhere?
> >
> > http://ostec.org/~dirk/mapserver-4.10.0.ebuild
>
> I'm not sure I see what the problem is. Have you tried wrapping _all_
> calls to webapp.eclass functions in use cgi && {} blocks?

I tried:

- to wrap all calls
- to wrap all calls that make the CGI being installed
- wrap all calls and 'inherit webapp'

They all showed unwanted side effects.

My goal is to make the dependency on Apache (or any other) webserver
optional for this package.

Dirk.
--
[hidden email] mailing list