Missing file so DIE; Seriously?!?!?!?

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Missing file so DIE; Seriously?!?!?!?

Alan Grimes
99.999% sure this is not my fault yet my build gets killed dead by it,
no "Okay, let's see what other things we can build", just DIE!!!


##########

>>> Verifying ebuild manifests

!!! A file listed in the Manifest could not be found:
/usr/portage/dev-python/pygments/files/pygments-2.2.0-sphinx17.patch

!!! A file listed in the Manifest could not be found:
/usr/portage/dev-lang/ruby/files/2.4/012-openssl_1.1.patch

!!! A file listed in the Manifest could not be found:
/usr/portage/dev-lang/ruby/files/2.4/012-openssl_1.1.patch

!!! A file listed in the Manifest could not be found:
/usr/portage/dev-lang/ruby/files/2.4/012-openssl_1.1.patch

!!! A file listed in the Manifest could not be found:
/usr/portage/app-text/libetonyek/files/libetonyek-0.1.8-no-parentheses.patch
!!! A file is not listed in the Manifest:
'/usr/portage/kde-apps/kde-dev-utils/files/kde-dev-utils-18.04.3-ki18n-5.48.patch'
!!! A file is not listed in the Manifest:
'/usr/portage/kde-apps/kwrite/files/kwrite-18.04.3-root-user.patch'

!!! A file listed in the Manifest could not be found:
/usr/portage/media-video/obs-studio/files/obs-studio-22.0.3-fdk-build-fix.patch

###############

Trying to mask ruby-2.4 now... =\ ################## Total: 1626
packages (427 upgrades, 34 new, 6 in new slots, 1159 reinstalls), Size
of downloads: 12,018 KiB Fetch Restriction: 2 packages The following
mask changes are necessary to proceed: (see "package.unmask" in the
portage(5) man page for more details) # required by
dev-ruby/kpeg-1.1.0-r1::gentoo[ruby_targets_ruby24] # required by
dev-ruby/rdoc-6.1.1::gentoo[ruby_targets_ruby26] # required by
dev-lang/ruby-2.5.3::gentoo[rdoc] # required by
dev-vcs/subversion-1.11.1::gentoo[ruby] # required by
app-portage/layman-2.4.2-r2::gentoo[subversion] # required by @selected
# required by @world (argument) # /etc/portage/package.mask: #broken,
pre-release package so don't really care =dev-lang/ruby-2.4.5-r1 NOTE:
The --autounmask-keep-masks option will prevent emerge from creating
package.unmask or ** keyword changes. Use --autounmask-write to write
changes to config files (honoring CONFIG_PROTECT). Carefully examine the
list of proposed changes, paying special attention to mask or keyword
changes that may expose experimental or unstable packages. tortoise
/usr/portage/dev-lang/ruby # ########################3

I literally have NO IDEA where ruby_targets_ruby24 is being defined, I am installing 23, 25, and 26 with a default of 26...


PAIN!!!

--
Please report bounces from this address to [hidden email]

Powers are not rights.


Reply | Threaded
Open this post in threaded view
|

Re: Missing file so DIE; Seriously?!?!?!?

Davyd McColl


On January 24, 2019 6:25:48 AM Alan Grimes <[hidden email]> wrote:

> 99.999% sure this is not my fault yet my build gets killed dead by it,
> no "Okay, let's see what other things we can build", just DIE!!!
>
Have you tried --keep-going?

>
> ##########
>
>>>> Verifying ebuild manifests
>
> !!! A file listed in the Manifest could not be found:
> /usr/portage/dev-python/pygments/files/pygments-2.2.0-sphinx17.patch
>
> !!! A file listed in the Manifest could not be found:
> /usr/portage/dev-lang/ruby/files/2.4/012-openssl_1.1.patch
>
> !!! A file listed in the Manifest could not be found:
> /usr/portage/dev-lang/ruby/files/2.4/012-openssl_1.1.patch
>
> !!! A file listed in the Manifest could not be found:
> /usr/portage/dev-lang/ruby/files/2.4/012-openssl_1.1.patch
>
> !!! A file listed in the Manifest could not be found:
> /usr/portage/app-text/libetonyek/files/libetonyek-0.1.8-no-parentheses.patch
> !!! A file is not listed in the Manifest:
> '/usr/portage/kde-apps/kde-dev-utils/files/kde-dev-utils-18.04.3-ki18n-5.48.patch'
> !!! A file is not listed in the Manifest:
> '/usr/portage/kde-apps/kwrite/files/kwrite-18.04.3-root-user.patch'
>
> !!! A file listed in the Manifest could not be found:
> /usr/portage/media-video/obs-studio/files/obs-studio-22.0.3-fdk-build-fix.patch
>
> ###############
>
> Trying to mask ruby-2.4 now... =\ ################## Total: 1626
> packages (427 upgrades, 34 new, 6 in new slots, 1159 reinstalls), Size
> of downloads: 12,018 KiB Fetch Restriction: 2 packages The following
> mask changes are necessary to proceed: (see "package.unmask" in the
> portage(5) man page for more details) # required by
> dev-ruby/kpeg-1.1.0-r1::gentoo[ruby_targets_ruby24] # required by
> dev-ruby/rdoc-6.1.1::gentoo[ruby_targets_ruby26] # required by
> dev-lang/ruby-2.5.3::gentoo[rdoc] # required by
> dev-vcs/subversion-1.11.1::gentoo[ruby] # required by
> app-portage/layman-2.4.2-r2::gentoo[subversion] # required by @selected
> # required by @world (argument) # /etc/portage/package.mask: #broken,
> pre-release package so don't really care =dev-lang/ruby-2.4.5-r1 NOTE:
> The --autounmask-keep-masks option will prevent emerge from creating
> package.unmask or ** keyword changes. Use --autounmask-write to write
> changes to config files (honoring CONFIG_PROTECT). Carefully examine the
> list of proposed changes, paying special attention to mask or keyword
> changes that may expose experimental or unstable packages. tortoise
> /usr/portage/dev-lang/ruby # ########################3
>
> I literally have NO IDEA where ruby_targets_ruby24 is being defined, I am
> installing 23, 25, and 26 with a default of 26...
>
>
> PAIN!!!
>
> --
> Please report bounces from this address to [hidden email]
>
> Powers are not rights.
>
>



Reply | Threaded
Open this post in threaded view
|

Re: Missing file so DIE; Seriously?!?!?!?

Mick-10
On Thursday, 24 January 2019 04:28:06 GMT Davyd McColl wrote:

> On January 24, 2019 6:25:48 AM Alan Grimes <[hidden email]> wrote:
> > 99.999% sure this is not my fault yet my build gets killed dead by it,
> > no "Okay, let's see what other things we can build", just DIE!!!
>
> Have you tried --keep-going?
>
> > ##########
> >
> >>>> Verifying ebuild manifests
> >
> > !!! A file listed in the Manifest could not be found:
> > /usr/portage/dev-python/pygments/files/pygments-2.2.0-sphinx17.patch
> >
> > !!! A file listed in the Manifest could not be found:
> > /usr/portage/dev-lang/ruby/files/2.4/012-openssl_1.1.patch
> >
> > !!! A file listed in the Manifest could not be found:
> > /usr/portage/dev-lang/ruby/files/2.4/012-openssl_1.1.patch
> >
> > !!! A file listed in the Manifest could not be found:
> > /usr/portage/dev-lang/ruby/files/2.4/012-openssl_1.1.patch
> >
> > !!! A file listed in the Manifest could not be found:
> > /usr/portage/app-text/libetonyek/files/libetonyek-0.1.8-no-parentheses.pat
> > ch !!! A file is not listed in the Manifest:
> > '/usr/portage/kde-apps/kde-dev-utils/files/kde-dev-utils-18.04.3-ki18n-5.4
> > 8.patch' !!! A file is not listed in the Manifest:
> > '/usr/portage/kde-apps/kwrite/files/kwrite-18.04.3-root-user.patch'
> >
> > !!! A file listed in the Manifest could not be found:
> > /usr/portage/media-video/obs-studio/files/obs-studio-22.0.3-fdk-build-fix.
> > patch
rm -Rf /usr/portage/*
emerge --sync

Then repeat your world update.

--
Regards,
Mick

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Missing file so DIE; Seriously?!?!?!?

John Covici
On Thu, 24 Jan 2019 06:07:57 -0500,
Mick wrote:

>
> [1  <text/plain; UTF-8 (7bit)>]
> On Thursday, 24 January 2019 04:28:06 GMT Davyd McColl wrote:
> > On January 24, 2019 6:25:48 AM Alan Grimes <[hidden email]> wrote:
> > > 99.999% sure this is not my fault yet my build gets killed dead by it,
> > > no "Okay, let's see what other things we can build", just DIE!!!
> >
> > Have you tried --keep-going?
> >
> > > ##########
> > >
> > >>>> Verifying ebuild manifests
> > >
> > > !!! A file listed in the Manifest could not be found:
> > > /usr/portage/dev-python/pygments/files/pygments-2.2.0-sphinx17.patch
> > >
> > > !!! A file listed in the Manifest could not be found:
> > > /usr/portage/dev-lang/ruby/files/2.4/012-openssl_1.1.patch
> > >
> > > !!! A file listed in the Manifest could not be found:
> > > /usr/portage/dev-lang/ruby/files/2.4/012-openssl_1.1.patch
> > >
> > > !!! A file listed in the Manifest could not be found:
> > > /usr/portage/dev-lang/ruby/files/2.4/012-openssl_1.1.patch
> > >
> > > !!! A file listed in the Manifest could not be found:
> > > /usr/portage/app-text/libetonyek/files/libetonyek-0.1.8-no-parentheses.pat
> > > ch !!! A file is not listed in the Manifest:
> > > '/usr/portage/kde-apps/kde-dev-utils/files/kde-dev-utils-18.04.3-ki18n-5.4
> > > 8.patch' !!! A file is not listed in the Manifest:
> > > '/usr/portage/kde-apps/kwrite/files/kwrite-18.04.3-root-user.patch'
> > >
> > > !!! A file listed in the Manifest could not be found:
> > > /usr/portage/media-video/obs-studio/files/obs-studio-22.0.3-fdk-build-fix.
> > > patch
>
> rm -Rf /usr/portage/*
> emerge --sync
>
> Then repeat your world update.

bBut save your distfiles and packages directories!!

--
Your life is like a penny.  You're going to lose it.  The question is:
How do
you spend it?

         John Covici wb2una
         [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Missing file so DIE; Seriously?!?!?!?

Mick-10
On Thursday, 24 January 2019 11:19:16 GMT John Covici wrote:

> On Thu, 24 Jan 2019 06:07:57 -0500,
>
> Mick wrote:
> > [1  <text/plain; UTF-8 (7bit)>]
> >
> > On Thursday, 24 January 2019 04:28:06 GMT Davyd McColl wrote:
> > > On January 24, 2019 6:25:48 AM Alan Grimes <[hidden email]> wrote:
> > > > 99.999% sure this is not my fault yet my build gets killed dead by it,
> > > > no "Okay, let's see what other things we can build", just DIE!!!
> > >
> > > Have you tried --keep-going?
> > >
> > > > ##########
> > > >
> > > >>>> Verifying ebuild manifests
> > > >
> > > > !!! A file listed in the Manifest could not be found:
> > > > /usr/portage/dev-python/pygments/files/pygments-2.2.0-sphinx17.patch
> > > >
> > > > !!! A file listed in the Manifest could not be found:
> > > > /usr/portage/dev-lang/ruby/files/2.4/012-openssl_1.1.patch
> > > >
> > > > !!! A file listed in the Manifest could not be found:
> > > > /usr/portage/dev-lang/ruby/files/2.4/012-openssl_1.1.patch
> > > >
> > > > !!! A file listed in the Manifest could not be found:
> > > > /usr/portage/dev-lang/ruby/files/2.4/012-openssl_1.1.patch
> > > >
> > > > !!! A file listed in the Manifest could not be found:
> > > > /usr/portage/app-text/libetonyek/files/libetonyek-0.1.8-no-parentheses
> > > > .pat
> > > > ch !!! A file is not listed in the Manifest:
> > > > '/usr/portage/kde-apps/kde-dev-utils/files/kde-dev-utils-18.04.3-ki18n
> > > > -5.4
> > > > 8.patch' !!! A file is not listed in the Manifest:
> > > > '/usr/portage/kde-apps/kwrite/files/kwrite-18.04.3-root-user.patch'
> > > >
> > > > !!! A file listed in the Manifest could not be found:
> > > > /usr/portage/media-video/obs-studio/files/obs-studio-22.0.3-fdk-build-
> > > > fix.
> > > > patch
> >
> > rm -Rf /usr/portage/*
> > emerge --sync
> >
> > Then repeat your world update.
>
> bBut save your distfiles and packages directories!!
Only if redownloading them from a mirror as needed is a problem (slow or no
Internet).  Given the errors about missing patches and manifests I'd delete
the lot and start afresh with a resync.

--
Regards,
Mick

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Missing file so DIE; Seriously?!?!?!?

J. Roeleveld
On January 24, 2019 11:23:34 AM UTC, Mick <[hidden email]> wrote:
On Thursday, 24 January 2019 11:19:16 GMT John Covici wrote:
On Thu, 24 Jan 2019 06:07:57 -0500,

Mick wrote:
[1 <text/plain; UTF-8 (7bit)>]

On Thursday, 24 January 2019 04:28:06 GMT Davyd McColl wrote:
On January 24, 2019 6:25:48 AM Alan Grimes <[hidden email]> wrote:
99.999% sure this is not my fault yet my build gets killed dead by it,
no "Okay, let's see what other things we can build", just DIE!!!

Have you tried --keep-going?

##########

Verifying ebuild manifests

!!! A file listed in the Manifest could not be found:
/usr/portage/dev-python/pygments/files/pygments-2.2.0-sphinx17.patch

!!! A file listed in the Manifest could not be found:
/usr/portage/dev-lang/ruby/files/2.4/012-openssl_1.1.patch

!!! A file listed in the Manifest could not be found:
/usr/portage/dev-lang/ruby/files/2.4/012-openssl_1.1.patch

!!! A file listed in the Manifest could not be found:
/usr/portage/dev-lang/ruby/files/2.4/012-openssl_1.1.patch

!!! A file listed in the Manifest could not be found:
/usr/portage/app-text/libetonyek/files/libetonyek-0.1.8-no-parentheses
.pat
ch !!! A file is not listed in the Manifest:
'/usr/portage/kde-apps/kde-dev-utils/files/kde-dev-utils-18.04.3-ki18n
-5.4
8.patch' !!! A file is not listed in the Manifest:
'/usr/portage/kde-apps/kwrite/files/kwrite-18.04.3-root-user.patch'

!!! A file listed in the Manifest could not be found:
/usr/portage/media-video/obs-studio/files/obs-studio-22.0.3-fdk-build-
fix.
patch

rm -Rf /usr/portage/*
emerge --sync

Then repeat your world update.

bBut save your distfiles and packages directories!!

Only if redownloading them from a mirror as needed is a problem (slow or no
Internet). Given the errors about missing patches and manifests I'd delete
the lot and start afresh with a resync.

No need to wipe it all.
Simply resync.

Been a while since I had an issue like this, but I switched to git for the repository a while ago...

--
Joost

Ps. OP is known for not following sane advice
--
Sent from my Android device with K-9 Mail. Please excuse my brevity.