Multilib or not?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Multilib or not?

João Matos-2
Hi list.

I've been using gentoo amd64 multilib for at least five year, and the system is working pretty well. But the recent discussion about 64 bit over 32
made me wonder about changing the profile to a non-multilib.

So I run 'revdep-rebuild --verbose' just to check what do I have that still depends on emul-linux-x86* and I've found:

app-emulation/wine-1.4
sys-boot/grub-0.97-r10
www-plugins/google-talkplugin-2.1.7.0
x11-drivers/nvidia-drivers-295.59
games-emulation/zsnes-1.51-r2
skype

I suppose that I'll have no problem with wine or nvidia-drivers based on preview discussion. But how about grub, zsnes, skype or some .bin games intalled outside portage, like Aminesia?

I'm assuming that I'll also have no problems with codecs, because since I compiled mplayer with vdpau support I can play all video stuff with it.

Thank you,
--
João de Matos
Linux User #461527

Reply | Threaded
Open this post in threaded view
|

Re: Multilib or not?

Edmar Wiggers
Hi,

I'm preparing to switch from Fedora 14 32bit to Gentoo 64bit
non-multilib. Gentoo setup procedure is basically finished and
working.

I'm using Lilo instead of Grub for bootloader, I read about grub being
incompatible with non-multilib somewhere in the Gentoo amd64 handbook.

I do not use graphics/X, so no other issues so far. Apache, OpenLDAP,
pam_ldap/nss_ldap, MySQL, PHP all seem fine.

Cheers,

Edmar Wiggers
Macrovita Alimentos

// BTM4758

2012/7/17 João Matos <[hidden email]>:

> Hi list.
>
> I've been using gentoo amd64 multilib for at least five year, and the system
> is working pretty well. But the recent discussion about 64 bit over 32 made
> me wonder about changing the profile to a non-multilib.
>
> So I run 'revdep-rebuild --verbose' just to check what do I have that still
> depends on emul-linux-x86* and I've found:
>
> app-emulation/wine-1.4
> sys-boot/grub-0.97-r10
> www-plugins/google-talkplugin-2.1.7.0
> x11-drivers/nvidia-drivers-295.59
> games-emulation/zsnes-1.51-r2
> skype
>
> I suppose that I'll have no problem with wine or nvidia-drivers based on
> preview discussion. But how about grub, zsnes, skype or some .bin games
> intalled outside portage, like Aminesia?
>
> I'm assuming that I'll also have no problems with codecs, because since I
> compiled mplayer with vdpau support I can play all video stuff with it.
>
> Thank you,
> --
> João de Matos
> Linux User #461527
>