Nach Update @preserved-rebuild

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Nach Update @preserved-rebuild

stefan.rohnke
Hallo,
seit Tagen erhalte ich die Meldung das ich @preserved-rebuild ausführen
soll.
emerge -av @preserved-rebuild
tut aber nichts.
Wie genau muss ich da vorgehen.
Gruß
Stefan Rohnke

Reply | Threaded
Open this post in threaded view
|

Re: Nach Update @preserved-rebuild

assabajanischer_hinterwaeldler
Hallo,

an sich sollte das glaub ich nur kommen, wenn es noch Pakete gibt, deren
Abhängigkeiten jetzt in einer neuen Version vorkommen.
Abhilfe sollte hier meistens 'revdep-rebuild' bringen.
Damit sollten zumindest Pakete erneut gebaut werden, die ins nichts
linken.

Der Aufruf an sich ist aber korrekt.

Welcher Aufruf führt den zu der Aufforderung?
Sofern ich mich recht entsinne kann es auch als Info-Nachricht kommen.
Bin mir aber gerade nicht mehr 100% sicher welcher es war.

Falls die Meldung weiterhin kommt kann auch noch folgendes helfen:
emerge --sync
emerge -avuDN --with-bdeps=y world
emerge -a --depclean
revdep-rebuild

Also alles auf den neusten Stand bringen, aufräumen und nachschauen ob
doch noch etwas ins Nirvana linkt.

Gerne auch nochmal den Aufruf davor mit dazu, der zum @preserved-rebuild
führt.

Gruß
Martin

On Mon, Dec 19, 2016 at 09:20:22AM +0100, Stefan Rohnke wrote:
> Hallo,
> seit Tagen erhalte ich die Meldung das ich @preserved-rebuild ausführen
> soll.
> emerge -av @preserved-rebuild
> tut aber nichts.
> Wie genau muss ich da vorgehen.
> Gruß
> Stefan Rohnke
>

Reply | Threaded
Open this post in threaded view
|

Re: Nach Update @preserved-rebuild

stefan.rohnke
Hallo Martin,
> an sich sollte das glaub ich nur kommen, wenn es noch Pakete gibt, deren
> Abhängigkeiten jetzt in einer neuen Version vorkommen.
Damit kann ich gleich aufklären, dass diese Meldung bei jedem:
emerge-webrsync
erscheint.
Die Befehle, die du genannt hast, führen leider zu keinerlei Ergebnis.
Gruß
Stefan

Reply | Threaded
Open this post in threaded view
|

Re: Nach Update @preserved-rebuild

assabajanischer_hinterwaeldler
Hall Stefan,

da ich den Befehl normalerweise nicht verwende, hab ichs gerade mal
ausgetestet und es ging.

Kannst du mal einen Output anhängen?

Danke
Martin

On Tue, Dec 20, 2016 at 12:34:45AM +0100, Stefan Rohnke wrote:

> Hallo Martin,
> > an sich sollte das glaub ich nur kommen, wenn es noch Pakete gibt, deren
> > Abhängigkeiten jetzt in einer neuen Version vorkommen.
> Damit kann ich gleich aufklären, dass diese Meldung bei jedem:
> emerge-webrsync
> erscheint.
> Die Befehle, die du genannt hast, führen leider zu keinerlei Ergebnis.
> Gruß
> Stefan
>

Reply | Threaded
Open this post in threaded view
|

Re: Nach Update @preserved-rebuild

stefan.rohnke
On Di, Dez 20, 2016 at 09:26:35 +0100, [hidden email] wrote:
> Hall Stefan,
Hallo
>
> da ich den Befehl normalerweise nicht verwende, hab ichs gerade mal
> ausgetestet und es ging.
Jetzt hat es sich bei mir sozusagen auch aufgelöst als heute Morgen ein
ncurses-update lief; manchmal hilft warten.
Trotzdem vielen Dank.
Gruß
Stefan Rohnke

>
> Kannst du mal einen Output anhängen?
>
> Danke
> Martin
>
> On Tue, Dec 20, 2016 at 12:34:45AM +0100, Stefan Rohnke wrote:
> > Hallo Martin,
> > > an sich sollte das glaub ich nur kommen, wenn es noch Pakete gibt, deren
> > > Abhängigkeiten jetzt in einer neuen Version vorkommen.
> > Damit kann ich gleich aufklären, dass diese Meldung bei jedem:
> > emerge-webrsync
> > erscheint.
> > Die Befehle, die du genannt hast, führen leider zu keinerlei Ergebnis.
> > Gruß
> > Stefan
> >
>