[PATCH] checks: Add more deprecated eclasses

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[PATCH] checks: Add more deprecated eclasses

Michał Górny-5
---
 repoman/pym/repoman/modules/scan/ebuild/checks.py | 5 +++++
 1 file changed, 5 insertions(+)

diff --git a/repoman/pym/repoman/modules/scan/ebuild/checks.py b/repoman/pym/repoman/modules/scan/ebuild/checks.py
index e6e5d78ba..a1fa066be 100644
--- a/repoman/pym/repoman/modules/scan/ebuild/checks.py
+++ b/repoman/pym/repoman/modules/scan/ebuild/checks.py
@@ -416,14 +416,18 @@ class InheritDeprecated(LineCheck):
 
  # deprecated eclass : new eclass (False if no new eclass)
  deprecated_eclasses = {
+ "autotools-multilib": False,
+ "autotools-utils": False,
  "base": False,
  "bash-completion": "bash-completion-r1",
  "boost-utils": False,
  "clutter": "gnome2",
  "confutils": False,
  "distutils": "distutils-r1",
+ "fdo-mime": "xdg-utils",
  "games": False,
  "gems": "ruby-fakegem",
+ "git-2": "git-r3",
  "gpe": False,
  "gst-plugins-bad": "gstreamer",
  "gst-plugins-base": "gstreamer",
@@ -434,6 +438,7 @@ class InheritDeprecated(LineCheck):
  "python": "python-r1 / python-single-r1 / python-any-r1",
  "ruby": "ruby-ng",
  "x-modular": "xorg-2",
+ "xfconf": False,
  }
 
  _inherit_re = re.compile(r'^\s*inherit\s(.*)$')
--
2.13.1


Reply | Threaded
Open this post in threaded view
|

[PATCH v2] checks: Add more deprecated eclasses

Michał Górny-5
Changes in v2:
* multilib-minimal is suggested replacement of autotools-multilib.

---
 repoman/pym/repoman/modules/scan/ebuild/checks.py | 5 +++++
 1 file changed, 5 insertions(+)

diff --git a/repoman/pym/repoman/modules/scan/ebuild/checks.py b/repoman/pym/repoman/modules/scan/ebuild/checks.py
index e6e5d78ba..de03bedd2 100644
--- a/repoman/pym/repoman/modules/scan/ebuild/checks.py
+++ b/repoman/pym/repoman/modules/scan/ebuild/checks.py
@@ -416,14 +416,18 @@ class InheritDeprecated(LineCheck):
 
  # deprecated eclass : new eclass (False if no new eclass)
  deprecated_eclasses = {
+ "autotools-multilib": "multilib-minimal",
+ "autotools-utils": False,
  "base": False,
  "bash-completion": "bash-completion-r1",
  "boost-utils": False,
  "clutter": "gnome2",
  "confutils": False,
  "distutils": "distutils-r1",
+ "fdo-mime": "xdg-utils",
  "games": False,
  "gems": "ruby-fakegem",
+ "git-2": "git-r3",
  "gpe": False,
  "gst-plugins-bad": "gstreamer",
  "gst-plugins-base": "gstreamer",
@@ -434,6 +438,7 @@ class InheritDeprecated(LineCheck):
  "python": "python-r1 / python-single-r1 / python-any-r1",
  "ruby": "ruby-ng",
  "x-modular": "xorg-2",
+ "xfconf": False,
  }
 
  _inherit_re = re.compile(r'^\s*inherit\s(.*)$')
--
2.13.1


Reply | Threaded
Open this post in threaded view
|

Re: [PATCH v2] checks: Add more deprecated eclasses

Brian Dolbec-3
On Mon, 19 Jun 2017 15:35:49 +0200
Michał Górny <[hidden email]> wrote:

> Changes in v2:
> * multilib-minimal is suggested replacement of autotools-multilib.
>
> ---
>  repoman/pym/repoman/modules/scan/ebuild/checks.py | 5 +++++
>  1 file changed, 5 insertions(+)
>
> diff --git a/repoman/pym/repoman/modules/scan/ebuild/checks.py
> b/repoman/pym/repoman/modules/scan/ebuild/checks.py index
> e6e5d78ba..de03bedd2 100644 ---
> a/repoman/pym/repoman/modules/scan/ebuild/checks.py +++
> b/repoman/pym/repoman/modules/scan/ebuild/checks.py @@ -416,14
> +416,18 @@ class InheritDeprecated(LineCheck):
>   # deprecated eclass : new eclass (False if no new eclass)
>   deprecated_eclasses = {
> + "autotools-multilib": "multilib-minimal",
> + "autotools-utils": False,
>   "base": False,
>   "bash-completion": "bash-completion-r1",
>   "boost-utils": False,
>   "clutter": "gnome2",
>   "confutils": False,
>   "distutils": "distutils-r1",
> + "fdo-mime": "xdg-utils",
>   "games": False,
>   "gems": "ruby-fakegem",
> + "git-2": "git-r3",
>   "gpe": False,
>   "gst-plugins-bad": "gstreamer",
>   "gst-plugins-base": "gstreamer",
> @@ -434,6 +438,7 @@ class InheritDeprecated(LineCheck):
>   "python": "python-r1 / python-single-r1 /
> python-any-r1", "ruby": "ruby-ng",
>   "x-modular": "xorg-2",
> + "xfconf": False,
>   }
>  
>   _inherit_re = re.compile(r'^\s*inherit\s(.*)$')


looks fine
--
Brian Dolbec <dolsen>


Reply | Threaded
Open this post in threaded view
|

Re: [PATCH v2] checks: Add more deprecated eclasses

Michał Górny-5
On pon, 2017-06-19 at 07:48 -0700, Brian Dolbec wrote:

> On Mon, 19 Jun 2017 15:35:49 +0200
> Michał Górny <[hidden email]> wrote:
>
> > Changes in v2:
> > * multilib-minimal is suggested replacement of autotools-multilib.
> >
> > ---
> >  repoman/pym/repoman/modules/scan/ebuild/checks.py | 5 +++++
> >  1 file changed, 5 insertions(+)
> >
> > diff --git a/repoman/pym/repoman/modules/scan/ebuild/checks.py
> > b/repoman/pym/repoman/modules/scan/ebuild/checks.py index
> > e6e5d78ba..de03bedd2 100644 ---
> > a/repoman/pym/repoman/modules/scan/ebuild/checks.py +++
> > b/repoman/pym/repoman/modules/scan/ebuild/checks.py @@ -416,14
> > +416,18 @@ class InheritDeprecated(LineCheck):
> >   # deprecated eclass : new eclass (False if no new eclass)
> >   deprecated_eclasses = {
> > + "autotools-multilib": "multilib-minimal",
> > + "autotools-utils": False,
> >   "base": False,
> >   "bash-completion": "bash-completion-r1",
> >   "boost-utils": False,
> >   "clutter": "gnome2",
> >   "confutils": False,
> >   "distutils": "distutils-r1",
> > + "fdo-mime": "xdg-utils",
> >   "games": False,
> >   "gems": "ruby-fakegem",
> > + "git-2": "git-r3",
> >   "gpe": False,
> >   "gst-plugins-bad": "gstreamer",
> >   "gst-plugins-base": "gstreamer",
> > @@ -434,6 +438,7 @@ class InheritDeprecated(LineCheck):
> >   "python": "python-r1 / python-single-r1 /
> > python-any-r1", "ruby": "ruby-ng",
> >   "x-modular": "xorg-2",
> > + "xfconf": False,
> >   }
> >  
> >   _inherit_re = re.compile(r'^\s*inherit\s(.*)$')
>
>
> looks fine
Pushed, thanks.
--
Best regards,
Michał Górny

signature.asc (1007 bytes) Download Attachment