[PATCH] travis.yml: drop python 2.7 (bug 731114)

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[PATCH] travis.yml: drop python 2.7 (bug 731114)

Zac Medico-2
It should be pretty safe to drop support for python2.7 at this point.

Bug: https://bugs.gentoo.org/731114
Signed-off-by: Zac Medico <[hidden email]>
---
 .travis.yml | 1 -
 tox.ini     | 6 ++----
 2 files changed, 2 insertions(+), 5 deletions(-)

diff --git a/.travis.yml b/.travis.yml
index 2132c8c87..d2935fdab 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,7 +1,6 @@
 dist: bionic
 language: python
 python:
-    - 2.7
     - 3.6
     - 3.7
     - 3.8
diff --git a/tox.ini b/tox.ini
index 79b5b45cb..050a2c455 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,14 +1,12 @@
 [tox]
-envlist = py27,py36,py37,py38,py39,pypy3
+envlist = py36,py37,py38,py39,pypy3
 skipsdist = True
 
 [testenv]
 deps =
  pygost
  pyyaml
- py27,py36,py37,py38,py39,pypy3: lxml!=4.2.0
- py27: pyblake2
- py27: pysha3
+ py36,py37,py38,py39,pypy3: lxml!=4.2.0
 setenv =
  PYTHONPATH={toxinidir}/lib
 commands =
--
2.25.3


Reply | Threaded
Open this post in threaded view
|

Re: [PATCH] travis.yml: drop python 2.7 (bug 731114)

Brian Dolbec-3
On Mon,  6 Jul 2020 11:42:06 -0700
Zac Medico <[hidden email]> wrote:

> It should be pretty safe to drop support for python2.7 at this point.
>
> Bug: https://bugs.gentoo.org/731114
> Signed-off-by: Zac Medico <[hidden email]>
> ---
>  .travis.yml | 1 -
>  tox.ini     | 6 ++----
>  2 files changed, 2 insertions(+), 5 deletions(-)
>
> diff --git a/.travis.yml b/.travis.yml
> index 2132c8c87..d2935fdab 100644
> --- a/.travis.yml
> +++ b/.travis.yml
> @@ -1,7 +1,6 @@
>  dist: bionic
>  language: python
>  python:
> -    - 2.7
>      - 3.6
>      - 3.7
>      - 3.8
> diff --git a/tox.ini b/tox.ini
> index 79b5b45cb..050a2c455 100644
> --- a/tox.ini
> +++ b/tox.ini
> @@ -1,14 +1,12 @@
>  [tox]
> -envlist = py27,py36,py37,py38,py39,pypy3
> +envlist = py36,py37,py38,py39,pypy3
>  skipsdist = True
>  
>  [testenv]
>  deps =
>   pygost
>   pyyaml
> - py27,py36,py37,py38,py39,pypy3: lxml!=4.2.0
> - py27: pyblake2
> - py27: pysha3
> + py36,py37,py38,py39,pypy3: lxml!=4.2.0
>  setenv =
>   PYTHONPATH={toxinidir}/lib
>  commands =

Go for it!

Reply | Threaded
Open this post in threaded view
|

Re: [PATCH] travis.yml: drop python 2.7 (bug 731114)

Michał Górny-5
In reply to this post by Zac Medico-2
On Mon, 2020-07-06 at 11:42 -0700, Zac Medico wrote:
> It should be pretty safe to drop support for python2.7 at this point.
>

We should probably also change the trove classifier to ... Python :: 3
:: Only

--
Best regards,
Michał Górny


signature.asc (631 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [PATCH] travis.yml: drop python 2.7 (bug 731114)

Zac Medico-2
On 7/6/20 12:07 PM, Michał Górny wrote:
> On Mon, 2020-07-06 at 11:42 -0700, Zac Medico wrote:
>> It should be pretty safe to drop support for python2.7 at this point.
>>
>
> We should probably also change the trove classifier to ... Python :: 3
> :: Only
>

Updated the classifier, and merged:

https://gitweb.gentoo.org/proj/portage.git/commit/?id=e59ec1924d6db957a01c828ce294a7675be5b27c
--
Thanks,
Zac


signature.asc (1000 bytes) Download Attachment