[PREFIX] there are no ebuilds to satisfy "app-text/ghostscript-gpl[cups]".

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[PREFIX] there are no ebuilds to satisfy "app-text/ghostscript-gpl[cups]".

Asfand Qazi
Hello, when I've been trying to do a emerge -DuvNta world recently, this
is what I've been getting:

emerge: there are no ebuilds to satisfy "app-text/ghostscript-gpl[cups]".
(dependency required by "net-print/cups-1.5.3" [ebuild])
(dependency required by "dev-java/icedtea-bin-7.2.1-r1[X]" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

I can create my own ebuild in my local overlay, but is there a more
permanent fix to this?

Thanks

--
Regards,
       Asfand Yar Qazi
       Team 87 - High Throughput Gene Targeting
       Wellcome Trust Sanger Institute


--
 The Wellcome Trust Sanger Institute is operated by Genome Research
 Limited, a charity registered in England with number 1021457 and a
 company registered in England with number 2742969, whose registered
 office is 215 Euston Road, London, NW1 2BE.

Reply | Threaded
Open this post in threaded view
|

Re: [PREFIX] there are no ebuilds to satisfy "app-text/ghostscript-gpl[cups]".

Jeremy Olexa-3
On Fri, Jun 15, 2012 at 9:44 AM, Asfand Qazi <[hidden email]> wrote:

> Hello, when I've been trying to do a emerge -DuvNta world recently, this is
> what I've been getting:
>
> emerge: there are no ebuilds to satisfy "app-text/ghostscript-gpl[cups]".
> (dependency required by "net-print/cups-1.5.3" [ebuild])
> (dependency required by "dev-java/icedtea-bin-7.2.1-r1[X]" [ebuild])
> (dependency required by "@selected" [set])
> (dependency required by "@world" [argument])
>
> I can create my own ebuild in my local overlay, but is there a more
> permanent fix to this?

USE=cups is masked. icedtea-bin[X] requires cups. icedtea-bin is not
keyworded for Gentoo Prefix.

With that above info, we have already taken care of protecting users
who are not hacking on Gentoo Prefix. After looking at the icedtea-bin
ebuild, looks like you can disable USE=X and install it without cups?

Good luck, you are in untested/unsupported territory,
Jeremy

Reply | Threaded
Open this post in threaded view
|

Re: [PREFIX] there are no ebuilds to satisfy "app-text/ghostscript-gpl[cups]".

Asfand Qazi
On 15/06/12 16:23, Jeremy Olexa wrote:

> On Fri, Jun 15, 2012 at 9:44 AM, Asfand Qazi<[hidden email]>  wrote:
>> Hello, when I've been trying to do a emerge -DuvNta world recently, this is
>> what I've been getting:
>>
>> emerge: there are no ebuilds to satisfy "app-text/ghostscript-gpl[cups]".
>> (dependency required by "net-print/cups-1.5.3" [ebuild])
>> (dependency required by "dev-java/icedtea-bin-7.2.1-r1[X]" [ebuild])
>> (dependency required by "@selected" [set])
>> (dependency required by "@world" [argument])
>>
>> I can create my own ebuild in my local overlay, but is there a more
>> permanent fix to this?
>
> USE=cups is masked. icedtea-bin[X] requires cups. icedtea-bin is not
> keyworded for Gentoo Prefix.
>
> With that above info, we have already taken care of protecting users
> who are not hacking on Gentoo Prefix. After looking at the icedtea-bin
> ebuild, looks like you can disable USE=X and install it without cups?
>
> Good luck, you are in untested/unsupported territory,
> Jeremy
>

Thanks.  I kind of need X with iced-tea to run desktop apps, so I'll try
unmasking USE=cups and see what happens.

--
Regards,
       Asfand Yar Qazi
       Team 87 - High Throughput Gene Targeting
       Wellcome Trust Sanger Institute


--
 The Wellcome Trust Sanger Institute is operated by Genome Research
 Limited, a charity registered in England with number 1021457 and a
 company registered in England with number 2742969, whose registered
 office is 215 Euston Road, London, NW1 2BE.