Portage strangeness with imagemagick

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Portage strangeness with imagemagick

Dan Johansson-4
Today when I do an update world on one of my serves I get the following:

----------------------------------------------------8<--------------------------------------------------
# emerge --update --deep --verbose --reinstall changed-use --with-bdeps y
world --pretend --tree

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy ">=x11-
libs/cairo-1.6[X]".
!!! One of the following packages is required to complete your request:
- x11-libs/cairo-1.8.8 (Change USE: +X)
(dependency required by "x11-libs/gtk+-2.16.6" [ebuild])
(dependency required by "media-gfx/ufraw-0.15-r1" [ebuild])
(dependency required by "media-gfx/imagemagick-6.5.2.9" [ebuild])
(dependency required by "www-apps/gallery-2.3" [ebuild])
(dependency required by "world" [argument])
----------------------------------------------------8<--------------------------------------------------

As this is a server I really do not want/need X on this host.

To see with which USE-flags my imagemagick is compiled I do:
----------------------------------------------------8<--------------------------------------------------
# eix media-gfx/imagemagick
[I] media-gfx/imagemagick
     Available versions:  6.5.2.9!u ~6.5.4.10!u ~6.5.7.0!u {X autotrace bzip2
corefonts djvu doc fftw fontconfig fpx graphviz gs hdri jbig jpeg jpeg2k lcms
lqr nocxx openexr openmp perl png q32 q8 raw svg tiff truetype wmf xml zlib}
     Installed versions:  6.5.2.9!u(11:02:58 10/04/09)(bzip2 corefonts jbig
jpeg perl png tiff xml zlib -X -djvu -doc -fontconfig -fpx -graphviz -gs -hdri
-jpeg2k -lcms -nocxx -openexr -openmp -q32 -q8 -raw -svg -truetype -wmf)
     Homepage:            http://www.imagemagick.org/
     Description:         A collection of tools and libraries for many image
formats
----------------------------------------------------8<--------------------------------------------------
From this I see that my Imagemagick is installed with the following USE-flags:
bzip2 corefonts jbig jpeg perl png tiff xml zlib

and now for the "strange" part (as far as I know):

----------------------------------------------------8<--------------------------------------------------
#  emerge --verbose --pretend media-gfx/imagemagick

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy ">=x11-
libs/cairo-1.6[X]".
!!! One of the following packages is required to complete your request:                
- x11-libs/cairo-1.8.8 (Change USE: +X)                                                
(dependency required by "x11-libs/gtk+-2.16.6" [ebuild])                              
(dependency required by "media-gfx/ufraw-0.15-r1" [ebuild])                            
(dependency required by "media-gfx/imagemagick-6.5.2.9" [ebuild])                      
(dependency required by "media-gfx/imagemagick" [argument])                            
----------------------------------------------------8<--------------------------------------------------
But:
----------------------------------------------------8<--------------------------------------------------
# USE="-* bzip2 corefonts jbig jpeg perl png tiff xml zlib" emerge --verbose
--pretend media-gfx/imagemagick

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] media-gfx/imagemagick-6.5.2.9  USE="bzip2 corefonts jbig jpeg
perl png tiff xml zlib -X -djvu -doc -fontconfig -fpx -graphviz -gs -hdri -
jpeg2k -lcms -nocxx -openexr -openmp -q32 -q8 -raw -svg -truetype -wmf" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB
----------------------------------------------------8<--------------------------------------------------

I can not see why it works if I first deletes all USE flags (-*) and the just
sets the USE flags I need again.

--
Dan Johansson, <http://www.dmj.nu>
***************************************************
This message is printed on 100% recycled electrons!
***************************************************

Reply | Threaded
Open this post in threaded view
|

Re: Portage strangeness with imagemagick

Dirk Heinrichs-2
Am Donnerstag 29 Oktober 2009 19:39:27 schrieb Dan Johansson:

> Today when I do an update world on one of my serves I get the following:
>
> ----------------------------------------------------8<---------------------
> ----------------------------- # emerge --update --deep --verbose
>  --reinstall changed-use --with-bdeps y world --pretend --tree
>
> These are the packages that would be merged, in reverse order:
>
> Calculating dependencies... done!
>
> emerge: there are no ebuilds built with USE flags to satisfy ">=x11-
> libs/cairo-1.6[X]".
> !!! One of the following packages is required to complete your request:
> - x11-libs/cairo-1.8.8 (Change USE: +X)
> (dependency required by "x11-libs/gtk+-2.16.6" [ebuild])
> (dependency required by "media-gfx/ufraw-0.15-r1" [ebuild])
> (dependency required by "media-gfx/imagemagick-6.5.2.9" [ebuild])
> (dependency required by "www-apps/gallery-2.3" [ebuild])
> (dependency required by "world" [argument])
> ----------------------------------------------------8<---------------------
> -----------------------------
>
> As this is a server I really do not want/need X on this host.
So why do have gtk+ in your USE, then? That's the one that makes ufraw pull in
gtk+ which in turn wants cairo with the X flag. OTOH, this doesn't mean you'll
get X installed on your machine. You'll only get a handful of X libs.
 
> I can not see why it works if I first deletes all USE flags (-*) and the
>  just sets the USE flags I need again.

Because it's not imagemagick that wants cairo with X (which the emerge output
above clearly states).

Bye...

        Dirk

signature.asc (197 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Portage strangeness with imagemagick

Dan Johansson-4
On Thursday 29 October 2009 19.52:52 Dirk Heinrichs wrote:

> Am Donnerstag 29 Oktober 2009 19:39:27 schrieb Dan Johansson:
> > Today when I do an update world on one of my serves I get the following:
> >
> > ----------------------------------------------------8<-------------------
> >-- ----------------------------- # emerge --update --deep --verbose
> > --reinstall changed-use --with-bdeps y world --pretend --tree
> >
> > These are the packages that would be merged, in reverse order:
> >
> > Calculating dependencies... done!
> >
> > emerge: there are no ebuilds built with USE flags to satisfy ">=x11-
> > libs/cairo-1.6[X]".
> > !!! One of the following packages is required to complete your request:
> > - x11-libs/cairo-1.8.8 (Change USE: +X)
> > (dependency required by "x11-libs/gtk+-2.16.6" [ebuild])
> > (dependency required by "media-gfx/ufraw-0.15-r1" [ebuild])
> > (dependency required by "media-gfx/imagemagick-6.5.2.9" [ebuild])
> > (dependency required by "www-apps/gallery-2.3" [ebuild])
> > (dependency required by "world" [argument])
> > ----------------------------------------------------8<-------------------
> >-- -----------------------------
> >
> > As this is a server I really do not want/need X on this host.
>
> So why do have gtk+ in your USE, then? That's the one that makes ufraw pull
>  in gtk+ which in turn wants cairo with the X flag. OTOH, this doesn't mean
>  you'll get X installed on your machine. You'll only get a handful of X
>  libs.
>
> > I can not see why it works if I first deletes all USE flags (-*) and the
> >  just sets the USE flags I need again.
>
> Because it's not imagemagick that wants cairo with X (which the emerge
>  output above clearly states).
>
> Bye...
>
> Dirk
>
Yes, I can see that it's not imagemagick directly that pulls in cairo. And I
do not have the gtk USE flag set:

# euse -i gtk
global use flags (searching: gtk)
************************************************************
[-    ] gtk - Adds support for x11-libs/gtk+ (The GIMP Toolkit)
<...snip...>

--
Dan Johansson, <http://www.dmj.nu>
***************************************************
This message is printed on 100% recycled electrons!
***************************************************

Reply | Threaded
Open this post in threaded view
|

Re: Portage strangeness with imagemagick

Alan McKinnon-2
On Thursday 29 October 2009 21:08:27 Dan Johansson wrote:

> On Thursday 29 October 2009 19.52:52 Dirk Heinrichs wrote:
> > Am Donnerstag 29 Oktober 2009 19:39:27 schrieb Dan Johansson:
> > > Today when I do an update world on one of my serves I get the
> > > following:
> > >
> > > ----------------------------------------------------8<-----------------
> > >-- -- ----------------------------- # emerge --update --deep --verbose
> > > --reinstall changed-use --with-bdeps y world --pretend --tree
> > >
> > > These are the packages that would be merged, in reverse order:
> > >
> > > Calculating dependencies... done!
> > >
> > > emerge: there are no ebuilds built with USE flags to satisfy ">=x11-
> > > libs/cairo-1.6[X]".
> > > !!! One of the following packages is required to complete your request:
> > > - x11-libs/cairo-1.8.8 (Change USE: +X)
> > > (dependency required by "x11-libs/gtk+-2.16.6" [ebuild])
> > > (dependency required by "media-gfx/ufraw-0.15-r1" [ebuild])
> > > (dependency required by "media-gfx/imagemagick-6.5.2.9" [ebuild])
> > > (dependency required by "www-apps/gallery-2.3" [ebuild])
> > > (dependency required by "world" [argument])
> > > ----------------------------------------------------8<-----------------
> > >-- -- -----------------------------
> > >
> > > As this is a server I really do not want/need X on this host.
> >
> > So why do have gtk+ in your USE, then? That's the one that makes ufraw
> > pull in gtk+ which in turn wants cairo with the X flag. OTOH, this
> > doesn't mean you'll get X installed on your machine. You'll only get a
> > handful of X libs.
> >
> > > I can not see why it works if I first deletes all USE flags (-*) and
> > > the just sets the USE flags I need again.
> >
> > Because it's not imagemagick that wants cairo with X (which the emerge
> >  output above clearly states).
> >
> > Bye...
> >
> > Dirk
>
> Yes, I can see that it's not imagemagick directly that pulls in cairo. And
>  I do not have the gtk USE flag set:
>
> # euse -i gtk
> global use flags (searching: gtk)
> ************************************************************
> [-    ] gtk - Adds support for x11-libs/gtk+ (The GIMP Toolkit)
> <...snip...>
>

ufraw's DEPEND:

RDEPEND="media-libs/jpeg
        >=media-libs/lcms-1.13
        media-libs/tiff
        >=x11-libs/gtk+-2.4.0

You don't have a choice. With ufraw you are going to get gtk+.

imagemagick pulls in ufraw:

RDEPEND="raw? ( media-gfx/ufraw )

But you have -raw in USE for imagemagick

Hmm. What does emerge --info have to say about USE=raw?
What does emerge -pvt imagemagick have to say?
I'm thinking raw may be overridden in your profile. what profile are you
using?


--
alan dot mckinnon at gmail dot com

Reply | Threaded
Open this post in threaded view
|

Re: Portage strangeness with imagemagick

Paul Hartman-3
In reply to this post by Dan Johansson-4
On Thu, Oct 29, 2009 at 2:08 PM, Dan Johansson <[hidden email]> wrote:

> On Thursday 29 October 2009 19.52:52 Dirk Heinrichs wrote:
>> Am Donnerstag 29 Oktober 2009 19:39:27 schrieb Dan Johansson:
>> > Today when I do an update world on one of my serves I get the following:
>> >
>> > ----------------------------------------------------8<-------------------
>> >-- ----------------------------- # emerge --update --deep --verbose
>> > --reinstall changed-use --with-bdeps y world --pretend --tree
>> >
>> > These are the packages that would be merged, in reverse order:
>> >
>> > Calculating dependencies... done!
>> >
>> > emerge: there are no ebuilds built with USE flags to satisfy ">=x11-
>> > libs/cairo-1.6[X]".
>> > !!! One of the following packages is required to complete your request:
>> > - x11-libs/cairo-1.8.8 (Change USE: +X)
>> > (dependency required by "x11-libs/gtk+-2.16.6" [ebuild])
>> > (dependency required by "media-gfx/ufraw-0.15-r1" [ebuild])
>> > (dependency required by "media-gfx/imagemagick-6.5.2.9" [ebuild])
>> > (dependency required by "www-apps/gallery-2.3" [ebuild])
>> > (dependency required by "world" [argument])
>> > ----------------------------------------------------8<-------------------
>> >-- -----------------------------
>> >
>> > As this is a server I really do not want/need X on this host.
>>
>> So why do have gtk+ in your USE, then? That's the one that makes ufraw pull
>>  in gtk+ which in turn wants cairo with the X flag. OTOH, this doesn't mean
>>  you'll get X installed on your machine. You'll only get a handful of X
>>  libs.
>>
>> > I can not see why it works if I first deletes all USE flags (-*) and the
>> >  just sets the USE flags I need again.
>>
>> Because it's not imagemagick that wants cairo with X (which the emerge
>>  output above clearly states).
>>
>> Bye...
>>
>>       Dirk
>>
> Yes, I can see that it's not imagemagick directly that pulls in cairo. And I
> do not have the gtk USE flag set:
>
> # euse -i gtk
> global use flags (searching: gtk)
> ************************************************************
> [-    ] gtk - Adds support for x11-libs/gtk+ (The GIMP Toolkit)
> <...snip...>

Do you have x11-libs/gtk+-2.16.6 installed? Or is one of the other new
things trying to pull it in?

Reply | Threaded
Open this post in threaded view
|

Re: Portage strangeness with imagemagick

Peter Alfredsen-3
In reply to this post by Alan McKinnon-2
On Thu, 29 Oct 2009 21:16:24 +0200
Alan McKinnon <[hidden email]> wrote:

> RDEPEND="media-libs/jpeg
>         >=media-libs/lcms-1.13
>         media-libs/tiff
>         >=x11-libs/gtk+-2.4.0
>
> You don't have a choice. With ufraw you are going to get gtk+.

Unless he keywords ufraw-0.16:
RDEPEND="
        media-libs/jpeg
        >=media-libs/lcms-1.13
        media-libs/tiff
        exif? ( >=media-gfx/exiv2-0.11 )
        gnome? ( gnome-base/gconf )
        gtk? ( >=x11-libs/gtk+-2.6.0
                >=media-gfx/gtkimageview-1.5.0
                gimp? ( >=media-gfx/gimp-2.0 ) )
        lensfun? ( >=media-libs/lensfun-0.2.3 )"

Reply | Threaded
Open this post in threaded view
|

Re: Portage strangeness with imagemagick

Dirk Heinrichs-2
In reply to this post by Dan Johansson-4
Am Donnerstag 29 Oktober 2009 20:08:27 schrieb Dan Johansson:

> On Thursday 29 October 2009 19.52:52 Dirk Heinrichs wrote:
> > Am Donnerstag 29 Oktober 2009 19:39:27 schrieb Dan Johansson:
> > > Today when I do an update world on one of my serves I get the
> > > following:
> > >
> > > ----------------------------------------------------8<-----------------
> > >-- -- ----------------------------- # emerge --update --deep --verbose
> > > --reinstall changed-use --with-bdeps y world --pretend --tree
> > >
> > > These are the packages that would be merged, in reverse order:
> > >
> > > Calculating dependencies... done!
> > >
> > > emerge: there are no ebuilds built with USE flags to satisfy ">=x11-
> > > libs/cairo-1.6[X]".
> > > !!! One of the following packages is required to complete your request:
> > > - x11-libs/cairo-1.8.8 (Change USE: +X)
> > > (dependency required by "x11-libs/gtk+-2.16.6" [ebuild])
> > > (dependency required by "media-gfx/ufraw-0.15-r1" [ebuild])
> > > (dependency required by "media-gfx/imagemagick-6.5.2.9" [ebuild])
> > > (dependency required by "www-apps/gallery-2.3" [ebuild])
> > > (dependency required by "world" [argument])
> > > ----------------------------------------------------8<-----------------
> > >-- -- -----------------------------
> > >
> > > As this is a server I really do not want/need X on this host.
> >
> > So why do have gtk+ in your USE, then? That's the one that makes ufraw
> > pull in gtk+ which in turn wants cairo with the X flag. OTOH, this
> > doesn't mean you'll get X installed on your machine. You'll only get a
> > handful of X libs.
> >
> > > I can not see why it works if I first deletes all USE flags (-*) and
> > > the just sets the USE flags I need again.
> >
> > Because it's not imagemagick that wants cairo with X (which the emerge
> >  output above clearly states).
> >
> > Bye...
> >
> > Dirk
>
> Yes, I can see that it's not imagemagick directly that pulls in cairo. And
>  I do not have the gtk USE flag set:
Oh, I looked into the 0.16 ebuild of ufraw, which contains this:

RDEPEND="
        media-libs/jpeg
        >=media-libs/lcms-1.13
        media-libs/tiff
        exif? ( >=media-gfx/exiv2-0.11 )
        gnome? ( gnome-base/gconf )
        gtk? ( >=x11-libs/gtk+-2.6.0
                >=media-gfx/gtkimageview-1.5.0
                gimp? ( >=media-gfx/gimp-2.0 ) )
        lensfun? ( >=media-libs/lensfun-0.2.3 )"

So this one really has the gtk+ dep depending on the presence of the gtk use
flag.

Bye...

        Dirk

signature.asc (197 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Portage strangeness with imagemagick

Dan Johansson-4
In reply to this post by Alan McKinnon-2
On Thursday 29 October 2009 20.16:24 Alan McKinnon wrote:

> On Thursday 29 October 2009 21:08:27 Dan Johansson wrote:
> > On Thursday 29 October 2009 19.52:52 Dirk Heinrichs wrote:
> > > Am Donnerstag 29 Oktober 2009 19:39:27 schrieb Dan Johansson:
> > > > Today when I do an update world on one of my serves I get the
> > > > following:
> > > >
> > > > ----------------------------------------------------8<---------------
> > > >-- -- -- ----------------------------- # emerge --update --deep
> > > > --verbose --reinstall changed-use --with-bdeps y world --pretend
> > > > --tree
> > > >
> > > > These are the packages that would be merged, in reverse order:
> > > >
> > > > Calculating dependencies... done!
> > > >
> > > > emerge: there are no ebuilds built with USE flags to satisfy ">=x11-
> > > > libs/cairo-1.6[X]".
> > > > !!! One of the following packages is required to complete your
> > > > request: - x11-libs/cairo-1.8.8 (Change USE: +X)
> > > > (dependency required by "x11-libs/gtk+-2.16.6" [ebuild])
> > > > (dependency required by "media-gfx/ufraw-0.15-r1" [ebuild])
> > > > (dependency required by "media-gfx/imagemagick-6.5.2.9" [ebuild])
> > > > (dependency required by "www-apps/gallery-2.3" [ebuild])
> > > > (dependency required by "world" [argument])
> > > > ----------------------------------------------------8<---------------
> > > >-- -- -- -----------------------------
> > > >
> > > > As this is a server I really do not want/need X on this host.
> > >
> > > So why do have gtk+ in your USE, then? That's the one that makes ufraw
> > > pull in gtk+ which in turn wants cairo with the X flag. OTOH, this
> > > doesn't mean you'll get X installed on your machine. You'll only get a
> > > handful of X libs.
> > >
> > > > I can not see why it works if I first deletes all USE flags (-*) and
> > > > the just sets the USE flags I need again.
> > >
> > > Because it's not imagemagick that wants cairo with X (which the emerge
> > >  output above clearly states).
> > >
> > > Bye...
> > >
> > > Dirk
> >
> > Yes, I can see that it's not imagemagick directly that pulls in cairo.
> > And I do not have the gtk USE flag set:
> >
> > # euse -i gtk
> > global use flags (searching: gtk)
> > ************************************************************
> > [-    ] gtk - Adds support for x11-libs/gtk+ (The GIMP Toolkit)
> > <...snip...>
>
> ufraw's DEPEND:
>
> RDEPEND="media-libs/jpeg
>
>         >=media-libs/lcms-1.13
>
>         media-libs/tiff
>
>         >=x11-libs/gtk+-2.4.0
>
> You don't have a choice. With ufraw you are going to get gtk+.
>
> imagemagick pulls in ufraw:
>
> RDEPEND="raw? ( media-gfx/ufraw )
>
> But you have -raw in USE for imagemagick
>
> Hmm. What does emerge --info have to say about USE=raw?
> What does emerge -pvt imagemagick have to say?
> I'm thinking raw may be overridden in your profile. what profile are you
> using?

That was it, if I put -raw in make.conf I am able to upgrade imagemagick
without pulling in all the X stuff (~25 new packages).

--
Dan Johansson, <http://www.dmj.nu>
***************************************************
This message is printed on 100% recycled electrons!
***************************************************