Probleme mit emerge und geblockten Paketen

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Probleme mit emerge und geblockten Paketen

Christian Schoepplein
Hallo zusammen,

seit letztem Wochenende läuft hier ein Gentoo und nach und nach versuche
ich die verschiedenen Tools, vor allem erstmal emerge, zu verstehen. Ich
habe die letzten Jahre nur Debian verwendet, daher sind einige Dinge neu
für mich bzw. erinnern sie mich stark an die Zeiten, wo wir im Job noch
FreeBSD eingesetzt haben.

Konkret habe ich geraqde folgendes Problem und komme damit absolut nicht
weiter:

srv ~ # emerge --update --deep --with-bdeps=y --newuse @system
Calculating dependencies... done!
[ebuild  NS    ] sys-libs/ncurses-5.9-r3 [5.9-r101] USE="cxx unicode
-ada -debug
)"
[ebuild     U  ] dev-libs/openssl-1.0.2d [1.0.1p] USE="asm%* -sctp%"
[blocks B      ] <sys-libs/ncurses-6:0 ("<sys-libs/ncurses-6:0" is
blocking sys-

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-libs/ncurses-5.9-r3:0/0::gentoo, ebuild scheduled for merge)
pulled in by
    sys-libs/ncurses:0= required by
(app-emulation/qemu-2.3.0-r5:0/0::gentoo, in
    sys-libs/ncurses:0= required by (sys-apps/openrc-0.17:0/0::gentoo,
installed
    sys-libs/ncurses:0= required by (dev-util/cmake-3.2.2:0/0::gentoo,
installed
    sys-libs/ncurses:0= required by
(dev-scheme/guile-1.8.8-r1:12/12::gentoo, in

  (sys-libs/ncurses-5.9-r101:5/5::gentoo, installed) pulled in by
    sys-libs/ncurses:5/5= required by
(app-emulation/qemu-2.3.0-r5:0/0::gentoo,
    sys-libs/ncurses required by @selected
    >=sys-libs/ncurses-5.2 required by
(dev-lang/python-2.7.9-r1:2.7/2.7::gentoo
    sys-libs/ncurses required by (sys-devel/gettext-0.19.4:0/0::gentoo,
installe
    >=sys-libs/ncurses-5.2-r5 required by
(sys-boot/grub-2.02_beta2-r7:2/2::gent
    >=sys-libs/ncurses-5.9-r1[unicode?]
(>=sys-libs/ncurses-5.9-r1[unicode]) req
    sys-libs/ncurses required by
(net-misc/telnet-bsd-1.2-r1:0/0::gentoo, instal
    >=sys-libs/ncurses-5.2 required by
(sys-devel/bc-1.06.95-r1:0/0::gentoo, ins
    >=sys-libs/ncurses-5.2-r2 required by
(sys-apps/util-linux-2.25.2-r2:0/0::ge
    >=sys-libs/ncurses-5.2 required by
(sys-kernel/gentoo-sources-4.0.5:4.0.5/4.
    sys-libs/ncurses required by (app-admin/eselect-1.4.4:0/0::gentoo,
installed
    >=sys-libs/ncurses-5.2-r2 required by
(app-shells/bash-4.3_p39:0/0::gentoo,
    >=sys-libs/ncurses-5.2 required by (sys-apps/less-478:0/0::gentoo,
installed
    >=sys-libs/ncurses-5.2-r2 required by
(sys-apps/texinfo-5.2:0/0::gentoo, ins
    sys-libs/ncurses required by
(app-emulation/libvirt-1.2.15-r1:0/1.2.15::gent
    >=sys-libs/ncurses-5.2 required by
(dev-lang/python-3.4.1:3.4/3.4::gentoo, i
    >=sys-libs/ncurses-5.2-r2 required by
(app-editors/vim-7.4.273:0/0::gentoo,
    >=sys-libs/ncurses-5.7-r7 required by
(sys-process/psmisc-22.21-r2:0/0::gent
    >=sys-libs/ncurses-5.7-r7[unicode?]
(>=sys-libs/ncurses-5.7-r7[unicode]) req
   
>=sys-libs/ncurses-5.9-r3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_
_s390_32(-)?,abi_s390_64(-)?] (>=sys-libs/ncurses-5.9-r3[abi_x86_64(-)])
require
    sys-libs/ncurses:5/5= required by (dev-util/cmake-3.2.2:0/0::gentoo,
install
    sys-libs/ncurses:5/5= required by (sys-apps/openrc-0.17:0/0::gentoo,
install
    sys-libs/ncurses:5/5= required by
(dev-scheme/guile-1.8.8-r1:12/12::gentoo,


For more information about Blocked Packages, please refer to the
following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages

srv ~ #

bzw.:

srv ~ # emerge --update --deep --with-bdeps=y --newuse @world
Calculating dependencies... done!
[ebuild  NS    ] sys-libs/ncurses-5.9-r3 [5.9-r101] USE="cxx unicode
-ada -debug -doc -gpm -minimal -profile -static-libs -tinfo -trace"
ABI_X86="(64) -32 (-x32
)"
[ebuild     U  ] dev-libs/libnl-3.2.26 [3.2.25]
[ebuild     U  ] dev-libs/openssl-1.0.2d [1.0.1p] USE="asm%* -sctp%"
[ebuild     U  ] dev-perl/Net-SSLeay-1.650.0-r1 [1.650.0]
[ebuild     U  ] app-vim/gentoo-syntax-20150823 [20130619]
[blocks B      ] <sys-libs/ncurses-6:0 ("<sys-libs/ncurses-6:0" is
blocking sys-libs/ncurses-5.9-r101)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-libs/ncurses-5.9-r3:0/0::gentoo, ebuild scheduled for merge)
pulled in by
    sys-libs/ncurses:0= required by
(app-emulation/qemu-2.3.0-r5:0/0::gentoo, installed)
    sys-libs/ncurses:0= required by (sys-apps/openrc-0.17:0/0::gentoo,
installed)
    sys-libs/ncurses:0= required by (dev-util/cmake-3.2.2:0/0::gentoo,
installed)
    sys-libs/ncurses:0= required by
(dev-scheme/guile-1.8.8-r1:12/12::gentoo, installed)

  (sys-libs/ncurses-5.9-r101:5/5::gentoo, installed) pulled in by
    sys-libs/ncurses:5/5= required by
(app-emulation/qemu-2.3.0-r5:0/0::gentoo, installed)
    sys-libs/ncurses required by @selected
    >=sys-libs/ncurses-5.2 required by
(dev-lang/python-2.7.9-r1:2.7/2.7::gentoo, installed)
    sys-libs/ncurses required by (sys-devel/gettext-0.19.4:0/0::gentoo,
installed)
    >=sys-libs/ncurses-5.7-r7 required by
(sys-process/psmisc-22.21-r2:0/0::gentoo, installed)
    sys-libs/ncurses required by
(net-misc/telnet-bsd-1.2-r1:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2 required by
(sys-devel/bc-1.06.95-r1:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2 required by
(sys-apps/util-linux-2.25.2-r2:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2 required by
(sys-kernel/gentoo-sources-4.0.5:4.0.5/4.0.5::gentoo, installed)
    sys-libs/ncurses required by (app-admin/eselect-1.4.4:0/0::gentoo,
installed)
    >=sys-libs/ncurses-5.2-r2 required by
(app-shells/bash-4.3_p39:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2 required by (sys-apps/less-478:0/0::gentoo,
installed)
    >=sys-libs/ncurses-5.2-r2 required by
(sys-apps/texinfo-5.2:0/0::gentoo, installed)
    sys-libs/ncurses required by
(app-emulation/libvirt-1.2.15-r1:0/1.2.15::gentoo, installed)
    >=sys-libs/ncurses-5.2 required by
(dev-lang/python-3.4.1:3.4/3.4::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2 required by
(app-editors/vim-7.4.273:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r5 required by
(sys-boot/grub-2.02_beta2-r7:2/2::gentoo, installed)
   
>=sys-libs/ncurses-5.9-r3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi
_s390_32(-)?,abi_s390_64(-)?] (>=sys-libs/ncurses-5.9-r3[abi_x86_64(-)])
required by (sys-libs/readline-6.3_p8-r2:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.7-r7[unicode?]
(>=sys-libs/ncurses-5.7-r7[unicode]) required by
(sys-process/procps-3.3.9-r2:0/0::gentoo, installed)
    sys-libs/ncurses:5/5= required by (dev-util/cmake-3.2.2:0/0::gentoo,
installed)
    sys-libs/ncurses:5/5= required by (sys-apps/openrc-0.17:0/0::gentoo,
installed)
    sys-libs/ncurses:5/5= required by
(dev-scheme/guile-1.8.8-r1:12/12::gentoo, installed)


For more information about Blocked Packages, please refer to the
following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages

srv ~ #

Ich verstehe so viel, dass sich irgendwie zwei Versionen von
sys-libs/ncurses in die Quere kommen, aber obwohl ich mir die
angesprochene Wiki-Page angesehen habe, hilft mir das nicht wirklich
weiter.

Hat jemand einen Tipp, was hier zu tun ist?

Ciao und danke,

  Christian


signature.asc (180 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Probleme mit emerge und geblockten Paketen

Marco Ziebell
Morgen,

das Problem ist bekannt, siehe[1]. Du musst nochmal ein "emerge --sync"
durchführen. Wenn du das Paket ncurses-5.9-r99 siehst, kannst du das
update problemlos durchführen.

Es kann sein dass deine Quelle, von der syncs, das "etwas" später
kriegt. Könnte also etwas dauern.

Viel Erfolg




[1] https://bugs.gentoo.org/show_bug.cgi?id=558856

Reply | Threaded
Open this post in threaded view
|

Re: Probleme mit emerge und geblockten Paketen

Christian Schoepplein
Hallo,

danke erstmal für Eure Tipps!

On Fri, Aug 28, 2015 at 06:52:46AM +0200, Marco Ziebell wrote:
>das Problem ist bekannt, siehe[1]. Du musst nochmal ein "emerge --sync"
>durchführen. Wenn du das Paket ncurses-5.9-r99 siehst, kannst du das
>update problemlos durchführen.

Sollte eigentlich jetzt der Fall sein, es ist sogar eine neuere Version
da:

srv sys-libs # pwd
/var/db/pkg/sys-libs
srv sys-libs # ls | grep ncurses
ncurses-5.9-r101
srv sys-libs #

Trotzdem geht nichts weiter mit dem Update :-(.

srv ~ # emerge --update --ask --deep --with-bdeps=y --newuse @system

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  NS    ] sys-libs/ncurses-5.9-r5 [5.9-r101] USE="cxx unicode
-ada -debug -doc -gpm -minimal -profile -static-libs -tinfo -trace"
ABI_X86="(64) -32 (-x32
)"
[ebuild     U  ] dev-libs/openssl-1.0.2d [1.0.1p] USE="asm%* -sctp%"
[blocks B      ] <sys-libs/ncurses-6:0 ("<sys-libs/ncurses-6:0" is
blocking sys-libs/ncurses-5.9-r101)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-libs/ncurses-5.9-r101:5/5::gentoo, installed) pulled in by
    sys-libs/ncurses:5/5= required by
(app-emulation/qemu-2.3.0-r5:0/0::gentoo, installed)
    sys-libs/ncurses required by @selected
    >=sys-libs/ncurses-5.2 required by
(dev-lang/python-2.7.9-r1:2.7/2.7::gentoo, installed)
    sys-libs/ncurses required by (sys-devel/gettext-0.19.4:0/0::gentoo,
installed)
    >=sys-libs/ncurses-5.2-r5 required by
(sys-boot/grub-2.02_beta2-r7:2/2::gentoo, installed)
    >=sys-libs/ncurses-5.9-r1[unicode?]
(>=sys-libs/ncurses-5.9-r1[unicode]) required by
(app-editors/nano-2.3.6:0/0::gentoo, installed)
    sys-libs/ncurses required by
(net-misc/telnet-bsd-1.2-r1:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2 required by
(sys-devel/bc-1.06.95-r1:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2 required by
(sys-apps/util-linux-2.25.2-r2:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2 required by
(sys-kernel/gentoo-sources-4.0.5:4.0.5/4.0.5::gentoo, installed)
    sys-libs/ncurses required by (app-admin/eselect-1.4.4:0/0::gentoo,
installed)
    >=sys-libs/ncurses-5.2-r2 required by
(app-shells/bash-4.3_p39:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2 required by (sys-apps/less-478:0/0::gentoo,
installed)
    >=sys-libs/ncurses-5.2-r2 required by
(sys-apps/texinfo-5.2:0/0::gentoo, installed)
    sys-libs/ncurses required by
(app-emulation/libvirt-1.2.15-r1:0/1.2.15::gentoo, installed)
    >=sys-libs/ncurses-5.2 required by
(dev-lang/python-3.4.1:3.4/3.4::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2 required by
(app-editors/vim-7.4.273:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.7-r7 required by
(sys-process/psmisc-22.21-r2:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.7-r7[unicode?]
(>=sys-libs/ncurses-5.7-r7[unicode]) required by
(sys-process/procps-3.3.9-r2:0/0::gentoo, installed)
   
>=sys-libs/ncurses-5.9-r3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi
_s390_32(-)?,abi_s390_64(-)?] (>=sys-libs/ncurses-5.9-r3[abi_x86_64(-)])
required by (sys-libs/readline-6.3_p8-r2:0/0::gentoo, installed)
    sys-libs/ncurses:5/5= required by (dev-util/cmake-3.2.2:0/0::gentoo,
installed)
    sys-libs/ncurses:5/5= required by (sys-apps/openrc-0.17:0/0::gentoo,
installed)
    sys-libs/ncurses:5/5= required by
(dev-scheme/guile-1.8.8-r1:12/12::gentoo, installed)

  (sys-libs/ncurses-5.9-r5:0/5::gentoo, ebuild scheduled for merge)
pulled in by
    sys-libs/ncurses:0= required by
(app-emulation/qemu-2.3.0-r5:0/0::gentoo, installed)
    sys-libs/ncurses:0= required by (sys-apps/openrc-0.17:0/0::gentoo,
installed)
    sys-libs/ncurses:0= required by (dev-util/cmake-3.2.2:0/0::gentoo,
installed)
    sys-libs/ncurses:0= required by
(dev-scheme/guile-1.8.8-r1:12/12::gentoo, installed)


For more information about Blocked Packages, please refer to the
following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages

srv ~ #

Irgendwas scheint auch generell mit ncurses kaputt zu sein,
wharscheinlich durh meine viele und unbedarfte Rumprobiererei in den
letzten Tagen. Wenn ich ein

emerge --update --ask @world

ausführe, soll vim aktualisiert werden. Die Übersetzung bricht jedoch
mit folgender Fehlermeldung im Log ab:

no terminal library found
checking for tgetent()... configure: error: NOT FOUND!
      You need to install a terminal library; for example ncurses.

Keine Ahnung, was da los ist, denn eigentlich bin ich schon der Meinung,
dass ncurses installiert ist:

srv ~ # emerge --search ncurses

...

*  sys-libs/ncurses
      Latest version available: 5.9-r101
      Latest version installed: 5.9-r101
      Size of files: 2.761 KiB
      Homepage:      https://www.gnu.org/software/ncurses/ 
http://dickey.his.com/ncurses/
      Description:   console display library
      License:       MIT

...

srv ~ #

Viele Programme verhalten sich auch recht seltsam, beim Aufruf von less
kommt z.B. erstmal die Meldung "WARNING: terminal is not fully
functional", vi lässt sich kaum mehr nutzen und nano startet gleich gar
nicht mehr und bricht mit der folgenden Meldung ab: "Error opening
terminal: linux."

Irgendwas scheint da also kaputt zu sein, vielleicht ist das ja auch der
Grund dafür, dass das Update gerade nicht geht.

Habt ihr denn noch Tipps?

Sorry übrigens für die vielleicht etwas doofen Fragen, aber emerge und
portage finde ich als Anfänger echt schwer zu durchblicken und wenns
dann gleich Probleme gibt, wirds nicht wirklich einfacher :-(.

Ciao und danke,

  Christian


Reply | Threaded
Open this post in threaded view
|

Re: Probleme mit emerge und geblockten Paketen

Peter Weilbacher
Hallo Christian,

On Sat, 29 Aug 2015, Christian Schoepplein wrote:

> On Fri, Aug 28, 2015 at 06:52:46AM +0200, Marco Ziebell wrote:
> >das Problem ist bekannt, siehe[1]. Du musst nochmal ein "emerge --sync"
> >durchführen. Wenn du das Paket ncurses-5.9-r99 siehst, kannst du das
> >update problemlos durchführen.
>
> Sollte eigentlich jetzt der Fall sein, es ist sogar eine neuere Version
> da:
>
> srv sys-libs # pwd
> /var/db/pkg/sys-libs
> srv sys-libs # ls | grep ncurses
> ncurses-5.9-r101
> srv sys-libs #

Sowas wird einfacher, wenn Du app-portage/gentoolkit installierst. Dann
gibt's das equery-Kommando. |equery l ncurses| sagt Dir dann, was
installiert ist.

Das ist übrigens nicht -r99, das Marco erwähnt hatte, aber ich kenne
mich mit der näheren Problematik dieses Paketes auch nicht aus.

> Trotzdem geht nichts weiter mit dem Update :-(.
>
> srv ~ # emerge --update --ask --deep --with-bdeps=y --newuse @system
>
> These are the packages that would be merged, in order:
>
> Calculating dependencies... done!
> [ebuild  NS    ] sys-libs/ncurses-5.9-r5 [5.9-r101] USE="cxx unicode -ada -debug -doc -gpm -minimal -profile -static-libs -tinfo -trace" ABI_X86="(64) -32 (-x32)"
> [ebuild     U  ] dev-libs/openssl-1.0.2d [1.0.1p] USE="asm%* -sctp%"
> [blocks B      ] <sys-libs/ncurses-6:0 ("<sys-libs/ncurses-6:0" is blocking sys-libs/ncurses-5.9-r101)
>
>  * Error: The above package list contains packages which cannot be
>  * installed at the same time on the same system.
>
>   (sys-libs/ncurses-5.9-r101:5/5::gentoo, installed) pulled in by
>     sys-libs/ncurses:5/5= required by

Diese und die vielen folgenden Zeilen finde ich auch immer sehr
irritierend (und tatsächlich nie hilfreich), insofern kann ich Deine
Verwirrung gut nachvollziehen.

Aber wie kommen bei Dir ncurses-5.9-r101 und -6.0 ins Spiel? Die sind
laut |equery m ncurses| "keyworded". 5.9-r99 ist die letzte stabile
Version. Oder hast Du ein "unstable" System (~amd64 o.ä.) installiert?
Das wäre gerade für einen Gentoo Neuling nicht gerade ideal.

   Peter.

Reply | Threaded
Open this post in threaded view
|

Re: Probleme mit emerge und geblockten Paketen

Marco Ziebell
Aus Gründen die ich nicht kenne hat das NCURSES paket einen SLOT
bekommen - SLOT=5. Das neuere Paket 5.9-r100:5 hat am Anfang alle
anderen Versionen die nicht SLOT=5 waren geblockt.
Da es aber immer noch Abhängigkeiten zu dem default-SLOT SLOT=0
gibt/gab konnte die NCURSES Version 5.9-r100 bzw. 5.9-r101 nicht
installiert werden.

Mit der Version 5.9-r99 ist das Problem behoben. Diese Version meldet
sich "so zu sagen" als SLOT=5 und SLOT=0. Deswegen ist es wichtig das
du so wartest und "emerge --sync" aufrufst bist du das Paket
ncurses-5.9-r99 siehst. Bei dem Spiel darfst du deine KEYWORDS aber
nicht vergessen!

Ich hoffe ich konnte helfen und habe nicht zu viele verwirrt.



Grüße


Marco

attachment0 (484 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Probleme mit emerge und geblockten Paketen

Randy Andy
In reply to this post by Peter Weilbacher
Hi Christian,

falls Du deine Blocker noch nicht auflösen konntest, versuch einfach
mal dein emerge Kommando mit --backtrack=150 oder größer zu ergänzen.
Damit klappt das häufig schon automatisch, erst danach würde ich zur
Holzhammer-Methode greifen.
Bei dieser deinstalliert/installiert man
Blocks händisch und repariert/rekompiliert anschließend eventuell
gebrochene Abhängigkeiten, z.B. mit emerge @preserved-rebuild.
Doch auch hier gilt es stets mit Bedacht und eingeschaltetem Verstand
zu arbeiten,  sprich keine Systemrelevanten Pakete zu deinstallieren
oder einen Neustart zu machen, bevor diese nicht wieder installiert
wurden.

Viel Erfolg, Andy.

Reply | Threaded
Open this post in threaded view
|

Re: Probleme mit emerge und geblockten Paketen

Christian Schoepplein
Hallo zusammen,

erst nochmal vielen Dank für all eure Tipps!

On Sun, Aug 30, 2015 at 03:01:39PM +0200, Randy Andy wrote:
>falls Du deine Blocker noch nicht auflösen konntest, versuch einfach
>mal dein emerge Kommando mit --backtrack=150 oder größer zu ergänzen.

Ich konnte die Geschichte gestern mit Hilfe eines Bekannten, der schon
länger Gentoo nutzt, zum Glück lösen *freu* :-).

Das Problem war, dass ich, wahrscheinlich durch irgendeinen
emerge-Aufruf, Keywords gesetzt hatte und auch in package.mask
irgendwelche Einträge vorhanden waren. Wie die dort hingekommen sind,
weiß ich nicht, wissentlich habe ich das nicht gemacht...

Wir haben diese Dinge entfernt und anschließend ließen sich alle Updates
installieren und ich bin jetzt wieder beruhigt und zufrieden :-).

Viele Grüße und vielen Dank nochmal,

  Christian