Problems updating Qt from 4.8.6 to 4.8.7

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Problems updating Qt from 4.8.6 to 4.8.7

Sebastian Pipping-5
Hi there!


I'm having trouble updating Qt:4 (dev-qt/qt*-4.8*:4) from 4.8.6 to 4.8.7.
Looking at the ebuilds, they require some 4.8.7 versions to be installed
already that in turn cannot be installed because other ebuilds require
4.8.6 while not yet upgraded.

I am running the latest version of portage.  Is there some trick I
should know about or am I stuck with Qt 4.8.6 on that box forever?  How
did you update?

Thanks for your help, best,



S

Reply | Threaded
Open this post in threaded view
|

Re: Problems updating Qt from 4.8.6 to 4.8.7

Alexandre Rostovtsev-2
On Sun, 2015-07-05 at 20:25 +0200, Sebastian Pipping wrote:

> Hi there!
>
>
> I'm having trouble updating Qt:4 (dev-qt/qt*-4.8*:4) from 4.8.6 to 4.8.7.
> Looking at the ebuilds, they require some 4.8.7 versions to be installed
> already that in turn cannot be installed because other ebuilds require
> 4.8.6 while not yet upgraded.
>
> I am running the latest version of portage.  Is there some trick I
> should know about or am I stuck with Qt 4.8.6 on that box forever?  How
> did you update?

What I usually end up doing is listing my installed dev-qt/qt* ebuilds, and
updating all of them together explicitly:

emerge -1 qtcore:4 qtgui:4 qtsql:4 etc.

Alternatively, just try "emerge --update --deep world" - it probably should
work if you have a consistent, complete and updateable world set.

Reply | Threaded
Open this post in threaded view
|

Re: Problems updating Qt from 4.8.6 to 4.8.7

Sebastian Pipping-5
On 05.07.2015 20:44, Alexandre Rostovtsev wrote:
> What I usually end up doing is listing my installed dev-qt/qt* ebuilds, and
> updating all of them together explicitly:
>
> emerge -1 qtcore:4 qtgui:4 qtsql:4 etc.

That's what I tried but it doesn't seem to work with this update.

Looking at the dependencies of qtgui

  dev-qt/qtgui-4.8.6-r4
    DEPEND
      ~dev-qt/qtcore-4.8.6

  dev-qt/qtgui-4.8.7
    DEPEND
      ~dev-qt/qtcore-4.8.7

I really wonder if there is any update path from having

  dev-qt/qtcore-4.8.6-r2
  dev-qt/qtgui-4.8.6-r4

installed before to

  dev-qt/qtcore-4.8.7
  dev-qt/qtgui-4.8.7

after.  Right now, it looks like I have to use "emerge -C .." to
un-install them completely, temporary breaking Qt and installing 4.8.7
fresh.  I'm still hoping for some way to not needing to do that.


> Alternatively, just try "emerge --update --deep world" - it probably should
> work if you have a consistent, complete and updateable world set.

That's where I'm coming from.  It doesn't stop complaining because of Qt.

Best,



Sebastian


Reply | Threaded
Open this post in threaded view
|

Re: Problems updating Qt from 4.8.6 to 4.8.7

Ben Kohler

On Sun, Jul 5, 2015 at 2:25 PM, Sebastian Pipping <[hidden email]> wrote:

I really wonder if there is any update path from having

  dev-qt/qtcore-4.8.6-r2
  dev-qt/qtgui-4.8.6-r4

installed before to

  dev-qt/qtcore-4.8.7
  dev-qt/qtgui-4.8.7



Usually this kind of conflict happens when for SOME reason, at least one part of the dev-qt/*:4 collection is not being pulled into the depgraph, like if there's one qt* package which is now orphaned/depcleanable.  If even one piece is not pulled into the dep list, it will try to hold all the rest of the pieces back at 4.8.6.

Something like this may help, to just force all installed qt4 pieces to upgrade, regardless of whether they are deps of anything:

emerge -1av $(qlist -ICS dev-qt/ | grep 4$)

Another possibility for a conflict is if you have some package.use entries for dev-qt/ that are too version specific, where the upgraded 4.8.7 version of some component would not meet the USE requirements of some reverse dep.  Then it'd lock that one component at 4.8.6 and again it's game-over for the upgrade.

Hope this helps,
Ben Kohler
(iamben @ Freenode)
Reply | Threaded
Open this post in threaded view
|

Re: Problems updating Qt from 4.8.6 to 4.8.7

Alexandre Rostovtsev-2
In reply to this post by Sebastian Pipping-5
On Sun, 2015-07-05 at 21:25 +0200, Sebastian Pipping wrote:

> On 05.07.2015 20:44, Alexandre Rostovtsev wrote:
> > What I usually end up doing is listing my installed dev-qt/qt* ebuilds, and
> > updating all of them together explicitly:
> >
> > emerge -1 qtcore:4 qtgui:4 qtsql:4 etc.
>
> That's what I tried but it doesn't seem to work with this update.
>
> Looking at the dependencies of qtgui
>
>   dev-qt/qtgui-4.8.6-r4
>     DEPEND
>       ~dev-qt/qtcore-4.8.6
>
>   dev-qt/qtgui-4.8.7
>     DEPEND
>       ~dev-qt/qtcore-4.8.7
>

I don't think that DEPEND would block an update unless --with-bdeps=y

Reply | Threaded
Open this post in threaded view
|

Re: Problems updating Qt from 4.8.6 to 4.8.7

Ben de Groot-2
In reply to this post by Sebastian Pipping-5
On 6 July 2015 at 03:25, Sebastian Pipping <[hidden email]> wrote:

> On 05.07.2015 20:44, Alexandre Rostovtsev wrote:
>> What I usually end up doing is listing my installed dev-qt/qt* ebuilds, and
>> updating all of them together explicitly:
>>
>> emerge -1 qtcore:4 qtgui:4 qtsql:4 etc.
>
> That's what I tried but it doesn't seem to work with this update.
>
> Looking at the dependencies of qtgui
>
>   dev-qt/qtgui-4.8.6-r4
>     DEPEND
>       ~dev-qt/qtcore-4.8.6
>
>   dev-qt/qtgui-4.8.7
>     DEPEND
>       ~dev-qt/qtcore-4.8.7
>
> I really wonder if there is any update path from having
>
>   dev-qt/qtcore-4.8.6-r2
>   dev-qt/qtgui-4.8.6-r4
>
> installed before to
>
>   dev-qt/qtcore-4.8.7
>   dev-qt/qtgui-4.8.7
>
> after.  Right now, it looks like I have to use "emerge -C .." to
> un-install them completely, temporary breaking Qt and installing 4.8.7
> fresh.  I'm still hoping for some way to not needing to do that.
>
>
>> Alternatively, just try "emerge --update --deep world" - it probably should
>> work if you have a consistent, complete and updateable world set.
>
> That's where I'm coming from.  It doesn't stop complaining because of Qt.
>
> Best,
>
>
>
> Sebastian
>
>

See also https://wiki.gentoo.org/wiki/Qt/FAQ#Why_do_I_get_blockers_when_trying_to_emerge_Qt.3F

--
Cheers,

Ben | yngwin
Gentoo developer