Python Abhängigkeiten

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Python Abhängigkeiten

Sebastian
Hallo,

Ich bekomme meine Abhängigkeiten bezüglich python nicht hin.
Beim Update erhalte ich folgende Meldung:

l1-gentoo /home/sebastian # emerge -avuND world

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The ebuild selected to satisfy ">=app-text/asciidoc-8.6.0" has unmet
requirements.
- app-text/asciidoc-8.6.10::gentoo USE="-examples -graphviz -highlight -test"
ABI_X86="(64)" PYTHON_SINGLE_TARGET="(-pypy) -python2_7"
PYTHON_TARGETS="python2_7 (-pypy)"

  The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( python_single_target_pypy python_single_target_python2_7
)

  The above constraints are a subset of the following complete expression:
    exactly-one-of ( python_single_target_pypy python_single_target_python2_7
) python_single_target_pypy? ( python_targets_pypy )
python_single_target_python2_7? ( python_targets_python2_7 )

(dependency required by "sys-fs/btrfs-progs-4.10.2::gentoo" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

In der Make conf habe ich schon verschiedenes Ausprobiert aber egal wie irgend
ein Program hat immer ein Problem mit der Python Einstellung. So wie jetzt
lief immerhin ein Emerge avuND @system durch.

Make conf Auszug:

PYTHON_TARGETS="python2_7 python3_5 python3_6"
PYTHON_SINGLE_TARGET="python3_6"

Wie kann ich das Problem näher eingrenzen und lösen?

Lieben Gruß
Sebastian



Reply | Threaded
Open this post in threaded view
|

Re: Python Abhängigkeiten

Juergen Rose
On Mon, 2018-08-13 at 12:15 +0200, Sebastian wrote:

> Hallo,
>
> Ich bekomme meine Abhängigkeiten bezüglich python nicht hin.
> Beim Update erhalte ich folgende Meldung:
>
> l1-gentoo /home/sebastian # emerge -avuND world
>
> These are the packages that would be merged, in order:
>
> Calculating dependencies... done!
>
> !!! The ebuild selected to satisfy ">=app-text/asciidoc-8.6.0" has
> unmet
> requirements.
> - app-text/asciidoc-8.6.10::gentoo USE="-examples -graphviz
> -highlight -test"
> ABI_X86="(64)" PYTHON_SINGLE_TARGET="(-pypy)
> -python2_7"
> PYTHON_TARGETS="python2_7 (-pypy)"
Wenn ich das richtig verstehe hast Du weder ein
PYTHON_SINGLE_TARGET=pypy noch ein PYTHON_SINGLE_TARGET=python2_7
fuer asciidoc-8.6.10 definiert.

>   The following REQUIRED_USE flag constraints are unsatisfied:
>     exactly-one-of ( python_single_target_pypy
> python_single_target_python2_7
> )

Genau eins dieser beiden Targets sollst Du definieren.

>   The above constraints are a subset of the following complete
> expression:
>     exactly-one-of ( python_single_target_pypy
> python_single_target_python2_7
> ) python_single_target_pypy? ( python_targets_pypy )
> python_single_target_python2_7? ( python_targets_python2_7 )
>
> (dependency required by "sys-fs/btrfs-progs-4.10.2::gentoo"
> [installed])
> (dependency required by "@selected" [set])
> (dependency required by "@world" [argument])
Ich definiere das PYTHON_SINGLE_TARGET python2_7 fuer asciidoc-8.6.10
in /etc/portage/packages.use mit der Zeile:

=app-text/asciidoc-8.6.10 python_single_target_python2_7

> In der Make conf habe ich schon verschiedenes Ausprobiert aber egal
> wie irgend
> ein Program hat immer ein Problem mit der Python Einstellung. So wie
> jetzt
> lief immerhin ein Emerge avuND @system durch.
>
> Make conf Auszug:
>
> PYTHON_TARGETS="python2_7 python3_5 python3_6"
> PYTHON_SINGLE_TARGET="python3_6"
>
> Wie kann ich das Problem näher eingrenzen und lösen?
>
> Lieben Gruß
> Sebastian

Beste Gruesse
Juergen

signature.asc (849 bytes) Download Attachment