Python / spyder

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Python / spyder

Stefan Nowy
Hallo!

Ich möchte spyder emergen, habe aber wohl ein Problem mit den python
targets:

emerge -pv spyder

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy
">=dev-python/rope-0.9.3[python_targets_python2_6(-)?,python_targets_python2_7(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-)]".
!!! One of the following packages is required to complete your request:
- dev-python/spyder-2.2.1::gentoo (Change USE:
-python_targets_python2_7, this change violates use flag constraints
defined by dev-python/spyder-2.2.1: 'any-of ( python_targets_python2_6
python_targets_python2_7 )')
(dependency required by "dev-python/spyder-2.2.1" [ebuild])
(dependency required by "spyder" [argument])


laut emerge --info habe ich:
PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7"

und eselect python list:
Available Python interpreters:
  [1]   python2.7 *
  [2]   python3.2


Ich habe schon einiges getestet, allerdings schaffe ich es nicht spyder
bzw. die abhängigen Pakete zu emergen...

Hat jemand eine Idee?

Danke und viele Grüße
Stefan


signature.asc (919 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Python / spyder

Marc Joliet
Am Sun, 11 Aug 2013 15:02:56 +0200
schrieb Stefan Nowy <[hidden email]>:

> Hallo!

Hallo,

> Ich möchte spyder emergen, habe aber wohl ein Problem mit den python
> targets:
>
> emerge -pv spyder
>
> These are the packages that would be merged, in order:
>
> Calculating dependencies... done!
>
> emerge: there are no ebuilds built with USE flags to satisfy
> ">=dev-python/rope-0.9.3[python_targets_python2_6(-)?,python_targets_python2_7(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-)]".
> !!! One of the following packages is required to complete your request:
> - dev-python/spyder-2.2.1::gentoo (Change USE:
> -python_targets_python2_7, this change violates use flag constraints
> defined by dev-python/spyder-2.2.1: 'any-of ( python_targets_python2_6
> python_targets_python2_7 )')
> (dependency required by "dev-python/spyder-2.2.1" [ebuild])
> (dependency required by "spyder" [argument])
>
>
> laut emerge --info habe ich:
> PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7"
>
> und eselect python list:
> Available Python interpreters:
>   [1]   python2.7 *
>   [2]   python3.2
>
>
> Ich habe schon einiges getestet, allerdings schaffe ich es nicht spyder
> bzw. die abhängigen Pakete zu emergen...
>
> Hat jemand eine Idee?
Mir scheint es, du benötigst die aktuellste ~arch Version von rope, denn nur
diese macht Gebrauch von den neuen Python Eclassen, kann also überhaupt die
USE-Abhängigkeiten erfüllen:

>> (0) % eix -e rope -l
[I] dev-python/rope
     Available versions:  
                0.9.3 {tbz2}
        (~) 0.9.4 {tbz2}
        (~) 0.9.4-r1 {tbz2} [python_targets_python2_5 python_targets_python2_6 python_targets_python2_7]
[...]

> Danke und viele Grüße
> Stefan

Gruß
--
Marc Joliet
--
"People who think they know everything really annoy those of us who know we
don't" - Bjarne Stroustrup

signature.asc (205 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Python / spyder

Stefan Nowy
Am 11.08.2013 16:09, schrieb Marc Joliet:
> Mir scheint es, du benötigst die aktuellste ~arch Version von rope, denn nur
> diese macht Gebrauch von den neuen Python Eclassen, kann also überhaupt die
> USE-Abhängigkeiten erfüllen:


Danke, das war's. Gleiches auch noch für weitere Pakete...

Viele Grüße
Stefan



signature.asc (919 bytes) Download Attachment