[RFC] >=udev-217 or >=eudev-2.1 upgrade news item

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

[RFC] >=udev-217 or >=eudev-2.1 upgrade news item

Samuli Suominen-4
request for review before committing, suggestions welcome since it's
rather short what
i got to say

thanks,
Samuli

2014-10-29-udev-upgrade.en.txt (744 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [RFC] >=udev-217 or >=eudev-2.1 upgrade news item

Alex Xu
On 29/10/14 07:28 AM, Samuli Suominen wrote:
> request for review before committing, suggestions welcome since it's
> rather short what
> i got to say
>
> thanks,
> Samuli
>

typical news items are in the format "<packages> no longer/now do
<thing>. [<thing> is <description of <thing>>.] if you need <thing>, do
<steps>. if you do not need <thing>, do <steps>."

[blah blah metadata, I hereby assign all copyright for the following
text to the Gentoo Foundation]

sys-fs/udev-217 and sys-fs/eudev-2.1 no longer provide a userspace
firmware loader. If you require firmware loading support, you must use
kernel 3.7 or greater with CONFIG_FW_LOADER_USER_HELPER=n. No action is
required if none of your kernel modules need firmware. See [1] for more
information on the upgrade.

[1]: https://wiki.gentoo.org/wiki/Udev/upgrade#udev_216_to_217


signature.asc (836 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [RFC] >=udev-217 or >=eudev-2.1 upgrade news item

Samuli Suominen-4

On 29/10/14 13:42, Alex Xu wrote:

> On 29/10/14 07:28 AM, Samuli Suominen wrote:
>> request for review before committing, suggestions welcome since it's
>> rather short what
>> i got to say
>>
>> thanks,
>> Samuli
>>
> typical news items are in the format "<packages> no longer/now do
> <thing>. [<thing> is <description of <thing>>.] if you need <thing>, do
> <steps>. if you do not need <thing>, do <steps>."
>
> [blah blah metadata, I hereby assign all copyright for the following
> text to the Gentoo Foundation]
>
> sys-fs/udev-217 and sys-fs/eudev-2.1 no longer provide a userspace
> firmware loader. If you require firmware loading support, you must use
> kernel 3.7 or greater with CONFIG_FW_LOADER_USER_HELPER=n. No action is
> required if none of your kernel modules need firmware. See [1] for more
> information on the upgrade.
>
> [1]: https://wiki.gentoo.org/wiki/Udev/upgrade#udev_216_to_217
>

I'll use your text. So, futher reviews should be aimed at this text.

I've never been a documentation type of guy, my grammar, quite likely,
sucks balls.

- Samuli

Reply | Threaded
Open this post in threaded view
|

Re: [RFC] >=udev-217 or >=eudev-2.1 upgrade news item

Samuli Suominen-4
In reply to this post by Alex Xu

On 29/10/14 13:42, Alex Xu wrote:

> On 29/10/14 07:28 AM, Samuli Suominen wrote:
>> request for review before committing, suggestions welcome since it's
>> rather short what
>> i got to say
>>
>> thanks,
>> Samuli
>>
> typical news items are in the format "<packages> no longer/now do
> <thing>. [<thing> is <description of <thing>>.] if you need <thing>, do
> <steps>. if you do not need <thing>, do <steps>."
>
> [blah blah metadata, I hereby assign all copyright for the following
> text to the Gentoo Foundation]
>
> sys-fs/udev-217 and sys-fs/eudev-2.1 no longer provide a userspace
> firmware loader. If you require firmware loading support, you must use
> kernel 3.7 or greater with CONFIG_FW_LOADER_USER_HELPER=n. No action is
> required if none of your kernel modules need firmware. See [1] for more
> information on the upgrade.
>
> [1]: https://wiki.gentoo.org/wiki/Udev/upgrade#udev_216_to_217
>

The news item has been committed today. :-)

Sorry for the delay. I'm running out of excuses with my health issues. :-(

Thanks and sorry,
Samuli

Reply | Threaded
Open this post in threaded view
|

Re: [RFC] >=udev-217 or >=eudev-2.1 upgrade news item

Alex Xu
On 07/11/14 07:13 AM, Samuli Suominen wrote:

>
> On 29/10/14 13:42, Alex Xu wrote:
>> On 29/10/14 07:28 AM, Samuli Suominen wrote:
>>> request for review before committing, suggestions welcome since it's
>>> rather short what
>>> i got to say
>>>
>>> thanks,
>>> Samuli
>>>
>> typical news items are in the format "<packages> no longer/now do
>> <thing>. [<thing> is <description of <thing>>.] if you need <thing>, do
>> <steps>. if you do not need <thing>, do <steps>."
>>
>> [blah blah metadata, I hereby assign all copyright for the following
>> text to the Gentoo Foundation]
>>
>> sys-fs/udev-217 and sys-fs/eudev-2.1 no longer provide a userspace
>> firmware loader. If you require firmware loading support, you must use
>> kernel 3.7 or greater with CONFIG_FW_LOADER_USER_HELPER=n. No action is
>> required if none of your kernel modules need firmware. See [1] for more
>> information on the upgrade.
>>
>> [1]: https://wiki.gentoo.org/wiki/Udev/upgrade#udev_216_to_217
>>
>
> The news item has been committed today. :-)
>
> Sorry for the delay. I'm running out of excuses with my health issues. :-(
>
> Thanks and sorry,
> Samuli
>
oh, I just figured something. what about systemd? looks like
IUSE=firmware-loader was removed in 217.


signature.asc (836 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [RFC] >=udev-217 or >=eudev-2.1 upgrade news item

Samuli Suominen-4

On 07/11/14 14:21, Alex Xu wrote:

> On 07/11/14 07:13 AM, Samuli Suominen wrote:
>> On 29/10/14 13:42, Alex Xu wrote:
>>> On 29/10/14 07:28 AM, Samuli Suominen wrote:
>>>> request for review before committing, suggestions welcome since it's
>>>> rather short what
>>>> i got to say
>>>>
>>>> thanks,
>>>> Samuli
>>>>
>>> typical news items are in the format "<packages> no longer/now do
>>> <thing>. [<thing> is <description of <thing>>.] if you need <thing>, do
>>> <steps>. if you do not need <thing>, do <steps>."
>>>
>>> [blah blah metadata, I hereby assign all copyright for the following
>>> text to the Gentoo Foundation]
>>>
>>> sys-fs/udev-217 and sys-fs/eudev-2.1 no longer provide a userspace
>>> firmware loader. If you require firmware loading support, you must use
>>> kernel 3.7 or greater with CONFIG_FW_LOADER_USER_HELPER=n. No action is
>>> required if none of your kernel modules need firmware. See [1] for more
>>> information on the upgrade.
>>>
>>> [1]: https://wiki.gentoo.org/wiki/Udev/upgrade#udev_216_to_217
>>>
>> The news item has been committed today. :-)
>>
>> Sorry for the delay. I'm running out of excuses with my health issues. :-(
>>
>> Thanks and sorry,
>> Samuli
>>
> oh, I just figured something. what about systemd? looks like
> IUSE=firmware-loader was removed in 217.
>

Linux 3.7 has been minimum req. for systemd for quite a while now, and I
consider systemd in Gentoo still
to be more of an work-in-progress
And someone agreed with me on #gentoo-systemd, Freenode, that it's not
necessary to include it, so I didn't

However if the maintainers want to add it, that's fine by me, easy to
add one line to the news item... I'll CC them to this
mail just in case

As in, noted

- Samuli