Re: RE: [gentoo-user-fr] elibtoolize Portage patch requested, but failed to apply! {120122}

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: RE: [gentoo-user-fr] elibtoolize Portage patch requested, but failed to apply! {120122}

ResRequest Support
## Reply ABOVE THIS LINE to add a note to this request ##
ResRequest Support Request Received View the complete request history


Thank you for contacting ResRequest Customer Service

Your request has been received and is being reviewed by our team. This is an automated message, so there is no need to reply to this email at this time.

You can add more information to your request or check your request for an online update (Request access key: 120122dfbagw).
Feel free to browser our self help wiki or online tutorials.



Our offices will be closed over the Easter Period on the following days: 14 April & 17 April 2017.
For urgent assistance please contact (Telephone) +27 (0) 83 633 5099 / +27 (0) 82 774 0820.


We will be at WTM in Cape Town from 19 to 21 April 2017 and Indaba in Durban from 16 to 18 May 2017. Please let us know if you'd like to arrange a meet before or after the conferences.

ResRequest News | Facebook | Twitter | Google+ | Linkedin

Reply | Threaded
Open this post in threaded view
|

Re: RE: [gentoo-user-fr] elibtoolize Portage patch requested, but failed to apply! {120122}

ResRequest Support
## Reply ABOVE THIS LINE to add a note to this request ##
Request Update View the complete request history

Good Day

Could you kindly advise which lodge you are working for, or how we may assist?

Regards,

Angie


From: Erwan RIGOLLOT <[hidden email]>
Sent: Wed, 29 Mar 2017 06:45:53 +0000
To: "[hidden email]" <[hidden email]>
Subject: RE: [gentoo-user-fr] elibtoolize Portage patch requested, but failed to apply!

Bonjour,

 

Merci pour ton aide Jean-François.

 

C’est résolu et c’était une erreur de ma part.

Juste après le –sync, je n’arrivais pas à monter en version portage car il avait besoin de elt-patches et je l’avais mis dans package.provided puis je l’ai oublié …..

 

Bonne journée,

 

De : Jean-Francois Maeyhieux [mailto:[hidden email]]
Envoyé : mardi 28 mars 2017 00:42
À : [hidden email]
Objet : Re: [gentoo-user-fr] elibtoolize Portage patch requested, but failed to apply!

 

 

Pour tester ta commande patch:

- Copier un fichier A quelconque et le copier en B

- Modifier quelques lignes de B

- diff -u A B > patch

- patch -i patch A

-> A doit etre égal a B

 

Sinon une méthode générale pour mettre à jour un système non mis a jour depuis longtemps:

 

emerge -av gcc

gcc-config 1

emerge -av1 linux-headers binutils glibc gcc libtool portage

emerge -aev1 --keep-going @system

emerge -aev1 --keep-going @world

 

 

 

 

 

Le lundi 27 mars 2017 à 15:42 +0000, Erwan RIGOLLOT a écrit :

Bonjour,

 

Merci pour ta réponse.

Comment puis-je tester ceci ?

 

Cela doit faire 1 an voir 2 ans :-/

 

J’ai aussi écrit à la liste anglophone et on m’a conseillé d’ouvrir un bugs :

https://bugs.gentoo.org/show_bug.cgi?id=614078

 

Merci beaucoup,

 

De : Jean-Francois Maeyhieux [[hidden email]]
Envoyé : lundi 27 mars 2017 17:40
À : [hidden email]
Objet : Re: [gentoo-user-fr] elibtoolize Portage patch requested, but failed to apply!

 

Bonjour,

 

je te conseille de vérifier tout d'abord si ta commande "patch" fonctionne correctement car tes erreurs sont similaires et se rapporte au fait qu'emerge n'arrive pas à appliquer un patch.

 

Depuis combien de temps le système n'avait pas été mis à jour ?

 

Zentoo

 

Le lundi 27 mars 2017 à 11:39 +0000, Erwan RIGOLLOT a écrit :

Bonjour à tous,

 

Je viens de faire un emerge –sync et une mise à jour de portage sur deux gentoo.

 

Certain package ne veulent plus se compiler.

 

Exemples

 

gcc :

* updating multilib directories to be: ../lib64 ../lib32

* Running elibtoolize in: gcc-4.9.4/

 

* Portage patch requested, but failed to apply!

* Please file a bug report to add a proper patch.

* ERROR: sys-devel/gcc-4.9.4::gentoo failed (prepare phase):

*   Portage patch requested, but failed to apply!

 

 

php-5.6.30 :

Running elibtoolize in: apr-1.5.2/build/

 

* Portage patch failed to apply (ltmain.sh version 2.4.6)!

* Please file a bug report to add a proper patch.

* ERROR: dev-libs/apr-1.5.2::gentoo failed (prepare phase):

*   Portage patch failed to apply!

*

* Call stack:

*     ebuild.sh, line  115:  Called src_prepare

*   environment, line 2726:  Called eautoreconf

*   environment, line  864:  Called elibtoolize '--force' '/var/tmp/portage/dev-libs/apr-1.5.2/work/apr-1.5.2'

*   environment, line 1116:  Called die

* The specific snippet of code:

*                                   die "Portage patch failed to apply!";

*

* If you need support, post the output of `emerge --info '=dev-libs/apr-1.5.2::gentoo'`,

* the complete build log and the output of `emerge -pqv '=dev-libs/apr-1.5.2::gentoo'`.

* The complete build log is located at '/var/tmp/portage/dev-libs/apr-1.5.2/temp/build.log'.

* The ebuild environment file is located at '/var/tmp/portage/dev-libs/apr-1.5.2/temp/environment'.

* Working directory: '/var/tmp/portage/dev-libs/apr-1.5.2/work/apr-1.5.2'

* S: '/var/tmp/portage/dev-libs/apr-1.5.2/work/apr-1.5.2'

 

 

J’ai tenté beaucoup de chose sans succès.

 

Quelqu’un a une idée de ce que je pourrais faire ?

 

Merci


Angie Geringer
Support Consultant
[hidden email] | Skype: angie-resrequest | +27 (0)35 772 5615
ResRequest News | Facebook | Twitter | Google+ | Linkedin


We will be at WTM in Cape Town from 19 to 21 April 2017 and Indaba in Durban from 16 to 18 May 2017.
Please let us know if you'd like to arrange a meet before or after the conferences.