Re: What happened with KDE?

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: What happened with KDE?

Alexander Skwar-11
Peper schrieb:
>> No idea, but 3.5.0_beta2 is solid here :)
> I wanted to switch to 3.5.0_beta2 too, but:
>
> emerge: there are no ebuilds to satisfy "~kde-base/libkpgp-3.5.0_beta2".
> (dependency required by "kde-base/certmanager-3.5.0_beta2" [ebuild])

http://packages.gentoo.org/search/?sstring=libkpgp

It's still at beta1.

Alexander Skwar
--
[hidden email] mailing list

Reply | Threaded
Open this post in threaded view
|

Re: What happened with KDE?

Neil Bothwick
On Fri, 4 Nov 2005 00:34:09 +0100, Peper wrote:

> emerge: there are no ebuilds to satisfy "~kde-base/libkpgp-3.5.0_beta2".
> (dependency required by "kde-base/certmanager-3.5.0_beta2" [ebuild])

According to the certmanager ebuild, it only depends on beta1, which is
available.
 
> I think kde 3.5.0_beta2 isn't a full release yet or hasn't been
> well/fully "imported" to portage.

I think it is more likely that some components have not changed since
beta1, so there is no need for updated ebuilds.


--
Neil Bothwick

I am NOT a NUMBER! I am a DEMOGRAPHIC!

signature.asc (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: What happened with KDE?

Bugzilla from volker.armin.hemmann@tu-clausthal.de
In reply to this post by Alexander Skwar-11
On Friday 04 November 2005 00:34, Peper wrote:
> > No idea, but 3.5.0_beta2 is solid here :)
>
> I wanted to switch to 3.5.0_beta2 too, but:
>
> emerge: there are no ebuilds to satisfy "~kde-base/libkpgp-3.5.0_beta2".
> (dependency required by "kde-base/certmanager-3.5.0_beta2" [ebuild])

if you'd used the 'monolithic' (I like to call them the 'correct' ebuilds),
all you need is some /etc/portage/package.unmask magic to get a full blown,
nice Kde 3.5.0:beta2.

KDE version:  3.4.92 (beta2, >= 20051010)

from, control center

;)
--
[hidden email] mailing list

Reply | Threaded
Open this post in threaded view
|

Re: What happened with KDE?

Piotr "Jaroszyński"
In reply to this post by Neil Bothwick
> > emerge: there are no ebuilds to satisfy "~kde-base/libkpgp-3.5.0_beta2".
> > (dependency required by "kde-base/certmanager-3.5.0_beta2" [ebuild])
>
> According to the certmanager ebuild, it only depends on beta1, which is
> available.
No, i think that you are misreading the ebuild. I haven't chagned a single
thing in it and emerge reports above error.

> > I think kde 3.5.0_beta2 isn't a full release yet or hasn't been
> > well/fully "imported" to portage.
>
> I think it is more likely that some components have not changed since
> beta1, so there is no need for updated ebuilds.
I think that there is an error in certmanager-3.5.0_beta2 ebuild. Changing
some things manualy to 3.5_beta1 causes the same error, but with another
version: missing ...3.5.0_beta1... So it could be a version naming error:
logicaly after 3.5_beta1 should be 3.5_beta2 not 3.5.0_beta2.

--
Best Regards,
Peper
--
[hidden email] mailing list

Reply | Threaded
Open this post in threaded view
|

Re: What happened with KDE?

Piotr "Jaroszyński"
In reply to this post by Bugzilla from volker.armin.hemmann@tu-clausthal.de
> > > No idea, but 3.5.0_beta2 is solid here :)
> >
> > I wanted to switch to 3.5.0_beta2 too, but:
> >
> > emerge: there are no ebuilds to satisfy "~kde-base/libkpgp-3.5.0_beta2".
> > (dependency required by "kde-base/certmanager-3.5.0_beta2" [ebuild])
>
> if you'd used the 'monolithic' (I like to call them the 'correct' ebuilds),
> all you need is some /etc/portage/package.unmask magic to get a full blown,
> nice Kde 3.5.0:beta2.
I am not using the kde-desktop, but a lot of its components and updating one
of them - kontact, for now, is not possilble with newest "monolithic" version
of ebuilds. Try to emerge certmanager(one of the kontact's dependecies) and
you will see...

--
Best Regards,
Peper
--
[hidden email] mailing list

Reply | Threaded
Open this post in threaded view
|

Re: What happened with KDE?

Neil Bothwick
In reply to this post by Piotr "Jaroszyński"
On Fri, 4 Nov 2005 15:25:15 +0100, Peper wrote:

> > According to the certmanager ebuild, it only depends on beta1, which
> > is available.

> No, i think that you are misreading the ebuild. I haven't chagned a
> single thing in it and emerge reports above error.

It emerges OK here, so it would appear I am reading it correctly.

# emerge certmanager -pv

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild   R   ] kde-base/certmanager-3.5.0_beta2  +arts -debug
+kdeenablefinal (-kdexdeltas) -xinerama 0 kB

Total size of downloads: 0 kB

[root@hactar localbackup]# emerge libkpgp -pv

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild   R   ] kde-base/libkpgp-3.5_beta1  +arts -debug +kdeenablefinal
(-kdexdeltas) -xinerama 0 kB

> > I think it is more likely that some components have not changed since
> > beta1, so there is no need for updated ebuilds.

> I think that there is an error in certmanager-3.5.0_beta2 ebuild.
> Changing some things manualy to 3.5_beta1 causes the same error, but
> with another version: missing ...3.5.0_beta1... So it could be a
> version naming error: logicaly after 3.5_beta1 should be 3.5_beta2 not
> 3.5.0_beta2.

It looks like they changed the naming between beta1 and beta2, but the
ebuild appears to take this into account.
 

--
Neil Bothwick

Press any key to continue or any other key to quit

signature.asc (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: What happened with KDE?

Piotr "Jaroszyński"
> It looks like they changed the naming between beta1 and beta2, but the
> ebuild appears to take this into account.
Sorry for saying thtat you are misreading the ebuilds.

I have just figured out how it works, but i think that is misleading:
Unless you unmask the libkpgp package, emerge reports missing beta2 ebuild. I
think that emerge instead of reporting that highest version of dep is
missing, should report masked beta1 ebuild, because it matches the
deprange(from 3.5_beta1 to 3.5.0_beta2).

--
Best Regards,
Peper
--
[hidden email] mailing list