Re: revdep-rebuild is giving me fits

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: revdep-rebuild is giving me fits

Dale-6
Holly Bostick wrote:

>By the way, what version of gentoolkit do you have installed? If the
>last stable (0.2.0-r2), you might very well want to consider unmasking
>the unstable version for this package only -- add
>"app-portage/gentoolkit ~x86" to /etc/portage/package.keywords-- as
>revdep-rebuild is vastly improved (though still not perfect) in the most
>recent unstable version.
>  
>

app-portage/gentoolkit-0.2.0-r2 is what I have.  I may update it when it
gets through with -ev world.

>It is within the realm of possiblility that your version of
>revdep-rebuild is less trustworthy than mine (I use the unstable
>version), so the reason why you're receiving untrustworthy reports, and
>I'm saying the application is trustworthy despite this is because my
>version *is* reasonably trustworthy and yours is not (which would make
>all of the following completely incorrect).
>
>I understand that all those "brokens" seem like they should be of
>concern, but the important thing is that *revdep-rebuild is not offering
>to rebuild anything*. What I suspect has happened is that you have
>changed your USE flags and possibly run revdep-rebuild based on a
>revdep-rebuild -p that you had done prior to changing your USE flags.
>  
>

Well, I'm the same way with my car, the house and just about everything
else I have.  If I think it has something that I *may* can not depend
on, I fix it.  I would rather fix it than to just hope for the best.
I'm one of those that has had my fair share of bad luck so I paln for
the worst and hope for the best.  Brakes on my car is a good example.  I
want them to work everytime, not just on occasion.

>I say this because I notice that gaim and python both have the tcltk USE
>flag available; they must have been compiled at least once with this
>flag active for them to require libtk8.3.so and libtcl8.3.so, but now,
>even though these libraries are broken, gaim and python are not offered
>to be rebuilt-- therefore the optional dependency on these libraries
>must have been removed in the meantime. This could occur if you had run
>revdep-rebuild -p (which makes a list of the proposed rebuilds based on
>the system at that moment), changed your USE flages, removing "tcltk",
>then re-emerged gaim and python during the course of a emerge --newuse
>world, and then run revdep-rebuild without the -p (which reads the list
>created from the previous --pretend run rather than re-evaluating the
>system).
>  
>

I do have tcltk in the USE section.  Pysol, one of my card games,
requires it.

>All the broken gnome libs depending on libsigc++ (which is where
>libsigc-1.2.so.5 comes from) seem to be deep dependencies (no packages
>are offered to be fixed related to them); since you appear to be a KDE
>user, the only way I see for these libraries to be on your system is
>that they were optional dependencies emerged via the +gnome USE flag
>(since the direct dependencies for these libraries are not being
>mentioned as broken, or offered to rebuild). Perhaps this USE flag has
>also been disabled and the applications previously using it rebuilt.
>  
>

I have not changed my USE flags in a really long time, that I can recall
anyway.  It is possible though.

>The icewm applications depending on libungif are also not offered to
>rebuild, although they are broken w.r.t the libraries, which suggests
>that icewm is not in your world file, but is a dependency or deep
>dependency of something that is.
>
>But what's interesting is that icewm does not depend on libungif, but
>giflib, which is apparently not broken, and certainly not broken w.r.t
>icewm.
>
>So what it looks like to me is that your system is very sloppy at the
>moment, but nothing in fact is broken by some miracle of fate, which is
>why revdep-rebuild put out all this output, but offered to fix nothing.
>  
>

Well, that is sort of what I am working on here.  I want to get
everything back up to fubar here.  I installed Gentoo a couple years ago
and have been doing my updates pretty regular but that is about it
really.  Time to change the oil so to speak.

>Or it's a gigantic bug. but if that was the case, you would likely have
>noticed; you would have rather a wide range of programs and DE/WMs that
>would not start, such as GNOME, IceWM, and Gaim, which I think you would
>have reported if it had happened.
>  
>

No Gnome or IceWM here.  That gaim sounds familiar though.  I may have
it but I don't use it.

>So I think that revdep-rebuild is telling the truth, and although many
>things are bent, nothing is broken and nothing in fact needs rebuilding.
>
>I would consider an
>
>emerge depclean -p (do *not* forget the "-p"!!!)
>
>to begin the process of getting rid of some of these apparently
>no-longer needed packages and libraries.
>
>*Absolutely* look at the list and make sure nothing essential is
>suggested to unmerge before attempting an emerge depclean without
>--pretend!!!!
>  
>

I'll do that in a bit and post what it says, we'll look at and see what
is *safe*.  LOL

>  
>
>>Well, that was the command I was given and copy and paste works.  I'm
>> a bad typer remember.  I copy and paste all I can.  It's safer.
>>    
>>
>
>
>That's the command you were given *when*? About the only time you are
>"given" that command is when you first install the system.
>  
>

Someone posted it in between your posts.  Same thread though.  What he
told me to run did fix a lot of stuff though.  I just copy and paste a
lot since I type pretty bad.  I love that -p though.

>Emerge --emptytree rebuilds every package in the system, as if nothing
>was installed at all (as if the "tree" was "empty"). Now I don't know
>how long it took you to emerge your system, but personally, I have no
>particular desire to emerge gcc and glibc and X and KDE and Mozilla and
>every single other package on my system all over again, since each one
>of those named packages takes at least two hours (some significantly
>more, like glibc and X, not to mention something like KDE) to emerge by
>itself, so emerging everything would probably take closer to 24 to 36
>hours than like....10 to 18 (which is still a da*m long time, btw) . And
>that's assuming everything went perfectly, which it often doesn't.
>
>The point is, emerge -e "should" only be used in the very most extreme
>of emergencies; it's a pretty desperate measure, not to be taken
>lightly, and very very rarely necessary.
>  
>

I do a emerge -ev world on occasion.  If it fails on something, I search
the forums and see if I can fix it.  All in a effort to keep me stable
and efficient here.

>
>I'm not clear what, at this point, you're trying to fix. The original
>issue, revdep-rebuild, is solved, insofar as revdep-rebuild has
>completed with no re-emerges necessary, and the xmlto thing should now
>be solved as well.
>  
>

Just keepng my ducks in a row here.  I like them ducks to be beak to
tail and in a straight line.  One gets out of line, I poke him/her back
in formation.  LOL

>>I do mine each night because I'm on dial-up and it is easier to get
>>little tidbits than to wait until there is a new KDE and Open Office
>>at the same time.  o_O  It takes me about three days to get just Open
>>Office so I like to nibble on it a bit.
>>    
>>
>
>Again, do you really *need* to be on the cutting edge every minute of
>the day? Especially when on dial-up? What good does the new version of
>KDE and Oo.o do for you that you have to upgrade every day? And you
>might also consider alternatives-- smaller alternatives-- like abiword
>or kwrite.
>  
>

I like Open Office but I really like Scribus.  Scribus is what they use
to lay out newspapers and magizines and such.  Really cool program.
Same as Quark XPress.  I do like to stay up to date.  It is one thing I
like about Linux and especially Gentoo.  It beats windoze for sure.
Anything can beat winders though.  LOL

>Heck, you might consider using icewm or xfce (or openbox or Windowmaker
>or fvwm) instead of KDE.
>  
>

I LOVE my KDE.  I have a slideshow background and over 10,000 pictures
for it to flip through.  I have a digital camera and can fill up a 1GB
card at a single party.

>If your means are limited (in terms of bandwidth), then it is well worth
>your time to consider how to maximize the effectiveness of what you
>spend that bandwidth on. Gentoo is about choice, but choice requires
>flexibility, and if you *can't* do everything you want (because you
>flatly don't have the bandwidth), then flexibility is a key skill to
>develop (how to get the most of what you want with the minimum of outlay).
>  
>

I usually connect, sync, fetch, update and let it compile all in one
command.  I sleep while it does its thing.  I have a friend that has DSL
and I can go download Open Office on her rig if I need to.  I never have
but I could.  I'm patient.

>Revdep-rebuild wasn't able to perform its suggested actions because of
>the block, but there are no more suggested actions, so everything is
>fine as far as that goes-- nothing is broke.
>  
>

I unmerged them both so it would leave me alone.  LOL  I'm not sure
which one is the *correct* one to install.  I assume it will sort itself
out eventually.

>Dynamic linking on your system is consistent... All done.
>
>means that nothing is broken! It's just bent, and that could be due to
>user inexperience; if you ran revdep-rebuild -p after a depclean and/or
>after an emerge -uaDNv world, you might find even those 'bent' reports
>disappeared.
>  
>

I would like to *bend* it back though.  If it is bent, it might break.  O_O

>Just because you put a single book away out of alphabetical order when
>at the public library, and the next person wanting it couldn't find it
>(because it's in the wrong place) wouldn't mean that the entire library building
>needed to be demolished and rebuilt!
>
>That's essentially what you're doing, with your emerge -e world.
>  
>

I hate when something is out of place.  I'm a recovering perfectionist
with a bit of OCD mixed in.  Now you know.  o_O  I'm disabled so I have
a lot of time on my hands.  My computer is what I spend most of my time
on.  I used to have a garden but it is either to wet or to dry.

>As I said, good luck.
>
>Holly
>  
>
I need some good luck, in a lot of ways.  My emerge -ev world is going
fine so far.  I'm on 380 out of 511 and no errors at all.  That is what
I was looking for.  If I can do a emerge -ev world with no errors, I'm
solid as a rock.

I'll let you know how it goes.  Thanks for the help, everybody.

Dale
:-)

--
To err is human, I'm most certainly human.

 

--
[hidden email] mailing list