Rpm/deb installieren

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Rpm/deb installieren

Sebastian
Hallo,

Kommerzielle Linux Software wird oft nur als deb oder rpm Angeboten, wie
installiere ich die am Besten im System damit ich diese auch wieder sauber
entfernen kann. Wie gehe ich mit Abhängigkeiten um welche die entsprechenden
Tools ja nicht finden da per emerge installiert.




Von einem Programm gibt es ein ebuild aber leider findet es das
heruntergeladene Packet nicht?

l1-gentoo /home/sebastian # emerge -av draftsight-bin

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N F  ~] media-gfx/draftsight-bin-1.6.1_beta::betagarden  149.699 KiB

Total: 1 package (1 new), Size of downloads: 149.699 KiB
Fetch Restriction: 1 package (1 unsatisfied)

Fetch instructions for media-gfx/draftsight-bin-1.6.1_beta:
 * Upstream has a mandatory EULA agreement to download this file.
 * Please navigate your browser to:
 * http://www.3ds.com/products-services/draftsight-cad-software/free-download/
 * Click "Download DraftSight 2015 for Ubuntu (beta)"
 * Download the deb file and move it to /var/tmp/tmp7l94zp2o/portage/media-gfx/
draftsight-bin-1.6.1_beta/distdir/draftsight-1.6.1_beta.deb

Would you like to merge these packages? [Yes/No]

Der Pfadnahme ändert sich aber jedes mal? Wenn ich die Datei entsptrechend
dahin kopiere kommt aber eine Fehlermeldung:

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) media-gfx/draftsight-bin-1.6.1_beta::betagarden

!!! media-gfx/draftsight-bin-1.6.1_beta has fetch restriction turned on.
!!! This probably means that this ebuild's files must be downloaded
!!! manually.  See the comments in the ebuild for more information.

 * Fetch failed for 'media-gfx/draftsight-bin-1.6.1_beta', Log file:
 *  '/var/tmp/portage/media-gfx/draftsight-bin-1.6.1_beta/temp/build.log'
 * Upstream has a mandatory EULA agreement to download this file.
 * Please navigate your browser to:
 * http://www.3ds.com/products-services/draftsight-cad-software/free-download/
 * Click "Download DraftSight 2015 for Ubuntu (beta)"
 * Download the deb file and move it to /var/tmp/portage/media-gfx/draftsight-
bin-1.6.1_beta/distdir/draftsight-1.6.1_beta.deb

>>> Failed to emerge media-gfx/draftsight-bin-1.6.1_beta, Log file:

>>>  '/var/tmp/portage/media-gfx/draftsight-bin-1.6.1_beta/temp/build.log'

 * Messages for package media-gfx/draftsight-bin-1.6.1_beta:

 * Fetch failed for 'media-gfx/draftsight-bin-1.6.1_beta', Log file:
 *  '/var/tmp/portage/media-gfx/draftsight-bin-1.6.1_beta/temp/build.log'
l1-gentoo /home/sebastian #

Hier wird jetzt ein anderer pfad verlangt aber auch dort liegt das Package,
warum dann die Fehlermeldung?

In der Log datei steht:

!!! media-gfx/draftsight-bin-1.6.1_beta has fetch restriction turned on.
!!! This probably means that this ebuild's files must be downloaded
!!! manually.  See the comments in the ebuild for more information.

 * Fetch failed for 'media-gfx/draftsight-bin-1.6.1_beta',
Log file:
 *  '/var/tmp/portage/media-gfx/draftsight-bin-1.6.1_beta/
temp/build.log'
 * Package:    media-gfx/draftsight-bin-1.6.1_beta
 * Repository: betagarden
 * Maintainer: [hidden email]
 * USE:        abi_x86_64 amd64 elibc_glibc kernel_linux
userland_GNU
 * FEATURES:   preserve-libs sandbox userpriv usersandbox
 * Upstream has a mandatory EULA agreement to download this file.
 * Please navigate your browser to:
 * http://www.3ds.com/products-services/draftsight-cad-software/
free-download/
 * Click "Download DraftSight 2015 for Ubuntu (beta)"
 * Download the deb file and move it to /var/tmp/portage/media-gfx/
draftsight-bin-1.6.1_beta/distdir/draftsight-1.6.1_beta.deb

Gruß
Sebastian




Reply | Threaded
Open this post in threaded view
|

Re: Rpm/deb installieren

Christian Bricart
Hallo Sebastian,

lege das runtergeladene .deb mal einfach in ${DISTDIR} (<-
/usr/portage/distfiles/ )

normalerweise suchen alle ebuilds mit fetch-restrictions dort nach den
händisch runtergeladenen Dateien..

Christian


Am 2018-04-12 12:44, schrieb Sebastian:

> Hallo,
>
> Kommerzielle Linux Software wird oft nur als deb oder rpm Angeboten,
> wie
> installiere ich die am Besten im System damit ich diese auch wieder
> sauber
> entfernen kann. Wie gehe ich mit Abhängigkeiten um welche die
> entsprechenden
> Tools ja nicht finden da per emerge installiert.
>
>
>
>
> Von einem Programm gibt es ein ebuild aber leider findet es das
> heruntergeladene Packet nicht?
>
> l1-gentoo /home/sebastian # emerge -av draftsight-bin
>
> These are the packages that would be merged, in order:
>
> Calculating dependencies... done!
> [ebuild  N F  ~] media-gfx/draftsight-bin-1.6.1_beta::betagarden  
> 149.699 KiB
>
> Total: 1 package (1 new), Size of downloads: 149.699 KiB
> Fetch Restriction: 1 package (1 unsatisfied)
>
> Fetch instructions for media-gfx/draftsight-bin-1.6.1_beta:
>  * Upstream has a mandatory EULA agreement to download this file.
>  * Please navigate your browser to:
>  *
> http://www.3ds.com/products-services/draftsight-cad-software/free-download/
>  * Click "Download DraftSight 2015 for Ubuntu (beta)"
>  * Download the deb file and move it to
> /var/tmp/tmp7l94zp2o/portage/media-gfx/
> draftsight-bin-1.6.1_beta/distdir/draftsight-1.6.1_beta.deb
>
> Would you like to merge these packages? [Yes/No]
>
> Der Pfadnahme ändert sich aber jedes mal? Wenn ich die Datei
> entsptrechend
> dahin kopiere kommt aber eine Fehlermeldung:
>
>>>> Verifying ebuild manifests
>
>>>> Emerging (1 of 1) media-gfx/draftsight-bin-1.6.1_beta::betagarden
>
> !!! media-gfx/draftsight-bin-1.6.1_beta has fetch restriction turned
> on.
> !!! This probably means that this ebuild's files must be downloaded
> !!! manually.  See the comments in the ebuild for more information.
>
>  * Fetch failed for 'media-gfx/draftsight-bin-1.6.1_beta', Log file:
>  *  
> '/var/tmp/portage/media-gfx/draftsight-bin-1.6.1_beta/temp/build.log'
>  * Upstream has a mandatory EULA agreement to download this file.
>  * Please navigate your browser to:
>  *
> http://www.3ds.com/products-services/draftsight-cad-software/free-download/
>  * Click "Download DraftSight 2015 for Ubuntu (beta)"
>  * Download the deb file and move it to
> /var/tmp/portage/media-gfx/draftsight-
> bin-1.6.1_beta/distdir/draftsight-1.6.1_beta.deb
>
>>>> Failed to emerge media-gfx/draftsight-bin-1.6.1_beta, Log file:
>
>>>>  
>>>> '/var/tmp/portage/media-gfx/draftsight-bin-1.6.1_beta/temp/build.log'
>
>  * Messages for package media-gfx/draftsight-bin-1.6.1_beta:
>
>  * Fetch failed for 'media-gfx/draftsight-bin-1.6.1_beta', Log file:
>  *  
> '/var/tmp/portage/media-gfx/draftsight-bin-1.6.1_beta/temp/build.log'
> l1-gentoo /home/sebastian #
>
> Hier wird jetzt ein anderer pfad verlangt aber auch dort liegt das
> Package,
> warum dann die Fehlermeldung?
>
> In der Log datei steht:
>
> !!! media-gfx/draftsight-bin-1.6.1_beta has fetch restriction turned
> on.
> !!! This probably means that this ebuild's files must be downloaded
> !!! manually.  See the comments in the ebuild for more information.
>
>  * Fetch failed for
> 'media-gfx/draftsight-bin-1.6.1_beta',
> Log file:
>  * 
> '/var/tmp/portage/media-gfx/draftsight-bin-1.6.1_beta/
> temp/build.log'
>  * Package:    media-gfx/draftsight-bin-1.6.1_beta
>  * Repository: betagarden
>  * Maintainer: [hidden email]
>  * USE:        abi_x86_64 amd64 elibc_glibc
> kernel_linux
> userland_GNU
>  * FEATURES:   preserve-libs sandbox userpriv
> usersandbox
>  * Upstream has a mandatory EULA agreement to download this
> file.
>  * Please navigate your browser to:
>  *
> http://www.3ds.com/products-services/draftsight-cad-software/
> free-download/
>  * Click "Download DraftSight 2015 for Ubuntu (beta)"
>  * Download the deb file and move it to
> /var/tmp/portage/media-gfx/
> draftsight-bin-1.6.1_beta/distdir/draftsight-1.6.1_beta.deb
>
> Gruß
> Sebastian

Reply | Threaded
Open this post in threaded view
|

Re: Rpm/deb installieren

assabajanischer_hinterwaeldler
In reply to this post by Sebastian
Hallo
der Fehler an sich sagt, dass die notwendige Datei nicht automatisch heruntergeladen werden kann. Daher muss man dies selbst tun. Bei Java von Oracle hat es gereicht diese nach /usr/portage/distfiles/ zu kopieren. Der log selbst sagt allerdings, dass er diese direkt im Arbeitsverzeichnis von portage haben will. Daher ausprobieren ob distfiles reicht oder nicht.

Einen generellen Weg kenne ich leider nicht. Gibt aber Möglichkeiten. Hatte aber noch nicht die Zeit sie genauer anzuschauen. An sich sind rpm2targz und co der weg. Evtl hilfts bei der Suche. Ansonsten auch mal greppen, was schon da ist an ebuilds die das machen oder bei arch spicken. Das lässt sich oft adaptieren.

Gruß
martin

Am 12. April 2018 12:44:11 MESZ schrieb Sebastian <[hidden email]>:
Hallo,

Kommerzielle Linux Software wird oft nur als deb oder rpm Angeboten, wie
installiere ich die am Besten im System damit ich diese auch wieder sauber
entfernen kann. Wie gehe ich mit Abhängigkeiten um welche die entsprechenden
Tools ja nicht finden da per emerge installiert.




Von einem Programm gibt es ein ebuild aber leider findet es das
heruntergeladene Packet nicht?

l1-gentoo /home/sebastian # emerge -av draftsight-bin

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild N F ~] media-gfx/draftsight-bin-1.6.1_beta::betagarden 149.699 KiB

Total: 1 package (1 new), Size of downloads: 149.699 KiB
Fetch Restriction: 1 package (1 unsatisfied)

Fetch instructions for media-gfx/draftsight-bin-1.6.1_beta:
* Upstream has a mandatory EULA agreement to download this file.
* Please navigate your browser to:
* http://www.3ds.com/products-services/draftsight-cad-software/free-download/
* Click "Download DraftSight 2015 for Ubuntu (beta)"
* Download the deb file and move it to /var/tmp/tmp7l94zp2o/portage/media-gfx/
draftsight-bin-1.6.1_beta/distdir/draftsight-1.6.1_beta.deb

Would you like to merge these packages? [Yes/No]

Der Pfadnahme ändert sich aber jedes mal? Wenn ich die Datei entsptrechend
dahin kopiere kommt aber eine Fehlermeldung:

Verifying ebuild manifests

Emerging (1 of 1) media-gfx/draftsight-bin-1.6.1_beta::betagarden

!!! media-gfx/draftsight-bin-1.6.1_beta has fetch restriction turned on.
!!! This probably means that this ebuild's files must be downloaded
!!! manually. See the comments in the ebuild for more information.

* Fetch failed for 'media-gfx/draftsight-bin-1.6.1_beta', Log file:
* '/var/tmp/portage/media-gfx/draftsight-bin-1.6.1_beta/temp/build.log'
* Upstream has a mandatory EULA agreement to download this file.
* Please navigate your browser to:
* http://www.3ds.com/products-services/draftsight-cad-software/free-download/
* Click "Download DraftSight 2015 for Ubuntu (beta)"
* Download the deb file and move it to /var/tmp/portage/media-gfx/draftsight-
bin-1.6.1_beta/distdir/draftsight-1.6.1_beta.deb

Failed to emerge media-gfx/draftsight-bin-1.6.1_beta, Log file:

'/var/tmp/portage/media-gfx/draftsight-bin-1.6.1_beta/temp/build.log'

* Messages for package media-gfx/draftsight-bin-1.6.1_beta:

* Fetch failed for 'media-gfx/draftsight-bin-1.6.1_beta', Log file:
* '/var/tmp/portage/media-gfx/draftsight-bin-1.6.1_beta/temp/build.log'
l1-gentoo /home/sebastian #

Hier wird jetzt ein anderer pfad verlangt aber auch dort liegt das Package,
warum dann die Fehlermeldung?

In der Log datei steht:

!!! media-gfx/draftsight-bin-1.6.1_beta has fetch restriction turned on.
!!! This probably means that this ebuild's files must be downloaded
!!! manually. See the comments in the ebuild for more information.

 * Fetch failed for 'media-gfx/draftsight-bin-1.6.1_beta',
Log file:
 *  '/var/tmp/portage/media-gfx/draftsight-bin-1.6.1_beta/
temp/build.log'
 * Package: media-gfx/draftsight-bin-1.6.1_beta
 * Repository: betagarden
 * Maintainer: [hidden email]
 * USE: abi_x86_64 amd64 elibc_glibc kernel_linux
userland_GNU
 * FEATURES: preserve-libs sandbox userpriv usersandbox
* Upstream has a mandatory EULA agreement to download this file.
* Please navigate your browser to:
* http://www.3ds.com/products-services/draftsight-cad-software/
free-download/
* Click "Download DraftSight 2015 for Ubuntu (beta)"
* Download the deb file and move it to /var/tmp/portage/media-gfx/
draftsight-bin-1.6.1_beta/distdir/draftsight-1.6.1_beta.deb

Gruß
Sebastian





--
Diese Nachricht wurde von meinem Android-Mobiltelefon mit K-9 Mail gesendet.