Samba 4 provision

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Samba 4 provision

François Mathias
Bonjour,

J'essaye de mettre en place un domaine active directory avec samba 4.2.11.

Une fois installé (et précédemment mon samba 3 désinstallé), je lance la
commande pour créer le domaine:

# samba-tool domain provision --use-rfc2307 --use-xattrs=yes
--interactive --option="interfaces=lo eth0" --option="bind interfaces
only=yes"
Realm [*************]: *************
  Domain [****]:
  Server Role (dc, member, standalone) [dc]:
  DNS backend (SAMBA_INTERNAL, BIND9_FLATFILE, BIND9_DLZ, NONE)
[SAMBA_INTERNAL]:
  DNS forwarder IP address (write 'none' to disable forwarding)
[192.168.0.1]: 8.8.8.8
Administrator password:
Retype password:
Looking up IPv4 addresses
Looking up IPv6 addresses
No IPv6 address will be assigned
Setting up secrets.ldb
Setting up the registry
Setting up the privileges database
Setting up idmap db
Setting up SAM db
Setting up sam.ldb partitions and settings
Setting up sam.ldb rootDSE
Pre-loading the Samba 4 and AD schema
Adding DomainDN: DC=***,DC=******,DC=***
Adding configuration container
Setting up sam.ldb schema
Setting up sam.ldb configuration data
Setting up display specifiers
Modifying display specifiers
Adding users container
Modifying users container
Adding computers container
Modifying computers container
Setting up sam.ldb data
Setting up well known security principals
Setting up sam.ldb users and groups
Setting up self join
set_nt_acl_no_snum: fset_nt_acl returned NT_STATUS_NOT_SUPPORTED.
ERROR(runtime): uncaught exception - (-1073741637, 'The request is not
supported.')
   File "/usr/lib64/python2.7/site-packages/samba/netcmd/__init__.py",
line 175, in _run
     return self.run(*args, **kwargs)
   File "/usr/lib64/python2.7/site-packages/samba/netcmd/domain.py",
line 434, in run
     nosync=ldap_backend_nosync, ldap_dryrun_mode=ldap_dryrun_mode)
   File
"/usr/lib64/python2.7/site-packages/samba/provision/__init__.py", line
2169, in provision
     skip_sysvolacl=skip_sysvolacl)
   File
"/usr/lib64/python2.7/site-packages/samba/provision/__init__.py", line
1803, in provision_fill
     names.domaindn, lp, use_ntvfs)
   File
"/usr/lib64/python2.7/site-packages/samba/provision/__init__.py", line
1600, in setsysvolacl
     service=SYSVOL_SERVICE)
   File "/usr/lib64/python2.7/site-packages/samba/ntacls.py", line 154,
in setntacl
     smbd.set_nt_acl(file, security.SECINFO_OWNER |
security.SECINFO_GROUP | security.SECINFO_DACL | security.SECINFO_SACL,
sd, service=service)

Et paf, le drame...

L'ennui c'est que je ne vois même pas d'où vient l'erreur, et Google ne
m'a pas vraiment aidé sur ce coup là.

Si quelqu'un avait une piste de quoi vérifier/changer/tester/...

Merci!

François