Samsung Q1 audio

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Samsung Q1 audio

Stefano Guglia-2

Hello everybody!

I am trying to replace WVista on my new Q1 but, despite a couple of howtos
where all seems too easy
( i.e. http://www.gentoo-wiki.info/Samsung_Q1-Ultra ),
I am still banging my head on the sound, touchscreen and some other settings.
I really would like to accomplish my mission, on youtube there are some videos
showing working machines on Ubuntu..On my Q1, Ubuntu + sound works so I know
that it is not impossible :-) but I'm a Gentoo-man so please help..

My conf:
kernel 2.6.26-r4 (tried both manual and genkernel modes)
card hda Intel, chip Realtek ALC262

my lsusb:
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and
945GT Express Memory Controller Hub (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and
945GT Express PCI Express Root Port (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS,
943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS, 943/940GML
Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition
Audio Controller (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI
Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge
(rev 02)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller
(rev 02)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev
02)
01:00.0 Ethernet controller: Atheros Communications, Inc. AR5006EG 802.11 b/g
Wireless PCI Express Adapter (rev 01)
02:05.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev
02)

aRts returns: no such device or address

I know there are lots of info missing here, but I will be glad to add whatever
needed to my helping gurus :-))
--


Cordiali saluti,

Stefano Guglia
Vicolo dell' Edera 4
34127 Trieste

+39 040 575739
+39 349 3722420

Reply | Threaded
Open this post in threaded view
|

Re: Samsung Q1 audio

david-108
Stefano Guglia wrote:

> Hello everybody!
>
> I am trying to replace WVista on my new Q1 but, despite a couple of howtos
> where all seems too easy
> ( i.e. http://www.gentoo-wiki.info/Samsung_Q1-Ultra ),
> I am still banging my head on the sound, touchscreen and some other settings.
> I really would like to accomplish my mission, on youtube there are some videos
> showing working machines on Ubuntu..On my Q1, Ubuntu + sound works so I know
> that it is not impossible :-) but I'm a Gentoo-man so please help..
>  
This may help for the touchscreen;
http://taxmantheblog.blogspot.com/2008/04/egalax-touchkit-driver-for-linux.html
http://sw64-17-162.adsl.seed.net.tw/web20/TouchKitDriver/linuxDriver.htm
http://wiki.linuxmce.org/index.php/Egalax-Touchscreen

--
Powered by Gentoo GNU/LINUX
http://www.linuxcrazy.com
pgp.mit.edu



Reply | Threaded
Open this post in threaded view
|

Re: Samsung Q1 audio

Beso-2
In reply to this post by Stefano Guglia-2
2008/12/23 Stefano Guglia <[hidden email]>:

>
> Hello everybody!
>
> I am trying to replace WVista on my new Q1 but, despite a couple of howtos
> where all seems too easy
> ( i.e. http://www.gentoo-wiki.info/Samsung_Q1-Ultra ),
> I am still banging my head on the sound, touchscreen and some other settings.
> I really would like to accomplish my mission, on youtube there are some videos
> showing working machines on Ubuntu..On my Q1, Ubuntu + sound works so I know
> that it is not impossible :-) but I'm a Gentoo-man so please help..
>
> My conf:
> kernel 2.6.26-r4 (tried both manual and genkernel modes)
> card hda Intel, chip Realtek ALC262
>
> my lsusb:
> 00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and
> 945GT Express Memory Controller Hub (rev 03)
> 00:01.0 PCI bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and
> 945GT Express PCI Express Root Port (rev 03)
> 00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS,
> 943/940GML Express Integrated Graphics Controller (rev 03)
> 00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS, 943/940GML
> Express Integrated Graphics Controller (rev 03)
> 00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition
> Audio Controller (rev 02)
> 00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
> Controller #1 (rev 02)
> 00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
> Controller #2 (rev 02)
> 00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
> Controller #3 (rev 02)
> 00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
> Controller #4 (rev 02)
> 00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI
> Controller (rev 02)
> 00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
> 00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge
> (rev 02)
> 00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller
> (rev 02)
> 00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev
> 02)
> 01:00.0 Ethernet controller: Atheros Communications, Inc. AR5006EG 802.11 b/g
> Wireless PCI Express Adapter (rev 01)
> 02:05.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev
> 02)
>
> aRts returns: no such device or address
>
> I know there are lots of info missing here, but I will be glad to add whatever
> needed to my helping gurus :-))
> --
>
what i can see the problem is arts. don't use it since it's not very good.
instead, use pulseaudio or jack as soundserver if you need one. this would mean
to rebuild the whole kde and some other packages with pulseaudio flag.
for more info
see pulseaudio perfect setup page here:
http://www.pulseaudio.org/wiki/PerfectSetup
on how to configure your board. also after installing alsa be sure to
run alsaconf to
automatically configure your board. i suggest you to use alsa and not oss with
oss support. i'm working on an how to setup sound for kde, but lately
i've had some
health issues and have been quite full at the office to be able to
work on this in the
proper way.

--
dott. ing. beso