Setools 4.1.0 emerge failure

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Setools 4.1.0 emerge failure

Robert Sharp

Hi,
just emerged the new setools-4.1.0 and it falls over. I do not have X on this machine and it seems to fail when patching to remove the gui? Here are the details.

From emerge:

[ebuild     U ~] app-admin/setools-4.1.0::gentoo [4.0.1::gentoo] USE="-X -debug {-test}" PYTHON_TARGETS="python2_7 python3_4 -python3_5" 0 KiB

And the error message, which comes up straight away:

>>> Unpacking source...
>>> Unpacking setools-4.1.0.tar.gz to /var/tmp/portage/app-admin/setools-4.1.0/work
>>> Source unpacked in /var/tmp/portage/app-admin/setools-4.1.0/work
>>> Preparing source in /var/tmp/portage/app-admin/setools-4.1.0/work/setools-4.1.0 ...
 * Applying setools-4.0.1-remove-gui.patch ...
1 out of 1 hunk FAILED -- saving rejects to file setup.py.rej
 [ !! ]
 * ERROR: app-admin/setools-4.1.0::gentoo failed (prepare phase):
 *   patch -p1  failed with /usr/portage/app-admin/setools/files/setools-4.0.1-remove-gui.patch


Quick google suggests the patch does not match the source file? Perhaps most people have the X flag enabled and have not met this yet? I can provide full details if this is not as simple as I think.

Thanks

Robert Sharp

Reply | Threaded
Open this post in threaded view
|

Re: Setools 4.1.0 emerge failure

Jason Zaman-2
On Fri, Feb 03, 2017 at 02:54:28PM +0000, Robert Sharp wrote:
> Hi,
> just emerged the new setools-4.1.0 and it falls over. I do not have X on
> this machine and it seems to fail when patching to remove the gui? Here
> are the details.

I fixed it yesterday, re-emerge and it'll work now.

Thanks,
Jason

>
>  From emerge:
>
> [ebuild     U ~] app-admin/setools-4.1.0::gentoo [4.0.1::gentoo] USE="-X
> -debug {-test}" PYTHON_TARGETS="python2_7 python3_4 -python3_5" 0 KiB
>
> And the error message, which comes up straight away:
>
>  >>> Unpacking source...
>  >>> Unpacking setools-4.1.0.tar.gz to
> /var/tmp/portage/app-admin/setools-4.1.0/work
>  >>> Source unpacked in /var/tmp/portage/app-admin/setools-4.1.0/work
>  >>> Preparing source in
> /var/tmp/portage/app-admin/setools-4.1.0/work/setools-4.1.0 ...
>   * Applying setools-4.0.1-remove-gui.patch ...
> 1 out of 1 hunk FAILED -- saving rejects to file setup.py.rej
>   [ !! ]
>   * ERROR: app-admin/setools-4.1.0::gentoo failed (prepare phase):
>   *   patch -p1  failed with
> /usr/portage/app-admin/setools/files/setools-4.0.1-remove-gui.patch
>
>
> Quick google suggests the patch does not match the source file? Perhaps
> most people have the X flag enabled and have not met this yet? I can
> provide full details if this is not as simple as I think.
>
> Thanks
>
> Robert Sharp
>

Reply | Threaded
Open this post in threaded view
|

Re: Setools 4.1.0 emerge failure

Robert Sharp
On 05/02/17 05:19, Jason Zaman wrote:
On Fri, Feb 03, 2017 at 02:54:28PM +0000, Robert Sharp wrote:
Hi,
just emerged the new setools-4.1.0 and it falls over. I do not have X on 
this machine and it seems to fail when patching to remove the gui? Here 
are the details.
I fixed it yesterday, re-emerge and it'll work now.

Thanks,
Jason
 From emerge:

[ebuild     U ~] app-admin/setools-4.1.0::gentoo [4.0.1::gentoo] USE="-X 
-debug {-test}" PYTHON_TARGETS="python2_7 python3_4 -python3_5" 0 KiB

And the error message, which comes up straight away:

 >>> Unpacking source...
 >>> Unpacking setools-4.1.0.tar.gz to 
/var/tmp/portage/app-admin/setools-4.1.0/work
 >>> Source unpacked in /var/tmp/portage/app-admin/setools-4.1.0/work
 >>> Preparing source in 
/var/tmp/portage/app-admin/setools-4.1.0/work/setools-4.1.0 ...
  * Applying setools-4.0.1-remove-gui.patch ...
1 out of 1 hunk FAILED -- saving rejects to file setup.py.rej
  [ !! ]
  * ERROR: app-admin/setools-4.1.0::gentoo failed (prepare phase):
  *   patch -p1  failed with 
/usr/portage/app-admin/setools/files/setools-4.0.1-remove-gui.patch


Quick google suggests the patch does not match the source file? Perhaps 
most people have the X flag enabled and have not met this yet? I can 
provide full details if this is not as simple as I think.

Thanks

Robert Sharp


    

All working now. Thanks very much.