Update auf kde5

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Update auf kde5

Sebastian
Hallo,

beim Update auf kde5 scheint etwas schief gelaufen zu sein. Kann mir jemand
Helfen die Blocks zu lösen?

Ich verstehe den Grund nicht bzw was ist der Unterschied der Variante ...
5.1.8 zu ... 5.1.8.0 Was den größten teil zu betreffen scheint.

Ich habe bisher nur die Möglichkeit:

emerge --ask --oneshot =kde-frameworks/kcrash-5.18.0 kde-plasma/polkit-kde-
agent kde-plasma/kscreenlocker kde-plasma/kwin

gefunden das wird aber sehr langwierig bis ich das alles abgearbeitet habe.

Ich bin nach der Anleitung:
https://wiki.gentoo.org/wiki/KDE/Plasma_5_upgrade vorgegangen.
Habe dann da ich die Blocks nicht zu lösen verstanden habe
emerge --ask kde-plasma/plasma-meta vor dem world Update gemacht.
Um mich dann in aller ruhe den Blocks widmen zu können das ist wohl schief
gegangen.





 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.



  (kde-plasma/kscreenlocker-5.5.5:5/5::gentoo, installed) pulled in by
    >=kde-plasma/kscreenlocker-5.5.5:5 required by (kde-plasma/plasma-
meta-5.5.5:5/5::gentoo, installed)
    >=kde-plasma/kscreenlocker-5.5.5:5 required by (kde-
plasma/kwin-5.5.5:5/5::gentoo, installed)
    >=kde-plasma/kscreenlocker-5.5.5:5 required by (kde-plasma/plasma-
workspace-5.5.5-r2:5/5::gentoo, installed)

  (kde-plasma/kde-cli-tools-5.5.5:5/5::gentoo, installed) pulled in by
    >=kde-plasma/kde-cli-tools-5.5.5:5 required by (kde-plasma/plasma-
meta-5.5.5:5/5::gentoo, installed)
    >=kde-plasma/kde-cli-tools-5.4.1:5 required by (kde-
apps/khelpcenter-5.5.5:5/5::gentoo, installed)
    >=kde-plasma/kde-cli-tools-5.5.5:5 required by (kde-
plasma/kinfocenter-5.5.5:5/5::gentoo, installed)
    >=kde-plasma/kde-cli-tools-5.5.5:5 required by (kde-
plasma/breeze-5.5.5:5/5::gentoo, installed)
    >=kde-plasma/kde-cli-tools-5.5.5:5 required by (kde-
plasma/khotkeys-5.5.5:5/5::gentoo, installed)
    >=kde-plasma/kde-cli-tools-5.5.5:5 required by (kde-plasma/plasma-
desktop-5.5.5:5/5::gentoo, installed)
    >=kde-plasma/kde-cli-tools-5.5.5:5 required by (kde-
plasma/powerdevil-5.5.5:5/5::gentoo, installed)
    >=kde-plasma/kde-cli-tools-5.5.5:5 required by (kde-
plasma/kscreenlocker-5.5.5:5/5::gentoo, installed)
    >=kde-plasma/kde-cli-tools-5.5.5:5 required by (kde-plasma/plasma-
workspace-5.5.5-r2:5/5::gentoo, installed)
    >=kde-plasma/kde-cli-tools-5.5.5:5 required by (kde-plasma/sddm-
kcm-5.5.5:5/5::gentoo, installed)
    >=kde-plasma/kde-cli-tools-5.5.5:5 required by (kde-
plasma/kscreen-5.5.5:5/5::gentoo, installed)
    >=kde-plasma/kde-cli-tools-5.5.5:5 required by (kde-
plasma/bluedevil-5.5.5:5/5::gentoo, installed)
    >=kde-plasma/kde-cli-tools-5.5.5:5 required by (kde-
plasma/kwin-5.5.5:5/5::gentoo, installed)

  (kde-plasma/kdecoration-5.5.5:5/5::gentoo, installed) pulled in by
    >=kde-plasma/kdecoration-5.5.5:5 required by (kde-plasma/plasma-
meta-5.5.5:5/5::gentoo, installed)
    >=kde-plasma/kdecoration-5.5.5:5 required by (kde-
plasma/breeze-5.5.5:5/5::gentoo, installed)
    >=kde-plasma/kdecoration-5.5.5:5 required by (kde-
plasma/oxygen-5.5.5:5/5::gentoo, installed)
    >=kde-plasma/kdecoration-5.5.5:5 required by (kde-
plasma/kwin-5.5.5:5/5::gentoo, installed)

  (kde-frameworks/solid-5.18.0:5/5.18::gentoo, installed) pulled in by
    >=kde-frameworks/solid-5.18:5 required by (kde-
frameworks/krunner-5.18.0:5/5.18::gentoo, installed)
    >=kde-frameworks/solid-5.18.0:5 required by (kde-apps/kio-
extras-15.08.3:5/5::gentoo, installed)
    >=kde-frameworks/solid-5.18:5 required by (kde-
frameworks/baloo-5.18.0:5/5.18::gentoo, installed)
    >=kde-frameworks/solid-5.18.0:5 required by (kde-plasma/plasma-
workspace-5.5.5-r2:5/5::gentoo, installed)
    >=kde-frameworks/solid-5.18:5 required by (kde-
frameworks/kio-5.18.0:5/5.18::gentoo, installed)
    >=kde-frameworks/solid-5.18:5 required by (kde-
frameworks/kdelibs4support-5.18.0:5/5.18::gentoo, installed)
    >=kde-frameworks/solid-5.18.0:5 required by (kde-plasma/plasma-
nm-5.5.5:5/5::gentoo, installed)
    >=kde-frameworks/solid-5.18.0:5 required by (kde-
plasma/kinfocenter-5.5.5:5/5::gentoo, installed)
    >=kde-frameworks/solid-5.18.0:5 required by (kde-
plasma/powerdevil-5.5.5:5/5::gentoo, installed)
    >=kde-frameworks/solid-5.18.0:5 required by (kde-plasma/plasma-
desktop-5.5.5:5/5::gentoo, installed)

die Liste geht in diesem Stiel noch nahezu endlos weiter.


Reply | Threaded
Open this post in threaded view
|

Re: Update auf kde5

Sven Eden
Hallo Sebastian.

Am Sonntag, 24. April 2016, 19:04:33 CEST schrieb Sebastian:
> Ich verstehe den Grund nicht bzw was ist der Unterschied der Variante ...
> 5.1.8 zu ... 5.1.8.0 Was den größten teil zu betreffen scheint.

Du meinst kde-frameworks, ja?
Ich sehe derzeit 5.18.0 und ~5.21.0. Eine Variante 5.1.8 gibt es gar nicht.

In Plasma gibt es 5.5.5, ~5.6.2 und ~5.6.3.

Plasma-5.5.5 arbeitet mit Frameworks-5.18.0 und Plasma-5.6.x mit
Frameworks-5.21.0.

> Habe dann da ich die Blocks nicht zu lösen verstanden habe
> emerge --ask kde-plasma/plasma-meta vor dem world Update gemacht.

Die Blocks wären interessant zu sehen.

>  * Error: The above package list contains packages which cannot be
>  * installed at the same time on the same system.
>
> (...) lange Liste

Statt der Liste wäre es interessanter zu sehen, wie der der Update-Baum
aussieht.

Ich tippe darauf, dass in kde-frameworks oder kde-plasma irgendwo ein Paket
zwischen ist, dass entweder
a) in der niedrigen Version noch ein keyword hat (~) oder
b) in der höheren Version freigeschaltet ist.

Beides würde für jede Menge Blocks sorgen, da die Abhängigkeiten nicht
aufgelöst werden können.

Gruß

Sven

signature.asc (484 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

erledigt: [gentoo-user-de] Update auf kde5

Sebastian
Hallo,

danke für die Rückmeldung.

Am Tuesday, 26. April 2016, 08:04:18 schrieb Sven Eden:
> Hallo Sebastian.
>
> Am Sonntag, 24. April 2016, 19:04:33 CEST schrieb Sebastian:
> > Ich verstehe den Grund nicht bzw was ist der Unterschied der Variante ...
> > 5.1.8 zu ... 5.1.8.0 Was den größten teil zu betreffen scheint.
>
> Du meinst kde-frameworks, ja?
> Ich sehe derzeit 5.18.0 und ~5.21.0. Eine Variante 5.1.8 gibt es gar nicht.

Ja ich meinte 5.18.0 da war ein Punkt zufiel.

>
> In Plasma gibt es 5.5.5, ~5.6.2 und ~5.6.3.

Hier 5.5.5

>
> Plasma-5.5.5 arbeitet mit Frameworks-5.18.0 und Plasma-5.6.x mit
> Frameworks-5.21.0.
>
> > Habe dann da ich die Blocks nicht zu lösen verstanden habe
> > emerge --ask kde-plasma/plasma-meta vor dem world Update gemacht.
>
> Die Blocks wären interessant zu sehen.
>
> >  * Error: The above package list contains packages which cannot be
> >  * installed at the same time on the same system.
> >
> > (...) lange Liste
>
> Statt der Liste wäre es interessanter zu sehen, wie der der Update-Baum
> aussieht.
>
> Ich tippe darauf, dass in kde-frameworks oder kde-plasma irgendwo ein Paket
> zwischen ist, dass entweder
> a) in der niedrigen Version noch ein keyword hat (~) oder
> b) in der höheren Version freigeschaltet ist.
>
> Beides würde für jede Menge Blocks sorgen, da die Abhängigkeiten nicht
> aufgelöst werden können.

da habe ich nochmal gründlicher nachgesehen und festgestellt dass es ein Use-
flag Problem ist. Mit ändern des Profiles von Desktop in Desktop/Plasma war das
Problem weg.
Dafür aber mein Fehler LO selber zu kompilieren führte zu Platzproblemen in
/var/tmp/portage.
Durch einbinden einer leeren Platte an dieser stelle läuft das Update jetzt.

Gruß
Sebastian