VirtualBox: invisible executable

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

VirtualBox: invisible executable

Tamas Karpati
Hi,
Sorry for a stupid question: VirtualBox installed faillessly, however,
couldn't find an appropriate executable to ignite it. Only I found
VBoxHeadless, VBoxSDL, VBoxVRDP, VBoxManage and
VBoxTunctl in /usr/bin ... no virtualbox or anything else I've seen
in wikis or at the home page. Checked /usr/lib64/virtualbox, too,
to no avail. The USE flag vboxwebsrv was off but the logs
mention an XPCOM server being present (after blind shooting at
various exes). OpenRC is aware of the modules, seen them via
lsmod after reboot. Stuck (ridicolous me today :(
Plz, ideas...

Thanks in advance,
  toma

Reply | Threaded
Open this post in threaded view
|

Re: VirtualBox: invisible executable

Mark Knecht
On Thu, Feb 5, 2015 at 7:23 AM, Tamas Karpati <[hidden email]> wrote:

> Hi,
> Sorry for a stupid question: VirtualBox installed faillessly, however,
> couldn't find an appropriate executable to ignite it. Only I found
> VBoxHeadless, VBoxSDL, VBoxVRDP, VBoxManage and
> VBoxTunctl in /usr/bin ... no virtualbox or anything else I've seen
> in wikis or at the home page. Checked /usr/lib64/virtualbox, too,
> to no avail. The USE flag vboxwebsrv was off but the logs
> mention an XPCOM server being present (after blind shooting at
> various exes). OpenRC is aware of the modules, seen them via
> lsmod after reboot. Stuck (ridicolous me today :(
> Plz, ideas...
>
> Thanks in advance,
>   toma
>

/usr/bin/VirtualBox

That should start up the GUI where you can do an install.

HTH,
Mark

Reply | Threaded
Open this post in threaded view
|

Re: VirtualBox: invisible executable

Mark Knecht
On Thu, Feb 5, 2015 at 7:54 AM, Mark Knecht <[hidden email]> wrote:

> On Thu, Feb 5, 2015 at 7:23 AM, Tamas Karpati <[hidden email]> wrote:
>> Hi,
>> Sorry for a stupid question: VirtualBox installed faillessly, however,
>> couldn't find an appropriate executable to ignite it. Only I found
>> VBoxHeadless, VBoxSDL, VBoxVRDP, VBoxManage and
>> VBoxTunctl in /usr/bin ... no virtualbox or anything else I've seen
>> in wikis or at the home page. Checked /usr/lib64/virtualbox, too,
>> to no avail. The USE flag vboxwebsrv was off but the logs
>> mention an XPCOM server being present (after blind shooting at
>> various exes). OpenRC is aware of the modules, seen them via
>> lsmod after reboot. Stuck (ridicolous me today :(
>> Plz, ideas...
>>
>> Thanks in advance,
>>   toma
>>
>
> /usr/bin/VirtualBox
>
> That should start up the GUI where you can do an install.
>
> HTH,
> Mark

In case it's a flags issue here's what I have installed:

c2RAID6 ~ # emerge -pv virtualbox virtualbox-additions
virtualbox-extpack-oracle virtualbox-modules

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ~] app-emulation/virtualbox-additions-4.3.20  0 KiB
[ebuild   R   ~] app-emulation/virtualbox-modules-4.3.20
USE="-pax_kernel" 0 KiB
[ebuild   R   ~] app-emulation/virtualbox-4.3.20-r1  USE="additions
alsa java opengl pam qt4 sdk udev -doc -extensions -headless
-pulseaudio -python -vboxwebsrv -vnc" PYTHON_TARGETS="python2_7" 0 KiB
[ebuild   R   ~] app-emulation/virtualbox-extpack-oracle-4.3.20.96996  0 KiB

Total: 4 packages (4 reinstalls), Size of downloads: 0 KiB
c2RAID6 ~ #

Reply | Threaded
Open this post in threaded view
|

Re: VirtualBox: invisible executable

Tamas Karpati
Dear Mark,

Thank you for your effort again. Quick rechecked to see that all four
pkgs that you've mentioned are already installed. I think this comes
from the USE flags, I've added extensions and sdk to defaults.
Besides, I use "emerge -vbuND", not just "emerge -v".

Regards,
  toma


On Thu, Feb 5, 2015 at 4:58 PM, Mark Knecht <[hidden email]> wrote:

> On Thu, Feb 5, 2015 at 7:54 AM, Mark Knecht <[hidden email]> wrote:
>> On Thu, Feb 5, 2015 at 7:23 AM, Tamas Karpati <[hidden email]> wrote:
>>> Hi,
>>> Sorry for a stupid question: VirtualBox installed faillessly, however,
>>> couldn't find an appropriate executable to ignite it. Only I found
>>> VBoxHeadless, VBoxSDL, VBoxVRDP, VBoxManage and
>>> VBoxTunctl in /usr/bin ... no virtualbox or anything else I've seen
>>> in wikis or at the home page. Checked /usr/lib64/virtualbox, too,
>>> to no avail. The USE flag vboxwebsrv was off but the logs
>>> mention an XPCOM server being present (after blind shooting at
>>> various exes). OpenRC is aware of the modules, seen them via
>>> lsmod after reboot. Stuck (ridicolous me today :(
>>> Plz, ideas...
>>>
>>> Thanks in advance,
>>>   toma
>>>
>>
>> /usr/bin/VirtualBox
>>
>> That should start up the GUI where you can do an install.
>>
>> HTH,
>> Mark
>
> In case it's a flags issue here's what I have installed:
>
> c2RAID6 ~ # emerge -pv virtualbox virtualbox-additions
> virtualbox-extpack-oracle virtualbox-modules
>
> These are the packages that would be merged, in order:
>
> Calculating dependencies... done!
> [ebuild   R   ~] app-emulation/virtualbox-additions-4.3.20  0 KiB
> [ebuild   R   ~] app-emulation/virtualbox-modules-4.3.20
> USE="-pax_kernel" 0 KiB
> [ebuild   R   ~] app-emulation/virtualbox-4.3.20-r1  USE="additions
> alsa java opengl pam qt4 sdk udev -doc -extensions -headless
> -pulseaudio -python -vboxwebsrv -vnc" PYTHON_TARGETS="python2_7" 0 KiB
> [ebuild   R   ~] app-emulation/virtualbox-extpack-oracle-4.3.20.96996  0 KiB
>
> Total: 4 packages (4 reinstalls), Size of downloads: 0 KiB
> c2RAID6 ~ #
>

Reply | Threaded
Open this post in threaded view
|

Re: VirtualBox: invisible executable

Mark Knecht
On Thu, Feb 5, 2015 at 11:43 AM, Tamas Karpati <[hidden email]> wrote:

> Dear Mark,
>
> Thank you for your effort again. Quick rechecked to see that all four
> pkgs that you've mentioned are already installed. I think this comes
> from the USE flags, I've added extensions and sdk to defaults.
> Besides, I use "emerge -vbuND", not just "emerge -v".
>
> Regards,
>   toma
>

Please bottom post if possible. Thanks.

-b is OK. I do that and a bit more in my make.conf file:

EMERGE_DEFAULT_OPTS="--with-bdeps=y --jobs=5"
MAKEOPTS="-j13 -l8"
PORTAGE_NICENESS=5
PORTAGE_IONICE_COMMAND="ionice -c 3 -p \${PID}"

Note that this is a 12 core processor machine so those setting may
well not be right for your hardware.

Cheers,
Mark

Reply | Threaded
Open this post in threaded view
|

Re: VirtualBox: invisible executable

Tamas Karpati
On Thu, Feb 5, 2015 at 8:48 PM, Mark Knecht <[hidden email]> wrote:

> On Thu, Feb 5, 2015 at 11:43 AM, Tamas Karpati <[hidden email]> wrote:
>> Dear Mark,
>>
>> Thank you for your effort again. Quick rechecked to see that all four
>> pkgs that you've mentioned are already installed. I think this comes
>> from the USE flags, I've added extensions and sdk to defaults.
>> Besides, I use "emerge -vbuND", not just "emerge -v".
>>
>> Regards,
>>   toma
>>
>
> Please bottom post if possible. Thanks.

sure. sorry!

> -b is OK. I do that and a bit more in my make.conf file:
>
> EMERGE_DEFAULT_OPTS="--with-bdeps=y --jobs=5"

Ooops, --jobs is very very wild! I will cosider bdeps, too.

> MAKEOPTS="-j13 -l8"

This I already use, although not much gain when Python is in action.
(Maybe --jobs was invented for this reason?)

> PORTAGE_NICENESS=5
> PORTAGE_IONICE_COMMAND="ionice -c 3 -p \${PID}"

Usually I just have my coffee during emerge -u, no desktop
work on this machine that time, but maybe usefull if do not want to kill
the simulations during builds that do not need the recompilation of the SWs.
I update when no calculation is in progress.
NB: last two options haven't yet hit my man pages.

> Note that this is a 12 core processor machine so those setting may
> well not be right for your hardware.

Wow, nice. kernel baked in 2 mins? great.

Anyways, VB is not yet working and only I'll have the time for WS next
week. Will let you know the results. Thank you so much so far,
   toma

Reply | Threaded
Open this post in threaded view
|

Re: VirtualBox: invisible executable

Tamas Karpati
sorry for not summarizing for so long...

It took time to figure out that the qt4 USE flag is necessary to
have the executable "VirtualBox" installed. Pkg compiles smoothly
and the exe presents me with a VMWare Workstation -like tool.
Its all nice, albeit somewhat slow, and does what I need.

I'm not sure if the mentioned USE flag behavior is the expected
or just an err, as I'm probably not an average user of VB.

In my experience some GUI problems that troubled me with _old_
VMWW-s are not present in actual VB but the speedlessness raises
other problems for otherwise slow GUIs running within the guest.
I will possibly continue using VB. On the other hand, I will work to
make VMWW run on my Gentoo box, although I don't want to
stick to specific kernel and ? SW pkgs just beacuse VMWW
needs them.

Thanks for all the comments.

Best regards,
  toma