Xorg

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Xorg

Jens Mueller-3
Hello,

I installed gentoo on my XBox following the instructions on
http://gentoo-wiki.com/Gentoo_for_Xbox.
After installing xorg-x11, I tried

$ X -configure

, which failed with
"Duplicate symbol NVDACInit in /usr/lib/modules/drivers/nvxbox_drv.o
Also defined in /usr/lib/modules/drivers/nv_drv.o"

That's why I

$ mv /usr/lib/modules/drivers/nv_drv.o /usr/lib/modules/drivers/nv_drv.o2

and executed again:

$ X -configure

with output
"(EE) Failed to load module "nv" (module does not exist, 0)
(++) Using config file: "/root/xorg.conf.new"
(EE) NVXBOX(0): No V_BIOS found


Xorg detected your mouse at device /dev/mouse.
Please check your config if the mouse is still not
operational, as by default Xorg tries to autodetect
the protocol.

Your xorg.conf file is /root/xorg.conf.new

To test the server, run 'X -config /root/xorg.conf.new'"

I tried starting the x server with

$ X -config /root/xorg.conf.new

, which failed with
"(EE) NVXBOX(0): No V_BIOS found

   *** If unresolved symbols were reported above, they might not
   *** be the reason for the server aborting.

Fatal server error:
Caught signal 11.  Server aborting"

I don't find any unresolved symbols in /var/log/Xorg.0.log.
I'm running Xorg 6.8.2 and kernel 2.6.14.3-xbox.  Has anybody a working
xorg.conf for the xbox?

Greetings,
Jens
--
[hidden email] mailing list

Reply | Threaded
Open this post in threaded view
|

Re: Xorg

Chris Bainbridge
On 19/02/06, Jens Mueller <[hidden email]> wrote:
> "Duplicate symbol NVDACInit in /usr/lib/modules/drivers/nvxbox_drv.o
> Also defined in /usr/lib/modules/drivers/nv_drv.o"

The symbol should probably be renamed for nvxbox.

> $ X -configure

I think this still doesn't work on the xbox.

> , which failed with
> "(EE) NVXBOX(0): No V_BIOS found

That message is normal. Any other errors?

> I don't find any unresolved symbols in /var/log/Xorg.0.log.
> I'm running Xorg 6.8.2 and kernel 2.6.14.3-xbox.  Has anybody a working
> xorg.conf for the xbox?

http://cvs.xbox-linux.org/viewcvs.py/xbox-linux/Xorg/

--
[hidden email] mailing list

Reply | Threaded
Open this post in threaded view
|

Re: Xorg

Jens Mueller-3
> > "Duplicate symbol NVDACInit in /usr/lib/modules/drivers/nvxbox_drv.o
> > Also defined in /usr/lib/modules/drivers/nv_drv.o"
>
> The symbol should probably be renamed for nvxbox.
>
> > $ X -configure
>
> I think this still doesn't work on the xbox.

I added a link to the working xorg.conf file to the wiki.

> > , which failed with
> > "(EE) NVXBOX(0): No V_BIOS found
>
> That message is normal. Any other errors?

I searched for "EE" in /var/log/Xorg.0.log, but didn't find anything
except the unproblematic 'No V_BIOS found'.

> > I don't find any unresolved symbols in /var/log/Xorg.0.log.
> > I'm running Xorg 6.8.2 and kernel 2.6.14.3-xbox.  Has anybody a working
> > xorg.conf for the xbox?
>
> http://cvs.xbox-linux.org/viewcvs.py/xbox-linux/Xorg/

Thanks. Sorry, I should have found that myself.

Greetings,
Jens
--
[hidden email] mailing list