colord failed to upgrade

classic Classic list List threaded Threaded
27 messages Options
12
Reply | Threaded
Open this post in threaded view
|

colord failed to upgrade

gevisz
In my today's system update I have got the following error message:

 * ERROR: x11-misc/colord-1.2.1-r1::gentoo failed (configure phase):
 *   econf failed
 *
 * Call stack:
 *          ebuild.sh, line   93:  Called src_configure
 *        environment, line 3551:  Called gnome2_src_configure
   '--disable-bash-completion' '--disable-examples' '--disable-static'
   '--enable-libcolordcompat' '--with-daemon-user=colord'
   '--localstatedir=/var' '--disable-print-profiles' '--enable-gusb'
   '--enable-reverse' '--enable-introspection' '--enable-polkit'
   '--disable-sane' '--disable-systemd-login' '--enable-udev'
   '--with-udevrulesdir=/lib/udev/rules.d' '--disable-vala'
   '--with-systemdsystemunitdir=/usr/lib/systemd/system'
 *        environment, line 2732:  Called econf
   '--docdir=/usr/share/doc/colord-1.2.1-r1'
   '--disable-schemas-compile' '--disable-gtk-doc'
   '--disable-bash-completion' '--disable-examples' '--disable-static'
   '--enable-libcolordcompat' '--with-daemon-user=colord'
   '--localstatedir=/var' '--disable-print-profiles' '--enable-gusb'
   '--enable-reverse' '--enable-introspection' '--enable-polkit'
   '--disable-sane' '--disable-systemd-login' '--enable-udev'
   '--with-udevrulesdir=/lib/udev/rules.d' '--disable-vala'
   '--with-systemdsystemunitdir=/usr/lib/systemd/system'
 *   phase-helpers.sh, line  584:  Called die
 * The specific snippet of code:
 *   die "econf failed"
 *
 * If you need support, post the output of `emerge --info
   '=x11-misc/colord-1.2.1-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv
   '=x11-misc/colord-1.2.1-r1::gentoo'`.
 * The complete build log is located at
   '/var/tmp/portage/x11-misc/colord-1.2.1-r1/temp/build.log'.
 * The ebuild environment file is located at
   '/var/tmp/portage/x11-misc/colord-1.2.1-r1/temp/environment'.
 * Working directory:
   '/var/tmp/portage/x11-misc/colord-1.2.1-r1/work/colord-1.2.1'
 * S: '/var/tmp/portage/x11-misc/colord-1.2.1-r1/work/colord-1.2.1'

# emerge --info '=x11-misc/colord-1.2.1-r1::gentoo'
Portage 2.2.8-r1 (default/linux/amd64/13.0/desktop/gnome, gcc-4.7.3,
glibc-2.19-r1, 3.12.21-gentoo-r1 x86_64)
=================================================================
System Settings
=================================================================
System uname:
Linux-3.12.21-gentoo-r1-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_5000+-with-gentoo-2.2
KiB Mem:     7907512 total,   4781784 free KiB Swap:   11999228 total,
11999228 free Timestamp of tree: Thu, 31 Jul 2014 00:45:01 +0000 ld GNU
ld (GNU Binutils) 2.23.2 app-shells/bash:          4.2_p45
dev-lang/python:          2.7.6, 3.3.3
dev-util/cmake:           2.8.12.2-r1
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.13.4
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.13 (virtual/os-headers)
sys-libs/glibc:           2.19-r1
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified
distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch
preserve-libs protect-owned sandbox sfperms strict
unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv
usersandbox usersync webrsync-gpg" FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://de-mirror.org/gentoo/" LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed" MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages" PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times
--omit-dir-times --compress --force --whole-file --delete --stats
--human-readable --timeout=180 --exclude=/distfiles --exclude=/local
--exclude=/packages" PORTAGE_TMPDIR="/var/tmp" PORTDIR="/usr/portage"
PORTDIR_OVERLAY="" SYNC=""
USE="X a52 aac acl acpi alsa amd64 berkdb bindist branding bzip2 cairo
cdda cdr cli colord consolekit cracklib crypt cups cxx dbus dri dts dvd
dvdr eds emboss encode evo exif fam firefox flac fortran gdbm gif
gnome-keyring gnome-online-accounts gpm gstreamer gtk gtkstyle iconv
introspection ipv6 jpeg lcms ldap libnotify libsecret mad mmx mng
modules mp3 mp4 mpeg multilib nautilus ncurses nls nptl ogg opengl
openmp pam pango pcre pdf png policykit ppds pulseaudio qt3support qt4
readline sdl session smp socialweb spell sse sse2 ssl
startup-notification svg tcpd tiff truetype udev udisks unicode upower
usb vorbis wxwidgets x264 xcb xml xv xvid zlib" ABI_X86="64"
ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci
emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0
intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci"
APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions
alias auth_basic authn_alias authn_anon authn_dbm authn_default
authn_file authz_dbm authz_default authz_groupfile authz_host
authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock
deflate dir disk_cache env expires ext_filter file_cache filter headers
include info log_config logio mem_cache mime mime_magic negotiation
rewrite setenvif speling status unique_id userdir usertrack
vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage
tables krita karbon braindump author" CAMERAS="ptp2"
COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog"
ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18
garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver
oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip
tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux"
LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb
ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console
presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice"
PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7"
PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20"
SANE_BACKENDS="hp3500" USERLAND="GNU" VIDEO_CARDS="radeon"
XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p
iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark
ipmark dhcpmac delude chaos account" Unset:  CPPFLAGS, CTARGET,
EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND,
PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS,
USE_PYTHON

Any thought? Thank you.

Reply | Threaded
Open this post in threaded view
|

Re: colord failed to upgrade

Alan McKinnon-2
On 31/07/2014 15:29, Gevisz wrote:
> In my today's system update I have got the following error message:
>
>  * ERROR: x11-misc/colord-1.2.1-r1::gentoo failed (configure phase):
>  *   econf failed




The actual error message is earlier than this point[1]. Please go
through that referenced log, find the error message and report



[1] all that the bit you posted says is "something went wrong", it
doesn't; say what




>  *
>  * Call stack:
>  *          ebuild.sh, line   93:  Called src_configure
>  *        environment, line 3551:  Called gnome2_src_configure
>    '--disable-bash-completion' '--disable-examples' '--disable-static'
>    '--enable-libcolordcompat' '--with-daemon-user=colord'
>    '--localstatedir=/var' '--disable-print-profiles' '--enable-gusb'
>    '--enable-reverse' '--enable-introspection' '--enable-polkit'
>    '--disable-sane' '--disable-systemd-login' '--enable-udev'
>    '--with-udevrulesdir=/lib/udev/rules.d' '--disable-vala'
>    '--with-systemdsystemunitdir=/usr/lib/systemd/system'
>  *        environment, line 2732:  Called econf
>    '--docdir=/usr/share/doc/colord-1.2.1-r1'
>    '--disable-schemas-compile' '--disable-gtk-doc'
>    '--disable-bash-completion' '--disable-examples' '--disable-static'
>    '--enable-libcolordcompat' '--with-daemon-user=colord'
>    '--localstatedir=/var' '--disable-print-profiles' '--enable-gusb'
>    '--enable-reverse' '--enable-introspection' '--enable-polkit'
>    '--disable-sane' '--disable-systemd-login' '--enable-udev'
>    '--with-udevrulesdir=/lib/udev/rules.d' '--disable-vala'
>    '--with-systemdsystemunitdir=/usr/lib/systemd/system'
>  *   phase-helpers.sh, line  584:  Called die
>  * The specific snippet of code:
>  *   die "econf failed"
>  *
>  * If you need support, post the output of `emerge --info
>    '=x11-misc/colord-1.2.1-r1::gentoo'`,
>  * the complete build log and the output of `emerge -pqv
>    '=x11-misc/colord-1.2.1-r1::gentoo'`.
>  * The complete build log is located at
>    '/var/tmp/portage/x11-misc/colord-1.2.1-r1/temp/build.log'.
>  * The ebuild environment file is located at
>    '/var/tmp/portage/x11-misc/colord-1.2.1-r1/temp/environment'.
>  * Working directory:
>    '/var/tmp/portage/x11-misc/colord-1.2.1-r1/work/colord-1.2.1'
>  * S: '/var/tmp/portage/x11-misc/colord-1.2.1-r1/work/colord-1.2.1'
>
> # emerge --info '=x11-misc/colord-1.2.1-r1::gentoo'
> Portage 2.2.8-r1 (default/linux/amd64/13.0/desktop/gnome, gcc-4.7.3,
> glibc-2.19-r1, 3.12.21-gentoo-r1 x86_64)
> =================================================================
> System Settings
> =================================================================
> System uname:
> Linux-3.12.21-gentoo-r1-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_5000+-with-gentoo-2.2
> KiB Mem:     7907512 total,   4781784 free KiB Swap:   11999228 total,
> 11999228 free Timestamp of tree: Thu, 31 Jul 2014 00:45:01 +0000 ld GNU
> ld (GNU Binutils) 2.23.2 app-shells/bash:          4.2_p45
> dev-lang/python:          2.7.6, 3.3.3
> dev-util/cmake:           2.8.12.2-r1
> dev-util/pkgconfig:       0.28-r1
> sys-apps/baselayout:      2.2
> sys-apps/openrc:          0.12.4
> sys-apps/sandbox:         2.6-r1
> sys-devel/autoconf:       2.13, 2.69
> sys-devel/automake:       1.11.6, 1.13.4
> sys-devel/binutils:       2.23.2
> sys-devel/gcc:            4.7.3-r1
> sys-devel/gcc-config:     1.7.3
> sys-devel/libtool:        2.4.2-r1
> sys-devel/make:           3.82-r4
> sys-kernel/linux-headers: 3.13 (virtual/os-headers)
> sys-libs/glibc:           2.19-r1
> Repositories: gentoo
> ACCEPT_KEYWORDS="amd64"
> ACCEPT_LICENSE="* -@EULA"
> CBUILD="x86_64-pc-linux-gnu"
> CFLAGS="-march=native -O2 -pipe"
> CHOST="x86_64-pc-linux-gnu"
> CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
> CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
> CXXFLAGS="-march=native -O2 -pipe"
> DISTDIR="/usr/portage/distfiles"
> FCFLAGS="-O2 -pipe"
> FEATURES="assume-digests binpkg-logs config-protect-if-modified
> distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch
> preserve-libs protect-owned sandbox sfperms strict
> unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv
> usersandbox usersync webrsync-gpg" FFLAGS="-O2 -pipe"
> GENTOO_MIRRORS="http://de-mirror.org/gentoo/" LANG="en_US.UTF-8"
> LDFLAGS="-Wl,-O1 -Wl,--as-needed" MAKEOPTS="-j3"
> PKGDIR="/usr/portage/packages" PORTAGE_CONFIGROOT="/"
> PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times
> --omit-dir-times --compress --force --whole-file --delete --stats
> --human-readable --timeout=180 --exclude=/distfiles --exclude=/local
> --exclude=/packages" PORTAGE_TMPDIR="/var/tmp" PORTDIR="/usr/portage"
> PORTDIR_OVERLAY="" SYNC=""
> USE="X a52 aac acl acpi alsa amd64 berkdb bindist branding bzip2 cairo
> cdda cdr cli colord consolekit cracklib crypt cups cxx dbus dri dts dvd
> dvdr eds emboss encode evo exif fam firefox flac fortran gdbm gif
> gnome-keyring gnome-online-accounts gpm gstreamer gtk gtkstyle iconv
> introspection ipv6 jpeg lcms ldap libnotify libsecret mad mmx mng
> modules mp3 mp4 mpeg multilib nautilus ncurses nls nptl ogg opengl
> openmp pam pango pcre pdf png policykit ppds pulseaudio qt3support qt4
> readline sdl session smp socialweb spell sse sse2 ssl
> startup-notification svg tcpd tiff truetype udev udisks unicode upower
> usb vorbis wxwidgets x264 xcb xml xv xvid zlib" ABI_X86="64"
> ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci
> emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0
> intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci"
> APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions
> alias auth_basic authn_alias authn_anon authn_dbm authn_default
> authn_file authz_dbm authz_default authz_groupfile authz_host
> authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock
> deflate dir disk_cache env expires ext_filter file_cache filter headers
> include info log_config logio mem_cache mime mime_magic negotiation
> rewrite setenvif speling status unique_id userdir usertrack
> vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage
> tables krita karbon braindump author" CAMERAS="ptp2"
> COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog"
> ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18
> garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver
> oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip
> tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux"
> LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb
> ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console
> presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice"
> PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7"
> PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20"
> SANE_BACKENDS="hp3500" USERLAND="GNU" VIDEO_CARDS="radeon"
> XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p
> iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark
> ipmark dhcpmac delude chaos account" Unset:  CPPFLAGS, CTARGET,
> EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND,
> PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS,
> USE_PYTHON
>
> Any thought? Thank you.
>
>
>


--
Alan McKinnon
[hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: colord failed to upgrade

gevisz
On Thu, 31 Jul 2014 15:36:38 +0200
Alan McKinnon <[hidden email]> wrote:

> On 31/07/2014 15:29, Gevisz wrote:
> > In my today's system update I have got the following error message:
> >
> >  * ERROR: x11-misc/colord-1.2.1-r1::gentoo failed (configure phase):
> >  *   econf failed
>
> The actual error message is earlier than this point[1]. Please go
> through that referenced log, find the error message and report

Yes, you are right. Earlier in the colord emege log
I have found the following:

checking for XML::Parser... configure: error: XML::Parser perl module
is required for intltool

And even earlier in the emerge log were the following:

 * Messages for package dev-lang/perl-5.18.2-r1:

 * UPDATE THE PERL MODULES:
 * After updating dev-lang/perl you must reinstall
 * the installed perl modules.
 * Use: perl-cleaner --all

And after running just now # perl-cleaner --all
I have got the real trouble. The output is below.
Shall I rename the Subject to "perl failed to upgrade"?

# perl-cleaner --all

 * Beginning a clean up of .ph files
 * Excluding files for 5.18.2 and 5.18.2/x86_64-linux from cleaning

 * Locating ph files for removal

 * Updating ph files.
 * Ignore all "No such file..." messages!
Can't open machine/ansi.h: No such file or directory
Can't open sys/_types.h: No such file or directory
Can't open gnu/stubs-x32.h: No such file or directory
Can't open gnu/stubs-x32.h: No such file or directory
Can't open gnu/stubs-x32.h: No such file or directory
Can't open gnu/stubs-x32.h: No such file or directory

 * Locating packages for an update
 * Locating ebuilds linked against libperl
 *   Adding to list: dev-perl/File-DesktopEntry:0
 *   Adding to list: dev-perl/XML-NamespaceSupport:0
 *   Adding to list: dev-perl/Authen-SASL:0
 *   Adding to list: dev-perl/OLE-StorageLite:0
 *   Adding to list: dev-perl/Digest-Perl-MD5:0
 *   Adding to list: dev-perl/XML-Simple:0
 *   Adding to list: dev-perl/Digest-HMAC:0
 *   Adding to list: dev-perl/Net-SMTP-SSL:0
 *   Adding to list: dev-perl/XML-SAX-Base:0
 *   Adding to list: dev-perl/File-MimeInfo:0
 *   Adding to list: dev-perl/Unicode-Map:0
 *   Adding to list: dev-perl/XML-LibXML:0
 *   Adding to list: dev-perl/Locale-gettext:0
 *   Adding to list: dev-perl/Crypt-RC4:0
 *   Adding to list: dev-perl/File-BaseDir:0
 *   Adding to list: dev-perl/XML-Parser:0
 *   Adding to list: dev-perl/XML-SAX:0
 *   Adding to list: dev-perl/Spreadsheet-ParseExcel:0
 *   Adding to list: dev-perl/IO-stringy:0
 *   Adding to list: perl-core/IPC-Cmd:0
 *                   virtual/perl-IPC-Cmd:0
 *   Adding to list: perl-core/Module-CoreList:0
 *                   virtual/perl-Module-CoreList:0
 *   Adding to list: perl-core/IO:0
 *                   virtual/perl-IO:0
 *   Adding to list: perl-core/File-Spec:0
 *                   virtual/perl-File-Spec:0
 *   Adding to list: perl-core/CPAN-Meta:0
 *                   virtual/perl-CPAN-Meta:0
 *   Adding to list: perl-core/Module-Build:0
 *                   virtual/perl-Module-Build:0
 *   Adding to list: perl-core/ExtUtils-ParseXS:0
 *                   virtual/perl-ExtUtils-ParseXS:0
 *   Adding to list: perl-core/version:0
 *                   virtual/perl-version:0
 *   Adding to list: perl-core/Archive-Tar:0
 *                   virtual/perl-Archive-Tar:0
 *   Adding to list: perl-core/Module-Load:0
 *                   virtual/perl-Module-Load:0
 *   Adding to list: perl-core/Test-Harness:0
 *                   virtual/perl-Test-Harness:0
 *   Adding to list: perl-core/CPAN-Meta-Requirements:0
 *                   virtual/perl-CPAN-Meta-Requirements:0
 *   Adding to list: perl-core/Compress-Raw-Bzip2:0
 *                   virtual/perl-Compress-Raw-Bzip2:0
 *   Adding to list: perl-core/IO-Compress:0
 *                   virtual/perl-IO-Compress:0
 *   Adding to list: perl-core/ExtUtils-MakeMaker:0
 *                   virtual/perl-ExtUtils-MakeMaker:0
 *   Adding to list: perl-core/Parse-CPAN-Meta:0
 *                   virtual/perl-Parse-CPAN-Meta:0
 *   Adding to list: perl-core/Digest-MD5:0
 *                   virtual/perl-Digest-MD5:0
 *   Adding to list: perl-core/ExtUtils-Manifest:0
 *                   virtual/perl-ExtUtils-Manifest:0
 *   Adding to list: perl-core/Module-Metadata:0
 *                   virtual/perl-Module-Metadata:0
 *   Adding to list: perl-core/Scalar-List-Utils:0
 *                   virtual/perl-Scalar-List-Utils:0
 *   Adding to list: perl-core/Compress-Raw-Zlib:0
 *                   virtual/perl-Compress-Raw-Zlib:0
 *   Adding to list: perl-core/Params-Check:0
 *                   virtual/perl-Params-Check:0
 *   Adding to list: perl-core/Time-Local:0
 *                   virtual/perl-Time-Local:0
 *   Adding to list: perl-core/ExtUtils-CBuilder:0
 *                   virtual/perl-ExtUtils-CBuilder:0
 *   Adding to list: perl-core/Module-Load-Conditional:0
 *                   virtual/perl-Module-Load-Conditional:0
 *   Adding to list: perl-core/CPAN-Meta-YAML:0
 *                   virtual/perl-CPAN-Meta-YAML:0
 * emerge -vD1 --backtrack=30 dev-perl/File-DesktopEntry:0
   dev-perl/XML-NamespaceSupport:0 dev-perl/Authen-SASL:0
   dev-perl/OLE-StorageLite:0 dev-perl/Digest-Perl-MD5:0
   dev-perl/XML-Simple:0 dev-perl/Digest-HMAC:0 dev-perl/Net-SMTP-SSL:0
   dev-perl/XML-SAX-Base:0 dev-perl/File-MimeInfo:0
   dev-perl/Unicode-Map:0 dev-perl/XML-LibXML:0
   dev-perl/Locale-gettext:0 dev-perl/Crypt-RC4:0
   dev-perl/File-BaseDir:0 dev-perl/XML-Parser:0 dev-perl/XML-SAX:0
   dev-perl/Spreadsheet-ParseExcel:0 dev-perl/IO-stringy:0
   perl-core/IPC-Cmd:0 virtual/perl-IPC-Cmd:0
   perl-core/Module-CoreList:0 virtual/perl-Module-CoreList:0
   perl-core/IO:0 virtual/perl-IO:0 perl-core/File-Spec:0
   virtual/perl-File-Spec:0 perl-core/CPAN-Meta:0
   virtual/perl-CPAN-Meta:0 perl-core/Module-Build:0
   virtual/perl-Module-Build:0 perl-core/ExtUtils-ParseXS:0
   virtual/perl-ExtUtils-ParseXS:0 perl-core/version:0
   virtual/perl-version:0 perl-core/Archive-Tar:0
   virtual/perl-Archive-Tar:0 perl-core/Module-Load:0
   virtual/perl-Module-Load:0 perl-core/Test-Harness:0
   virtual/perl-Test-Harness:0 perl-core/CPAN-Meta-Requirements:0
   virtual/perl-CPAN-Meta-Requirements:0 perl-core/Compress-Raw-Bzip2:0
   virtual/perl-Compress-Raw-Bzip2:0 perl-core/IO-Compress:0
   virtual/perl-IO-Compress:0 perl-core/ExtUtils-MakeMaker:0
   virtual/perl-ExtUtils-MakeMaker:0 perl-core/Parse-CPAN-Meta:0
   virtual/perl-Parse-CPAN-Meta:0 perl-core/Digest-MD5:0
   virtual/perl-Digest-MD5:0 perl-core/ExtUtils-Manifest:0
   virtual/perl-ExtUtils-Manifest:0 perl-core/Module-Metadata:0
   virtual/perl-Module-Metadata:0 perl-core/Scalar-List-Utils:0
   virtual/perl-Scalar-List-Utils:0 perl-core/Compress-Raw-Zlib:0
   virtual/perl-Compress-Raw-Zlib:0 perl-core/Params-Check:0
   virtual/perl-Params-Check:0 perl-core/Time-Local:0
   virtual/perl-Time-Local:0 perl-core/ExtUtils-CBuilder:0
   virtual/perl-ExtUtils-CBuilder:0 perl-core/Module-Load-Conditional:0
   virtual/perl-Module-Load-Conditional:0 perl-core/CPAN-Meta-YAML:0
   virtual/perl-CPAN-Meta-YAML:0

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] virtual/perl-File-Spec-3.400.0-r2  0 kB
[ebuild     U  ] virtual/perl-version-0.990.200-r1 [0.990.100] 0 kB
[ebuild   R    ] virtual/perl-Scalar-List-Utils-1.270.0-r2  0 kB
[ebuild   R    ] dev-perl/XML-NamespaceSupport-1.110.0  0 kB
[ebuild   R    ] virtual/perl-Module-Build-0.400.300-r1  0 kB
[ebuild   R    ] virtual/perl-Parse-CPAN-Meta-1.440.400-r1  0 kB
[ebuild   R    ] virtual/perl-CPAN-Meta-YAML-0.8.0-r2  0 kB
[ebuild   R    ] virtual/perl-CPAN-Meta-2.120.921-r2  0 kB
[ebuild   R    ] virtual/perl-Module-Metadata-1.0.11-r1  0 kB
[ebuild   R    ] virtual/perl-Params-Check-0.360.0-r1  0 kB
[ebuild     U  ] virtual/perl-ExtUtils-CBuilder-0.280.210-r1
[0.280.205] 0 kB [ebuild   R    ] dev-perl/OLE-StorageLite-0.190.0  0 kB
[ebuild   R    ] dev-perl/Digest-Perl-MD5-1.800.0  0 kB
[ebuild   R    ] dev-perl/XML-SAX-Base-1.80.0  0 kB
[ebuild   R    ] dev-perl/Unicode-Map-0.112.0  0 kB
[ebuild   R    ] dev-perl/Crypt-RC4-2.020.0  0 kB
[ebuild   R    ] dev-perl/XML-Parser-2.410.0  0 kB
[ebuild   R    ] dev-perl/IO-stringy-2.110.0  0 kB
[ebuild     U  ] virtual/perl-IPC-Cmd-0.800.0-r1 [0.780.0] 0 kB
[ebuild     U  ] virtual/perl-Module-CoreList-3.30.0 [2.840.0] 0 kB
[ebuild     U  ] virtual/perl-IO-1.280.0-r1 [1.25] 0 kB
[ebuild   R    ] virtual/perl-ExtUtils-ParseXS-3.180.0-r2  0 kB
[ebuild   R    ] virtual/perl-Archive-Tar-1.900.0-r2  0 kB
[ebuild   R    ] virtual/perl-Module-Load-0.240.0-r1  0 kB
[ebuild   R    ] virtual/perl-Test-Harness-3.260.0-r2  0 kB
[ebuild   R    ] virtual/perl-CPAN-Meta-Requirements-2.122.0-r2  0 kB
[ebuild   R    ] virtual/perl-Compress-Raw-Bzip2-2.60.0-r2  0 kB
[ebuild   R    ] virtual/perl-IO-Compress-2.60.0-r1  0 kB
[ebuild     U  ] virtual/perl-ExtUtils-MakeMaker-6.660.0-r1 [6.640.0] 0
kB [ebuild   R    ] virtual/perl-Digest-MD5-2.520.0-r2  0 kB
[ebuild     U  ] virtual/perl-ExtUtils-Manifest-1.630.0-r1 [1.610.0] 0
kB [ebuild   R    ] virtual/perl-Compress-Raw-Zlib-2.60.0-r2  0 kB
[ebuild   R    ] virtual/perl-Module-Load-Conditional-0.540.0-r1  0 kB
[ebuild  N     ] perl-core/JSON-PP-2.272.0-r1  0 kB
[ebuild  N     ] perl-core/File-Temp-0.220.0-r1  38 kB
[ebuild  N     ] perl-core/Perl-OSType-1.2.0-r1  USE="{-test}" 0 kB
[ebuild   R    ] perl-core/Module-CoreList-2.840.0  0 kB
[ebuild   R    ] perl-core/IO-1.25-r1  0 kB
[ebuild   R    ] perl-core/File-Spec-3.400.0  0 kB
[ebuild     U  ] perl-core/version-0.990.100-r1 [0.990.100] 0 kB
[ebuild   R    ] perl-core/Module-Load-0.240.0  0 kB
[ebuild   R    ] perl-core/Test-Harness-3.260.0  0 kB
[ebuild   R    ] perl-core/Compress-Raw-Bzip2-2.60.0  0 kB
[ebuild     U  ] perl-core/ExtUtils-Manifest-1.610.0-r1 [1.610.0] 0 kB
[ebuild   R    ] perl-core/Scalar-List-Utils-1.270.0  0 kB
[ebuild   R    ] perl-core/Compress-Raw-Zlib-2.60.0  0 kB
[ebuild     U  ] perl-core/Time-Local-1.230.0-r1 [1.230.0] 0 kB
[ebuild   R    ] virtual/perl-Time-Local-1.230.0-r1  0 kB
[ebuild     U  ] perl-core/CPAN-Meta-YAML-0.8.0-r1 [0.8.0] 0 kB
[ebuild   R    ] dev-perl/File-BaseDir-0.30.0  USE="{-test}" 0 kB
[ebuild   R    ] dev-perl/Spreadsheet-ParseExcel-0.590.0  USE="unicode
-cjk {-test}" 0 kB [ebuild     U  ] perl-core/IPC-Cmd-0.780.0-r1
[0.780.0] 0 kB [ebuild     U  ] perl-core/ExtUtils-ParseXS-3.180.0-r1
[3.180.0] 0 kB [ebuild   R    ] perl-core/Archive-Tar-1.900.0-r1  0 kB
[ebuild     U  ] perl-core/CPAN-Meta-Requirements-2.122.0-r1 [2.122.0]
0 kB [ebuild   R    ] perl-core/IO-Compress-2.60.0  0 kB
[ebuild     U  ] perl-core/Digest-MD5-2.520.0-r1 [2.520.0] 0 kB
[ebuild     U  ] perl-core/Module-Metadata-1.0.11-r1 [1.0.11] 0 kB
[ebuild     U  ] perl-core/Params-Check-0.360.0-r1 [0.360.0] 0 kB
[ebuild   R    ] perl-core/Module-Load-Conditional-0.540.0  0 kB
[ebuild   R    ] dev-perl/File-DesktopEntry-0.40.0  USE="{-test}" 0 kB
[ebuild   R    ] dev-perl/Digest-HMAC-1.30.0  0 kB
[ebuild     U  ] perl-core/CPAN-Meta-2.120.921-r1 [2.120.921] 0 kB
[ebuild     U  ] perl-core/Module-Build-0.400.300-r1 [0.400.300]
USE="{-test}" 0 kB [ebuild     U  ]
perl-core/Parse-CPAN-Meta-1.440.400-r1 [1.440.400] 0 kB [ebuild     U
] perl-core/ExtUtils-CBuilder-0.280.205-r1 [0.280.205] 0 kB [ebuild
R    ] dev-perl/Authen-SASL-2.160.0  USE="-kerberos" 0 kB [ebuild
R    ] dev-perl/Net-SMTP-SSL-1.10.0  0 kB [ebuild     UD ]
dev-lang/perl-5.16.3:0/5.16 [5.18.2-r1:0/5.18] USE="berkdb gdbm -debug
-doc -ithreads" 0 kB [ebuild     U  ]
perl-core/ExtUtils-MakeMaker-6.640.0-r1 [6.640.0] 0 kB [ebuild   R    ]
dev-perl/XML-SAX-0.990.0  0 kB [ebuild   R    ]
dev-perl/File-MimeInfo-0.170.0  USE="{-test}" 0 kB [ebuild   R    ]
dev-perl/XML-LibXML-2.1.400  USE="{-test}" 0 kB [ebuild   R    ]
dev-perl/Locale-gettext-1.50.0  0 kB [ebuild   R    ]
dev-perl/XML-Simple-2.200.0  0 kB [blocks B      ]
<perl-core/Module-CoreList-3.30.0 ("<perl-core/Module-CoreList-3.30.0"
is blocking virtual/perl-Module-CoreList-3.30.0) [blocks B      ]
<perl-core/IPC-Cmd-0.800.0 ("<perl-core/IPC-Cmd-0.800.0" is blocking
virtual/perl-IPC-Cmd-0.800.0-r1) [blocks B      ]
<perl-core/ExtUtils-Manifest-1.630.0
("<perl-core/ExtUtils-Manifest-1.630.0" is blocking
virtual/perl-ExtUtils-Manifest-1.630.0-r1) [blocks B      ]
<perl-core/ExtUtils-MakeMaker-6.660.0
("<perl-core/ExtUtils-MakeMaker-6.660.0" is blocking
virtual/perl-ExtUtils-MakeMaker-6.660.0-r1) [blocks B      ]
<perl-core/IO-1.280.0 ("<perl-core/IO-1.280.0" is blocking
virtual/perl-IO-1.280.0-r1) [blocks B      ]
<perl-core/version-0.990.200 ("<perl-core/version-0.990.200" is
blocking virtual/perl-version-0.990.200-r1) [blocks B      ]
<perl-core/ExtUtils-CBuilder-0.280.210
("<perl-core/ExtUtils-CBuilder-0.280.210" is blocking
virtual/perl-ExtUtils-CBuilder-0.280.210-r1)

Total: 75 packages (22 upgrades, 1 downgrade, 3 new, 49 reinstalls),
Size of downloads: 38 kB Conflict: 7 blocks (7 unsatisfied)

!!! Multiple package instances within a single package slot have been
pulled !!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.16.3::gentoo, ebuild scheduled for merge) pulled in
  by =dev-lang/perl-5.16* required by
  (virtual/perl-ExtUtils-Install-1.580.0-r1::gentoo, installed)

  (dev-lang/perl-5.18.2-r1::gentoo, installed) pulled in by
    dev-lang/perl:0/5.18=[-build(-)] required by
  (dev-perl/URI-1.600.0-r1::gentoo, installed)
  dev-lang/perl:0/5.18=[-build(-)] required by
  (dev-perl/Net-SSLeay-1.550::gentoo, installed)
  dev-lang/perl:0/5.18=[-build(-)] required by
  (dev-perl/Error-0.170.210::gentoo, installed)
  dev-lang/perl:0/5.18=[-build(-)] required by
  (dev-perl/Text-CSV_XS-0.950.0::gentoo, installed)
  dev-lang/perl:0/5.18=[-build(-)] required by
  (dev-perl/IO-Socket-SSL-1.953.0::gentoo, installed)
  dev-lang/perl:0/5.18=[-build(-)] required by
  (perl-core/Digest-SHA-5.820.0::gentoo, installed)
  dev-lang/perl:0/5.18=[-build(-)] required by
  (dev-perl/Algorithm-Diff-1.190.200-r1::gentoo, installed)
  dev-lang/perl:0/5.18=[-build(-)] required by
  (dev-vcs/git-1.8.5.5::gentoo, installed) =dev-lang/perl-5.18*
  required by (virtual/perl-Digest-MD5-2.520.0-r2::gentoo, ebuild
  scheduled for merge) (and 35 more with the same problems)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (virtual/perl-ExtUtils-Manifest-1.630.0-r1::gentoo, ebuild scheduled
  for merge) pulled in by virtual/perl-ExtUtils-Manifest:0
    >=virtual/perl-ExtUtils-Manifest-1.600.0 required by
  (perl-core/ExtUtils-MakeMaker-6.640.0-r1::gentoo, ebuild scheduled
  for merge) =virtual/perl-ExtUtils-Manifest-1.630.0-r1 required by
  (perl-core/ExtUtils-MakeMaker-6.640.0-r1::gentoo, ebuild scheduled
  for merge)

  (virtual/perl-IO-1.280.0-r1::gentoo, ebuild scheduled for merge)
  pulled in by virtual/perl-IO:0
    =virtual/perl-IO-1.280.0-r1 required by
  (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for
  merge) virtual/perl-IO required by
  (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for merge)

  (virtual/perl-Module-CoreList-3.30.0::gentoo, ebuild scheduled for
  merge) pulled in by =virtual/perl-Module-CoreList-3.30.0 required by
  (perl-core/Module-Load-Conditional-0.540.0::gentoo, ebuild scheduled
  for merge) virtual/perl-Module-CoreList:0
  >=virtual/perl-Module-CoreList-0.22 required by
  (perl-core/Module-Load-Conditional-0.540.0::gentoo, ebuild scheduled
  for merge)

  (perl-core/Module-CoreList-2.840.0::gentoo, ebuild scheduled for
  merge) pulled in by perl-core/Module-CoreList:0

  (virtual/perl-version-0.990.200-r1::gentoo, ebuild scheduled for
  merge) pulled in by >=virtual/perl-version-0.870 required by
  (perl-core/Module-Metadata-1.0.11-r1::gentoo, ebuild scheduled for
  merge) >=virtual/perl-version-0.77 required by
  (perl-core/CPAN-Meta-Requirements-2.122.0-r1::gentoo, ebuild
  scheduled for merge) =virtual/perl-version-0.990.200-r1 required by
  (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for
  merge) >=virtual/perl-version-0.82 required by
  (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for
  merge) =virtual/perl-version-0.990.200-r1 required by
  (perl-core/Module-Load-Conditional-0.540.0::gentoo, ebuild scheduled
  for merge) =virtual/perl-version-0.990.200-r1 required by
  (perl-core/Module-Build-0.400.300-r1::gentoo, ebuild scheduled for
  merge) >=virtual/perl-version-0.87 required by
  (perl-core/Module-Build-0.400.300-r1::gentoo, ebuild scheduled for
  merge) virtual/perl-version:0 virtual/perl-version required by
  (perl-core/Module-Load-Conditional-0.540.0::gentoo, ebuild scheduled
  for merge) =virtual/perl-version-0.990.200-r1 required by
  (perl-core/CPAN-Meta-Requirements-2.122.0-r1::gentoo, ebuild
  scheduled for merge) =virtual/perl-version-0.990.200-r1 required by
  (perl-core/Module-Metadata-1.0.11-r1::gentoo, ebuild scheduled for
  merge)

  (virtual/perl-ExtUtils-MakeMaker-6.660.0-r1::gentoo, ebuild scheduled
  for merge) pulled in by virtual/perl-ExtUtils-MakeMaker:0
    >=virtual/perl-ExtUtils-MakeMaker-6.56 required by
  (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for
  merge) =virtual/perl-ExtUtils-MakeMaker-6.660.0-r1 required by
  (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for merge)

  (virtual/perl-IPC-Cmd-0.800.0-r1::gentoo, ebuild scheduled for merge)
  pulled in by virtual/perl-IPC-Cmd:0
    virtual/perl-IPC-Cmd required by
  (perl-core/ExtUtils-CBuilder-0.280.205-r1::gentoo, ebuild scheduled
  for merge) =virtual/perl-IPC-Cmd-0.800.0-r1 required by
  (perl-core/ExtUtils-CBuilder-0.280.205-r1::gentoo, ebuild scheduled
  for merge)

  (perl-core/IPC-Cmd-0.780.0-r1::gentoo, ebuild scheduled for merge)
  pulled in by perl-core/IPC-Cmd:0

  (perl-core/version-0.990.100-r1::gentoo, ebuild scheduled for merge)
  pulled in by perl-core/version:0

  (virtual/perl-ExtUtils-CBuilder-0.280.210-r1::gentoo, ebuild
  scheduled for merge) pulled in by virtual/perl-ExtUtils-CBuilder:0
    virtual/perl-ExtUtils-CBuilder required by
  (perl-core/ExtUtils-ParseXS-3.180.0-r1::gentoo, ebuild scheduled for
  merge) >=virtual/perl-ExtUtils-CBuilder-0.27 required by
  (perl-core/Module-Build-0.400.300-r1::gentoo, ebuild scheduled for
  merge) =virtual/perl-ExtUtils-CBuilder-0.280.210-r1 required by
  (perl-core/Module-Build-0.400.300-r1::gentoo, ebuild scheduled for
  merge) =virtual/perl-ExtUtils-CBuilder-0.280.210-r1 required by
  (perl-core/ExtUtils-ParseXS-3.180.0-r1::gentoo, ebuild scheduled for
  merge)

  (perl-core/ExtUtils-Manifest-1.610.0-r1::gentoo, ebuild scheduled for
  merge) pulled in by perl-core/ExtUtils-Manifest:0

  (perl-core/ExtUtils-MakeMaker-6.640.0-r1::gentoo, ebuild scheduled
  for merge) pulled in by perl-core/ExtUtils-MakeMaker:0

  (perl-core/IO-1.25-r1::gentoo, ebuild scheduled for merge) pulled in
  by perl-core/IO:0

  (perl-core/ExtUtils-CBuilder-0.280.205-r1::gentoo, ebuild scheduled
  for merge) pulled in by perl-core/ExtUtils-CBuilder:0


For more information about Blocked Packages, please refer to the
following section of the Gentoo Linux x86 Handbook (architecture is
irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

 * perl-cleaner is stopping here:
 * Fix the problem and start perl-cleaner again.
 *
 * If you encounter blockers involving virtuals and perl-core, here are
 * some things to try:
 *   Remove all perl-core packages from your world file
 *     emerge --deselect --ask $(qlist -IC 'perl-core/*')
 *   Update all the installed Perl virtuals
 *     emerge -uD1a $(qlist -IC 'virtual/perl-*')
 *   Afterwards re-run perl-cleaner
 *
 * Note that upgrading Perl with emerge option
   --ignore-built-slot-operator-deps=y is not supported.

Currently trying the above suggestions but I have no perl in my world.

Reply | Threaded
Open this post in threaded view
|

Re: colord failed to upgrade

Alec Ten Harmsel
I can't comment on a long-term, real, proper solution, but for right now

    emerge --oneshot dev-perl/XML-Parser

should at least allow you to continue building colord.

On Thu 31 Jul 2014 09:58:17 AM EDT, Gevisz wrote:

> On Thu, 31 Jul 2014 15:36:38 +0200
> Alan McKinnon <[hidden email]> wrote:
>
>> On 31/07/2014 15:29, Gevisz wrote:
>>> In my today's system update I have got the following error message:
>>>
>>>  * ERROR: x11-misc/colord-1.2.1-r1::gentoo failed (configure phase):
>>>  *   econf failed
>>
>> The actual error message is earlier than this point[1]. Please go
>> through that referenced log, find the error message and report
>
> Yes, you are right. Earlier in the colord emege log
> I have found the following:
>
> checking for XML::Parser... configure: error: XML::Parser perl module
> is required for intltool
>
> And even earlier in the emerge log were the following:
>
>  * Messages for package dev-lang/perl-5.18.2-r1:
>
>  * UPDATE THE PERL MODULES:
>  * After updating dev-lang/perl you must reinstall
>  * the installed perl modules.
>  * Use: perl-cleaner --all
>
> And after running just now # perl-cleaner --all
> I have got the real trouble. The output is below.
> Shall I rename the Subject to "perl failed to upgrade"?
>
> # perl-cleaner --all
>
>  * Beginning a clean up of .ph files
>  * Excluding files for 5.18.2 and 5.18.2/x86_64-linux from cleaning
>
>  * Locating ph files for removal
>
>  * Updating ph files.
>  * Ignore all "No such file..." messages!
> Can't open machine/ansi.h: No such file or directory
> Can't open sys/_types.h: No such file or directory
> Can't open gnu/stubs-x32.h: No such file or directory
> Can't open gnu/stubs-x32.h: No such file or directory
> Can't open gnu/stubs-x32.h: No such file or directory
> Can't open gnu/stubs-x32.h: No such file or directory
>
>  * Locating packages for an update
>  * Locating ebuilds linked against libperl
>  *   Adding to list: dev-perl/File-DesktopEntry:0
>  *   Adding to list: dev-perl/XML-NamespaceSupport:0
>  *   Adding to list: dev-perl/Authen-SASL:0
>  *   Adding to list: dev-perl/OLE-StorageLite:0
>  *   Adding to list: dev-perl/Digest-Perl-MD5:0
>  *   Adding to list: dev-perl/XML-Simple:0
>  *   Adding to list: dev-perl/Digest-HMAC:0
>  *   Adding to list: dev-perl/Net-SMTP-SSL:0
>  *   Adding to list: dev-perl/XML-SAX-Base:0
>  *   Adding to list: dev-perl/File-MimeInfo:0
>  *   Adding to list: dev-perl/Unicode-Map:0
>  *   Adding to list: dev-perl/XML-LibXML:0
>  *   Adding to list: dev-perl/Locale-gettext:0
>  *   Adding to list: dev-perl/Crypt-RC4:0
>  *   Adding to list: dev-perl/File-BaseDir:0
>  *   Adding to list: dev-perl/XML-Parser:0
>  *   Adding to list: dev-perl/XML-SAX:0
>  *   Adding to list: dev-perl/Spreadsheet-ParseExcel:0
>  *   Adding to list: dev-perl/IO-stringy:0
>  *   Adding to list: perl-core/IPC-Cmd:0
>  *                   virtual/perl-IPC-Cmd:0
>  *   Adding to list: perl-core/Module-CoreList:0
>  *                   virtual/perl-Module-CoreList:0
>  *   Adding to list: perl-core/IO:0
>  *                   virtual/perl-IO:0
>  *   Adding to list: perl-core/File-Spec:0
>  *                   virtual/perl-File-Spec:0
>  *   Adding to list: perl-core/CPAN-Meta:0
>  *                   virtual/perl-CPAN-Meta:0
>  *   Adding to list: perl-core/Module-Build:0
>  *                   virtual/perl-Module-Build:0
>  *   Adding to list: perl-core/ExtUtils-ParseXS:0
>  *                   virtual/perl-ExtUtils-ParseXS:0
>  *   Adding to list: perl-core/version:0
>  *                   virtual/perl-version:0
>  *   Adding to list: perl-core/Archive-Tar:0
>  *                   virtual/perl-Archive-Tar:0
>  *   Adding to list: perl-core/Module-Load:0
>  *                   virtual/perl-Module-Load:0
>  *   Adding to list: perl-core/Test-Harness:0
>  *                   virtual/perl-Test-Harness:0
>  *   Adding to list: perl-core/CPAN-Meta-Requirements:0
>  *                   virtual/perl-CPAN-Meta-Requirements:0
>  *   Adding to list: perl-core/Compress-Raw-Bzip2:0
>  *                   virtual/perl-Compress-Raw-Bzip2:0
>  *   Adding to list: perl-core/IO-Compress:0
>  *                   virtual/perl-IO-Compress:0
>  *   Adding to list: perl-core/ExtUtils-MakeMaker:0
>  *                   virtual/perl-ExtUtils-MakeMaker:0
>  *   Adding to list: perl-core/Parse-CPAN-Meta:0
>  *                   virtual/perl-Parse-CPAN-Meta:0
>  *   Adding to list: perl-core/Digest-MD5:0
>  *                   virtual/perl-Digest-MD5:0
>  *   Adding to list: perl-core/ExtUtils-Manifest:0
>  *                   virtual/perl-ExtUtils-Manifest:0
>  *   Adding to list: perl-core/Module-Metadata:0
>  *                   virtual/perl-Module-Metadata:0
>  *   Adding to list: perl-core/Scalar-List-Utils:0
>  *                   virtual/perl-Scalar-List-Utils:0
>  *   Adding to list: perl-core/Compress-Raw-Zlib:0
>  *                   virtual/perl-Compress-Raw-Zlib:0
>  *   Adding to list: perl-core/Params-Check:0
>  *                   virtual/perl-Params-Check:0
>  *   Adding to list: perl-core/Time-Local:0
>  *                   virtual/perl-Time-Local:0
>  *   Adding to list: perl-core/ExtUtils-CBuilder:0
>  *                   virtual/perl-ExtUtils-CBuilder:0
>  *   Adding to list: perl-core/Module-Load-Conditional:0
>  *                   virtual/perl-Module-Load-Conditional:0
>  *   Adding to list: perl-core/CPAN-Meta-YAML:0
>  *                   virtual/perl-CPAN-Meta-YAML:0
>  * emerge -vD1 --backtrack=30 dev-perl/File-DesktopEntry:0
>    dev-perl/XML-NamespaceSupport:0 dev-perl/Authen-SASL:0
>    dev-perl/OLE-StorageLite:0 dev-perl/Digest-Perl-MD5:0
>    dev-perl/XML-Simple:0 dev-perl/Digest-HMAC:0 dev-perl/Net-SMTP-SSL:0
>    dev-perl/XML-SAX-Base:0 dev-perl/File-MimeInfo:0
>    dev-perl/Unicode-Map:0 dev-perl/XML-LibXML:0
>    dev-perl/Locale-gettext:0 dev-perl/Crypt-RC4:0
>    dev-perl/File-BaseDir:0 dev-perl/XML-Parser:0 dev-perl/XML-SAX:0
>    dev-perl/Spreadsheet-ParseExcel:0 dev-perl/IO-stringy:0
>    perl-core/IPC-Cmd:0 virtual/perl-IPC-Cmd:0
>    perl-core/Module-CoreList:0 virtual/perl-Module-CoreList:0
>    perl-core/IO:0 virtual/perl-IO:0 perl-core/File-Spec:0
>    virtual/perl-File-Spec:0 perl-core/CPAN-Meta:0
>    virtual/perl-CPAN-Meta:0 perl-core/Module-Build:0
>    virtual/perl-Module-Build:0 perl-core/ExtUtils-ParseXS:0
>    virtual/perl-ExtUtils-ParseXS:0 perl-core/version:0
>    virtual/perl-version:0 perl-core/Archive-Tar:0
>    virtual/perl-Archive-Tar:0 perl-core/Module-Load:0
>    virtual/perl-Module-Load:0 perl-core/Test-Harness:0
>    virtual/perl-Test-Harness:0 perl-core/CPAN-Meta-Requirements:0
>    virtual/perl-CPAN-Meta-Requirements:0 perl-core/Compress-Raw-Bzip2:0
>    virtual/perl-Compress-Raw-Bzip2:0 perl-core/IO-Compress:0
>    virtual/perl-IO-Compress:0 perl-core/ExtUtils-MakeMaker:0
>    virtual/perl-ExtUtils-MakeMaker:0 perl-core/Parse-CPAN-Meta:0
>    virtual/perl-Parse-CPAN-Meta:0 perl-core/Digest-MD5:0
>    virtual/perl-Digest-MD5:0 perl-core/ExtUtils-Manifest:0
>    virtual/perl-ExtUtils-Manifest:0 perl-core/Module-Metadata:0
>    virtual/perl-Module-Metadata:0 perl-core/Scalar-List-Utils:0
>    virtual/perl-Scalar-List-Utils:0 perl-core/Compress-Raw-Zlib:0
>    virtual/perl-Compress-Raw-Zlib:0 perl-core/Params-Check:0
>    virtual/perl-Params-Check:0 perl-core/Time-Local:0
>    virtual/perl-Time-Local:0 perl-core/ExtUtils-CBuilder:0
>    virtual/perl-ExtUtils-CBuilder:0 perl-core/Module-Load-Conditional:0
>    virtual/perl-Module-Load-Conditional:0 perl-core/CPAN-Meta-YAML:0
>    virtual/perl-CPAN-Meta-YAML:0
>
> These are the packages that would be merged, in order:
>
> Calculating dependencies... done!
> [ebuild   R    ] virtual/perl-File-Spec-3.400.0-r2  0 kB
> [ebuild     U  ] virtual/perl-version-0.990.200-r1 [0.990.100] 0 kB
> [ebuild   R    ] virtual/perl-Scalar-List-Utils-1.270.0-r2  0 kB
> [ebuild   R    ] dev-perl/XML-NamespaceSupport-1.110.0  0 kB
> [ebuild   R    ] virtual/perl-Module-Build-0.400.300-r1  0 kB
> [ebuild   R    ] virtual/perl-Parse-CPAN-Meta-1.440.400-r1  0 kB
> [ebuild   R    ] virtual/perl-CPAN-Meta-YAML-0.8.0-r2  0 kB
> [ebuild   R    ] virtual/perl-CPAN-Meta-2.120.921-r2  0 kB
> [ebuild   R    ] virtual/perl-Module-Metadata-1.0.11-r1  0 kB
> [ebuild   R    ] virtual/perl-Params-Check-0.360.0-r1  0 kB
> [ebuild     U  ] virtual/perl-ExtUtils-CBuilder-0.280.210-r1
> [0.280.205] 0 kB [ebuild   R    ] dev-perl/OLE-StorageLite-0.190.0  0 kB
> [ebuild   R    ] dev-perl/Digest-Perl-MD5-1.800.0  0 kB
> [ebuild   R    ] dev-perl/XML-SAX-Base-1.80.0  0 kB
> [ebuild   R    ] dev-perl/Unicode-Map-0.112.0  0 kB
> [ebuild   R    ] dev-perl/Crypt-RC4-2.020.0  0 kB
> [ebuild   R    ] dev-perl/XML-Parser-2.410.0  0 kB
> [ebuild   R    ] dev-perl/IO-stringy-2.110.0  0 kB
> [ebuild     U  ] virtual/perl-IPC-Cmd-0.800.0-r1 [0.780.0] 0 kB
> [ebuild     U  ] virtual/perl-Module-CoreList-3.30.0 [2.840.0] 0 kB
> [ebuild     U  ] virtual/perl-IO-1.280.0-r1 [1.25] 0 kB
> [ebuild   R    ] virtual/perl-ExtUtils-ParseXS-3.180.0-r2  0 kB
> [ebuild   R    ] virtual/perl-Archive-Tar-1.900.0-r2  0 kB
> [ebuild   R    ] virtual/perl-Module-Load-0.240.0-r1  0 kB
> [ebuild   R    ] virtual/perl-Test-Harness-3.260.0-r2  0 kB
> [ebuild   R    ] virtual/perl-CPAN-Meta-Requirements-2.122.0-r2  0 kB
> [ebuild   R    ] virtual/perl-Compress-Raw-Bzip2-2.60.0-r2  0 kB
> [ebuild   R    ] virtual/perl-IO-Compress-2.60.0-r1  0 kB
> [ebuild     U  ] virtual/perl-ExtUtils-MakeMaker-6.660.0-r1 [6.640.0] 0
> kB [ebuild   R    ] virtual/perl-Digest-MD5-2.520.0-r2  0 kB
> [ebuild     U  ] virtual/perl-ExtUtils-Manifest-1.630.0-r1 [1.610.0] 0
> kB [ebuild   R    ] virtual/perl-Compress-Raw-Zlib-2.60.0-r2  0 kB
> [ebuild   R    ] virtual/perl-Module-Load-Conditional-0.540.0-r1  0 kB
> [ebuild  N     ] perl-core/JSON-PP-2.272.0-r1  0 kB
> [ebuild  N     ] perl-core/File-Temp-0.220.0-r1  38 kB
> [ebuild  N     ] perl-core/Perl-OSType-1.2.0-r1  USE="{-test}" 0 kB
> [ebuild   R    ] perl-core/Module-CoreList-2.840.0  0 kB
> [ebuild   R    ] perl-core/IO-1.25-r1  0 kB
> [ebuild   R    ] perl-core/File-Spec-3.400.0  0 kB
> [ebuild     U  ] perl-core/version-0.990.100-r1 [0.990.100] 0 kB
> [ebuild   R    ] perl-core/Module-Load-0.240.0  0 kB
> [ebuild   R    ] perl-core/Test-Harness-3.260.0  0 kB
> [ebuild   R    ] perl-core/Compress-Raw-Bzip2-2.60.0  0 kB
> [ebuild     U  ] perl-core/ExtUtils-Manifest-1.610.0-r1 [1.610.0] 0 kB
> [ebuild   R    ] perl-core/Scalar-List-Utils-1.270.0  0 kB
> [ebuild   R    ] perl-core/Compress-Raw-Zlib-2.60.0  0 kB
> [ebuild     U  ] perl-core/Time-Local-1.230.0-r1 [1.230.0] 0 kB
> [ebuild   R    ] virtual/perl-Time-Local-1.230.0-r1  0 kB
> [ebuild     U  ] perl-core/CPAN-Meta-YAML-0.8.0-r1 [0.8.0] 0 kB
> [ebuild   R    ] dev-perl/File-BaseDir-0.30.0  USE="{-test}" 0 kB
> [ebuild   R    ] dev-perl/Spreadsheet-ParseExcel-0.590.0  USE="unicode
> -cjk {-test}" 0 kB [ebuild     U  ] perl-core/IPC-Cmd-0.780.0-r1
> [0.780.0] 0 kB [ebuild     U  ] perl-core/ExtUtils-ParseXS-3.180.0-r1
> [3.180.0] 0 kB [ebuild   R    ] perl-core/Archive-Tar-1.900.0-r1  0 kB
> [ebuild     U  ] perl-core/CPAN-Meta-Requirements-2.122.0-r1 [2.122.0]
> 0 kB [ebuild   R    ] perl-core/IO-Compress-2.60.0  0 kB
> [ebuild     U  ] perl-core/Digest-MD5-2.520.0-r1 [2.520.0] 0 kB
> [ebuild     U  ] perl-core/Module-Metadata-1.0.11-r1 [1.0.11] 0 kB
> [ebuild     U  ] perl-core/Params-Check-0.360.0-r1 [0.360.0] 0 kB
> [ebuild   R    ] perl-core/Module-Load-Conditional-0.540.0  0 kB
> [ebuild   R    ] dev-perl/File-DesktopEntry-0.40.0  USE="{-test}" 0 kB
> [ebuild   R    ] dev-perl/Digest-HMAC-1.30.0  0 kB
> [ebuild     U  ] perl-core/CPAN-Meta-2.120.921-r1 [2.120.921] 0 kB
> [ebuild     U  ] perl-core/Module-Build-0.400.300-r1 [0.400.300]
> USE="{-test}" 0 kB [ebuild     U  ]
> perl-core/Parse-CPAN-Meta-1.440.400-r1 [1.440.400] 0 kB [ebuild     U
> ] perl-core/ExtUtils-CBuilder-0.280.205-r1 [0.280.205] 0 kB [ebuild
> R    ] dev-perl/Authen-SASL-2.160.0  USE="-kerberos" 0 kB [ebuild
> R    ] dev-perl/Net-SMTP-SSL-1.10.0  0 kB [ebuild     UD ]
> dev-lang/perl-5.16.3:0/5.16 [5.18.2-r1:0/5.18] USE="berkdb gdbm -debug
> -doc -ithreads" 0 kB [ebuild     U  ]
> perl-core/ExtUtils-MakeMaker-6.640.0-r1 [6.640.0] 0 kB [ebuild   R    ]
> dev-perl/XML-SAX-0.990.0  0 kB [ebuild   R    ]
> dev-perl/File-MimeInfo-0.170.0  USE="{-test}" 0 kB [ebuild   R    ]
> dev-perl/XML-LibXML-2.1.400  USE="{-test}" 0 kB [ebuild   R    ]
> dev-perl/Locale-gettext-1.50.0  0 kB [ebuild   R    ]
> dev-perl/XML-Simple-2.200.0  0 kB [blocks B      ]
> <perl-core/Module-CoreList-3.30.0 ("<perl-core/Module-CoreList-3.30.0"
> is blocking virtual/perl-Module-CoreList-3.30.0) [blocks B      ]
> <perl-core/IPC-Cmd-0.800.0 ("<perl-core/IPC-Cmd-0.800.0" is blocking
> virtual/perl-IPC-Cmd-0.800.0-r1) [blocks B      ]
> <perl-core/ExtUtils-Manifest-1.630.0
> ("<perl-core/ExtUtils-Manifest-1.630.0" is blocking
> virtual/perl-ExtUtils-Manifest-1.630.0-r1) [blocks B      ]
> <perl-core/ExtUtils-MakeMaker-6.660.0
> ("<perl-core/ExtUtils-MakeMaker-6.660.0" is blocking
> virtual/perl-ExtUtils-MakeMaker-6.660.0-r1) [blocks B      ]
> <perl-core/IO-1.280.0 ("<perl-core/IO-1.280.0" is blocking
> virtual/perl-IO-1.280.0-r1) [blocks B      ]
> <perl-core/version-0.990.200 ("<perl-core/version-0.990.200" is
> blocking virtual/perl-version-0.990.200-r1) [blocks B      ]
> <perl-core/ExtUtils-CBuilder-0.280.210
> ("<perl-core/ExtUtils-CBuilder-0.280.210" is blocking
> virtual/perl-ExtUtils-CBuilder-0.280.210-r1)
>
> Total: 75 packages (22 upgrades, 1 downgrade, 3 new, 49 reinstalls),
> Size of downloads: 38 kB Conflict: 7 blocks (7 unsatisfied)
>
> !!! Multiple package instances within a single package slot have been
> pulled !!! into the dependency graph, resulting in a slot conflict:
>
> dev-lang/perl:0
>
>   (dev-lang/perl-5.16.3::gentoo, ebuild scheduled for merge) pulled in
>   by =dev-lang/perl-5.16* required by
>   (virtual/perl-ExtUtils-Install-1.580.0-r1::gentoo, installed)
>
>   (dev-lang/perl-5.18.2-r1::gentoo, installed) pulled in by
>     dev-lang/perl:0/5.18=[-build(-)] required by
>   (dev-perl/URI-1.600.0-r1::gentoo, installed)
>   dev-lang/perl:0/5.18=[-build(-)] required by
>   (dev-perl/Net-SSLeay-1.550::gentoo, installed)
>   dev-lang/perl:0/5.18=[-build(-)] required by
>   (dev-perl/Error-0.170.210::gentoo, installed)
>   dev-lang/perl:0/5.18=[-build(-)] required by
>   (dev-perl/Text-CSV_XS-0.950.0::gentoo, installed)
>   dev-lang/perl:0/5.18=[-build(-)] required by
>   (dev-perl/IO-Socket-SSL-1.953.0::gentoo, installed)
>   dev-lang/perl:0/5.18=[-build(-)] required by
>   (perl-core/Digest-SHA-5.820.0::gentoo, installed)
>   dev-lang/perl:0/5.18=[-build(-)] required by
>   (dev-perl/Algorithm-Diff-1.190.200-r1::gentoo, installed)
>   dev-lang/perl:0/5.18=[-build(-)] required by
>   (dev-vcs/git-1.8.5.5::gentoo, installed) =dev-lang/perl-5.18*
>   required by (virtual/perl-Digest-MD5-2.520.0-r2::gentoo, ebuild
>   scheduled for merge) (and 35 more with the same problems)
>
>
> It may be possible to solve this problem by using package.mask to
> prevent one of those packages from being selected. However, it is also
> possible that conflicting dependencies exist such that they are
> impossible to satisfy simultaneously.  If such a conflict exists in
> the dependencies of two different packages, then those packages can
> not be installed simultaneously.
>
> For more information, see MASKED PACKAGES section in the emerge man
> page or refer to the Gentoo Handbook.
>
>
>  * Error: The above package list contains packages which cannot be
>  * installed at the same time on the same system.
>
>   (virtual/perl-ExtUtils-Manifest-1.630.0-r1::gentoo, ebuild scheduled
>   for merge) pulled in by virtual/perl-ExtUtils-Manifest:0
>     >=virtual/perl-ExtUtils-Manifest-1.600.0 required by
>   (perl-core/ExtUtils-MakeMaker-6.640.0-r1::gentoo, ebuild scheduled
>   for merge) =virtual/perl-ExtUtils-Manifest-1.630.0-r1 required by
>   (perl-core/ExtUtils-MakeMaker-6.640.0-r1::gentoo, ebuild scheduled
>   for merge)
>
>   (virtual/perl-IO-1.280.0-r1::gentoo, ebuild scheduled for merge)
>   pulled in by virtual/perl-IO:0
>     =virtual/perl-IO-1.280.0-r1 required by
>   (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for
>   merge) virtual/perl-IO required by
>   (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for merge)
>
>   (virtual/perl-Module-CoreList-3.30.0::gentoo, ebuild scheduled for
>   merge) pulled in by =virtual/perl-Module-CoreList-3.30.0 required by
>   (perl-core/Module-Load-Conditional-0.540.0::gentoo, ebuild scheduled
>   for merge) virtual/perl-Module-CoreList:0
>   >=virtual/perl-Module-CoreList-0.22 required by
>   (perl-core/Module-Load-Conditional-0.540.0::gentoo, ebuild scheduled
>   for merge)
>
>   (perl-core/Module-CoreList-2.840.0::gentoo, ebuild scheduled for
>   merge) pulled in by perl-core/Module-CoreList:0
>
>   (virtual/perl-version-0.990.200-r1::gentoo, ebuild scheduled for
>   merge) pulled in by >=virtual/perl-version-0.870 required by
>   (perl-core/Module-Metadata-1.0.11-r1::gentoo, ebuild scheduled for
>   merge) >=virtual/perl-version-0.77 required by
>   (perl-core/CPAN-Meta-Requirements-2.122.0-r1::gentoo, ebuild
>   scheduled for merge) =virtual/perl-version-0.990.200-r1 required by
>   (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for
>   merge) >=virtual/perl-version-0.82 required by
>   (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for
>   merge) =virtual/perl-version-0.990.200-r1 required by
>   (perl-core/Module-Load-Conditional-0.540.0::gentoo, ebuild scheduled
>   for merge) =virtual/perl-version-0.990.200-r1 required by
>   (perl-core/Module-Build-0.400.300-r1::gentoo, ebuild scheduled for
>   merge) >=virtual/perl-version-0.87 required by
>   (perl-core/Module-Build-0.400.300-r1::gentoo, ebuild scheduled for
>   merge) virtual/perl-version:0 virtual/perl-version required by
>   (perl-core/Module-Load-Conditional-0.540.0::gentoo, ebuild scheduled
>   for merge) =virtual/perl-version-0.990.200-r1 required by
>   (perl-core/CPAN-Meta-Requirements-2.122.0-r1::gentoo, ebuild
>   scheduled for merge) =virtual/perl-version-0.990.200-r1 required by
>   (perl-core/Module-Metadata-1.0.11-r1::gentoo, ebuild scheduled for
>   merge)
>
>   (virtual/perl-ExtUtils-MakeMaker-6.660.0-r1::gentoo, ebuild scheduled
>   for merge) pulled in by virtual/perl-ExtUtils-MakeMaker:0
>     >=virtual/perl-ExtUtils-MakeMaker-6.56 required by
>   (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for
>   merge) =virtual/perl-ExtUtils-MakeMaker-6.660.0-r1 required by
>   (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for merge)
>
>   (virtual/perl-IPC-Cmd-0.800.0-r1::gentoo, ebuild scheduled for merge)
>   pulled in by virtual/perl-IPC-Cmd:0
>     virtual/perl-IPC-Cmd required by
>   (perl-core/ExtUtils-CBuilder-0.280.205-r1::gentoo, ebuild scheduled
>   for merge) =virtual/perl-IPC-Cmd-0.800.0-r1 required by
>   (perl-core/ExtUtils-CBuilder-0.280.205-r1::gentoo, ebuild scheduled
>   for merge)
>
>   (perl-core/IPC-Cmd-0.780.0-r1::gentoo, ebuild scheduled for merge)
>   pulled in by perl-core/IPC-Cmd:0
>
>   (perl-core/version-0.990.100-r1::gentoo, ebuild scheduled for merge)
>   pulled in by perl-core/version:0
>
>   (virtual/perl-ExtUtils-CBuilder-0.280.210-r1::gentoo, ebuild
>   scheduled for merge) pulled in by virtual/perl-ExtUtils-CBuilder:0
>     virtual/perl-ExtUtils-CBuilder required by
>   (perl-core/ExtUtils-ParseXS-3.180.0-r1::gentoo, ebuild scheduled for
>   merge) >=virtual/perl-ExtUtils-CBuilder-0.27 required by
>   (perl-core/Module-Build-0.400.300-r1::gentoo, ebuild scheduled for
>   merge) =virtual/perl-ExtUtils-CBuilder-0.280.210-r1 required by
>   (perl-core/Module-Build-0.400.300-r1::gentoo, ebuild scheduled for
>   merge) =virtual/perl-ExtUtils-CBuilder-0.280.210-r1 required by
>   (perl-core/ExtUtils-ParseXS-3.180.0-r1::gentoo, ebuild scheduled for
>   merge)
>
>   (perl-core/ExtUtils-Manifest-1.610.0-r1::gentoo, ebuild scheduled for
>   merge) pulled in by perl-core/ExtUtils-Manifest:0
>
>   (perl-core/ExtUtils-MakeMaker-6.640.0-r1::gentoo, ebuild scheduled
>   for merge) pulled in by perl-core/ExtUtils-MakeMaker:0
>
>   (perl-core/IO-1.25-r1::gentoo, ebuild scheduled for merge) pulled in
>   by perl-core/IO:0
>
>   (perl-core/ExtUtils-CBuilder-0.280.205-r1::gentoo, ebuild scheduled
>   for merge) pulled in by perl-core/ExtUtils-CBuilder:0
>
>
> For more information about Blocked Packages, please refer to the
> following section of the Gentoo Linux x86 Handbook (architecture is
> irrelevant):
>
> http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked
>
>  * perl-cleaner is stopping here:
>  * Fix the problem and start perl-cleaner again.
>  *
>  * If you encounter blockers involving virtuals and perl-core, here are
>  * some things to try:
>  *   Remove all perl-core packages from your world file
>  *     emerge --deselect --ask $(qlist -IC 'perl-core/*')
>  *   Update all the installed Perl virtuals
>  *     emerge -uD1a $(qlist -IC 'virtual/perl-*')
>  *   Afterwards re-run perl-cleaner
>  *
>  * Note that upgrading Perl with emerge option
>    --ignore-built-slot-operator-deps=y is not supported.
>
> Currently trying the above suggestions but I have no perl in my world.
>

Reply | Threaded
Open this post in threaded view
|

Re: colord failed to upgrade

J. Roeleveld
In reply to this post by gevisz
On 31 July 2014 15:58:17 CEST, Gevisz <[hidden email]> wrote:

>On Thu, 31 Jul 2014 15:36:38 +0200
>Alan McKinnon <[hidden email]> wrote:
>
>> On 31/07/2014 15:29, Gevisz wrote:
>> > In my today's system update I have got the following error message:
>> >
>> >  * ERROR: x11-misc/colord-1.2.1-r1::gentoo failed (configure
>phase):
>> >  *   econf failed
>>
>> The actual error message is earlier than this point[1]. Please go
>> through that referenced log, find the error message and report
>
>Yes, you are right. Earlier in the colord emege log
>I have found the following:
>
>checking for XML::Parser... configure: error: XML::Parser perl module
>is required for intltool
>
>And even earlier in the emerge log were the following:
>
> * Messages for package dev-lang/perl-5.18.2-r1:
>
> * UPDATE THE PERL MODULES:
> * After updating dev-lang/perl you must reinstall
> * the installed perl modules.
> * Use: perl-cleaner --all
>
>And after running just now # perl-cleaner --all
>I have got the real trouble. The output is below.
>Shall I rename the Subject to "perl failed to upgrade"?
>
># perl-cleaner --all
>
> * Beginning a clean up of .ph files
> * Excluding files for 5.18.2 and 5.18.2/x86_64-linux from cleaning
>
> * Locating ph files for removal
>
> * Updating ph files.
> * Ignore all "No such file..." messages!
>Can't open machine/ansi.h: No such file or directory
>Can't open sys/_types.h: No such file or directory
>Can't open gnu/stubs-x32.h: No such file or directory
>Can't open gnu/stubs-x32.h: No such file or directory
>Can't open gnu/stubs-x32.h: No such file or directory
>Can't open gnu/stubs-x32.h: No such file or directory
>
> * Locating packages for an update
> * Locating ebuilds linked against libperl
> *   Adding to list: dev-perl/File-DesktopEntry:0
> *   Adding to list: dev-perl/XML-NamespaceSupport:0
> *   Adding to list: dev-perl/Authen-SASL:0
> *   Adding to list: dev-perl/OLE-StorageLite:0
> *   Adding to list: dev-perl/Digest-Perl-MD5:0
> *   Adding to list: dev-perl/XML-Simple:0
> *   Adding to list: dev-perl/Digest-HMAC:0
> *   Adding to list: dev-perl/Net-SMTP-SSL:0
> *   Adding to list: dev-perl/XML-SAX-Base:0
> *   Adding to list: dev-perl/File-MimeInfo:0
> *   Adding to list: dev-perl/Unicode-Map:0
> *   Adding to list: dev-perl/XML-LibXML:0
> *   Adding to list: dev-perl/Locale-gettext:0
> *   Adding to list: dev-perl/Crypt-RC4:0
> *   Adding to list: dev-perl/File-BaseDir:0
> *   Adding to list: dev-perl/XML-Parser:0
> *   Adding to list: dev-perl/XML-SAX:0
> *   Adding to list: dev-perl/Spreadsheet-ParseExcel:0
> *   Adding to list: dev-perl/IO-stringy:0
> *   Adding to list: perl-core/IPC-Cmd:0
> *                   virtual/perl-IPC-Cmd:0
> *   Adding to list: perl-core/Module-CoreList:0
> *                   virtual/perl-Module-CoreList:0
> *   Adding to list: perl-core/IO:0
> *                   virtual/perl-IO:0
> *   Adding to list: perl-core/File-Spec:0
> *                   virtual/perl-File-Spec:0
> *   Adding to list: perl-core/CPAN-Meta:0
> *                   virtual/perl-CPAN-Meta:0
> *   Adding to list: perl-core/Module-Build:0
> *                   virtual/perl-Module-Build:0
> *   Adding to list: perl-core/ExtUtils-ParseXS:0
> *                   virtual/perl-ExtUtils-ParseXS:0
> *   Adding to list: perl-core/version:0
> *                   virtual/perl-version:0
> *   Adding to list: perl-core/Archive-Tar:0
> *                   virtual/perl-Archive-Tar:0
> *   Adding to list: perl-core/Module-Load:0
> *                   virtual/perl-Module-Load:0
> *   Adding to list: perl-core/Test-Harness:0
> *                   virtual/perl-Test-Harness:0
> *   Adding to list: perl-core/CPAN-Meta-Requirements:0
> *                   virtual/perl-CPAN-Meta-Requirements:0
> *   Adding to list: perl-core/Compress-Raw-Bzip2:0
> *                   virtual/perl-Compress-Raw-Bzip2:0
> *   Adding to list: perl-core/IO-Compress:0
> *                   virtual/perl-IO-Compress:0
> *   Adding to list: perl-core/ExtUtils-MakeMaker:0
> *                   virtual/perl-ExtUtils-MakeMaker:0
> *   Adding to list: perl-core/Parse-CPAN-Meta:0
> *                   virtual/perl-Parse-CPAN-Meta:0
> *   Adding to list: perl-core/Digest-MD5:0
> *                   virtual/perl-Digest-MD5:0
> *   Adding to list: perl-core/ExtUtils-Manifest:0
> *                   virtual/perl-ExtUtils-Manifest:0
> *   Adding to list: perl-core/Module-Metadata:0
> *                   virtual/perl-Module-Metadata:0
> *   Adding to list: perl-core/Scalar-List-Utils:0
> *                   virtual/perl-Scalar-List-Utils:0
> *   Adding to list: perl-core/Compress-Raw-Zlib:0
> *                   virtual/perl-Compress-Raw-Zlib:0
> *   Adding to list: perl-core/Params-Check:0
> *                   virtual/perl-Params-Check:0
> *   Adding to list: perl-core/Time-Local:0
> *                   virtual/perl-Time-Local:0
> *   Adding to list: perl-core/ExtUtils-CBuilder:0
> *                   virtual/perl-ExtUtils-CBuilder:0
> *   Adding to list: perl-core/Module-Load-Conditional:0
> *                   virtual/perl-Module-Load-Conditional:0
> *   Adding to list: perl-core/CPAN-Meta-YAML:0
> *                   virtual/perl-CPAN-Meta-YAML:0
> * emerge -vD1 --backtrack=30 dev-perl/File-DesktopEntry:0
>   dev-perl/XML-NamespaceSupport:0 dev-perl/Authen-SASL:0
>   dev-perl/OLE-StorageLite:0 dev-perl/Digest-Perl-MD5:0
>   dev-perl/XML-Simple:0 dev-perl/Digest-HMAC:0 dev-perl/Net-SMTP-SSL:0
>   dev-perl/XML-SAX-Base:0 dev-perl/File-MimeInfo:0
>   dev-perl/Unicode-Map:0 dev-perl/XML-LibXML:0
>   dev-perl/Locale-gettext:0 dev-perl/Crypt-RC4:0
>   dev-perl/File-BaseDir:0 dev-perl/XML-Parser:0 dev-perl/XML-SAX:0
>   dev-perl/Spreadsheet-ParseExcel:0 dev-perl/IO-stringy:0
>   perl-core/IPC-Cmd:0 virtual/perl-IPC-Cmd:0
>   perl-core/Module-CoreList:0 virtual/perl-Module-CoreList:0
>   perl-core/IO:0 virtual/perl-IO:0 perl-core/File-Spec:0
>   virtual/perl-File-Spec:0 perl-core/CPAN-Meta:0
>   virtual/perl-CPAN-Meta:0 perl-core/Module-Build:0
>   virtual/perl-Module-Build:0 perl-core/ExtUtils-ParseXS:0
>   virtual/perl-ExtUtils-ParseXS:0 perl-core/version:0
>   virtual/perl-version:0 perl-core/Archive-Tar:0
>   virtual/perl-Archive-Tar:0 perl-core/Module-Load:0
>   virtual/perl-Module-Load:0 perl-core/Test-Harness:0
>   virtual/perl-Test-Harness:0 perl-core/CPAN-Meta-Requirements:0
>   virtual/perl-CPAN-Meta-Requirements:0 perl-core/Compress-Raw-Bzip2:0
>   virtual/perl-Compress-Raw-Bzip2:0 perl-core/IO-Compress:0
>   virtual/perl-IO-Compress:0 perl-core/ExtUtils-MakeMaker:0
>   virtual/perl-ExtUtils-MakeMaker:0 perl-core/Parse-CPAN-Meta:0
>   virtual/perl-Parse-CPAN-Meta:0 perl-core/Digest-MD5:0
>   virtual/perl-Digest-MD5:0 perl-core/ExtUtils-Manifest:0
>   virtual/perl-ExtUtils-Manifest:0 perl-core/Module-Metadata:0
>   virtual/perl-Module-Metadata:0 perl-core/Scalar-List-Utils:0
>   virtual/perl-Scalar-List-Utils:0 perl-core/Compress-Raw-Zlib:0
>   virtual/perl-Compress-Raw-Zlib:0 perl-core/Params-Check:0
>   virtual/perl-Params-Check:0 perl-core/Time-Local:0
>   virtual/perl-Time-Local:0 perl-core/ExtUtils-CBuilder:0
>   virtual/perl-ExtUtils-CBuilder:0 perl-core/Module-Load-Conditional:0
>   virtual/perl-Module-Load-Conditional:0 perl-core/CPAN-Meta-YAML:0
>   virtual/perl-CPAN-Meta-YAML:0
>
>These are the packages that would be merged, in order:
>
>Calculating dependencies... done!
>[ebuild   R    ] virtual/perl-File-Spec-3.400.0-r2  0 kB
>[ebuild     U  ] virtual/perl-version-0.990.200-r1 [0.990.100] 0 kB
>[ebuild   R    ] virtual/perl-Scalar-List-Utils-1.270.0-r2  0 kB
>[ebuild   R    ] dev-perl/XML-NamespaceSupport-1.110.0  0 kB
>[ebuild   R    ] virtual/perl-Module-Build-0.400.300-r1  0 kB
>[ebuild   R    ] virtual/perl-Parse-CPAN-Meta-1.440.400-r1  0 kB
>[ebuild   R    ] virtual/perl-CPAN-Meta-YAML-0.8.0-r2  0 kB
>[ebuild   R    ] virtual/perl-CPAN-Meta-2.120.921-r2  0 kB
>[ebuild   R    ] virtual/perl-Module-Metadata-1.0.11-r1  0 kB
>[ebuild   R    ] virtual/perl-Params-Check-0.360.0-r1  0 kB
>[ebuild     U  ] virtual/perl-ExtUtils-CBuilder-0.280.210-r1
>[0.280.205] 0 kB [ebuild   R    ] dev-perl/OLE-StorageLite-0.190.0  0
>kB
>[ebuild   R    ] dev-perl/Digest-Perl-MD5-1.800.0  0 kB
>[ebuild   R    ] dev-perl/XML-SAX-Base-1.80.0  0 kB
>[ebuild   R    ] dev-perl/Unicode-Map-0.112.0  0 kB
>[ebuild   R    ] dev-perl/Crypt-RC4-2.020.0  0 kB
>[ebuild   R    ] dev-perl/XML-Parser-2.410.0  0 kB
>[ebuild   R    ] dev-perl/IO-stringy-2.110.0  0 kB
>[ebuild     U  ] virtual/perl-IPC-Cmd-0.800.0-r1 [0.780.0] 0 kB
>[ebuild     U  ] virtual/perl-Module-CoreList-3.30.0 [2.840.0] 0 kB
>[ebuild     U  ] virtual/perl-IO-1.280.0-r1 [1.25] 0 kB
>[ebuild   R    ] virtual/perl-ExtUtils-ParseXS-3.180.0-r2  0 kB
>[ebuild   R    ] virtual/perl-Archive-Tar-1.900.0-r2  0 kB
>[ebuild   R    ] virtual/perl-Module-Load-0.240.0-r1  0 kB
>[ebuild   R    ] virtual/perl-Test-Harness-3.260.0-r2  0 kB
>[ebuild   R    ] virtual/perl-CPAN-Meta-Requirements-2.122.0-r2  0 kB
>[ebuild   R    ] virtual/perl-Compress-Raw-Bzip2-2.60.0-r2  0 kB
>[ebuild   R    ] virtual/perl-IO-Compress-2.60.0-r1  0 kB
>[ebuild     U  ] virtual/perl-ExtUtils-MakeMaker-6.660.0-r1 [6.640.0] 0
>kB [ebuild   R    ] virtual/perl-Digest-MD5-2.520.0-r2  0 kB
>[ebuild     U  ] virtual/perl-ExtUtils-Manifest-1.630.0-r1 [1.610.0] 0
>kB [ebuild   R    ] virtual/perl-Compress-Raw-Zlib-2.60.0-r2  0 kB
>[ebuild   R    ] virtual/perl-Module-Load-Conditional-0.540.0-r1  0 kB
>[ebuild  N     ] perl-core/JSON-PP-2.272.0-r1  0 kB
>[ebuild  N     ] perl-core/File-Temp-0.220.0-r1  38 kB
>[ebuild  N     ] perl-core/Perl-OSType-1.2.0-r1  USE="{-test}" 0 kB
>[ebuild   R    ] perl-core/Module-CoreList-2.840.0  0 kB
>[ebuild   R    ] perl-core/IO-1.25-r1  0 kB
>[ebuild   R    ] perl-core/File-Spec-3.400.0  0 kB
>[ebuild     U  ] perl-core/version-0.990.100-r1 [0.990.100] 0 kB
>[ebuild   R    ] perl-core/Module-Load-0.240.0  0 kB
>[ebuild   R    ] perl-core/Test-Harness-3.260.0  0 kB
>[ebuild   R    ] perl-core/Compress-Raw-Bzip2-2.60.0  0 kB
>[ebuild     U  ] perl-core/ExtUtils-Manifest-1.610.0-r1 [1.610.0] 0 kB
>[ebuild   R    ] perl-core/Scalar-List-Utils-1.270.0  0 kB
>[ebuild   R    ] perl-core/Compress-Raw-Zlib-2.60.0  0 kB
>[ebuild     U  ] perl-core/Time-Local-1.230.0-r1 [1.230.0] 0 kB
>[ebuild   R    ] virtual/perl-Time-Local-1.230.0-r1  0 kB
>[ebuild     U  ] perl-core/CPAN-Meta-YAML-0.8.0-r1 [0.8.0] 0 kB
>[ebuild   R    ] dev-perl/File-BaseDir-0.30.0  USE="{-test}" 0 kB
>[ebuild   R    ] dev-perl/Spreadsheet-ParseExcel-0.590.0  USE="unicode
>-cjk {-test}" 0 kB [ebuild     U  ] perl-core/IPC-Cmd-0.780.0-r1
>[0.780.0] 0 kB [ebuild     U  ] perl-core/ExtUtils-ParseXS-3.180.0-r1
>[3.180.0] 0 kB [ebuild   R    ] perl-core/Archive-Tar-1.900.0-r1  0 kB
>[ebuild     U  ] perl-core/CPAN-Meta-Requirements-2.122.0-r1 [2.122.0]
>0 kB [ebuild   R    ] perl-core/IO-Compress-2.60.0  0 kB
>[ebuild     U  ] perl-core/Digest-MD5-2.520.0-r1 [2.520.0] 0 kB
>[ebuild     U  ] perl-core/Module-Metadata-1.0.11-r1 [1.0.11] 0 kB
>[ebuild     U  ] perl-core/Params-Check-0.360.0-r1 [0.360.0] 0 kB
>[ebuild   R    ] perl-core/Module-Load-Conditional-0.540.0  0 kB
>[ebuild   R    ] dev-perl/File-DesktopEntry-0.40.0  USE="{-test}" 0 kB
>[ebuild   R    ] dev-perl/Digest-HMAC-1.30.0  0 kB
>[ebuild     U  ] perl-core/CPAN-Meta-2.120.921-r1 [2.120.921] 0 kB
>[ebuild     U  ] perl-core/Module-Build-0.400.300-r1 [0.400.300]
>USE="{-test}" 0 kB [ebuild     U  ]
>perl-core/Parse-CPAN-Meta-1.440.400-r1 [1.440.400] 0 kB [ebuild     U
>] perl-core/ExtUtils-CBuilder-0.280.205-r1 [0.280.205] 0 kB [ebuild
>R    ] dev-perl/Authen-SASL-2.160.0  USE="-kerberos" 0 kB [ebuild
>R    ] dev-perl/Net-SMTP-SSL-1.10.0  0 kB [ebuild     UD ]
>dev-lang/perl-5.16.3:0/5.16 [5.18.2-r1:0/5.18] USE="berkdb gdbm -debug
>-doc -ithreads" 0 kB [ebuild     U  ]
>perl-core/ExtUtils-MakeMaker-6.640.0-r1 [6.640.0] 0 kB [ebuild   R    ]
>dev-perl/XML-SAX-0.990.0  0 kB [ebuild   R    ]
>dev-perl/File-MimeInfo-0.170.0  USE="{-test}" 0 kB [ebuild   R    ]
>dev-perl/XML-LibXML-2.1.400  USE="{-test}" 0 kB [ebuild   R    ]
>dev-perl/Locale-gettext-1.50.0  0 kB [ebuild   R    ]
>dev-perl/XML-Simple-2.200.0  0 kB [blocks B      ]
><perl-core/Module-CoreList-3.30.0 ("<perl-core/Module-CoreList-3.30.0"
>is blocking virtual/perl-Module-CoreList-3.30.0) [blocks B      ]
><perl-core/IPC-Cmd-0.800.0 ("<perl-core/IPC-Cmd-0.800.0" is blocking
>virtual/perl-IPC-Cmd-0.800.0-r1) [blocks B      ]
><perl-core/ExtUtils-Manifest-1.630.0
>("<perl-core/ExtUtils-Manifest-1.630.0" is blocking
>virtual/perl-ExtUtils-Manifest-1.630.0-r1) [blocks B      ]
><perl-core/ExtUtils-MakeMaker-6.660.0
>("<perl-core/ExtUtils-MakeMaker-6.660.0" is blocking
>virtual/perl-ExtUtils-MakeMaker-6.660.0-r1) [blocks B      ]
><perl-core/IO-1.280.0 ("<perl-core/IO-1.280.0" is blocking
>virtual/perl-IO-1.280.0-r1) [blocks B      ]
><perl-core/version-0.990.200 ("<perl-core/version-0.990.200" is
>blocking virtual/perl-version-0.990.200-r1) [blocks B      ]
><perl-core/ExtUtils-CBuilder-0.280.210
>("<perl-core/ExtUtils-CBuilder-0.280.210" is blocking
>virtual/perl-ExtUtils-CBuilder-0.280.210-r1)
>
>Total: 75 packages (22 upgrades, 1 downgrade, 3 new, 49 reinstalls),
>Size of downloads: 38 kB Conflict: 7 blocks (7 unsatisfied)
>
>!!! Multiple package instances within a single package slot have been
>pulled !!! into the dependency graph, resulting in a slot conflict:
>
>dev-lang/perl:0
>
>  (dev-lang/perl-5.16.3::gentoo, ebuild scheduled for merge) pulled in
>  by =dev-lang/perl-5.16* required by
>  (virtual/perl-ExtUtils-Install-1.580.0-r1::gentoo, installed)
>
>  (dev-lang/perl-5.18.2-r1::gentoo, installed) pulled in by
>    dev-lang/perl:0/5.18=[-build(-)] required by
>  (dev-perl/URI-1.600.0-r1::gentoo, installed)
>  dev-lang/perl:0/5.18=[-build(-)] required by
>  (dev-perl/Net-SSLeay-1.550::gentoo, installed)
>  dev-lang/perl:0/5.18=[-build(-)] required by
>  (dev-perl/Error-0.170.210::gentoo, installed)
>  dev-lang/perl:0/5.18=[-build(-)] required by
>  (dev-perl/Text-CSV_XS-0.950.0::gentoo, installed)
>  dev-lang/perl:0/5.18=[-build(-)] required by
>  (dev-perl/IO-Socket-SSL-1.953.0::gentoo, installed)
>  dev-lang/perl:0/5.18=[-build(-)] required by
>  (perl-core/Digest-SHA-5.820.0::gentoo, installed)
>  dev-lang/perl:0/5.18=[-build(-)] required by
>  (dev-perl/Algorithm-Diff-1.190.200-r1::gentoo, installed)
>  dev-lang/perl:0/5.18=[-build(-)] required by
>  (dev-vcs/git-1.8.5.5::gentoo, installed) =dev-lang/perl-5.18*
>  required by (virtual/perl-Digest-MD5-2.520.0-r2::gentoo, ebuild
>  scheduled for merge) (and 35 more with the same problems)
>
>
>It may be possible to solve this problem by using package.mask to
>prevent one of those packages from being selected. However, it is also
>possible that conflicting dependencies exist such that they are
>impossible to satisfy simultaneously.  If such a conflict exists in
>the dependencies of two different packages, then those packages can
>not be installed simultaneously.
>
>For more information, see MASKED PACKAGES section in the emerge man
>page or refer to the Gentoo Handbook.
>
>
> * Error: The above package list contains packages which cannot be
> * installed at the same time on the same system.
>
>  (virtual/perl-ExtUtils-Manifest-1.630.0-r1::gentoo, ebuild scheduled
>  for merge) pulled in by virtual/perl-ExtUtils-Manifest:0
>    >=virtual/perl-ExtUtils-Manifest-1.600.0 required by
>  (perl-core/ExtUtils-MakeMaker-6.640.0-r1::gentoo, ebuild scheduled
>  for merge) =virtual/perl-ExtUtils-Manifest-1.630.0-r1 required by
>  (perl-core/ExtUtils-MakeMaker-6.640.0-r1::gentoo, ebuild scheduled
>  for merge)
>
>  (virtual/perl-IO-1.280.0-r1::gentoo, ebuild scheduled for merge)
>  pulled in by virtual/perl-IO:0
>    =virtual/perl-IO-1.280.0-r1 required by
>  (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for
>  merge) virtual/perl-IO required by
> (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for merge)
>
>  (virtual/perl-Module-CoreList-3.30.0::gentoo, ebuild scheduled for
>  merge) pulled in by =virtual/perl-Module-CoreList-3.30.0 required by
>  (perl-core/Module-Load-Conditional-0.540.0::gentoo, ebuild scheduled
>  for merge) virtual/perl-Module-CoreList:0
>  >=virtual/perl-Module-CoreList-0.22 required by
>  (perl-core/Module-Load-Conditional-0.540.0::gentoo, ebuild scheduled
>  for merge)
>
>  (perl-core/Module-CoreList-2.840.0::gentoo, ebuild scheduled for
>  merge) pulled in by perl-core/Module-CoreList:0
>
>  (virtual/perl-version-0.990.200-r1::gentoo, ebuild scheduled for
>  merge) pulled in by >=virtual/perl-version-0.870 required by
>  (perl-core/Module-Metadata-1.0.11-r1::gentoo, ebuild scheduled for
>  merge) >=virtual/perl-version-0.77 required by
>  (perl-core/CPAN-Meta-Requirements-2.122.0-r1::gentoo, ebuild
>  scheduled for merge) =virtual/perl-version-0.990.200-r1 required by
>  (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for
>  merge) >=virtual/perl-version-0.82 required by
>  (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for
>  merge) =virtual/perl-version-0.990.200-r1 required by
>  (perl-core/Module-Load-Conditional-0.540.0::gentoo, ebuild scheduled
>  for merge) =virtual/perl-version-0.990.200-r1 required by
>  (perl-core/Module-Build-0.400.300-r1::gentoo, ebuild scheduled for
>  merge) >=virtual/perl-version-0.87 required by
>  (perl-core/Module-Build-0.400.300-r1::gentoo, ebuild scheduled for
>  merge) virtual/perl-version:0 virtual/perl-version required by
>  (perl-core/Module-Load-Conditional-0.540.0::gentoo, ebuild scheduled
>  for merge) =virtual/perl-version-0.990.200-r1 required by
>  (perl-core/CPAN-Meta-Requirements-2.122.0-r1::gentoo, ebuild
>  scheduled for merge) =virtual/perl-version-0.990.200-r1 required by
>  (perl-core/Module-Metadata-1.0.11-r1::gentoo, ebuild scheduled for
>  merge)
>
>  (virtual/perl-ExtUtils-MakeMaker-6.660.0-r1::gentoo, ebuild scheduled
>  for merge) pulled in by virtual/perl-ExtUtils-MakeMaker:0
>    >=virtual/perl-ExtUtils-MakeMaker-6.56 required by
>  (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for
>  merge) =virtual/perl-ExtUtils-MakeMaker-6.660.0-r1 required by
> (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for merge)
>
>  (virtual/perl-IPC-Cmd-0.800.0-r1::gentoo, ebuild scheduled for merge)
>  pulled in by virtual/perl-IPC-Cmd:0
>    virtual/perl-IPC-Cmd required by
>  (perl-core/ExtUtils-CBuilder-0.280.205-r1::gentoo, ebuild scheduled
>  for merge) =virtual/perl-IPC-Cmd-0.800.0-r1 required by
>  (perl-core/ExtUtils-CBuilder-0.280.205-r1::gentoo, ebuild scheduled
>  for merge)
>
>  (perl-core/IPC-Cmd-0.780.0-r1::gentoo, ebuild scheduled for merge)
>  pulled in by perl-core/IPC-Cmd:0
>
>  (perl-core/version-0.990.100-r1::gentoo, ebuild scheduled for merge)
>  pulled in by perl-core/version:0
>
>  (virtual/perl-ExtUtils-CBuilder-0.280.210-r1::gentoo, ebuild
>  scheduled for merge) pulled in by virtual/perl-ExtUtils-CBuilder:0
>    virtual/perl-ExtUtils-CBuilder required by
>  (perl-core/ExtUtils-ParseXS-3.180.0-r1::gentoo, ebuild scheduled for
>  merge) >=virtual/perl-ExtUtils-CBuilder-0.27 required by
>  (perl-core/Module-Build-0.400.300-r1::gentoo, ebuild scheduled for
>  merge) =virtual/perl-ExtUtils-CBuilder-0.280.210-r1 required by
>  (perl-core/Module-Build-0.400.300-r1::gentoo, ebuild scheduled for
>  merge) =virtual/perl-ExtUtils-CBuilder-0.280.210-r1 required by
>  (perl-core/ExtUtils-ParseXS-3.180.0-r1::gentoo, ebuild scheduled for
>  merge)
>
>  (perl-core/ExtUtils-Manifest-1.610.0-r1::gentoo, ebuild scheduled for
>  merge) pulled in by perl-core/ExtUtils-Manifest:0
>
>  (perl-core/ExtUtils-MakeMaker-6.640.0-r1::gentoo, ebuild scheduled
>  for merge) pulled in by perl-core/ExtUtils-MakeMaker:0
>
>  (perl-core/IO-1.25-r1::gentoo, ebuild scheduled for merge) pulled in
>  by perl-core/IO:0
>
>  (perl-core/ExtUtils-CBuilder-0.280.205-r1::gentoo, ebuild scheduled
>  for merge) pulled in by perl-core/ExtUtils-CBuilder:0
>
>
>For more information about Blocked Packages, please refer to the
>following section of the Gentoo Linux x86 Handbook (architecture is
>irrelevant):
>
>http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked
>
> * perl-cleaner is stopping here:
> * Fix the problem and start perl-cleaner again.
> *
> * If you encounter blockers involving virtuals and perl-core, here are
> * some things to try:
> *   Remove all perl-core packages from your world file
> *     emerge --deselect --ask $(qlist -IC 'perl-core/*')
> *   Update all the installed Perl virtuals
> *     emerge -uD1a $(qlist -IC 'virtual/perl-*')
> *   Afterwards re-run perl-cleaner
> *
> * Note that upgrading Perl with emerge option
>   --ignore-built-slot-operator-deps=y is not supported.
>
>Currently trying the above suggestions but I have no perl in my world.

Run the 2 commands listed at the bottom of that message.
They start with emerge

Replying from mobile. Copy paste doesn't work well with bumpy rides.

--
Joost
--
Sent from my Android device with K-9 Mail. Please excuse my brevity.

Reply | Threaded
Open this post in threaded view
|

Re: colord failed to upgrade

gevisz
In reply to this post by Alec Ten Harmsel
On Thu, 31 Jul 2014 10:03:09 -0400
Alec Ten Harmsel <[hidden email]> wrote:

> I can't comment on a long-term, real, proper solution, but for right
> now
>
>     emerge --oneshot dev-perl/XML-Parser
>
> should at least allow you to continue building colord.

It seems that it helped, but not the suggestions from
  # perl-cleaner --all
output.

Thank you.

Reply | Threaded
Open this post in threaded view
|

Re: colord failed to upgrade

J. Roeleveld
In reply to this post by Alec Ten Harmsel
On 31 July 2014 16:03:09 CEST, Alec Ten Harmsel <[hidden email]> wrote:
>I can't comment on a long-term, real, proper solution, but for right
>now
>
>    emerge --oneshot dev-perl/XML-Parser
>
>should at least allow you to continue building colord.
>

Please do not top post.

A long term solution is listed at the bottom of the output from perl-cleaner.




>On Thu 31 Jul 2014 09:58:17 AM EDT, Gevisz wrote:
>> On Thu, 31 Jul 2014 15:36:38 +0200
>> Alan McKinnon <[hidden email]> wrote:
>>
>>> On 31/07/2014 15:29, Gevisz wrote:
>>>> In my today's system update I have got the following error message:
>>>>
>>>>  * ERROR: x11-misc/colord-1.2.1-r1::gentoo failed (configure
>phase):
>>>>  *   econf failed
>>>
>>> The actual error message is earlier than this point[1]. Please go
>>> through that referenced log, find the error message and report
>>
>> Yes, you are right. Earlier in the colord emege log
>> I have found the following:
>>
>> checking for XML::Parser... configure: error: XML::Parser perl module
>> is required for intltool
>>
>> And even earlier in the emerge log were the following:
>>
>>  * Messages for package dev-lang/perl-5.18.2-r1:
>>
>>  * UPDATE THE PERL MODULES:
>>  * After updating dev-lang/perl you must reinstall
>>  * the installed perl modules.
>>  * Use: perl-cleaner --all
>>
>> And after running just now # perl-cleaner --all
>> I have got the real trouble. The output is below.
>> Shall I rename the Subject to "perl failed to upgrade"?
>>
>> # perl-cleaner --all
>>
>>  * Beginning a clean up of .ph files
>>  * Excluding files for 5.18.2 and 5.18.2/x86_64-linux from cleaning
>>
>>  * Locating ph files for removal
>>
>>  * Updating ph files.
>>  * Ignore all "No such file..." messages!
>> Can't open machine/ansi.h: No such file or directory
>> Can't open sys/_types.h: No such file or directory
>> Can't open gnu/stubs-x32.h: No such file or directory
>> Can't open gnu/stubs-x32.h: No such file or directory
>> Can't open gnu/stubs-x32.h: No such file or directory
>> Can't open gnu/stubs-x32.h: No such file or directory
>>
>>  * Locating packages for an update
>>  * Locating ebuilds linked against libperl
>>  *   Adding to list: dev-perl/File-DesktopEntry:0
>>  *   Adding to list: dev-perl/XML-NamespaceSupport:0
>>  *   Adding to list: dev-perl/Authen-SASL:0
>>  *   Adding to list: dev-perl/OLE-StorageLite:0
>>  *   Adding to list: dev-perl/Digest-Perl-MD5:0
>>  *   Adding to list: dev-perl/XML-Simple:0
>>  *   Adding to list: dev-perl/Digest-HMAC:0
>>  *   Adding to list: dev-perl/Net-SMTP-SSL:0
>>  *   Adding to list: dev-perl/XML-SAX-Base:0
>>  *   Adding to list: dev-perl/File-MimeInfo:0
>>  *   Adding to list: dev-perl/Unicode-Map:0
>>  *   Adding to list: dev-perl/XML-LibXML:0
>>  *   Adding to list: dev-perl/Locale-gettext:0
>>  *   Adding to list: dev-perl/Crypt-RC4:0
>>  *   Adding to list: dev-perl/File-BaseDir:0
>>  *   Adding to list: dev-perl/XML-Parser:0
>>  *   Adding to list: dev-perl/XML-SAX:0
>>  *   Adding to list: dev-perl/Spreadsheet-ParseExcel:0
>>  *   Adding to list: dev-perl/IO-stringy:0
>>  *   Adding to list: perl-core/IPC-Cmd:0
>>  *                   virtual/perl-IPC-Cmd:0
>>  *   Adding to list: perl-core/Module-CoreList:0
>>  *                   virtual/perl-Module-CoreList:0
>>  *   Adding to list: perl-core/IO:0
>>  *                   virtual/perl-IO:0
>>  *   Adding to list: perl-core/File-Spec:0
>>  *                   virtual/perl-File-Spec:0
>>  *   Adding to list: perl-core/CPAN-Meta:0
>>  *                   virtual/perl-CPAN-Meta:0
>>  *   Adding to list: perl-core/Module-Build:0
>>  *                   virtual/perl-Module-Build:0
>>  *   Adding to list: perl-core/ExtUtils-ParseXS:0
>>  *                   virtual/perl-ExtUtils-ParseXS:0
>>  *   Adding to list: perl-core/version:0
>>  *                   virtual/perl-version:0
>>  *   Adding to list: perl-core/Archive-Tar:0
>>  *                   virtual/perl-Archive-Tar:0
>>  *   Adding to list: perl-core/Module-Load:0
>>  *                   virtual/perl-Module-Load:0
>>  *   Adding to list: perl-core/Test-Harness:0
>>  *                   virtual/perl-Test-Harness:0
>>  *   Adding to list: perl-core/CPAN-Meta-Requirements:0
>>  *                   virtual/perl-CPAN-Meta-Requirements:0
>>  *   Adding to list: perl-core/Compress-Raw-Bzip2:0
>>  *                   virtual/perl-Compress-Raw-Bzip2:0
>>  *   Adding to list: perl-core/IO-Compress:0
>>  *                   virtual/perl-IO-Compress:0
>>  *   Adding to list: perl-core/ExtUtils-MakeMaker:0
>>  *                   virtual/perl-ExtUtils-MakeMaker:0
>>  *   Adding to list: perl-core/Parse-CPAN-Meta:0
>>  *                   virtual/perl-Parse-CPAN-Meta:0
>>  *   Adding to list: perl-core/Digest-MD5:0
>>  *                   virtual/perl-Digest-MD5:0
>>  *   Adding to list: perl-core/ExtUtils-Manifest:0
>>  *                   virtual/perl-ExtUtils-Manifest:0
>>  *   Adding to list: perl-core/Module-Metadata:0
>>  *                   virtual/perl-Module-Metadata:0
>>  *   Adding to list: perl-core/Scalar-List-Utils:0
>>  *                   virtual/perl-Scalar-List-Utils:0
>>  *   Adding to list: perl-core/Compress-Raw-Zlib:0
>>  *                   virtual/perl-Compress-Raw-Zlib:0
>>  *   Adding to list: perl-core/Params-Check:0
>>  *                   virtual/perl-Params-Check:0
>>  *   Adding to list: perl-core/Time-Local:0
>>  *                   virtual/perl-Time-Local:0
>>  *   Adding to list: perl-core/ExtUtils-CBuilder:0
>>  *                   virtual/perl-ExtUtils-CBuilder:0
>>  *   Adding to list: perl-core/Module-Load-Conditional:0
>>  *                   virtual/perl-Module-Load-Conditional:0
>>  *   Adding to list: perl-core/CPAN-Meta-YAML:0
>>  *                   virtual/perl-CPAN-Meta-YAML:0
>>  * emerge -vD1 --backtrack=30 dev-perl/File-DesktopEntry:0
>>    dev-perl/XML-NamespaceSupport:0 dev-perl/Authen-SASL:0
>>    dev-perl/OLE-StorageLite:0 dev-perl/Digest-Perl-MD5:0
>>    dev-perl/XML-Simple:0 dev-perl/Digest-HMAC:0
>dev-perl/Net-SMTP-SSL:0
>>    dev-perl/XML-SAX-Base:0 dev-perl/File-MimeInfo:0
>>    dev-perl/Unicode-Map:0 dev-perl/XML-LibXML:0
>>    dev-perl/Locale-gettext:0 dev-perl/Crypt-RC4:0
>>    dev-perl/File-BaseDir:0 dev-perl/XML-Parser:0 dev-perl/XML-SAX:0
>>    dev-perl/Spreadsheet-ParseExcel:0 dev-perl/IO-stringy:0
>>    perl-core/IPC-Cmd:0 virtual/perl-IPC-Cmd:0
>>    perl-core/Module-CoreList:0 virtual/perl-Module-CoreList:0
>>    perl-core/IO:0 virtual/perl-IO:0 perl-core/File-Spec:0
>>    virtual/perl-File-Spec:0 perl-core/CPAN-Meta:0
>>    virtual/perl-CPAN-Meta:0 perl-core/Module-Build:0
>>    virtual/perl-Module-Build:0 perl-core/ExtUtils-ParseXS:0
>>    virtual/perl-ExtUtils-ParseXS:0 perl-core/version:0
>>    virtual/perl-version:0 perl-core/Archive-Tar:0
>>    virtual/perl-Archive-Tar:0 perl-core/Module-Load:0
>>    virtual/perl-Module-Load:0 perl-core/Test-Harness:0
>>    virtual/perl-Test-Harness:0 perl-core/CPAN-Meta-Requirements:0
>>    virtual/perl-CPAN-Meta-Requirements:0
>perl-core/Compress-Raw-Bzip2:0
>>    virtual/perl-Compress-Raw-Bzip2:0 perl-core/IO-Compress:0
>>    virtual/perl-IO-Compress:0 perl-core/ExtUtils-MakeMaker:0
>>    virtual/perl-ExtUtils-MakeMaker:0 perl-core/Parse-CPAN-Meta:0
>>    virtual/perl-Parse-CPAN-Meta:0 perl-core/Digest-MD5:0
>>    virtual/perl-Digest-MD5:0 perl-core/ExtUtils-Manifest:0
>>    virtual/perl-ExtUtils-Manifest:0 perl-core/Module-Metadata:0
>>    virtual/perl-Module-Metadata:0 perl-core/Scalar-List-Utils:0
>>    virtual/perl-Scalar-List-Utils:0 perl-core/Compress-Raw-Zlib:0
>>    virtual/perl-Compress-Raw-Zlib:0 perl-core/Params-Check:0
>>    virtual/perl-Params-Check:0 perl-core/Time-Local:0
>>    virtual/perl-Time-Local:0 perl-core/ExtUtils-CBuilder:0
>>    virtual/perl-ExtUtils-CBuilder:0
>perl-core/Module-Load-Conditional:0
>>    virtual/perl-Module-Load-Conditional:0 perl-core/CPAN-Meta-YAML:0
>>    virtual/perl-CPAN-Meta-YAML:0
>>
>> These are the packages that would be merged, in order:
>>
>> Calculating dependencies... done!
>> [ebuild   R    ] virtual/perl-File-Spec-3.400.0-r2  0 kB
>> [ebuild     U  ] virtual/perl-version-0.990.200-r1 [0.990.100] 0 kB
>> [ebuild   R    ] virtual/perl-Scalar-List-Utils-1.270.0-r2  0 kB
>> [ebuild   R    ] dev-perl/XML-NamespaceSupport-1.110.0  0 kB
>> [ebuild   R    ] virtual/perl-Module-Build-0.400.300-r1  0 kB
>> [ebuild   R    ] virtual/perl-Parse-CPAN-Meta-1.440.400-r1  0 kB
>> [ebuild   R    ] virtual/perl-CPAN-Meta-YAML-0.8.0-r2  0 kB
>> [ebuild   R    ] virtual/perl-CPAN-Meta-2.120.921-r2  0 kB
>> [ebuild   R    ] virtual/perl-Module-Metadata-1.0.11-r1  0 kB
>> [ebuild   R    ] virtual/perl-Params-Check-0.360.0-r1  0 kB
>> [ebuild     U  ] virtual/perl-ExtUtils-CBuilder-0.280.210-r1
>> [0.280.205] 0 kB [ebuild   R    ] dev-perl/OLE-StorageLite-0.190.0  0
>kB
>> [ebuild   R    ] dev-perl/Digest-Perl-MD5-1.800.0  0 kB
>> [ebuild   R    ] dev-perl/XML-SAX-Base-1.80.0  0 kB
>> [ebuild   R    ] dev-perl/Unicode-Map-0.112.0  0 kB
>> [ebuild   R    ] dev-perl/Crypt-RC4-2.020.0  0 kB
>> [ebuild   R    ] dev-perl/XML-Parser-2.410.0  0 kB
>> [ebuild   R    ] dev-perl/IO-stringy-2.110.0  0 kB
>> [ebuild     U  ] virtual/perl-IPC-Cmd-0.800.0-r1 [0.780.0] 0 kB
>> [ebuild     U  ] virtual/perl-Module-CoreList-3.30.0 [2.840.0] 0 kB
>> [ebuild     U  ] virtual/perl-IO-1.280.0-r1 [1.25] 0 kB
>> [ebuild   R    ] virtual/perl-ExtUtils-ParseXS-3.180.0-r2  0 kB
>> [ebuild   R    ] virtual/perl-Archive-Tar-1.900.0-r2  0 kB
>> [ebuild   R    ] virtual/perl-Module-Load-0.240.0-r1  0 kB
>> [ebuild   R    ] virtual/perl-Test-Harness-3.260.0-r2  0 kB
>> [ebuild   R    ] virtual/perl-CPAN-Meta-Requirements-2.122.0-r2  0 kB
>> [ebuild   R    ] virtual/perl-Compress-Raw-Bzip2-2.60.0-r2  0 kB
>> [ebuild   R    ] virtual/perl-IO-Compress-2.60.0-r1  0 kB
>> [ebuild     U  ] virtual/perl-ExtUtils-MakeMaker-6.660.0-r1 [6.640.0]
>0
>> kB [ebuild   R    ] virtual/perl-Digest-MD5-2.520.0-r2  0 kB
>> [ebuild     U  ] virtual/perl-ExtUtils-Manifest-1.630.0-r1 [1.610.0]
>0
>> kB [ebuild   R    ] virtual/perl-Compress-Raw-Zlib-2.60.0-r2  0 kB
>> [ebuild   R    ] virtual/perl-Module-Load-Conditional-0.540.0-r1  0
>kB
>> [ebuild  N     ] perl-core/JSON-PP-2.272.0-r1  0 kB
>> [ebuild  N     ] perl-core/File-Temp-0.220.0-r1  38 kB
>> [ebuild  N     ] perl-core/Perl-OSType-1.2.0-r1  USE="{-test}" 0 kB
>> [ebuild   R    ] perl-core/Module-CoreList-2.840.0  0 kB
>> [ebuild   R    ] perl-core/IO-1.25-r1  0 kB
>> [ebuild   R    ] perl-core/File-Spec-3.400.0  0 kB
>> [ebuild     U  ] perl-core/version-0.990.100-r1 [0.990.100] 0 kB
>> [ebuild   R    ] perl-core/Module-Load-0.240.0  0 kB
>> [ebuild   R    ] perl-core/Test-Harness-3.260.0  0 kB
>> [ebuild   R    ] perl-core/Compress-Raw-Bzip2-2.60.0  0 kB
>> [ebuild     U  ] perl-core/ExtUtils-Manifest-1.610.0-r1 [1.610.0] 0
>kB
>> [ebuild   R    ] perl-core/Scalar-List-Utils-1.270.0  0 kB
>> [ebuild   R    ] perl-core/Compress-Raw-Zlib-2.60.0  0 kB
>> [ebuild     U  ] perl-core/Time-Local-1.230.0-r1 [1.230.0] 0 kB
>> [ebuild   R    ] virtual/perl-Time-Local-1.230.0-r1  0 kB
>> [ebuild     U  ] perl-core/CPAN-Meta-YAML-0.8.0-r1 [0.8.0] 0 kB
>> [ebuild   R    ] dev-perl/File-BaseDir-0.30.0  USE="{-test}" 0 kB
>> [ebuild   R    ] dev-perl/Spreadsheet-ParseExcel-0.590.0
>USE="unicode
>> -cjk {-test}" 0 kB [ebuild     U  ] perl-core/IPC-Cmd-0.780.0-r1
>> [0.780.0] 0 kB [ebuild     U  ] perl-core/ExtUtils-ParseXS-3.180.0-r1
>> [3.180.0] 0 kB [ebuild   R    ] perl-core/Archive-Tar-1.900.0-r1  0
>kB
>> [ebuild     U  ] perl-core/CPAN-Meta-Requirements-2.122.0-r1
>[2.122.0]
>> 0 kB [ebuild   R    ] perl-core/IO-Compress-2.60.0  0 kB
>> [ebuild     U  ] perl-core/Digest-MD5-2.520.0-r1 [2.520.0] 0 kB
>> [ebuild     U  ] perl-core/Module-Metadata-1.0.11-r1 [1.0.11] 0 kB
>> [ebuild     U  ] perl-core/Params-Check-0.360.0-r1 [0.360.0] 0 kB
>> [ebuild   R    ] perl-core/Module-Load-Conditional-0.540.0  0 kB
>> [ebuild   R    ] dev-perl/File-DesktopEntry-0.40.0  USE="{-test}" 0
>kB
>> [ebuild   R    ] dev-perl/Digest-HMAC-1.30.0  0 kB
>> [ebuild     U  ] perl-core/CPAN-Meta-2.120.921-r1 [2.120.921] 0 kB
>> [ebuild     U  ] perl-core/Module-Build-0.400.300-r1 [0.400.300]
>> USE="{-test}" 0 kB [ebuild     U  ]
>> perl-core/Parse-CPAN-Meta-1.440.400-r1 [1.440.400] 0 kB [ebuild     U
>> ] perl-core/ExtUtils-CBuilder-0.280.205-r1 [0.280.205] 0 kB [ebuild
>> R    ] dev-perl/Authen-SASL-2.160.0  USE="-kerberos" 0 kB [ebuild
>> R    ] dev-perl/Net-SMTP-SSL-1.10.0  0 kB [ebuild     UD ]
>> dev-lang/perl-5.16.3:0/5.16 [5.18.2-r1:0/5.18] USE="berkdb gdbm
>-debug
>> -doc -ithreads" 0 kB [ebuild     U  ]
>> perl-core/ExtUtils-MakeMaker-6.640.0-r1 [6.640.0] 0 kB [ebuild   R  
>]
>> dev-perl/XML-SAX-0.990.0  0 kB [ebuild   R    ]
>> dev-perl/File-MimeInfo-0.170.0  USE="{-test}" 0 kB [ebuild   R    ]
>> dev-perl/XML-LibXML-2.1.400  USE="{-test}" 0 kB [ebuild   R    ]
>> dev-perl/Locale-gettext-1.50.0  0 kB [ebuild   R    ]
>> dev-perl/XML-Simple-2.200.0  0 kB [blocks B      ]
>> <perl-core/Module-CoreList-3.30.0
>("<perl-core/Module-CoreList-3.30.0"
>> is blocking virtual/perl-Module-CoreList-3.30.0) [blocks B      ]
>> <perl-core/IPC-Cmd-0.800.0 ("<perl-core/IPC-Cmd-0.800.0" is blocking
>> virtual/perl-IPC-Cmd-0.800.0-r1) [blocks B      ]
>> <perl-core/ExtUtils-Manifest-1.630.0
>> ("<perl-core/ExtUtils-Manifest-1.630.0" is blocking
>> virtual/perl-ExtUtils-Manifest-1.630.0-r1) [blocks B      ]
>> <perl-core/ExtUtils-MakeMaker-6.660.0
>> ("<perl-core/ExtUtils-MakeMaker-6.660.0" is blocking
>> virtual/perl-ExtUtils-MakeMaker-6.660.0-r1) [blocks B      ]
>> <perl-core/IO-1.280.0 ("<perl-core/IO-1.280.0" is blocking
>> virtual/perl-IO-1.280.0-r1) [blocks B      ]
>> <perl-core/version-0.990.200 ("<perl-core/version-0.990.200" is
>> blocking virtual/perl-version-0.990.200-r1) [blocks B      ]
>> <perl-core/ExtUtils-CBuilder-0.280.210
>> ("<perl-core/ExtUtils-CBuilder-0.280.210" is blocking
>> virtual/perl-ExtUtils-CBuilder-0.280.210-r1)
>>
>> Total: 75 packages (22 upgrades, 1 downgrade, 3 new, 49 reinstalls),
>> Size of downloads: 38 kB Conflict: 7 blocks (7 unsatisfied)
>>
>> !!! Multiple package instances within a single package slot have been
>> pulled !!! into the dependency graph, resulting in a slot conflict:
>>
>> dev-lang/perl:0
>>
>>   (dev-lang/perl-5.16.3::gentoo, ebuild scheduled for merge) pulled
>in
>>   by =dev-lang/perl-5.16* required by
>>   (virtual/perl-ExtUtils-Install-1.580.0-r1::gentoo, installed)
>>
>>   (dev-lang/perl-5.18.2-r1::gentoo, installed) pulled in by
>>     dev-lang/perl:0/5.18=[-build(-)] required by
>>   (dev-perl/URI-1.600.0-r1::gentoo, installed)
>>   dev-lang/perl:0/5.18=[-build(-)] required by
>>   (dev-perl/Net-SSLeay-1.550::gentoo, installed)
>>   dev-lang/perl:0/5.18=[-build(-)] required by
>>   (dev-perl/Error-0.170.210::gentoo, installed)
>>   dev-lang/perl:0/5.18=[-build(-)] required by
>>   (dev-perl/Text-CSV_XS-0.950.0::gentoo, installed)
>>   dev-lang/perl:0/5.18=[-build(-)] required by
>>   (dev-perl/IO-Socket-SSL-1.953.0::gentoo, installed)
>>   dev-lang/perl:0/5.18=[-build(-)] required by
>>   (perl-core/Digest-SHA-5.820.0::gentoo, installed)
>>   dev-lang/perl:0/5.18=[-build(-)] required by
>>   (dev-perl/Algorithm-Diff-1.190.200-r1::gentoo, installed)
>>   dev-lang/perl:0/5.18=[-build(-)] required by
>>   (dev-vcs/git-1.8.5.5::gentoo, installed) =dev-lang/perl-5.18*
>>   required by (virtual/perl-Digest-MD5-2.520.0-r2::gentoo, ebuild
>>   scheduled for merge) (and 35 more with the same problems)
>>
>>
>> It may be possible to solve this problem by using package.mask to
>> prevent one of those packages from being selected. However, it is
>also
>> possible that conflicting dependencies exist such that they are
>> impossible to satisfy simultaneously.  If such a conflict exists in
>> the dependencies of two different packages, then those packages can
>> not be installed simultaneously.
>>
>> For more information, see MASKED PACKAGES section in the emerge man
>> page or refer to the Gentoo Handbook.
>>
>>
>>  * Error: The above package list contains packages which cannot be
>>  * installed at the same time on the same system.
>>
>>   (virtual/perl-ExtUtils-Manifest-1.630.0-r1::gentoo, ebuild
>scheduled
>>   for merge) pulled in by virtual/perl-ExtUtils-Manifest:0
>>     >=virtual/perl-ExtUtils-Manifest-1.600.0 required by
>>   (perl-core/ExtUtils-MakeMaker-6.640.0-r1::gentoo, ebuild scheduled
>>   for merge) =virtual/perl-ExtUtils-Manifest-1.630.0-r1 required by
>>   (perl-core/ExtUtils-MakeMaker-6.640.0-r1::gentoo, ebuild scheduled
>>   for merge)
>>
>>   (virtual/perl-IO-1.280.0-r1::gentoo, ebuild scheduled for merge)
>>   pulled in by virtual/perl-IO:0
>>     =virtual/perl-IO-1.280.0-r1 required by
>>   (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for
>>   merge) virtual/perl-IO required by
>>   (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for
>merge)
>>
>>   (virtual/perl-Module-CoreList-3.30.0::gentoo, ebuild scheduled for
>>   merge) pulled in by =virtual/perl-Module-CoreList-3.30.0 required
>by
>>   (perl-core/Module-Load-Conditional-0.540.0::gentoo, ebuild
>scheduled
>>   for merge) virtual/perl-Module-CoreList:0
>>   >=virtual/perl-Module-CoreList-0.22 required by
>>   (perl-core/Module-Load-Conditional-0.540.0::gentoo, ebuild
>scheduled
>>   for merge)
>>
>>   (perl-core/Module-CoreList-2.840.0::gentoo, ebuild scheduled for
>>   merge) pulled in by perl-core/Module-CoreList:0
>>
>>   (virtual/perl-version-0.990.200-r1::gentoo, ebuild scheduled for
>>   merge) pulled in by >=virtual/perl-version-0.870 required by
>>   (perl-core/Module-Metadata-1.0.11-r1::gentoo, ebuild scheduled for
>>   merge) >=virtual/perl-version-0.77 required by
>>   (perl-core/CPAN-Meta-Requirements-2.122.0-r1::gentoo, ebuild
>>   scheduled for merge) =virtual/perl-version-0.990.200-r1 required by
>>   (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for
>>   merge) >=virtual/perl-version-0.82 required by
>>   (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for
>>   merge) =virtual/perl-version-0.990.200-r1 required by
>>   (perl-core/Module-Load-Conditional-0.540.0::gentoo, ebuild
>scheduled
>>   for merge) =virtual/perl-version-0.990.200-r1 required by
>>   (perl-core/Module-Build-0.400.300-r1::gentoo, ebuild scheduled for
>>   merge) >=virtual/perl-version-0.87 required by
>>   (perl-core/Module-Build-0.400.300-r1::gentoo, ebuild scheduled for
>>   merge) virtual/perl-version:0 virtual/perl-version required by
>>   (perl-core/Module-Load-Conditional-0.540.0::gentoo, ebuild
>scheduled
>>   for merge) =virtual/perl-version-0.990.200-r1 required by
>>   (perl-core/CPAN-Meta-Requirements-2.122.0-r1::gentoo, ebuild
>>   scheduled for merge) =virtual/perl-version-0.990.200-r1 required by
>>   (perl-core/Module-Metadata-1.0.11-r1::gentoo, ebuild scheduled for
>>   merge)
>>
>>   (virtual/perl-ExtUtils-MakeMaker-6.660.0-r1::gentoo, ebuild
>scheduled
>>   for merge) pulled in by virtual/perl-ExtUtils-MakeMaker:0
>>     >=virtual/perl-ExtUtils-MakeMaker-6.56 required by
>>   (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for
>>   merge) =virtual/perl-ExtUtils-MakeMaker-6.660.0-r1 required by
>>   (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for
>merge)
>>
>>   (virtual/perl-IPC-Cmd-0.800.0-r1::gentoo, ebuild scheduled for
>merge)
>>   pulled in by virtual/perl-IPC-Cmd:0
>>     virtual/perl-IPC-Cmd required by
>>   (perl-core/ExtUtils-CBuilder-0.280.205-r1::gentoo, ebuild scheduled
>>   for merge) =virtual/perl-IPC-Cmd-0.800.0-r1 required by
>>   (perl-core/ExtUtils-CBuilder-0.280.205-r1::gentoo, ebuild scheduled
>>   for merge)
>>
>>   (perl-core/IPC-Cmd-0.780.0-r1::gentoo, ebuild scheduled for merge)
>>   pulled in by perl-core/IPC-Cmd:0
>>
>>   (perl-core/version-0.990.100-r1::gentoo, ebuild scheduled for
>merge)
>>   pulled in by perl-core/version:0
>>
>>   (virtual/perl-ExtUtils-CBuilder-0.280.210-r1::gentoo, ebuild
>>   scheduled for merge) pulled in by virtual/perl-ExtUtils-CBuilder:0
>>     virtual/perl-ExtUtils-CBuilder required by
>>   (perl-core/ExtUtils-ParseXS-3.180.0-r1::gentoo, ebuild scheduled
>for
>>   merge) >=virtual/perl-ExtUtils-CBuilder-0.27 required by
>>   (perl-core/Module-Build-0.400.300-r1::gentoo, ebuild scheduled for
>>   merge) =virtual/perl-ExtUtils-CBuilder-0.280.210-r1 required by
>>   (perl-core/Module-Build-0.400.300-r1::gentoo, ebuild scheduled for
>>   merge) =virtual/perl-ExtUtils-CBuilder-0.280.210-r1 required by
>>   (perl-core/ExtUtils-ParseXS-3.180.0-r1::gentoo, ebuild scheduled
>for
>>   merge)
>>
>>   (perl-core/ExtUtils-Manifest-1.610.0-r1::gentoo, ebuild scheduled
>for
>>   merge) pulled in by perl-core/ExtUtils-Manifest:0
>>
>>   (perl-core/ExtUtils-MakeMaker-6.640.0-r1::gentoo, ebuild scheduled
>>   for merge) pulled in by perl-core/ExtUtils-MakeMaker:0
>>
>>   (perl-core/IO-1.25-r1::gentoo, ebuild scheduled for merge) pulled
>in
>>   by perl-core/IO:0
>>
>>   (perl-core/ExtUtils-CBuilder-0.280.205-r1::gentoo, ebuild scheduled
>>   for merge) pulled in by perl-core/ExtUtils-CBuilder:0
>>
>>
>> For more information about Blocked Packages, please refer to the
>> following section of the Gentoo Linux x86 Handbook (architecture is
>> irrelevant):
>>
>> http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked
>>
>>  * perl-cleaner is stopping here:
>>  * Fix the problem and start perl-cleaner again.
>>  *
>>  * If you encounter blockers involving virtuals and perl-core, here
>are
>>  * some things to try:
>>  *   Remove all perl-core packages from your world file
>>  *     emerge --deselect --ask $(qlist -IC 'perl-core/*')
>>  *   Update all the installed Perl virtuals
>>  *     emerge -uD1a $(qlist -IC 'virtual/perl-*')
>>  *   Afterwards re-run perl-cleaner
>>  *
>>  * Note that upgrading Perl with emerge option
>>    --ignore-built-slot-operator-deps=y is not supported.
>>
>> Currently trying the above suggestions but I have no perl in my
>world.
>>


--
Sent from my Android device with K-9 Mail. Please excuse my brevity.

Reply | Threaded
Open this post in threaded view
|

Re: colord failed to upgrade

gevisz
In reply to this post by J. Roeleveld
On Thu, 31 Jul 2014 16:18:35 +0200
"J. Roeleveld" <[hidden email]> wrote:

> On 31 July 2014 15:58:17 CEST, Gevisz <[hidden email]> wrote:
> >On Thu, 31 Jul 2014 15:36:38 +0200
> >Alan McKinnon <[hidden email]> wrote:
> >
> >> On 31/07/2014 15:29, Gevisz wrote:
> >> > In my today's system update I have got the following error
> >> > message:
> >> >
> >> >  * ERROR: x11-misc/colord-1.2.1-r1::gentoo failed (configure
> >phase):
> >> >  *   econf failed
> >>
> >> The actual error message is earlier than this point[1]. Please go
> >> through that referenced log, find the error message and report
> >
> >Yes, you are right. Earlier in the colord emege log
> >I have found the following:
> >
> >checking for XML::Parser... configure: error: XML::Parser perl module
> >is required for intltool
> >
> >And even earlier in the emerge log were the following:
> >
> > * Messages for package dev-lang/perl-5.18.2-r1:
> >
> > * UPDATE THE PERL MODULES:
> > * After updating dev-lang/perl you must reinstall
> > * the installed perl modules.
> > * Use: perl-cleaner --all
> >
> >And after running just now # perl-cleaner --all
> >I have got the real trouble. The output is below.
> >Shall I rename the Subject to "perl failed to upgrade"?
> >
> ># perl-cleaner --all
> >
> > * Beginning a clean up of .ph files
> > * Excluding files for 5.18.2 and 5.18.2/x86_64-linux from cleaning
> >
> > * Locating ph files for removal
> >
> > * Updating ph files.
> > * Ignore all "No such file..." messages!
> >Can't open machine/ansi.h: No such file or directory
> >Can't open sys/_types.h: No such file or directory
> >Can't open gnu/stubs-x32.h: No such file or directory
> >Can't open gnu/stubs-x32.h: No such file or directory
> >Can't open gnu/stubs-x32.h: No such file or directory
> >Can't open gnu/stubs-x32.h: No such file or directory
> >
> > * Locating packages for an update
> > * Locating ebuilds linked against libperl
> > *   Adding to list: dev-perl/File-DesktopEntry:0
> > *   Adding to list: dev-perl/XML-NamespaceSupport:0
> > *   Adding to list: dev-perl/Authen-SASL:0
> > *   Adding to list: dev-perl/OLE-StorageLite:0
> > *   Adding to list: dev-perl/Digest-Perl-MD5:0
> > *   Adding to list: dev-perl/XML-Simple:0
> > *   Adding to list: dev-perl/Digest-HMAC:0
> > *   Adding to list: dev-perl/Net-SMTP-SSL:0
> > *   Adding to list: dev-perl/XML-SAX-Base:0
> > *   Adding to list: dev-perl/File-MimeInfo:0
> > *   Adding to list: dev-perl/Unicode-Map:0
> > *   Adding to list: dev-perl/XML-LibXML:0
> > *   Adding to list: dev-perl/Locale-gettext:0
> > *   Adding to list: dev-perl/Crypt-RC4:0
> > *   Adding to list: dev-perl/File-BaseDir:0
> > *   Adding to list: dev-perl/XML-Parser:0
> > *   Adding to list: dev-perl/XML-SAX:0
> > *   Adding to list: dev-perl/Spreadsheet-ParseExcel:0
> > *   Adding to list: dev-perl/IO-stringy:0
> > *   Adding to list: perl-core/IPC-Cmd:0
> > *                   virtual/perl-IPC-Cmd:0
> > *   Adding to list: perl-core/Module-CoreList:0
> > *                   virtual/perl-Module-CoreList:0
> > *   Adding to list: perl-core/IO:0
> > *                   virtual/perl-IO:0
> > *   Adding to list: perl-core/File-Spec:0
> > *                   virtual/perl-File-Spec:0
> > *   Adding to list: perl-core/CPAN-Meta:0
> > *                   virtual/perl-CPAN-Meta:0
> > *   Adding to list: perl-core/Module-Build:0
> > *                   virtual/perl-Module-Build:0
> > *   Adding to list: perl-core/ExtUtils-ParseXS:0
> > *                   virtual/perl-ExtUtils-ParseXS:0
> > *   Adding to list: perl-core/version:0
> > *                   virtual/perl-version:0
> > *   Adding to list: perl-core/Archive-Tar:0
> > *                   virtual/perl-Archive-Tar:0
> > *   Adding to list: perl-core/Module-Load:0
> > *                   virtual/perl-Module-Load:0
> > *   Adding to list: perl-core/Test-Harness:0
> > *                   virtual/perl-Test-Harness:0
> > *   Adding to list: perl-core/CPAN-Meta-Requirements:0
> > *                   virtual/perl-CPAN-Meta-Requirements:0
> > *   Adding to list: perl-core/Compress-Raw-Bzip2:0
> > *                   virtual/perl-Compress-Raw-Bzip2:0
> > *   Adding to list: perl-core/IO-Compress:0
> > *                   virtual/perl-IO-Compress:0
> > *   Adding to list: perl-core/ExtUtils-MakeMaker:0
> > *                   virtual/perl-ExtUtils-MakeMaker:0
> > *   Adding to list: perl-core/Parse-CPAN-Meta:0
> > *                   virtual/perl-Parse-CPAN-Meta:0
> > *   Adding to list: perl-core/Digest-MD5:0
> > *                   virtual/perl-Digest-MD5:0
> > *   Adding to list: perl-core/ExtUtils-Manifest:0
> > *                   virtual/perl-ExtUtils-Manifest:0
> > *   Adding to list: perl-core/Module-Metadata:0
> > *                   virtual/perl-Module-Metadata:0
> > *   Adding to list: perl-core/Scalar-List-Utils:0
> > *                   virtual/perl-Scalar-List-Utils:0
> > *   Adding to list: perl-core/Compress-Raw-Zlib:0
> > *                   virtual/perl-Compress-Raw-Zlib:0
> > *   Adding to list: perl-core/Params-Check:0
> > *                   virtual/perl-Params-Check:0
> > *   Adding to list: perl-core/Time-Local:0
> > *                   virtual/perl-Time-Local:0
> > *   Adding to list: perl-core/ExtUtils-CBuilder:0
> > *                   virtual/perl-ExtUtils-CBuilder:0
> > *   Adding to list: perl-core/Module-Load-Conditional:0
> > *                   virtual/perl-Module-Load-Conditional:0
> > *   Adding to list: perl-core/CPAN-Meta-YAML:0
> > *                   virtual/perl-CPAN-Meta-YAML:0
> > * emerge -vD1 --backtrack=30 dev-perl/File-DesktopEntry:0
> >   dev-perl/XML-NamespaceSupport:0 dev-perl/Authen-SASL:0
> >   dev-perl/OLE-StorageLite:0 dev-perl/Digest-Perl-MD5:0
> >   dev-perl/XML-Simple:0 dev-perl/Digest-HMAC:0
> > dev-perl/Net-SMTP-SSL:0 dev-perl/XML-SAX-Base:0
> > dev-perl/File-MimeInfo:0 dev-perl/Unicode-Map:0
> > dev-perl/XML-LibXML:0 dev-perl/Locale-gettext:0 dev-perl/Crypt-RC4:0
> >   dev-perl/File-BaseDir:0 dev-perl/XML-Parser:0 dev-perl/XML-SAX:0
> >   dev-perl/Spreadsheet-ParseExcel:0 dev-perl/IO-stringy:0
> >   perl-core/IPC-Cmd:0 virtual/perl-IPC-Cmd:0
> >   perl-core/Module-CoreList:0 virtual/perl-Module-CoreList:0
> >   perl-core/IO:0 virtual/perl-IO:0 perl-core/File-Spec:0
> >   virtual/perl-File-Spec:0 perl-core/CPAN-Meta:0
> >   virtual/perl-CPAN-Meta:0 perl-core/Module-Build:0
> >   virtual/perl-Module-Build:0 perl-core/ExtUtils-ParseXS:0
> >   virtual/perl-ExtUtils-ParseXS:0 perl-core/version:0
> >   virtual/perl-version:0 perl-core/Archive-Tar:0
> >   virtual/perl-Archive-Tar:0 perl-core/Module-Load:0
> >   virtual/perl-Module-Load:0 perl-core/Test-Harness:0
> >   virtual/perl-Test-Harness:0 perl-core/CPAN-Meta-Requirements:0
> >   virtual/perl-CPAN-Meta-Requirements:0
> > perl-core/Compress-Raw-Bzip2:0 virtual/perl-Compress-Raw-Bzip2:0
> > perl-core/IO-Compress:0 virtual/perl-IO-Compress:0
> > perl-core/ExtUtils-MakeMaker:0 virtual/perl-ExtUtils-MakeMaker:0
> > perl-core/Parse-CPAN-Meta:0 virtual/perl-Parse-CPAN-Meta:0
> > perl-core/Digest-MD5:0 virtual/perl-Digest-MD5:0
> > perl-core/ExtUtils-Manifest:0 virtual/perl-ExtUtils-Manifest:0
> > perl-core/Module-Metadata:0 virtual/perl-Module-Metadata:0
> > perl-core/Scalar-List-Utils:0 virtual/perl-Scalar-List-Utils:0
> > perl-core/Compress-Raw-Zlib:0 virtual/perl-Compress-Raw-Zlib:0
> > perl-core/Params-Check:0 virtual/perl-Params-Check:0
> > perl-core/Time-Local:0 virtual/perl-Time-Local:0
> > perl-core/ExtUtils-CBuilder:0 virtual/perl-ExtUtils-CBuilder:0
> > perl-core/Module-Load-Conditional:0
> > virtual/perl-Module-Load-Conditional:0 perl-core/CPAN-Meta-YAML:0
> > virtual/perl-CPAN-Meta-YAML:0
> >
> >These are the packages that would be merged, in order:
> >
> >Calculating dependencies... done!
> >[ebuild   R    ] virtual/perl-File-Spec-3.400.0-r2  0 kB
> >[ebuild     U  ] virtual/perl-version-0.990.200-r1 [0.990.100] 0 kB
> >[ebuild   R    ] virtual/perl-Scalar-List-Utils-1.270.0-r2  0 kB
> >[ebuild   R    ] dev-perl/XML-NamespaceSupport-1.110.0  0 kB
> >[ebuild   R    ] virtual/perl-Module-Build-0.400.300-r1  0 kB
> >[ebuild   R    ] virtual/perl-Parse-CPAN-Meta-1.440.400-r1  0 kB
> >[ebuild   R    ] virtual/perl-CPAN-Meta-YAML-0.8.0-r2  0 kB
> >[ebuild   R    ] virtual/perl-CPAN-Meta-2.120.921-r2  0 kB
> >[ebuild   R    ] virtual/perl-Module-Metadata-1.0.11-r1  0 kB
> >[ebuild   R    ] virtual/perl-Params-Check-0.360.0-r1  0 kB
> >[ebuild     U  ] virtual/perl-ExtUtils-CBuilder-0.280.210-r1
> >[0.280.205] 0 kB [ebuild   R    ] dev-perl/OLE-StorageLite-0.190.0  0
> >kB
> >[ebuild   R    ] dev-perl/Digest-Perl-MD5-1.800.0  0 kB
> >[ebuild   R    ] dev-perl/XML-SAX-Base-1.80.0  0 kB
> >[ebuild   R    ] dev-perl/Unicode-Map-0.112.0  0 kB
> >[ebuild   R    ] dev-perl/Crypt-RC4-2.020.0  0 kB
> >[ebuild   R    ] dev-perl/XML-Parser-2.410.0  0 kB
> >[ebuild   R    ] dev-perl/IO-stringy-2.110.0  0 kB
> >[ebuild     U  ] virtual/perl-IPC-Cmd-0.800.0-r1 [0.780.0] 0 kB
> >[ebuild     U  ] virtual/perl-Module-CoreList-3.30.0 [2.840.0] 0 kB
> >[ebuild     U  ] virtual/perl-IO-1.280.0-r1 [1.25] 0 kB
> >[ebuild   R    ] virtual/perl-ExtUtils-ParseXS-3.180.0-r2  0 kB
> >[ebuild   R    ] virtual/perl-Archive-Tar-1.900.0-r2  0 kB
> >[ebuild   R    ] virtual/perl-Module-Load-0.240.0-r1  0 kB
> >[ebuild   R    ] virtual/perl-Test-Harness-3.260.0-r2  0 kB
> >[ebuild   R    ] virtual/perl-CPAN-Meta-Requirements-2.122.0-r2  0 kB
> >[ebuild   R    ] virtual/perl-Compress-Raw-Bzip2-2.60.0-r2  0 kB
> >[ebuild   R    ] virtual/perl-IO-Compress-2.60.0-r1  0 kB
> >[ebuild     U  ] virtual/perl-ExtUtils-MakeMaker-6.660.0-r1
> >[6.640.0] 0 kB [ebuild   R    ] virtual/perl-Digest-MD5-2.520.0-r2
> >0 kB [ebuild     U  ] virtual/perl-ExtUtils-Manifest-1.630.0-r1
> >[1.610.0] 0 kB [ebuild   R    ]
> >virtual/perl-Compress-Raw-Zlib-2.60.0-r2  0 kB [ebuild   R    ]
> >virtual/perl-Module-Load-Conditional-0.540.0-r1  0 kB [ebuild  N
> >] perl-core/JSON-PP-2.272.0-r1  0 kB [ebuild  N     ]
> >perl-core/File-Temp-0.220.0-r1  38 kB [ebuild  N     ]
> >perl-core/Perl-OSType-1.2.0-r1  USE="{-test}" 0 kB [ebuild   R    ]
> >perl-core/Module-CoreList-2.840.0  0 kB [ebuild   R    ]
> >perl-core/IO-1.25-r1  0 kB [ebuild   R    ]
> >perl-core/File-Spec-3.400.0  0 kB [ebuild     U  ]
> >perl-core/version-0.990.100-r1 [0.990.100] 0 kB [ebuild   R    ]
> >perl-core/Module-Load-0.240.0  0 kB [ebuild   R    ]
> >perl-core/Test-Harness-3.260.0  0 kB [ebuild   R    ]
> >perl-core/Compress-Raw-Bzip2-2.60.0  0 kB [ebuild     U  ]
> >perl-core/ExtUtils-Manifest-1.610.0-r1 [1.610.0] 0 kB [ebuild   R
> >] perl-core/Scalar-List-Utils-1.270.0  0 kB [ebuild   R    ]
> >perl-core/Compress-Raw-Zlib-2.60.0  0 kB [ebuild     U  ]
> >perl-core/Time-Local-1.230.0-r1 [1.230.0] 0 kB [ebuild   R    ]
> >virtual/perl-Time-Local-1.230.0-r1  0 kB [ebuild     U  ]
> >perl-core/CPAN-Meta-YAML-0.8.0-r1 [0.8.0] 0 kB [ebuild   R    ]
> >dev-perl/File-BaseDir-0.30.0  USE="{-test}" 0 kB [ebuild   R    ]
> >dev-perl/Spreadsheet-ParseExcel-0.590.0  USE="unicode -cjk {-test}"
> >0 kB [ebuild     U  ] perl-core/IPC-Cmd-0.780.0-r1 [0.780.0] 0 kB
> >[ebuild     U  ] perl-core/ExtUtils-ParseXS-3.180.0-r1 [3.180.0] 0
> >kB [ebuild   R    ] perl-core/Archive-Tar-1.900.0-r1  0 kB
> >[ebuild     U  ] perl-core/CPAN-Meta-Requirements-2.122.0-r1
> >[2.122.0] 0 kB [ebuild   R    ] perl-core/IO-Compress-2.60.0  0 kB
> >[ebuild     U  ] perl-core/Digest-MD5-2.520.0-r1 [2.520.0] 0 kB
> >[ebuild     U  ] perl-core/Module-Metadata-1.0.11-r1 [1.0.11] 0 kB
> >[ebuild     U  ] perl-core/Params-Check-0.360.0-r1 [0.360.0] 0 kB
> >[ebuild   R    ] perl-core/Module-Load-Conditional-0.540.0  0 kB
> >[ebuild   R    ] dev-perl/File-DesktopEntry-0.40.0  USE="{-test}" 0
> >kB [ebuild   R    ] dev-perl/Digest-HMAC-1.30.0  0 kB [ebuild     U
> >] perl-core/CPAN-Meta-2.120.921-r1 [2.120.921] 0 kB [ebuild     U  ]
> >perl-core/Module-Build-0.400.300-r1 [0.400.300] USE="{-test}" 0 kB
> >[ebuild     U  ] perl-core/Parse-CPAN-Meta-1.440.400-r1 [1.440.400]
> >0 kB [ebuild     U ] perl-core/ExtUtils-CBuilder-0.280.205-r1
> >[0.280.205] 0 kB [ebuild R    ] dev-perl/Authen-SASL-2.160.0
> >USE="-kerberos" 0 kB [ebuild R    ] dev-perl/Net-SMTP-SSL-1.10.0  0
> >kB [ebuild     UD ] dev-lang/perl-5.16.3:0/5.16 [5.18.2-r1:0/5.18]
> >USE="berkdb gdbm -debug -doc -ithreads" 0 kB [ebuild     U  ]
> >perl-core/ExtUtils-MakeMaker-6.640.0-r1 [6.640.0] 0 kB [ebuild
> >R    ] dev-perl/XML-SAX-0.990.0  0 kB [ebuild   R    ]
> >dev-perl/File-MimeInfo-0.170.0  USE="{-test}" 0 kB [ebuild   R    ]
> >dev-perl/XML-LibXML-2.1.400  USE="{-test}" 0 kB [ebuild   R    ]
> >dev-perl/Locale-gettext-1.50.0  0 kB [ebuild   R    ]
> >dev-perl/XML-Simple-2.200.0  0 kB [blocks B      ]
> ><perl-core/Module-CoreList-3.30.0
> >("<perl-core/Module-CoreList-3.30.0" is blocking
> >virtual/perl-Module-CoreList-3.30.0) [blocks B      ]
> ><perl-core/IPC-Cmd-0.800.0 ("<perl-core/IPC-Cmd-0.800.0" is blocking
> >virtual/perl-IPC-Cmd-0.800.0-r1) [blocks B      ]
> ><perl-core/ExtUtils-Manifest-1.630.0
> >("<perl-core/ExtUtils-Manifest-1.630.0" is blocking
> >virtual/perl-ExtUtils-Manifest-1.630.0-r1) [blocks B      ]
> ><perl-core/ExtUtils-MakeMaker-6.660.0
> >("<perl-core/ExtUtils-MakeMaker-6.660.0" is blocking
> >virtual/perl-ExtUtils-MakeMaker-6.660.0-r1) [blocks B      ]
> ><perl-core/IO-1.280.0 ("<perl-core/IO-1.280.0" is blocking
> >virtual/perl-IO-1.280.0-r1) [blocks B      ]
> ><perl-core/version-0.990.200 ("<perl-core/version-0.990.200" is
> >blocking virtual/perl-version-0.990.200-r1) [blocks B      ]
> ><perl-core/ExtUtils-CBuilder-0.280.210
> >("<perl-core/ExtUtils-CBuilder-0.280.210" is blocking
> >virtual/perl-ExtUtils-CBuilder-0.280.210-r1)
> >
> >Total: 75 packages (22 upgrades, 1 downgrade, 3 new, 49 reinstalls),
> >Size of downloads: 38 kB Conflict: 7 blocks (7 unsatisfied)
> >
> >!!! Multiple package instances within a single package slot have been
> >pulled !!! into the dependency graph, resulting in a slot conflict:
> >
> >dev-lang/perl:0
> >
> >  (dev-lang/perl-5.16.3::gentoo, ebuild scheduled for merge) pulled
> > in by =dev-lang/perl-5.16* required by
> >  (virtual/perl-ExtUtils-Install-1.580.0-r1::gentoo, installed)
> >
> >  (dev-lang/perl-5.18.2-r1::gentoo, installed) pulled in by
> >    dev-lang/perl:0/5.18=[-build(-)] required by
> >  (dev-perl/URI-1.600.0-r1::gentoo, installed)
> >  dev-lang/perl:0/5.18=[-build(-)] required by
> >  (dev-perl/Net-SSLeay-1.550::gentoo, installed)
> >  dev-lang/perl:0/5.18=[-build(-)] required by
> >  (dev-perl/Error-0.170.210::gentoo, installed)
> >  dev-lang/perl:0/5.18=[-build(-)] required by
> >  (dev-perl/Text-CSV_XS-0.950.0::gentoo, installed)
> >  dev-lang/perl:0/5.18=[-build(-)] required by
> >  (dev-perl/IO-Socket-SSL-1.953.0::gentoo, installed)
> >  dev-lang/perl:0/5.18=[-build(-)] required by
> >  (perl-core/Digest-SHA-5.820.0::gentoo, installed)
> >  dev-lang/perl:0/5.18=[-build(-)] required by
> >  (dev-perl/Algorithm-Diff-1.190.200-r1::gentoo, installed)
> >  dev-lang/perl:0/5.18=[-build(-)] required by
> >  (dev-vcs/git-1.8.5.5::gentoo, installed) =dev-lang/perl-5.18*
> >  required by (virtual/perl-Digest-MD5-2.520.0-r2::gentoo, ebuild
> >  scheduled for merge) (and 35 more with the same problems)
> >
> >
> >It may be possible to solve this problem by using package.mask to
> >prevent one of those packages from being selected. However, it is
> >also possible that conflicting dependencies exist such that they are
> >impossible to satisfy simultaneously.  If such a conflict exists in
> >the dependencies of two different packages, then those packages can
> >not be installed simultaneously.
> >
> >For more information, see MASKED PACKAGES section in the emerge man
> >page or refer to the Gentoo Handbook.
> >
> >
> > * Error: The above package list contains packages which cannot be
> > * installed at the same time on the same system.
> >
> >  (virtual/perl-ExtUtils-Manifest-1.630.0-r1::gentoo, ebuild
> > scheduled for merge) pulled in by virtual/perl-ExtUtils-Manifest:0
> >    >=virtual/perl-ExtUtils-Manifest-1.600.0 required by
> >  (perl-core/ExtUtils-MakeMaker-6.640.0-r1::gentoo, ebuild scheduled
> >  for merge) =virtual/perl-ExtUtils-Manifest-1.630.0-r1 required by
> >  (perl-core/ExtUtils-MakeMaker-6.640.0-r1::gentoo, ebuild scheduled
> >  for merge)
> >
> >  (virtual/perl-IO-1.280.0-r1::gentoo, ebuild scheduled for merge)
> >  pulled in by virtual/perl-IO:0
> >    =virtual/perl-IO-1.280.0-r1 required by
> >  (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for
> >  merge) virtual/perl-IO required by
> > (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for
> > merge)
> >
> >  (virtual/perl-Module-CoreList-3.30.0::gentoo, ebuild scheduled for
> >  merge) pulled in by =virtual/perl-Module-CoreList-3.30.0 required
> > by (perl-core/Module-Load-Conditional-0.540.0::gentoo, ebuild
> > scheduled for merge) virtual/perl-Module-CoreList:0
> >  >=virtual/perl-Module-CoreList-0.22 required by
> >  (perl-core/Module-Load-Conditional-0.540.0::gentoo, ebuild
> > scheduled for merge)
> >
> >  (perl-core/Module-CoreList-2.840.0::gentoo, ebuild scheduled for
> >  merge) pulled in by perl-core/Module-CoreList:0
> >
> >  (virtual/perl-version-0.990.200-r1::gentoo, ebuild scheduled for
> >  merge) pulled in by >=virtual/perl-version-0.870 required by
> >  (perl-core/Module-Metadata-1.0.11-r1::gentoo, ebuild scheduled for
> >  merge) >=virtual/perl-version-0.77 required by
> >  (perl-core/CPAN-Meta-Requirements-2.122.0-r1::gentoo, ebuild
> >  scheduled for merge) =virtual/perl-version-0.990.200-r1 required by
> >  (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for
> >  merge) >=virtual/perl-version-0.82 required by
> >  (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for
> >  merge) =virtual/perl-version-0.990.200-r1 required by
> >  (perl-core/Module-Load-Conditional-0.540.0::gentoo, ebuild
> > scheduled for merge) =virtual/perl-version-0.990.200-r1 required by
> >  (perl-core/Module-Build-0.400.300-r1::gentoo, ebuild scheduled for
> >  merge) >=virtual/perl-version-0.87 required by
> >  (perl-core/Module-Build-0.400.300-r1::gentoo, ebuild scheduled for
> >  merge) virtual/perl-version:0 virtual/perl-version required by
> >  (perl-core/Module-Load-Conditional-0.540.0::gentoo, ebuild
> > scheduled for merge) =virtual/perl-version-0.990.200-r1 required by
> >  (perl-core/CPAN-Meta-Requirements-2.122.0-r1::gentoo, ebuild
> >  scheduled for merge) =virtual/perl-version-0.990.200-r1 required by
> >  (perl-core/Module-Metadata-1.0.11-r1::gentoo, ebuild scheduled for
> >  merge)
> >
> >  (virtual/perl-ExtUtils-MakeMaker-6.660.0-r1::gentoo, ebuild
> > scheduled for merge) pulled in by virtual/perl-ExtUtils-MakeMaker:0
> >    >=virtual/perl-ExtUtils-MakeMaker-6.56 required by
> >  (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for
> >  merge) =virtual/perl-ExtUtils-MakeMaker-6.660.0-r1 required by
> > (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for
> > merge)
> >
> >  (virtual/perl-IPC-Cmd-0.800.0-r1::gentoo, ebuild scheduled for
> > merge) pulled in by virtual/perl-IPC-Cmd:0
> >    virtual/perl-IPC-Cmd required by
> >  (perl-core/ExtUtils-CBuilder-0.280.205-r1::gentoo, ebuild scheduled
> >  for merge) =virtual/perl-IPC-Cmd-0.800.0-r1 required by
> >  (perl-core/ExtUtils-CBuilder-0.280.205-r1::gentoo, ebuild scheduled
> >  for merge)
> >
> >  (perl-core/IPC-Cmd-0.780.0-r1::gentoo, ebuild scheduled for merge)
> >  pulled in by perl-core/IPC-Cmd:0
> >
> >  (perl-core/version-0.990.100-r1::gentoo, ebuild scheduled for
> > merge) pulled in by perl-core/version:0
> >
> >  (virtual/perl-ExtUtils-CBuilder-0.280.210-r1::gentoo, ebuild
> >  scheduled for merge) pulled in by virtual/perl-ExtUtils-CBuilder:0
> >    virtual/perl-ExtUtils-CBuilder required by
> >  (perl-core/ExtUtils-ParseXS-3.180.0-r1::gentoo, ebuild scheduled
> > for merge) >=virtual/perl-ExtUtils-CBuilder-0.27 required by
> >  (perl-core/Module-Build-0.400.300-r1::gentoo, ebuild scheduled for
> >  merge) =virtual/perl-ExtUtils-CBuilder-0.280.210-r1 required by
> >  (perl-core/Module-Build-0.400.300-r1::gentoo, ebuild scheduled for
> >  merge) =virtual/perl-ExtUtils-CBuilder-0.280.210-r1 required by
> >  (perl-core/ExtUtils-ParseXS-3.180.0-r1::gentoo, ebuild scheduled
> > for merge)
> >
> >  (perl-core/ExtUtils-Manifest-1.610.0-r1::gentoo, ebuild scheduled
> > for merge) pulled in by perl-core/ExtUtils-Manifest:0
> >
> >  (perl-core/ExtUtils-MakeMaker-6.640.0-r1::gentoo, ebuild scheduled
> >  for merge) pulled in by perl-core/ExtUtils-MakeMaker:0
> >
> >  (perl-core/IO-1.25-r1::gentoo, ebuild scheduled for merge) pulled
> > in by perl-core/IO:0
> >
> >  (perl-core/ExtUtils-CBuilder-0.280.205-r1::gentoo, ebuild scheduled
> >  for merge) pulled in by perl-core/ExtUtils-CBuilder:0
> >
> >
> >For more information about Blocked Packages, please refer to the
> >following section of the Gentoo Linux x86 Handbook (architecture is
> >irrelevant):
> >
> >http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked
> >
> > * perl-cleaner is stopping here:
> > * Fix the problem and start perl-cleaner again.
> > *
> > * If you encounter blockers involving virtuals and perl-core, here
> > are
> > * some things to try:
> > *   Remove all perl-core packages from your world file
> > *     emerge --deselect --ask $(qlist -IC 'perl-core/*')
> > *   Update all the installed Perl virtuals
> > *     emerge -uD1a $(qlist -IC 'virtual/perl-*')
> > *   Afterwards re-run perl-cleaner
> > *
> > * Note that upgrading Perl with emerge option
> >   --ignore-built-slot-operator-deps=y is not supported.
> >
> >Currently trying the above suggestions but I have no perl in my
> >world.
>
> Run the 2 commands listed at the bottom of that message.
> They start with emerge

Thank you for the help but after running the last 2 command from
above suggestions and then trying
  # emerge --update --deep --with-bdeps=y --newuse --ask world
the colord package still failed to compile with the same error message.

Only after running # emerge --oneshot dev-perl/XML-Parser
# emerge --update --deep --with-bdeps=y --newuse --backtrack=60 --ask world
seemed to properly update the remaining 2 packages:
  x11-misc/colord-1.2.1-r1 [1.2.1] [ebuild   R    ]
  net-im/telepathy-mission-control-5.16.2  USE="upower%*"

After that I have also run # emerge --depclean --ask
that removed about 52 mostly perl-related packages,
then, just in case, I run # perl-cleaner --all
again, that once again rebuilt about 18 perl-related packages.

Then # revdep-rebuild

And only now I feel that everything is done.

Just because  
# emerge --update --deep --with-bdeps=y --newuse --backtrack=60 --ask world
says that it is nothing to update. :)

Reply | Threaded
Open this post in threaded view
|

Re: colord failed to upgrade

J. Roeleveld
On 31 July 2014 17:19:20 CEST, Gevisz <[hidden email]> wrote:

>On Thu, 31 Jul 2014 16:18:35 +0200
>"J. Roeleveld" <[hidden email]> wrote:
>
>> On 31 July 2014 15:58:17 CEST, Gevisz <[hidden email]> wrote:
>> >On Thu, 31 Jul 2014 15:36:38 +0200
>> >Alan McKinnon <[hidden email]> wrote:
>> >
>> >> On 31/07/2014 15:29, Gevisz wrote:
>> >> > In my today's system update I have got the following error
>> >> > message:
>> >> >
>> >> >  * ERROR: x11-misc/colord-1.2.1-r1::gentoo failed (configure
>> >phase):
>> >> >  *   econf failed
>> >>
>> >> The actual error message is earlier than this point[1]. Please go
>> >> through that referenced log, find the error message and report
>> >
>> >Yes, you are right. Earlier in the colord emege log
>> >I have found the following:
>> >
>> >checking for XML::Parser... configure: error: XML::Parser perl
>module
>> >is required for intltool
>> >
>> >And even earlier in the emerge log were the following:
>> >
>> > * Messages for package dev-lang/perl-5.18.2-r1:
>> >
>> > * UPDATE THE PERL MODULES:
>> > * After updating dev-lang/perl you must reinstall
>> > * the installed perl modules.
>> > * Use: perl-cleaner --all
>> >
>> >And after running just now # perl-cleaner --all
>> >I have got the real trouble. The output is below.
>> >Shall I rename the Subject to "perl failed to upgrade"?
>> >
>> ># perl-cleaner --all
>> >
>> > * Beginning a clean up of .ph files
>> > * Excluding files for 5.18.2 and 5.18.2/x86_64-linux from cleaning
>> >
>> > * Locating ph files for removal
>> >
>> > * Updating ph files.
>> > * Ignore all "No such file..." messages!
>> >Can't open machine/ansi.h: No such file or directory
>> >Can't open sys/_types.h: No such file or directory
>> >Can't open gnu/stubs-x32.h: No such file or directory
>> >Can't open gnu/stubs-x32.h: No such file or directory
>> >Can't open gnu/stubs-x32.h: No such file or directory
>> >Can't open gnu/stubs-x32.h: No such file or directory
>> >
>> > * Locating packages for an update
>> > * Locating ebuilds linked against libperl
>> > *   Adding to list: dev-perl/File-DesktopEntry:0
>> > *   Adding to list: dev-perl/XML-NamespaceSupport:0
>> > *   Adding to list: dev-perl/Authen-SASL:0
>> > *   Adding to list: dev-perl/OLE-StorageLite:0
>> > *   Adding to list: dev-perl/Digest-Perl-MD5:0
>> > *   Adding to list: dev-perl/XML-Simple:0
>> > *   Adding to list: dev-perl/Digest-HMAC:0
>> > *   Adding to list: dev-perl/Net-SMTP-SSL:0
>> > *   Adding to list: dev-perl/XML-SAX-Base:0
>> > *   Adding to list: dev-perl/File-MimeInfo:0
>> > *   Adding to list: dev-perl/Unicode-Map:0
>> > *   Adding to list: dev-perl/XML-LibXML:0
>> > *   Adding to list: dev-perl/Locale-gettext:0
>> > *   Adding to list: dev-perl/Crypt-RC4:0
>> > *   Adding to list: dev-perl/File-BaseDir:0
>> > *   Adding to list: dev-perl/XML-Parser:0
>> > *   Adding to list: dev-perl/XML-SAX:0
>> > *   Adding to list: dev-perl/Spreadsheet-ParseExcel:0
>> > *   Adding to list: dev-perl/IO-stringy:0
>> > *   Adding to list: perl-core/IPC-Cmd:0
>> > *                   virtual/perl-IPC-Cmd:0
>> > *   Adding to list: perl-core/Module-CoreList:0
>> > *                   virtual/perl-Module-CoreList:0
>> > *   Adding to list: perl-core/IO:0
>> > *                   virtual/perl-IO:0
>> > *   Adding to list: perl-core/File-Spec:0
>> > *                   virtual/perl-File-Spec:0
>> > *   Adding to list: perl-core/CPAN-Meta:0
>> > *                   virtual/perl-CPAN-Meta:0
>> > *   Adding to list: perl-core/Module-Build:0
>> > *                   virtual/perl-Module-Build:0
>> > *   Adding to list: perl-core/ExtUtils-ParseXS:0
>> > *                   virtual/perl-ExtUtils-ParseXS:0
>> > *   Adding to list: perl-core/version:0
>> > *                   virtual/perl-version:0
>> > *   Adding to list: perl-core/Archive-Tar:0
>> > *                   virtual/perl-Archive-Tar:0
>> > *   Adding to list: perl-core/Module-Load:0
>> > *                   virtual/perl-Module-Load:0
>> > *   Adding to list: perl-core/Test-Harness:0
>> > *                   virtual/perl-Test-Harness:0
>> > *   Adding to list: perl-core/CPAN-Meta-Requirements:0
>> > *                   virtual/perl-CPAN-Meta-Requirements:0
>> > *   Adding to list: perl-core/Compress-Raw-Bzip2:0
>> > *                   virtual/perl-Compress-Raw-Bzip2:0
>> > *   Adding to list: perl-core/IO-Compress:0
>> > *                   virtual/perl-IO-Compress:0
>> > *   Adding to list: perl-core/ExtUtils-MakeMaker:0
>> > *                   virtual/perl-ExtUtils-MakeMaker:0
>> > *   Adding to list: perl-core/Parse-CPAN-Meta:0
>> > *                   virtual/perl-Parse-CPAN-Meta:0
>> > *   Adding to list: perl-core/Digest-MD5:0
>> > *                   virtual/perl-Digest-MD5:0
>> > *   Adding to list: perl-core/ExtUtils-Manifest:0
>> > *                   virtual/perl-ExtUtils-Manifest:0
>> > *   Adding to list: perl-core/Module-Metadata:0
>> > *                   virtual/perl-Module-Metadata:0
>> > *   Adding to list: perl-core/Scalar-List-Utils:0
>> > *                   virtual/perl-Scalar-List-Utils:0
>> > *   Adding to list: perl-core/Compress-Raw-Zlib:0
>> > *                   virtual/perl-Compress-Raw-Zlib:0
>> > *   Adding to list: perl-core/Params-Check:0
>> > *                   virtual/perl-Params-Check:0
>> > *   Adding to list: perl-core/Time-Local:0
>> > *                   virtual/perl-Time-Local:0
>> > *   Adding to list: perl-core/ExtUtils-CBuilder:0
>> > *                   virtual/perl-ExtUtils-CBuilder:0
>> > *   Adding to list: perl-core/Module-Load-Conditional:0
>> > *                   virtual/perl-Module-Load-Conditional:0
>> > *   Adding to list: perl-core/CPAN-Meta-YAML:0
>> > *                   virtual/perl-CPAN-Meta-YAML:0
>> > * emerge -vD1 --backtrack=30 dev-perl/File-DesktopEntry:0
>> >   dev-perl/XML-NamespaceSupport:0 dev-perl/Authen-SASL:0
>> >   dev-perl/OLE-StorageLite:0 dev-perl/Digest-Perl-MD5:0
>> >   dev-perl/XML-Simple:0 dev-perl/Digest-HMAC:0
>> > dev-perl/Net-SMTP-SSL:0 dev-perl/XML-SAX-Base:0
>> > dev-perl/File-MimeInfo:0 dev-perl/Unicode-Map:0
>> > dev-perl/XML-LibXML:0 dev-perl/Locale-gettext:0
>dev-perl/Crypt-RC4:0
>> >   dev-perl/File-BaseDir:0 dev-perl/XML-Parser:0 dev-perl/XML-SAX:0
>> >   dev-perl/Spreadsheet-ParseExcel:0 dev-perl/IO-stringy:0
>> >   perl-core/IPC-Cmd:0 virtual/perl-IPC-Cmd:0
>> >   perl-core/Module-CoreList:0 virtual/perl-Module-CoreList:0
>> >   perl-core/IO:0 virtual/perl-IO:0 perl-core/File-Spec:0
>> >   virtual/perl-File-Spec:0 perl-core/CPAN-Meta:0
>> >   virtual/perl-CPAN-Meta:0 perl-core/Module-Build:0
>> >   virtual/perl-Module-Build:0 perl-core/ExtUtils-ParseXS:0
>> >   virtual/perl-ExtUtils-ParseXS:0 perl-core/version:0
>> >   virtual/perl-version:0 perl-core/Archive-Tar:0
>> >   virtual/perl-Archive-Tar:0 perl-core/Module-Load:0
>> >   virtual/perl-Module-Load:0 perl-core/Test-Harness:0
>> >   virtual/perl-Test-Harness:0 perl-core/CPAN-Meta-Requirements:0
>> >   virtual/perl-CPAN-Meta-Requirements:0
>> > perl-core/Compress-Raw-Bzip2:0 virtual/perl-Compress-Raw-Bzip2:0
>> > perl-core/IO-Compress:0 virtual/perl-IO-Compress:0
>> > perl-core/ExtUtils-MakeMaker:0 virtual/perl-ExtUtils-MakeMaker:0
>> > perl-core/Parse-CPAN-Meta:0 virtual/perl-Parse-CPAN-Meta:0
>> > perl-core/Digest-MD5:0 virtual/perl-Digest-MD5:0
>> > perl-core/ExtUtils-Manifest:0 virtual/perl-ExtUtils-Manifest:0
>> > perl-core/Module-Metadata:0 virtual/perl-Module-Metadata:0
>> > perl-core/Scalar-List-Utils:0 virtual/perl-Scalar-List-Utils:0
>> > perl-core/Compress-Raw-Zlib:0 virtual/perl-Compress-Raw-Zlib:0
>> > perl-core/Params-Check:0 virtual/perl-Params-Check:0
>> > perl-core/Time-Local:0 virtual/perl-Time-Local:0
>> > perl-core/ExtUtils-CBuilder:0 virtual/perl-ExtUtils-CBuilder:0
>> > perl-core/Module-Load-Conditional:0
>> > virtual/perl-Module-Load-Conditional:0 perl-core/CPAN-Meta-YAML:0
>> > virtual/perl-CPAN-Meta-YAML:0
>> >
>> >These are the packages that would be merged, in order:
>> >
>> >Calculating dependencies... done!
>> >[ebuild   R    ] virtual/perl-File-Spec-3.400.0-r2  0 kB
>> >[ebuild     U  ] virtual/perl-version-0.990.200-r1 [0.990.100] 0 kB
>> >[ebuild   R    ] virtual/perl-Scalar-List-Utils-1.270.0-r2  0 kB
>> >[ebuild   R    ] dev-perl/XML-NamespaceSupport-1.110.0  0 kB
>> >[ebuild   R    ] virtual/perl-Module-Build-0.400.300-r1  0 kB
>> >[ebuild   R    ] virtual/perl-Parse-CPAN-Meta-1.440.400-r1  0 kB
>> >[ebuild   R    ] virtual/perl-CPAN-Meta-YAML-0.8.0-r2  0 kB
>> >[ebuild   R    ] virtual/perl-CPAN-Meta-2.120.921-r2  0 kB
>> >[ebuild   R    ] virtual/perl-Module-Metadata-1.0.11-r1  0 kB
>> >[ebuild   R    ] virtual/perl-Params-Check-0.360.0-r1  0 kB
>> >[ebuild     U  ] virtual/perl-ExtUtils-CBuilder-0.280.210-r1
>> >[0.280.205] 0 kB [ebuild   R    ] dev-perl/OLE-StorageLite-0.190.0
>0
>> >kB
>> >[ebuild   R    ] dev-perl/Digest-Perl-MD5-1.800.0  0 kB
>> >[ebuild   R    ] dev-perl/XML-SAX-Base-1.80.0  0 kB
>> >[ebuild   R    ] dev-perl/Unicode-Map-0.112.0  0 kB
>> >[ebuild   R    ] dev-perl/Crypt-RC4-2.020.0  0 kB
>> >[ebuild   R    ] dev-perl/XML-Parser-2.410.0  0 kB
>> >[ebuild   R    ] dev-perl/IO-stringy-2.110.0  0 kB
>> >[ebuild     U  ] virtual/perl-IPC-Cmd-0.800.0-r1 [0.780.0] 0 kB
>> >[ebuild     U  ] virtual/perl-Module-CoreList-3.30.0 [2.840.0] 0 kB
>> >[ebuild     U  ] virtual/perl-IO-1.280.0-r1 [1.25] 0 kB
>> >[ebuild   R    ] virtual/perl-ExtUtils-ParseXS-3.180.0-r2  0 kB
>> >[ebuild   R    ] virtual/perl-Archive-Tar-1.900.0-r2  0 kB
>> >[ebuild   R    ] virtual/perl-Module-Load-0.240.0-r1  0 kB
>> >[ebuild   R    ] virtual/perl-Test-Harness-3.260.0-r2  0 kB
>> >[ebuild   R    ] virtual/perl-CPAN-Meta-Requirements-2.122.0-r2  0
>kB
>> >[ebuild   R    ] virtual/perl-Compress-Raw-Bzip2-2.60.0-r2  0 kB
>> >[ebuild   R    ] virtual/perl-IO-Compress-2.60.0-r1  0 kB
>> >[ebuild     U  ] virtual/perl-ExtUtils-MakeMaker-6.660.0-r1
>> >[6.640.0] 0 kB [ebuild   R    ] virtual/perl-Digest-MD5-2.520.0-r2
>> >0 kB [ebuild     U  ] virtual/perl-ExtUtils-Manifest-1.630.0-r1
>> >[1.610.0] 0 kB [ebuild   R    ]
>> >virtual/perl-Compress-Raw-Zlib-2.60.0-r2  0 kB [ebuild   R    ]
>> >virtual/perl-Module-Load-Conditional-0.540.0-r1  0 kB [ebuild  N
>> >] perl-core/JSON-PP-2.272.0-r1  0 kB [ebuild  N     ]
>> >perl-core/File-Temp-0.220.0-r1  38 kB [ebuild  N     ]
>> >perl-core/Perl-OSType-1.2.0-r1  USE="{-test}" 0 kB [ebuild   R    ]
>> >perl-core/Module-CoreList-2.840.0  0 kB [ebuild   R    ]
>> >perl-core/IO-1.25-r1  0 kB [ebuild   R    ]
>> >perl-core/File-Spec-3.400.0  0 kB [ebuild     U  ]
>> >perl-core/version-0.990.100-r1 [0.990.100] 0 kB [ebuild   R    ]
>> >perl-core/Module-Load-0.240.0  0 kB [ebuild   R    ]
>> >perl-core/Test-Harness-3.260.0  0 kB [ebuild   R    ]
>> >perl-core/Compress-Raw-Bzip2-2.60.0  0 kB [ebuild     U  ]
>> >perl-core/ExtUtils-Manifest-1.610.0-r1 [1.610.0] 0 kB [ebuild   R
>> >] perl-core/Scalar-List-Utils-1.270.0  0 kB [ebuild   R    ]
>> >perl-core/Compress-Raw-Zlib-2.60.0  0 kB [ebuild     U  ]
>> >perl-core/Time-Local-1.230.0-r1 [1.230.0] 0 kB [ebuild   R    ]
>> >virtual/perl-Time-Local-1.230.0-r1  0 kB [ebuild     U  ]
>> >perl-core/CPAN-Meta-YAML-0.8.0-r1 [0.8.0] 0 kB [ebuild   R    ]
>> >dev-perl/File-BaseDir-0.30.0  USE="{-test}" 0 kB [ebuild   R    ]
>> >dev-perl/Spreadsheet-ParseExcel-0.590.0  USE="unicode -cjk {-test}"
>> >0 kB [ebuild     U  ] perl-core/IPC-Cmd-0.780.0-r1 [0.780.0] 0 kB
>> >[ebuild     U  ] perl-core/ExtUtils-ParseXS-3.180.0-r1 [3.180.0] 0
>> >kB [ebuild   R    ] perl-core/Archive-Tar-1.900.0-r1  0 kB
>> >[ebuild     U  ] perl-core/CPAN-Meta-Requirements-2.122.0-r1
>> >[2.122.0] 0 kB [ebuild   R    ] perl-core/IO-Compress-2.60.0  0 kB
>> >[ebuild     U  ] perl-core/Digest-MD5-2.520.0-r1 [2.520.0] 0 kB
>> >[ebuild     U  ] perl-core/Module-Metadata-1.0.11-r1 [1.0.11] 0 kB
>> >[ebuild     U  ] perl-core/Params-Check-0.360.0-r1 [0.360.0] 0 kB
>> >[ebuild   R    ] perl-core/Module-Load-Conditional-0.540.0  0 kB
>> >[ebuild   R    ] dev-perl/File-DesktopEntry-0.40.0  USE="{-test}" 0
>> >kB [ebuild   R    ] dev-perl/Digest-HMAC-1.30.0  0 kB [ebuild     U
>> >] perl-core/CPAN-Meta-2.120.921-r1 [2.120.921] 0 kB [ebuild     U  ]
>> >perl-core/Module-Build-0.400.300-r1 [0.400.300] USE="{-test}" 0 kB
>> >[ebuild     U  ] perl-core/Parse-CPAN-Meta-1.440.400-r1 [1.440.400]
>> >0 kB [ebuild     U ] perl-core/ExtUtils-CBuilder-0.280.205-r1
>> >[0.280.205] 0 kB [ebuild R    ] dev-perl/Authen-SASL-2.160.0
>> >USE="-kerberos" 0 kB [ebuild R    ] dev-perl/Net-SMTP-SSL-1.10.0  0
>> >kB [ebuild     UD ] dev-lang/perl-5.16.3:0/5.16 [5.18.2-r1:0/5.18]
>> >USE="berkdb gdbm -debug -doc -ithreads" 0 kB [ebuild     U  ]
>> >perl-core/ExtUtils-MakeMaker-6.640.0-r1 [6.640.0] 0 kB [ebuild
>> >R    ] dev-perl/XML-SAX-0.990.0  0 kB [ebuild   R    ]
>> >dev-perl/File-MimeInfo-0.170.0  USE="{-test}" 0 kB [ebuild   R    ]
>> >dev-perl/XML-LibXML-2.1.400  USE="{-test}" 0 kB [ebuild   R    ]
>> >dev-perl/Locale-gettext-1.50.0  0 kB [ebuild   R    ]
>> >dev-perl/XML-Simple-2.200.0  0 kB [blocks B      ]
>> ><perl-core/Module-CoreList-3.30.0
>> >("<perl-core/Module-CoreList-3.30.0" is blocking
>> >virtual/perl-Module-CoreList-3.30.0) [blocks B      ]
>> ><perl-core/IPC-Cmd-0.800.0 ("<perl-core/IPC-Cmd-0.800.0" is blocking
>> >virtual/perl-IPC-Cmd-0.800.0-r1) [blocks B      ]
>> ><perl-core/ExtUtils-Manifest-1.630.0
>> >("<perl-core/ExtUtils-Manifest-1.630.0" is blocking
>> >virtual/perl-ExtUtils-Manifest-1.630.0-r1) [blocks B      ]
>> ><perl-core/ExtUtils-MakeMaker-6.660.0
>> >("<perl-core/ExtUtils-MakeMaker-6.660.0" is blocking
>> >virtual/perl-ExtUtils-MakeMaker-6.660.0-r1) [blocks B      ]
>> ><perl-core/IO-1.280.0 ("<perl-core/IO-1.280.0" is blocking
>> >virtual/perl-IO-1.280.0-r1) [blocks B      ]
>> ><perl-core/version-0.990.200 ("<perl-core/version-0.990.200" is
>> >blocking virtual/perl-version-0.990.200-r1) [blocks B      ]
>> ><perl-core/ExtUtils-CBuilder-0.280.210
>> >("<perl-core/ExtUtils-CBuilder-0.280.210" is blocking
>> >virtual/perl-ExtUtils-CBuilder-0.280.210-r1)
>> >
>> >Total: 75 packages (22 upgrades, 1 downgrade, 3 new, 49 reinstalls),
>> >Size of downloads: 38 kB Conflict: 7 blocks (7 unsatisfied)
>> >
>> >!!! Multiple package instances within a single package slot have
>been
>> >pulled !!! into the dependency graph, resulting in a slot conflict:
>> >
>> >dev-lang/perl:0
>> >
>> >  (dev-lang/perl-5.16.3::gentoo, ebuild scheduled for merge) pulled
>> > in by =dev-lang/perl-5.16* required by
>> >  (virtual/perl-ExtUtils-Install-1.580.0-r1::gentoo, installed)
>> >
>> >  (dev-lang/perl-5.18.2-r1::gentoo, installed) pulled in by
>> >    dev-lang/perl:0/5.18=[-build(-)] required by
>> >  (dev-perl/URI-1.600.0-r1::gentoo, installed)
>> >  dev-lang/perl:0/5.18=[-build(-)] required by
>> >  (dev-perl/Net-SSLeay-1.550::gentoo, installed)
>> >  dev-lang/perl:0/5.18=[-build(-)] required by
>> >  (dev-perl/Error-0.170.210::gentoo, installed)
>> >  dev-lang/perl:0/5.18=[-build(-)] required by
>> >  (dev-perl/Text-CSV_XS-0.950.0::gentoo, installed)
>> >  dev-lang/perl:0/5.18=[-build(-)] required by
>> >  (dev-perl/IO-Socket-SSL-1.953.0::gentoo, installed)
>> >  dev-lang/perl:0/5.18=[-build(-)] required by
>> >  (perl-core/Digest-SHA-5.820.0::gentoo, installed)
>> >  dev-lang/perl:0/5.18=[-build(-)] required by
>> >  (dev-perl/Algorithm-Diff-1.190.200-r1::gentoo, installed)
>> >  dev-lang/perl:0/5.18=[-build(-)] required by
>> >  (dev-vcs/git-1.8.5.5::gentoo, installed) =dev-lang/perl-5.18*
>> >  required by (virtual/perl-Digest-MD5-2.520.0-r2::gentoo, ebuild
>> >  scheduled for merge) (and 35 more with the same problems)
>> >
>> >
>> >It may be possible to solve this problem by using package.mask to
>> >prevent one of those packages from being selected. However, it is
>> >also possible that conflicting dependencies exist such that they are
>> >impossible to satisfy simultaneously.  If such a conflict exists in
>> >the dependencies of two different packages, then those packages can
>> >not be installed simultaneously.
>> >
>> >For more information, see MASKED PACKAGES section in the emerge man
>> >page or refer to the Gentoo Handbook.
>> >
>> >
>> > * Error: The above package list contains packages which cannot be
>> > * installed at the same time on the same system.
>> >
>> >  (virtual/perl-ExtUtils-Manifest-1.630.0-r1::gentoo, ebuild
>> > scheduled for merge) pulled in by virtual/perl-ExtUtils-Manifest:0
>> >    >=virtual/perl-ExtUtils-Manifest-1.600.0 required by
>> >  (perl-core/ExtUtils-MakeMaker-6.640.0-r1::gentoo, ebuild scheduled
>> >  for merge) =virtual/perl-ExtUtils-Manifest-1.630.0-r1 required by
>> >  (perl-core/ExtUtils-MakeMaker-6.640.0-r1::gentoo, ebuild scheduled
>> >  for merge)
>> >
>> >  (virtual/perl-IO-1.280.0-r1::gentoo, ebuild scheduled for merge)
>> >  pulled in by virtual/perl-IO:0
>> >    =virtual/perl-IO-1.280.0-r1 required by
>> >  (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for
>> >  merge) virtual/perl-IO required by
>> > (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for
>> > merge)
>> >
>> >  (virtual/perl-Module-CoreList-3.30.0::gentoo, ebuild scheduled for
>> >  merge) pulled in by =virtual/perl-Module-CoreList-3.30.0 required
>> > by (perl-core/Module-Load-Conditional-0.540.0::gentoo, ebuild
>> > scheduled for merge) virtual/perl-Module-CoreList:0
>> >  >=virtual/perl-Module-CoreList-0.22 required by
>> >  (perl-core/Module-Load-Conditional-0.540.0::gentoo, ebuild
>> > scheduled for merge)
>> >
>> >  (perl-core/Module-CoreList-2.840.0::gentoo, ebuild scheduled for
>> >  merge) pulled in by perl-core/Module-CoreList:0
>> >
>> >  (virtual/perl-version-0.990.200-r1::gentoo, ebuild scheduled for
>> >  merge) pulled in by >=virtual/perl-version-0.870 required by
>> >  (perl-core/Module-Metadata-1.0.11-r1::gentoo, ebuild scheduled for
>> >  merge) >=virtual/perl-version-0.77 required by
>> >  (perl-core/CPAN-Meta-Requirements-2.122.0-r1::gentoo, ebuild
>> >  scheduled for merge) =virtual/perl-version-0.990.200-r1 required
>by
>> >  (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for
>> >  merge) >=virtual/perl-version-0.82 required by
>> >  (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for
>> >  merge) =virtual/perl-version-0.990.200-r1 required by
>> >  (perl-core/Module-Load-Conditional-0.540.0::gentoo, ebuild
>> > scheduled for merge) =virtual/perl-version-0.990.200-r1 required by
>> >  (perl-core/Module-Build-0.400.300-r1::gentoo, ebuild scheduled for
>> >  merge) >=virtual/perl-version-0.87 required by
>> >  (perl-core/Module-Build-0.400.300-r1::gentoo, ebuild scheduled for
>> >  merge) virtual/perl-version:0 virtual/perl-version required by
>> >  (perl-core/Module-Load-Conditional-0.540.0::gentoo, ebuild
>> > scheduled for merge) =virtual/perl-version-0.990.200-r1 required by
>> >  (perl-core/CPAN-Meta-Requirements-2.122.0-r1::gentoo, ebuild
>> >  scheduled for merge) =virtual/perl-version-0.990.200-r1 required
>by
>> >  (perl-core/Module-Metadata-1.0.11-r1::gentoo, ebuild scheduled for
>> >  merge)
>> >
>> >  (virtual/perl-ExtUtils-MakeMaker-6.660.0-r1::gentoo, ebuild
>> > scheduled for merge) pulled in by virtual/perl-ExtUtils-MakeMaker:0
>> >    >=virtual/perl-ExtUtils-MakeMaker-6.56 required by
>> >  (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for
>> >  merge) =virtual/perl-ExtUtils-MakeMaker-6.660.0-r1 required by
>> > (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for
>> > merge)
>> >
>> >  (virtual/perl-IPC-Cmd-0.800.0-r1::gentoo, ebuild scheduled for
>> > merge) pulled in by virtual/perl-IPC-Cmd:0
>> >    virtual/perl-IPC-Cmd required by
>> >  (perl-core/ExtUtils-CBuilder-0.280.205-r1::gentoo, ebuild
>scheduled
>> >  for merge) =virtual/perl-IPC-Cmd-0.800.0-r1 required by
>> >  (perl-core/ExtUtils-CBuilder-0.280.205-r1::gentoo, ebuild
>scheduled
>> >  for merge)
>> >
>> >  (perl-core/IPC-Cmd-0.780.0-r1::gentoo, ebuild scheduled for merge)
>> >  pulled in by perl-core/IPC-Cmd:0
>> >
>> >  (perl-core/version-0.990.100-r1::gentoo, ebuild scheduled for
>> > merge) pulled in by perl-core/version:0
>> >
>> >  (virtual/perl-ExtUtils-CBuilder-0.280.210-r1::gentoo, ebuild
>> >  scheduled for merge) pulled in by virtual/perl-ExtUtils-CBuilder:0
>> >    virtual/perl-ExtUtils-CBuilder required by
>> >  (perl-core/ExtUtils-ParseXS-3.180.0-r1::gentoo, ebuild scheduled
>> > for merge) >=virtual/perl-ExtUtils-CBuilder-0.27 required by
>> >  (perl-core/Module-Build-0.400.300-r1::gentoo, ebuild scheduled for
>> >  merge) =virtual/perl-ExtUtils-CBuilder-0.280.210-r1 required by
>> >  (perl-core/Module-Build-0.400.300-r1::gentoo, ebuild scheduled for
>> >  merge) =virtual/perl-ExtUtils-CBuilder-0.280.210-r1 required by
>> >  (perl-core/ExtUtils-ParseXS-3.180.0-r1::gentoo, ebuild scheduled
>> > for merge)
>> >
>> >  (perl-core/ExtUtils-Manifest-1.610.0-r1::gentoo, ebuild scheduled
>> > for merge) pulled in by perl-core/ExtUtils-Manifest:0
>> >
>> >  (perl-core/ExtUtils-MakeMaker-6.640.0-r1::gentoo, ebuild scheduled
>> >  for merge) pulled in by perl-core/ExtUtils-MakeMaker:0
>> >
>> >  (perl-core/IO-1.25-r1::gentoo, ebuild scheduled for merge) pulled
>> > in by perl-core/IO:0
>> >
>> >  (perl-core/ExtUtils-CBuilder-0.280.205-r1::gentoo, ebuild
>scheduled
>> >  for merge) pulled in by perl-core/ExtUtils-CBuilder:0
>> >
>> >
>> >For more information about Blocked Packages, please refer to the
>> >following section of the Gentoo Linux x86 Handbook (architecture is
>> >irrelevant):
>> >
>>
>>http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked
>> >
>> > * perl-cleaner is stopping here:
>> > * Fix the problem and start perl-cleaner again.
>> > *
>> > * If you encounter blockers involving virtuals and perl-core, here
>> > are
>> > * some things to try:
>> > *   Remove all perl-core packages from your world file
>> > *     emerge --deselect --ask $(qlist -IC 'perl-core/*')
>> > *   Update all the installed Perl virtuals
>> > *     emerge -uD1a $(qlist -IC 'virtual/perl-*')
>> > *   Afterwards re-run perl-cleaner
>> > *
>> > * Note that upgrading Perl with emerge option
>> >   --ignore-built-slot-operator-deps=y is not supported.
>> >
>> >Currently trying the above suggestions but I have no perl in my
>> >world.
>>
>> Run the 2 commands listed at the bottom of that message.
>> They start with emerge
>
>Thank you for the help but after running the last 2 command from
>above suggestions and then trying
>  # emerge --update --deep --with-bdeps=y --newuse --ask world
>the colord package still failed to compile with the same error message.
>
>Only after running # emerge --oneshot dev-perl/XML-Parser
># emerge --update --deep --with-bdeps=y --newuse --backtrack=60 --ask
>world
>seemed to properly update the remaining 2 packages:
>  x11-misc/colord-1.2.1-r1 [1.2.1] [ebuild   R    ]
>  net-im/telepathy-mission-control-5.16.2  USE="upower%*"
>
>After that I have also run # emerge --depclean --ask
>that removed about 52 mostly perl-related packages,
>then, just in case, I run # perl-cleaner --all
>again, that once again rebuilt about 18 perl-related packages.
>
>Then # revdep-rebuild
>
>And only now I feel that everything is done.
>
>Just because  
># emerge --update --deep --with-bdeps=y --newuse --backtrack=60 --ask
>world
>says that it is nothing to update. :)

Please reread the message.

Run the 2 commands.
Afterwards, rerun perl cleaner again.

--
Joost
--
Sent from my Android device with K-9 Mail. Please excuse my brevity.

Reply | Threaded
Open this post in threaded view
|

Re: colord failed to upgrade

J. Roeleveld
In reply to this post by gevisz
On 31 July 2014 16:19:21 CEST, Gevisz <[hidden email]> wrote:

>On Thu, 31 Jul 2014 10:03:09 -0400
>Alec Ten Harmsel <[hidden email]> wrote:
>
>> I can't comment on a long-term, real, proper solution, but for right
>> now
>>
>>     emerge --oneshot dev-perl/XML-Parser
>>
>> should at least allow you to continue building colord.
>
>It seems that it helped, but not the suggestions from
>  # perl-cleaner --all
>output.
>
>Thank you.

Did you run the commands and then rerun perlcleaner as the output mentions at the end of the text?

--
Joost
--
Sent from my Android device with K-9 Mail. Please excuse my brevity.

Reply | Threaded
Open this post in threaded view
|

Re: colord failed to upgrade

gevisz
On Thu, 31 Jul 2014 20:17:54 +0200
"J. Roeleveld" <[hidden email]> wrote:

> On 31 July 2014 16:19:21 CEST, Gevisz <[hidden email]> wrote:
> >On Thu, 31 Jul 2014 10:03:09 -0400
> >Alec Ten Harmsel <[hidden email]> wrote:
> >
> >> I can't comment on a long-term, real, proper solution, but for
> >> right now
> >>
> >>     emerge --oneshot dev-perl/XML-Parser
> >>
> >> should at least allow you to continue building colord.
> >
> >It seems that it helped, but not the suggestions from
> >  # perl-cleaner --all
> >output.
> >
> >Thank you.
>
> Did you run the commands and then rerun perlcleaner as the output
> mentions at the end of the text?

No. I did not run perl-cleaner just after those 2 suggested commands
because I had not noted that demand. So, my complaint that the
suggested "long-term" solution does not work may be incorrect.

However, I run perl-cleaner after

# emerge --oneshot dev-perl/XML-Parser
# emerge --update --deep --with-bdeps=y --newuse --backtrack=60 --ask world
# emerge --depclean --ask

So, I hope that the problem was fixed.


Reply | Threaded
Open this post in threaded view
|

Re: colord failed to upgrade

J. Roeleveld

On Friday, August 01, 2014 07:11:59 AM Gevisz wrote:

> On Thu, 31 Jul 2014 20:17:54 +0200

>

> "J. Roeleveld" <[hidden email]> wrote:

> > On 31 July 2014 16:19:21 CEST, Gevisz <[hidden email]> wrote:

> > >On Thu, 31 Jul 2014 10:03:09 -0400

> > >

> > >Alec Ten Harmsel <[hidden email]> wrote:

> > >> I can't comment on a long-term, real, proper solution, but for

> > >> right now

> > >>

> > >> emerge --oneshot dev-perl/XML-Parser

> > >>

> > >> should at least allow you to continue building colord.

> > >

> > >It seems that it helped, but not the suggestions from

> > >

> > > # perl-cleaner --all

> > >

> > >output.

> > >

> > >Thank you.

> >

> > Did you run the commands and then rerun perlcleaner as the output

> > mentions at the end of the text?

>

> No. I did not run perl-cleaner just after those 2 suggested commands

> because I had not noted that demand. So, my complaint that the

> suggested "long-term" solution does not work may be incorrect.

 

The claim is incorrect. I did what it said in the output and it resolved the issue on my systems.

 

> However, I run perl-cleaner after

>

> # emerge --oneshot dev-perl/XML-Parser

> # emerge --update --deep --with-bdeps=y --newuse --backtrack=60 --ask world

> # emerge --depclean --ask

>

> So, I hope that the problem was fixed.

 

It should be resolved now.

I don't add the "--backtrack" part.

It hasn't been needed for me ever since I started using Gentoo sometime in 2004. (Not sure when it got introduced?)

 

--

Joost

Reply | Threaded
Open this post in threaded view
|

Re: colord failed to upgrade

gevisz
On Fri, 01 Aug 2014 10:07:18 +0200
"J. Roeleveld" <[hidden email]> wrote:

> On Friday, August 01, 2014 07:11:59 AM Gevisz wrote:
> > On Thu, 31 Jul 2014 20:17:54 +0200
> >
> > "J. Roeleveld" <[hidden email]> wrote:
> > > On 31 July 2014 16:19:21 CEST, Gevisz <[hidden email]> wrote:
> > > >On Thu, 31 Jul 2014 10:03:09 -0400
> > > >
> > > >Alec Ten Harmsel <[hidden email]> wrote:
> > > >> I can't comment on a long-term, real, proper solution, but for
> > > >> right now
> > > >>
> > > >>     emerge --oneshot dev-perl/XML-Parser
> > > >>
> > > >> should at least allow you to continue building colord.
> > > >
> > > >It seems that it helped, but not the suggestions from
> > > >
> > > >  # perl-cleaner --all
> > > >
> > > >output.
> > > >
> > > >Thank you.
> > >
> > > Did you run the commands and then rerun perlcleaner as the output
> > > mentions at the end of the text?
> >
> > No. I did not run perl-cleaner just after those 2 suggested commands
> > because I had not noted that demand. So, my complaint that the
> > suggested "long-term" solution does not work may be incorrect.
>
> The claim is incorrect. I did what it said in the output and it
> resolved the issue on my systems.
>
> > However, I run perl-cleaner after
> >
> > # emerge --oneshot dev-perl/XML-Parser
> > # emerge --update --deep --with-bdeps=y --newuse --backtrack=60
> > --ask
> world
> > # emerge --depclean --ask
> >
> > So, I hope that the problem was fixed.
>
> It should be resolved now.
> I don't add the "--backtrack" part.
> It hasn't been needed for me ever since I started using Gentoo
> sometime in 2004. (Not sure when it got introduced?)

I am not sure if it was needed this time, but only this option
helped me to fix the problem with my previous system update when
I deviated a bit from my usual system update routine and got a similar
message about blocked packages.
 


Reply | Threaded
Open this post in threaded view
|

Re: colord failed to upgrade

Peter Humphrey-3
In reply to this post by J. Roeleveld
On Thursday 31 July 2014 16:19:41 J. Roeleveld wrote:
> On 31 July 2014 16:03:09 CEST, Alec Ten Harmsel <[hidden email]>
wrote:
> >I can't comment on a long-term, real, proper solution, but for right
> >now
> >
> >    emerge --oneshot dev-perl/XML-Parser
> >
> >should at least allow you to continue building colord.
>
> Please do not top post.

Far worse than top-posting is leaving reams and reams of quoted text in a
reply that have nothing to do with your own contribution. I'm repeatedly
surprised at how many old-timers forget that.

Please snip irrelevancies out.

--
Regards
Peter


Reply | Threaded
Open this post in threaded view
|

Re: colord failed to upgrade

J. Roeleveld

On Friday, August 01, 2014 11:00:11 AM Peter Humphrey wrote:

> On Thursday 31 July 2014 16:19:41 J. Roeleveld wrote:

> > On 31 July 2014 16:03:09 CEST, Alec Ten Harmsel <[hidden email]>

>

> wrote:

> > >I can't comment on a long-term, real, proper solution, but for right

> > >now

> > >

> > > emerge --oneshot dev-perl/XML-Parser

> > >

> > >should at least allow you to continue building colord.

> >

> > Please do not top post.

>

> Far worse than top-posting is leaving reams and reams of quoted text in a

> reply that have nothing to do with your own contribution. I'm repeatedly

> surprised at how many old-timers forget that.

>

> Please snip irrelevancies out.

 

Snipping emails using a mobile phone on a bumpy road doesn't work...

If you know of a decent email client for Android that makes it simpler?

 

--

Joost

Reply | Threaded
Open this post in threaded view
|

Re: colord failed to upgrade

tanstaafl-2
On 8/1/2014 7:53 AM, J. Roeleveld <[hidden email]> wrote:
> Snipping emails using a mobile phone on a bumpy road doesn't work...

So, you're replying to emails while driving?

<bites tongue hard>

<bashes knuckles harder>

Are you insane?

Reply | Threaded
Open this post in threaded view
|

Re: colord failed to upgrade

J. Roeleveld

On Friday, August 01, 2014 08:05:27 AM Tanstaafl wrote:

> On 8/1/2014 7:53 AM, J. Roeleveld <[hidden email]> wrote:

> > Snipping emails using a mobile phone on a bumpy road doesn't work...

>

> So, you're replying to emails while driving?

 

Yes

 

> <bites tongue hard>

>

> <bashes knuckles harder>

>

> Are you insane?

 

Sometimes...

 

But I don't drive myself when using my mobile.

This is on a bus...

Reply | Threaded
Open this post in threaded view
|

Re: colord failed to upgrade

tanstaafl-2
On 8/1/2014 8:42 AM, J. Roeleveld <[hidden email]> wrote:
> But I don't drive myself when using my mobile.
>
> This is on a bus...

Lol... sorry, I never ride a bus so didn't consider that possibility... ;)

Reply | Threaded
Open this post in threaded view
|

Re: colord failed to upgrade

Alan McKinnon-2
In reply to this post by J. Roeleveld
On 01/08/2014 10:07, J. Roeleveld wrote:

> On Friday, August 01, 2014 07:11:59 AM Gevisz wrote:
>
>> On Thu, 31 Jul 2014 20:17:54 +0200
>
>>
>
>> "J. Roeleveld" <[hidden email]> wrote:
>
>> > On 31 July 2014 16:19:21 CEST, Gevisz <[hidden email]> wrote:
>
>> > >On Thu, 31 Jul 2014 10:03:09 -0400
>
>> > >
>
>> > >Alec Ten Harmsel <[hidden email]> wrote:
>
>> > >> I can't comment on a long-term, real, proper solution, but for
>
>> > >> right now
>
>> > >>
>
>> > >> emerge --oneshot dev-perl/XML-Parser
>
>> > >>
>
>> > >> should at least allow you to continue building colord.
>
>> > >
>
>> > >It seems that it helped, but not the suggestions from
>
>> > >
>
>> > > # perl-cleaner --all
>
>> > >
>
>> > >output.
>
>> > >
>
>> > >Thank you.
>
>> >
>
>> > Did you run the commands and then rerun perlcleaner as the output
>
>> > mentions at the end of the text?
>
>>
>
>> No. I did not run perl-cleaner just after those 2 suggested commands
>
>> because I had not noted that demand. So, my complaint that the
>
>> suggested "long-term" solution does not work may be incorrect.
>
>  
>
> The claim is incorrect. I did what it said in the output and it resolved
> the issue on my systems.
>
>  
>
>> However, I run perl-cleaner after
>
>>
>
>> # emerge --oneshot dev-perl/XML-Parser
>
>> # emerge --update --deep --with-bdeps=y --newuse --backtrack=60 --ask
> world
>
>> # emerge --depclean --ask
>
>>
>
>> So, I hope that the problem was fixed.
>
>  
>
> It should be resolved now.
>
> I don't add the "--backtrack" part.
>
> It hasn't been needed for me ever since I started using Gentoo sometime
> in 2004. (Not sure when it got introduced?)



s/(Not sure when it got introduced)/$1 or even what it is for?/g

There ya go, fixed that for ya.

This appears to hold true for every Gentoo'er in the universe except <10
people in the magic $I_GROK_PORTAGE group.

I myself am not in that group.



--
Alan McKinnon
[hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: colord failed to upgrade

Alan McKinnon-2
In reply to this post by J. Roeleveld
On 01/08/2014 13:53, J. Roeleveld wrote:

> On Friday, August 01, 2014 11:00:11 AM Peter Humphrey wrote:
>
>> On Thursday 31 July 2014 16:19:41 J. Roeleveld wrote:
>
>> > On 31 July 2014 16:03:09 CEST, Alec Ten Harmsel
> <[hidden email]>
>
>>
>
>> wrote:
>
>> > >I can't comment on a long-term, real, proper solution, but for right
>
>> > >now
>
>> > >
>
>> > > emerge --oneshot dev-perl/XML-Parser
>
>> > >
>
>> > >should at least allow you to continue building colord.
>
>> >
>
>> > Please do not top post.
>
>>
>
>> Far worse than top-posting is leaving reams and reams of quoted text in a
>
>> reply that have nothing to do with your own contribution. I'm repeatedly
>
>> surprised at how many old-timers forget that.
>
>>
>
>> Please snip irrelevancies out.
>
>  
>
> Snipping emails using a mobile phone on a bumpy road doesn't work...
>
> If you know of a decent email client for Android that makes it simpler?

k9 mail is pretty good, but you still have to deal with the Android
touchscreen interface which makes select-delete hard. This may be the
actual root of the problem.

The other solution is peace, tolerance and understanding on the part of
complainers. We can see your mail client and it's not like you are a
clueless Web2.0 newbie without street cred.

I had to eat humble pie a few years ago and back off and stop being the
biggest ass BOFH in the world when folks used a phone. I recommend
people do this. One's number of friends goes up :-)

--
Alan McKinnon
[hidden email]


12