dev-php/xdebug-2.6.1 will not build

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

dev-php/xdebug-2.6.1 will not build

John Covici
Hi.  I have dev-php/xdebug in my world file, but when I tried to do my
world update I get the following.  Note that I have the following line
in my make.conf
PHP_TARGETS="php5-6 php7-0 php-7-1 php-7-2"

but I get the following output
!!! Problem resolving dependencies for dev-php/xdebug from @selected
... done!

!!! The ebuild selected to satisfy "dev-php/xdebug" has unmet
    requirements.
    - dev-php/xdebug-2.6.1::gentoo USE="" ABI_X86="(64)"
    PHP_TARGETS="(-php7-0) -php7-1 -php7-2"

  The following REQUIRED_USE flag constraints are unsatisfied:
      any-of ( php_targets_php7-0 php_targets_php7-1
      php_targets_php7-2 )

(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

I even tried putting a use flag in package.use, but no joy.

Thanks in advance for any suggestions.

--
Your life is like a penny.  You're going to lose it.  The question is:
How do
you spend it?

         John Covici wb2una
         [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: dev-php/xdebug-2.6.1 will not build

Andrew Udvare


> On Jan 29, 2019, at 06:26, John Covici <[hidden email]> wrote:
>
> Hi.  I have dev-php/xdebug in my world file, but when I tried to do my
> world update I get the following.  Note that I have the following line
> in my make.conf
> PHP_TARGETS="php5-6 php7-0 php-7-1 php-7-2"

The last two are not written correctly. Remove the extra dash: php7-1 php7-2

Reply | Threaded
Open this post in threaded view
|

Re: dev-php/xdebug-2.6.1 will not build

John Covici
On Tue, 29 Jan 2019 08:01:30 -0500,
Andrew Udvare wrote:

>
>
>
> > On Jan 29, 2019, at 06:26, John Covici <[hidden email]> wrote:
> >
> > Hi.  I have dev-php/xdebug in my world file, but when I tried to do my
> > world update I get the following.  Note that I have the following line
> > in my make.conf
> > PHP_TARGETS="php5-6 php7-0 php-7-1 php-7-2"
>
> The last two are not written correctly. Remove the extra dash: php7-1 php7-2
>

OK, thanks, but it still should have worked with the php7.0.  Yes?


--
Your life is like a penny.  You're going to lose it.  The question is:
How do
you spend it?

         John Covici wb2una
         [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: dev-php/xdebug-2.6.1 will not build

John Covici
In reply to this post by Andrew Udvare
On Tue, 29 Jan 2019 08:01:30 -0500,
Andrew Udvare wrote:

>
>
>
> > On Jan 29, 2019, at 06:26, John Covici <[hidden email]> wrote:
> >
> > Hi.  I have dev-php/xdebug in my world file, but when I tried to do my
> > world update I get the following.  Note that I have the following line
> > in my make.conf
> > PHP_TARGETS="php5-6 php7-0 php-7-1 php-7-2"
>
> The last two are not written correctly. Remove the extra dash: php7-1 php7-2
>

Well, that seems to have fixed it, I have other problems, but maybe
they are normal such as perl 5.28 -- I wonder if its ready for prime
time yet?

--
Your life is like a penny.  You're going to lose it.  The question is:
How do
you spend it?

         John Covici wb2una
         [hidden email]