difficulties with glibc and GCC

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

difficulties with glibc and GCC

jeff sacksteder
I'm currently using:

glibc-2.3.2-r1
gcc-3.2.3-r2
linux 2.4

I'm not able to compile a newer glibc with this setup, but newer versions of gcc require it. I would prefer not to take this server down for several days to reinstall. First I attempted to prepare a new chroot-ed enviroment so I could just cut over once it was ready, but 2.4/2.6 incompatabilities prevent me from doing that effectively. Secondly, I thought of getting a newer glibc out of GRP to bootstrap into a new enviroment rather than building it myself. There does not appear to be a GRP for Alpha. It seems I am stuck.

Can anyone suggest an alternative to re-installation?
Reply | Threaded
Open this post in threaded view
|

Re: difficulties with glibc and GCC

davide cittaro
Which error do you have? I've recently emerge/update system to default-linux/alpha/no-nptl/2.4, gcc-3.4.6, glibc-2.3.5-r3, 2.4.30 alpha and, as far as I remember, it was painless...
 
d
 
On 8/18/06, jeff sacksteder <[hidden email]> wrote:
I'm currently using:

glibc-2.3.2-r1
gcc-3.2.3-r2
linux 2.4

I'm not able to compile a newer glibc with this setup, but newer versions of gcc require it. I would prefer not to take this server down for several days to reinstall. First I attempted to prepare a new chroot-ed enviroment so I could just cut over once it was ready, but 2.4/2.6 incompatabilities prevent me from doing that effectively. Secondly, I thought of getting a newer glibc out of GRP to bootstrap into a new enviroment rather than building it myself. There does not appear to be a GRP for Alpha. It seems I am stuck.

Can anyone suggest an alternative to re-installation?