emerge --oneshot gcc-4.1.2

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

emerge --oneshot gcc-4.1.2

sand1234
Hi all
I have to emerge gcc-4.1.2 to use with CUDA. However, I receive the
following message.

!!! 'gcc-4.1.2' is not a valid package atom.
!!! Please check ebuild(5) for full details.

What should I do to avoid of this problem?

Thanks a lot
Hung

Reply | Threaded
Open this post in threaded view
|

Re: emerge --oneshot gcc-4.1.2

Nikos Chantziaras
Hung Dang wrote:
> Hi all
> I have to emerge gcc-4.1.2 to use with CUDA. However, I receive the
> following message.
>
> !!! 'gcc-4.1.2' is not a valid package atom.
> !!! Please check ebuild(5) for full details.
>
> What should I do to avoid of this problem?

Try:

   emerge --oneshot =gcc-4.1.2

(that is, you need an "=" in front.)

Or simply just:

   emerge --oneshot gcc

if you're not using an ~arch ("testing") GCC.


Reply | Threaded
Open this post in threaded view
|

Re: emerge --oneshot gcc-4.1.2

Ivan Kazbanov
In reply to this post by sand1234
On Sat, 02 May 2009 11:27:11 -0600
Hung Dang <[hidden email]> wrote:

> Hi all
> I have to emerge gcc-4.1.2 to use with CUDA. However, I receive the
> following message.
>
> !!! 'gcc-4.1.2' is not a valid package atom.
> !!! Please check ebuild(5) for full details.
>
> What should I do to avoid of this problem?
>
> Thanks a lot
> Hung
>

Try to use the following command
emerge  =gcc-4.1.2

Reply | Threaded
Open this post in threaded view
|

Re: emerge --oneshot gcc-4.1.2

Xavier Parizet-2
In reply to this post by sand1234
Hung Dang a écrit :
> Hi all
> I have to emerge gcc-4.1.2 to use with CUDA. However, I receive the
> following message.
>
> !!! 'gcc-4.1.2' is not a valid package atom.
> !!! Please check ebuild(5) for full details.
>
> What should I do to avoid of this problem?

emerge --oneshot =sys-devel/gcc-4.1.2
Check man 5 ebuild to have more information about package atom syntax :)

HTH

> Thanks a lot
> Hung
>


--
      Xavier Parizet
YaGB :   http://gentooist.com
GPG  :    DC81 6FEE 6EBE FCE4
1C18 202F E575 4A5D 036D 1408



signature.asc (269 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: emerge --oneshot gcc-4.1.2

sand1234
Thanks all of you for the quick help. Thing seem to be OK now

Have a nice weekend
Hung

Xavier Parizet wrote:

> Hung Dang a écrit :
>  
>> Hi all
>> I have to emerge gcc-4.1.2 to use with CUDA. However, I receive the
>> following message.
>>
>> !!! 'gcc-4.1.2' is not a valid package atom.
>> !!! Please check ebuild(5) for full details.
>>
>> What should I do to avoid of this problem?
>>    
>
> emerge --oneshot =sys-devel/gcc-4.1.2
> Check man 5 ebuild to have more information about package atom syntax :)
>
> HTH
>
>  
>> Thanks a lot
>> Hung
>>
>>    
>
>
>  


Reply | Threaded
Open this post in threaded view
|

Re: Re: emerge --oneshot gcc-4.1.2

Jorge Morais-3
In reply to this post by Nikos Chantziaras
On Sat, 02 May 2009 20:34:02 +0300
Nikos Chantziaras <[hidden email]> wrote:

> Hung Dang wrote:
> > Hi all
> > I have to emerge gcc-4.1.2 to use with CUDA. However, I receive the
> > following message.
> >
> > !!! 'gcc-4.1.2' is not a valid package atom.
> > !!! Please check ebuild(5) for full details.
> >
> > What should I do to avoid of this problem?
>
> Try:
>
>    emerge --oneshot =gcc-4.1.2
>
> (that is, you need an "=" in front.)
>
> Or simply just:
>
>    emerge --oneshot gcc
>
> if you're not using an ~arch ("testing") GCC.
>
In many architectures GCC 4.3 is the newest stable versions, dude.

Reply | Threaded
Open this post in threaded view
|

Re: Re: emerge --oneshot gcc-4.1.2

sand1234
I need gcc-4.1.2 because CUDA examples are failed when compiled with
gcc-4.3.3 or at least I could not make it work with CUDA.
Now I have the new problem that I could not compile gcc-4.1.2 with
gcc-4.3.3 and it seem hard to solve this problem.

Does anyone here in our forum could make CUDA work on Gentoo with gcc-4.3?

Thanks a lot
Hung


Jorge Morais wrote:

> On Sat, 02 May 2009 20:34:02 +0300
> Nikos Chantziaras <[hidden email]> wrote:
>
>  
>> Hung Dang wrote:
>>    
>>> Hi all
>>> I have to emerge gcc-4.1.2 to use with CUDA. However, I receive the
>>> following message.
>>>
>>> !!! 'gcc-4.1.2' is not a valid package atom.
>>> !!! Please check ebuild(5) for full details.
>>>
>>> What should I do to avoid of this problem?
>>>      
>> Try:
>>
>>    emerge --oneshot =gcc-4.1.2
>>
>> (that is, you need an "=" in front.)
>>
>> Or simply just:
>>
>>    emerge --oneshot gcc
>>
>> if you're not using an ~arch ("testing") GCC.
>>
>>    
> In many architectures GCC 4.3 is the newest stable versions, dude.
>
>