genkernel-next instead of genkernel?

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

genkernel-next instead of genkernel?

Kuzminsky, Sebastian

Hello catalysts, I need to build a systemd-based stage4 with a kernel.


I think this means I need to provide a binary kernel package "out of band" as suggested in the catalyst HOWTO, or switch catalyst to use genkernel-next.


I prefer to teach catalyst to use genkernel-next, because it simplifies my build system to have catalyst do everything.  Iit was pretty easy to get this going.  I'm attaching my tiny patches (against the 2.X branch) as a starting place.  These patches switch catalyst entirely away from genkernel and to genkernel-next, which does what I need but is a little heavy handed...


If this looks like a useful approach i'll be happy to try to integrate these changes more cleanly, perhaps by letting the user select (in the catalyst-spec) between genkernel and -next.


Feedback is welcome.



-- 
Sebastian Kuzminsky

0002-accept-any-version-of-genkernel.patch (1K) Download Attachment
0001-emerge-genkernel-next-instead-of-genkernel.patch (888 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: genkernel-next instead of genkernel?

Mike Frysinger
the chances of catalyst switching to genkernel-next is pretty low
to non-existent.  they forked an old version of genkernel and dropped
support for things like cross-compiling.
-mike

signature.asc (836 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: genkernel-next instead of genkernel?

Leno Hou
On Sat, Dec 17, 2016 at 3:30 AM, Mike Frysinger <[hidden email]> wrote:
the chances of catalyst switching to genkernel-next is pretty low
to non-existent.  they forked an old version of genkernel and dropped
support for things like cross-compiling.

It's not forced to use genkernel-next to build systems-based stage4. 
Actually, I have successfully built gentoo@ppc64le with systemd by genkernel.

-Leno Hou

Reply | Threaded
Open this post in threaded view
|

Re: genkernel-next instead of genkernel?

Marshall McMullen
​I was under the impression that gentoo-next was required in order to use systemd. I thought I was unable to emerge genkernel at all while systemd was installed. Has that problem been fixed?​

On Fri, Dec 16, 2016 at 1:13 PM, Leno Hou <[hidden email]> wrote:
On Sat, Dec 17, 2016 at 3:30 AM, Mike Frysinger <[hidden email]> wrote:
the chances of catalyst switching to genkernel-next is pretty low
to non-existent.  they forked an old version of genkernel and dropped
support for things like cross-compiling.

It's not forced to use genkernel-next to build systems-based stage4. 
Actually, I have successfully built gentoo@ppc64le with systemd by genkernel.

-Leno Hou