блокирование gpgme

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

блокирование gpgme

Alex Efros-4
Hi!

Здесь что-то уже полтора года тихо, непорядок, надо хоть что-то написать.
:)

Я, вероятно, не знаю чего-то тривиального, но я перестал понимать
сообщения о блокировании пакетов. Раньше по ним было вполне очевидно, что
нужно предпринять. А сейчас то ли со мной что-то не так, то ли с этими
сообщениями.

Итак, сижу, никого не трогаю, починяю примус… э… обновляю world:


home ~ # emerge -uDNpv world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] app-crypt/gpgme-1.8.0-r2:1/11::gentoo [1.5.5:1/11::gentoo] USE="cxx%* -common-lisp -python% -qt5% -static-libs" PYTHON_TARGETS="python2_7%* python3_4%* (-python3_5)" 1268 KiB
[blocks B      ] kde-apps/gpgmepp ("kde-apps/gpgmepp" is blocking app-crypt/gpgme-1.8.0-r2)
[blocks B      ] kde-apps/kdepimlibs:4 ("kde-apps/kdepimlibs:4" is blocking app-crypt/gpgme-1.8.0-r2)

Total: 1 package (1 upgrade), Size of downloads: 1268 KiB
Conflict: 2 blocks (2 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (app-crypt/gpgme-1.8.0-r2:1/11::gentoo, ebuild scheduled for merge) pulled in by
    >=app-crypt/gpgme-0.9.0:= required by (mail-client/mutt-1.8.0:0/0::gentoo, installed)
    >=app-crypt/gpgme-0.9.0:1/11= required by (mail-client/mutt-1.8.0:0/0::gentoo, installed)
    app-crypt/gpgme required by (kde-frameworks/kwallet-5.29.0:5/5.29::gentoo, installed)
    app-crypt/gpgme required by (kde-apps/kwalletd-16.04.3:4/16.04::gentoo, installed)
    app-crypt/gpgme:= required by (kde-apps/gpgmepp-16.08.3:5/5::gentoo, installed)
    >=app-crypt/gpgme-1.1.6 required by (kde-apps/kdepimlibs-4.14.11_pre20160211-r2:4/4.14::gentoo, installed)
    app-crypt/gpgme:1/11= required by (kde-apps/gpgmepp-16.08.3:5/5::gentoo, installed)

  (kde-apps/gpgmepp-16.08.3:5/5::gentoo, installed) pulled in by
    >=kde-apps/gpgmepp-14.12.0:5 required by (kde-frameworks/kwallet-5.29.0:5/5.29::gentoo, installed)

  (kde-apps/kdepimlibs-4.14.11_pre20160211-r2:4/4.14::gentoo, installed) pulled in by
    >=kde-apps/kdepimlibs-4.14.3:4[aqua=] (>=kde-apps/kdepimlibs-4.14.3:4[-aqua]) required by (kde-apps/kwalletd-16.04.3:4/16.04::gentoo, installed)


У меня ушло некоторое время на то, чтобы предположить, что зависимость без
указания двоеточия ">=app-crypt/gpgme-1.1.6" означает не "любой слот", а
"слот 0", и раз слот у gpgme 1/11 то он не подходит. Дальше пришлось
ручками пройтись по цепочке зависимостей, и половина проблемы решилась так:

    echo "kde-apps/kdebase-runtime-meta -oldwallet" >> /etc/portage/package.use
    emerge -1av kde-apps/kdebase-runtime-meta && emerge -a --depclean

в результате чего были удалены:

    dev-libs/cyrus-sasl-2.1.26-r9
    dev-libs/libical-1.0.1
    kde-apps/akonadi-1.13.1_pre20160203-r1
    kde-apps/kdepimlibs-4.14.11_pre20160211-r2
    kde-apps/kwalletd-16.04.3
    kde-plasma/kwallet-pam-5.8.5

Но вторая половина проблемы никуда не делась:


home ~ # emerge -uDNpv world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] app-crypt/gpgme-1.8.0-r2:1/11::gentoo [1.5.5:1/11::gentoo] USE="cxx%* -common-lisp -python% -qt5% -static-libs" PYTHON_TARGETS="python2_7%* python3_4%* (-python3_5)" 1268 KiB
[blocks B      ] kde-apps/gpgmepp ("kde-apps/gpgmepp" is blocking app-crypt/gpgme-1.8.0-r2)

Total: 1 package (1 upgrade), Size of downloads: 1268 KiB
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-apps/gpgmepp-16.08.3:5/5::gentoo, installed) pulled in by
    >=kde-apps/gpgmepp-14.12.0:5 required by (kde-frameworks/kwallet-5.29.0:5/5.29::gentoo, installed)

  (app-crypt/gpgme-1.8.0-r2:1/11::gentoo, ebuild scheduled for merge) pulled in by
    >=app-crypt/gpgme-0.9.0:1/11= required by (mail-client/mutt-1.8.0:0/0::gentoo, installed)
    >=app-crypt/gpgme-0.9.0:= required by (mail-client/mutt-1.8.0:0/0::gentoo, installed)
    app-crypt/gpgme required by (kde-frameworks/kwallet-5.29.0:5/5.29::gentoo, installed)
    app-crypt/gpgme:1/11= required by (kde-apps/gpgmepp-16.08.3:5/5::gentoo, installed)
    app-crypt/gpgme:= required by (kde-apps/gpgmepp-16.08.3:5/5::gentoo, installed)


Не то, чтобы я пользовался KDE, но несколько приложений стоит, а глядя на
цепочку зависимостей kwallet не похоже, чтобы его можно было снести. Но у
него тоже обнаружился интересный USE-флаг, что и позволило окончательно
решить проблему:

    echo "kde-frameworks/kwallet -gpg" >> /etc/portage/package.use
    emerge -1av kde-frameworks/kwallet && emerge -a --depclean

в результате чего был удалён:

    kde-apps/gpgmepp-16.08.3

И вот, ура!


home ~ # emerge -uDNav world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] app-crypt/gpgme-1.8.0-r2:1/11::gentoo [1.5.5:1/11::gentoo] USE="cxx%* -common-lisp -python% -qt5% -static-libs" PYTHON_TARGETS="python2_7%* python3_4%* (-python3_5)" 1268 KiB

Total: 1 package (1 upgrade), Size of downloads: 1268 KiB

Would you like to merge these packages? [Yes/No]


В связи со всем этим у меня два вопроса:
- предыдущая версия app-crypt/gpgme тоже была из слота 1/11, но никаких
  проблем это не вызывало - как так?
- как предполагается по выводу информации о блокировании догадываться,
  какие USE-флаги у каких пакетов (в т.ч. не упомянутых в выводе блокеров)
  нужно переключить для решения проблемы?

--
  WBR, Alex.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [gentoo-user-ru] блокирование gpgme

Sergey Popov
04.03.2017 11:10, Alex Efros пишет:
> У меня ушло некоторое время на то, чтобы предположить, что зависимость без
> указания двоеточия ">=app-crypt/gpgme-1.1.6" означает не "любой слот", а
> "слот 0", и раз слот у gpgme 1/11 то он не подходит. Дальше пришлось
> ручками пройтись по цепочке зависимостей, и половина проблемы решилась так:

Не совсем так, но для новых EAPI - именно так и есть. Чтобы тянуть любой
слот нужно явно указывать :*

> Не то, чтобы я пользовался KDE, но несколько приложений стоит, а глядя на
> цепочку зависимостей kwallet не похоже, чтобы его можно было снести. Но у
> него тоже обнаружился интересный USE-флаг, что и позволило окончательно
> решить проблему:
>
>     echo "kde-frameworks/kwallet -gpg" >> /etc/portage/package.use
>     emerge -1av kde-frameworks/kwallet && emerge -a --depclean
>
> в результате чего был удалён:
>
>     kde-apps/gpgmepp-16.08.3
>
> И вот, ура!
>
>
> В связи со всем этим у меня два вопроса:
> - предыдущая версия app-crypt/gpgme тоже была из слота 1/11, но никаких
>   проблем это не вызывало - как так?
Не распарсил...

> - как предполагается по выводу информации о блокировании догадываться,
>   какие USE-флаги у каких пакетов (в т.ч. не упомянутых в выводе блокеров)
>   нужно переключить для решения проблемы?
>

Только смотря в ебилды, в данном случае не сам флаг вызывает конфликт, а
зависимости потянутые через этот флаг(а то и зависимости, зависимостей).
Резолвер "треснул" и не смог предложить какой именно флаг надо отключить
-> получили блокировку, которую надо решать только руками.

--
Best regards, Sergey Popov
Gentoo developer
Gentoo Desktop Effects project lead
Gentoo Quality Assurance project lead


signature.asc (465 bytes) Download Attachment
Loading...