locale

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

locale

Jens Wefer
hey,
hier lief laengere zeit gentoo fehlerfrei und zuverlaessig, bis es
nicht mehr wollte;-)
http://www.gentooforum.de/artikel/22027/kernel-panic-not-symcing-attempted-to-kill-the-idle-task.html?s=ddd1773c00829e1f08ad9b5fa7b8eb97b3b9475a

egal problem hat sich nach einigen monaten erledigt.
ich kann mich aber nicht erinnern das ich je probleme mit der
lokalisierung gehabt habe.

wenn ich jetzt in 02locale ein utf8 oder einen deutschen zeichensatz
setze kommen z.b. systemmeldungen fehlerhaft.
z.b. mkdir: cannot create '/fff/fff': ...
die haeckchenkommen als nichtdruckbare zeichen.
wenn ich LC_TYPE="C" setze kommen auch die haeckchen richtig, sieht auf
deutsch nur sehr komisch aus.
dann noch conolefont's probiert z.b. lat9w-16 da gabs dann wenigstens
ein € zeichen. wenn ich umlaute eingebe und rueckwaerts loesche werden
auch mehr zeichen geloescht.
umlaute benutz ich eh kaum, hab ich mirt schon abgewoehnt als ich meine
programme auf lochkarte gestanzt hab, damals gabs allerdings auch nur
grossschreibung. ^ ^ , aber das € zeichen wuerd ich doch gern haben.

hab auch schon use flag unicode probiert.

kann mir jmd tip geben wo ich schaun muss?

bye.

Reply | Threaded
Open this post in threaded view
|

Re: locale

Johann Schmitz (ercpe)
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Hi,

wenn schon, dann richtig:

- - locales in /etc/locale.gen einstellen. Bspw.

de_DE.UTF-8 UTF-8
en_GB.UTF-8 UTF-8

- - locale-gen aufrufen

- - eselect locale list
- - eselect locale set <locale>

Das legt dir dein 02locale korrekt an.

Wie du schon erkannt hast, muss dein Font (und auch dein Terminal)
auch die Unicode-Zeichen darstellen können.

Um sicherzustellen, das Unicode funktioniert:

wget https://www.cl.cam.ac.uk/~mgk25/ucs/examples/UTF-8-demo.txt
cat UTF-8-demo.txt

Nicht alle Fonts können alles in der Datei darstellen, allerdings
sollte der Großteil korrekt gerendert werden. Wenn nicht, zurück auf
Anfang.

Wenn es bis hier funktioniert, du allerdings bei der Eingabe Probleme
hast, dann schau dir deine Keymaps an.

Um Dateinamen korrekt in UTF-8 zu haben, muss im Kernel Native
Language Support aktiviert und korrekt gesetzt sein.

Johann

On 02.12.2015 01:35, jens wefer wrote:
> hey, hier lief laengere zeit gentoo fehlerfrei und zuverlaessig,
> bis es nicht mehr wollte;-)
> http://www.gentooforum.de/artikel/22027/kernel-panic-not-symcing-attem
pted-to-kill-the-idle-task.html?s=ddd1773c00829e1f08ad9b5fa7b8eb97b3b947
5a

>
>  egal problem hat sich nach einigen monaten erledigt. ich kann mich
> aber nicht erinnern das ich je probleme mit der lokalisierung
> gehabt habe.
>
> wenn ich jetzt in 02locale ein utf8 oder einen deutschen
> zeichensatz setze kommen z.b. systemmeldungen fehlerhaft. z.b.
> mkdir: cannot create '/fff/fff': ... die haeckchenkommen als
> nichtdruckbare zeichen. wenn ich LC_TYPE="C" setze kommen auch die
> haeckchen richtig, sieht auf deutsch nur sehr komisch aus. dann
> noch conolefont's probiert z.b. lat9w-16 da gabs dann wenigstens
> ein € zeichen. wenn ich umlaute eingebe und rueckwaerts loesche
> werden auch mehr zeichen geloescht. umlaute benutz ich eh kaum, hab
> ich mirt schon abgewoehnt als ich meine programme auf lochkarte
> gestanzt hab, damals gabs allerdings auch nur grossschreibung. ^ ^
> , aber das € zeichen wuerd ich doch gern haben.
>
> hab auch schon use flag unicode probiert.
>
> kann mir jmd tip geben wo ich schaun muss?
>
> bye.
>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iQEcBAEBCAAGBQJWXnmdAAoJEKCEBkJ3xQHt9JsH/2lz5aKktHg+LIlmznrjMpmR
1OJoJ+WV44UNFC6VNvOmxpTOhasHtsU+SI/pNmTIbV40rnNAhRw0oCK9sYn0rSoY
KQM4S8IfNaBmswEzPICsl9MF6oHkHaert4Btu9mUBsCv2iRq8Btg6RFQmkkWC9QF
1KdhfTp2AoT7ZhScRWkL8I6p/kYdJ18DOWmeseVMIAaSVnwfwj6GudFy0u9f5eYg
QPajeuEGNI4rDASf4fHz+QDCb7Yqf/cATyHKTwkfYLfsrgPeTTj6coaI8gJuJ7P9
dukg5j4GM8EL4/IcdcP1GX7gS0tnOYiLI/v27xkQb/9IUW5jhXNdTN5h2XXUr7Y=
=H2U6
-----END PGP SIGNATURE-----

Reply | Threaded
Open this post in threaded view
|

Re: locale

Jens Wefer
sorry fuer mein geschwaffel, jetzt mal kurz und knapp: natuerlich hab
ich 02locale nicht selbst editiert, sondern nach handbuch locale.gen,
locale-gen aufgerufen eselect, env-update && source /etc/profile.
localization guide gelesen, stunden mit fehlersuche und
internetrecherche verbracht.

bin doch kein anfaenger, wenn ich mich grad auch so fuehle, kann
hoechstens sein das ich langsam zu alt werde.;-)

bye, jens.

On Wed, 2 Dec 2015 05:54:54 +0100
"Johann Schmitz (ercpe)" <[hidden email]> wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA256
>
> Hi,
>
> wenn schon, dann richtig:
>
> - - locales in /etc/locale.gen einstellen. Bspw.
>
> de_DE.UTF-8 UTF-8
> en_GB.UTF-8 UTF-8
>
> - - locale-gen aufrufen
>
> - - eselect locale list
> - - eselect locale set <locale>
>
> Das legt dir dein 02locale korrekt an.
>
> Wie du schon erkannt hast, muss dein Font (und auch dein Terminal)
> auch die Unicode-Zeichen darstellen können.
>
> Um sicherzustellen, das Unicode funktioniert:
>
> wget https://www.cl.cam.ac.uk/~mgk25/ucs/examples/UTF-8-demo.txt
> cat UTF-8-demo.txt
>
> Nicht alle Fonts können alles in der Datei darstellen, allerdings
> sollte der Großteil korrekt gerendert werden. Wenn nicht, zurück auf
> Anfang.
>
> Wenn es bis hier funktioniert, du allerdings bei der Eingabe Probleme
> hast, dann schau dir deine Keymaps an.
>
> Um Dateinamen korrekt in UTF-8 zu haben, muss im Kernel Native
> Language Support aktiviert und korrekt gesetzt sein.
>
> Johann
>

Reply | Threaded
Open this post in threaded view
|

Re: locale

Jens Wefer
ist anscheinend nen gentoo future, zumindest scheint es niemand zu
stoeren sonst waer ich bei der suche in foren etc darauf gestossen.
wenn LC_CTYPE auf C oder POSIX werden die internationalisierten
meldungen richtig dargestellt, hat aber unerwünschte nebeneffekt z.b.
beim editiren der kommandozeile wenn umlaute verwendet werden.
ich nehme jetzt de_DE.utf8, consolefont lat0-16(wg. ncurses).
macht die wenigsten probleme, erscheinen abundzu bei sonderzeichen nur
Fragezeichen auf dem Bildschirm.

bei der aktuellsten systemrecue-cd hat man auch gleich fehlerhafte
meldungen, die basiert ja auf gentoo, verwendet als locale en_US.utf8

das aktuelle gentoo installimage verwendet posix, da ist alles ok, bis
man auf de_DE.utf8 umstellt.

fuers erste ok, wenn ich mal langeweile hab....
bye.