lots of problems in world update including new perl -- need some help

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

lots of problems in world update including new perl -- need some help

John Covici
Hi.  I am having lots of problems doing my world update -- usually it
works fine, but todays is having problems.

One of the problems is a new major version of perl.  In the past it
would emerge and then I had to use perl-cleaner to fix, but not this
time.

Also openssl is giving me problems.  I tried to mask off the new
version, but no joy there.

Here is the relevant ouput -- I can send you the whole thing if that
would help.


Thanks in advance for any suggestions.

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.28.0:0/5.28::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.28* required by (virtual/perl-CPAN-Meta-2.150.10-r1:0/0::gentoo, installed)
    ^              ^^^^^                                                                        
    (and 47 more with the same problem)

  (dev-lang/perl-5.26.2:0/5.26::gentoo, installed) pulled in by
    dev-lang/perl:0/5.26= required by (dev-perl/Net-DBus-1.1.0:0/0::gentoo, installed)
                 ^^^^^^^^                                                              
    (and 180 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-libs/openssl-1.0.2q-r200:1.0.0/1.0.0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/openssl-0.9.8:* required by (net-vpn/openvpn-2.4.6:0/0::gentoo, installed)
    dev-libs/openssl:= required by (net-irc/irssi-1.1.2:0/0::gentoo, ebuild scheduled for merge)
    dev-libs/openssl required by @selected

  (dev-libs/openssl-1.0.2q:0/0::gentoo, installed) pulled in by
    >=dev-libs/openssl-1.0.1:0[bindist=] (>=dev-libs/openssl-1.0.1:0[-bindist]) required by (net-misc/openssh-7.9_p1-r2:0/0::gentoo, ebuild scheduled for merge)
    <dev-libs/openssl-1.1:0/0= required by (dev-lang/ruby-2.3.8-r1:2.3/2.3::gentoo, installed)
    dev-libs/openssl:0= required by (media-sound/pulseaudio-12.2:0/0::gentoo, installed)
    dev-libs/openssl:0= required by (mail-filter/spamassassin-3.4.2-r3:0/0::gentoo, installed)
    dev-libs/openssl:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (dev-libs/openssl:0=[abi_x86_64(-)]) required by (app-arch/libarchive-3.3.3:0/13::gentoo, installed)
    dev-libs/openssl:0= required by (dev-perl/Crypt-OpenSSL-Random-0.110.0:0/0::gentoo, installed)
    dev-libs/openssl:0= required by (net-libs/c-client-2007f-r6:0/0::gentoo, installed)
    dev-libs/openssl:0 required by (net-vpn/ipsec-tools-0.8.2-r5:0/0::gentoo, installed)
    dev-libs/openssl:0/0= required by (dev-perl/Crypt-OpenSSL-Bignum-0.90.0:0/0::gentoo, installed)
    dev-libs/openssl:0= required by (dev-perl/Crypt-OpenSSL-RSA-0.280.0-r3:0/0::gentoo, installed)
    dev-libs/openssl:0/0=[-bindist] required by (dev-qt/qtnetwork-5.11.3:5/5.11::gentoo, installed)
    dev-libs/openssl:0= required by (media-libs/libshout-2.4.1-r2:0/0::gentoo, installed)
    >=dev-libs/openssl-1.0.0:0= required by (dev-db/mysql-5.7.25:0/18::gentoo, ebuild scheduled for merge)
    dev-libs/openssl:0= required by (net-analyzer/nmap-7.70:0/0::gentoo, installed)
    >=dev-libs/openssl-1.0.1h-r2:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=dev-libs/openssl-1.0.1h-r2:0[abi_x86_64(-)]) required by (sys-auth/nss_ldap-265-r5:0/0::gentoo, installed)
    dev-libs/openssl:0= required by (dev-lang/php-7.1.26:7.1/7.1::gentoo, ebuild scheduled for merge)
    dev-libs/openssl:0 required by (app-portage/conf-update-1.0.3-r1:0/0::gentoo, installed)
    dev-libs/openssl:0=[-bindist(-)] required by (dev-python/m2crypto-0.31.0:0/0::gentoo, installed)
    >=dev-libs/openssl-1.0.1h-r2:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=dev-libs/openssl-1.0.1h-r2:0=[abi_x86_64(-)]) required by (net-libs/libssh2-1.8.0-r2:0/0::gentoo, installed)
    dev-libs/openssl:0/0= required by (net-misc/dhcp-4.4.1:0/0::gentoo, installed)
    <dev-libs/openssl-1.1:0= required by (dev-lang/ruby-2.3.8-r1:2.3/2.3::gentoo, installed)
    dev-libs/openssl:0/0= required by (dev-lang/ruby-2.4.5-r1:2.4/2.4::gentoo, installed)
    <dev-libs/openssl-1.1.0:0[bindist=] (<dev-libs/openssl-1.1.0:0[-bindist]) required by (net-misc/openssh-7.9_p1-r2:0/0::gentoo, ebuild scheduled for merge)
    >=dev-libs/openssl-1.0.1h-r2:0/0=[abi_x86_64(-)] required by (net-libs/libssh2-1.8.0-r2:0/0::gentoo, installed)
    dev-libs/openssl:0=[static-libs?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (dev-libs/openssl:0=[abi_x86_64(-)]) required by (net-misc/curl-7.63.0-r1:0/0::gentoo, installed)
    dev-libs/openssl:0/0= required by (net-misc/ntp-4.2.8_p12:0/0::gentoo, installed)
    dev-libs/openssl:0/0= required by (dev-lang/ruby-2.5.3:2.5/2.5::gentoo, installed)
    dev-libs/openssl:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (dev-libs/openssl:0=[abi_x86_64(-)]) required by (app-crypt/rhash-1.3.7:0/0::gentoo, ebuild scheduled for merge)
    dev-libs/openssl:0= required by (dev-perl/Crypt-OpenSSL-Bignum-0.90.0:0/0::gentoo, installed)
    dev-libs/openssl:0/0= required by (net-libs/c-client-2007f-r6:0/0::gentoo, installed)
    dev-libs/openssl:0= required by (net-mail/courier-imap-4.18.2:0/0::gentoo, installed)
    >=dev-libs/openssl-0.9.6m:0= required by (net-analyzer/tcpdump-4.9.2:0/0::gentoo, installed)
    dev-libs/openssl:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (dev-libs/openssl:0=[abi_x86_64(-)]) required by (net-libs/neon-0.30.2:0/27::gentoo, installed)
    dev-libs/openssl:0/0= required by (dev-vcs/git-2.20.1:0/0::gentoo, installed)
    dev-libs/openssl:0= required by (dev-lang/python-3.7.0:3.7/3.7m::gentoo, installed)
    dev-libs/openssl:0/0= required by (www-client/lynx-2.8.9_p1:0/0::gentoo, installed)
    >=dev-libs/openssl-1.0.1e:0=[-bindist,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=dev-libs/openssl-1.0.1e:0=[-bindist,abi_x86_64(-)]) required by (net-libs/ldns-1.7.0-r2:0/0::gentoo, installed)
    dev-libs/openssl:0/0= required by (media-sound/pulseaudio-12.2:0/0::gentoo, installed)
    dev-libs/openssl:0= required by (dev-lang/php-7.2.14:7.2/7.2::gentoo, ebuild scheduled for merge)
    dev-libs/openssl:0= required by (net-misc/mosh-1.3.2:0/0::gentoo, installed)
    =dev-libs/openssl-1.0.2*:0=[-bindist] required by (net-libs/nodejs-8.15.0:0/0::gentoo, ebuild scheduled for merge)
    dev-libs/openssl:0= required by (dev-lang/php-5.6.40:5.6/5.6::gentoo, ebuild scheduled for merge)
    dev-libs/openssl:0/0= required by (net-mail/courier-imap-4.18.2:0/0::gentoo, installed)
    dev-libs/openssl:0= required by (net-dns/bind-tools-9.12.3_p1:0/0::gentoo, ebuild scheduled for merge)
    dev-libs/openssl:0/0=[abi_x86_64(-)] required by (app-arch/libarchive-3.3.3:0/13::gentoo, installed)
    dev-libs/openssl:0= required by (net-misc/ntp-4.2.8_p12:0/0::gentoo, installed)
    dev-libs/openssl:0/0= required by (net-ftp/proftpd-1.3.6-r2:0/0::gentoo, installed)
    >=dev-libs/openssl-1.0.1e:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=dev-libs/openssl-1.0.1e:0=[abi_x86_64(-)]) required by (net-libs/ldns-1.7.0-r2:0/0::gentoo, installed)
    dev-libs/openssl:0/0= required by (dev-python/cryptography-2.4.2:0/0::gentoo, installed)
    dev-libs/openssl:0/0= required by (app-admin/syslog-ng-3.19.1:0/0::gentoo, installed)
    >=dev-libs/openssl-1.0.1h-r2:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=dev-libs/openssl-1.0.1h-r2:0=[abi_x86_64(-)]) required by (media-video/ffmpeg-4.0.3:0/56.58.58::gentoo, installed)
    dev-libs/openssl:0= required by (dev-lang/python-2.7.15:2.7/2.7::gentoo, installed)
    dev-libs/openssl:0= required by (dev-lang/rust-1.32.0:stable/1.32::gentoo, ebuild scheduled for merge)
    dev-libs/openssl:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (dev-libs/openssl:0=[abi_x86_64(-)]) required by (dev-db/mysql-connector-c-6.1.11-r1:0/18::gentoo, installed)
    dev-libs/openssl:0= required by (net-misc/dhcp-4.4.1:0/0::gentoo, installed)
    dev-libs/openssl:0= required by (net-misc/iputils-20180629:0/0::gentoo, installed)
    dev-libs/openssl:0/0= required by (x11-base/xorg-server-1.20.3:0/1.20.3::gentoo, installed)
    dev-libs/openssl:0/0= required by (net-libs/serf-1.3.9:1/1::gentoo, installed)
    dev-libs/openssl:0/0= required by (dev-lang/python-3.7.0:3.7/3.7m::gentoo, installed)
    dev-libs/openssl:0/0= required by (net-nntp/inn-2.5.5-r1:0/0::gentoo, installed)
    dev-libs/openssl:0= required by (app-admin/syslog-ng-3.19.1:0/0::gentoo, installed)
    dev-libs/openssl:0= required by (app-text/podofo-0.9.6_p20180715:0/0.9.6::mv, installed)
    dev-libs/openssl:0=[-bindist(-)] required by (media-video/makemkv-1.14.2:0/0::gentoo, installed)
    dev-libs/openssl:0/0= required by (app-text/podofo-0.9.6_p20180715:0/0.9.6::mv, installed)
    dev-libs/openssl:0/0= required by (net-misc/iputils-20180629:0/0::gentoo, installed)
    dev-libs/openssl:0= required by (net-misc/wget-1.20.1:0/0::gentoo, ebuild scheduled for merge)
    dev-libs/openssl:0= required by (net-libs/libtorrent-0.13.7-r1:0/0::gentoo, installed)
    dev-libs/openssl:0/0=[abi_x86_64(-)] required by (net-misc/curl-7.63.0-r1:0/0::gentoo, installed)
    dev-libs/openssl:0= required by (net-wireless/crda-3.18-r2:0/0::gentoo, installed)
    dev-libs/openssl:0= required by (app-admin/apache-tools-2.4.38:0/0::gentoo, ebuild scheduled for merge)
    dev-libs/openssl:0/0=[abi_x86_64(-)] required by (net-libs/neon-0.30.2:0/27::gentoo, installed)
    >=dev-libs/openssl-1.0.1h-r2:0/0=[abi_x86_64(-)] required by (media-video/ffmpeg-4.0.3:0/56.58.58::gentoo, installed)
    dev-libs/openssl:0= required by (x11-base/xorg-server-1.20.3:0/1.20.3::gentoo, installed)
    dev-libs/openssl:0/0= required by (media-libs/libshout-2.4.1-r2:0/0::gentoo, installed)
    dev-libs/openssl:0/0= required by (www-client/elinks-0.13_pre_pre20180225:0/0::gentoo, installed)
    >=dev-libs/openssl-1.0.2:0=[-bindist,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=dev-libs/openssl-1.0.2:0=[-bindist,abi_x86_64(-)]) required by (net-libs/nghttp2-1.36.0:0/1.14::gentoo, ebuild scheduled for merge)
    dev-libs/openssl:0/0= required by (net-libs/libtorrent-0.13.7-r1:0/0::gentoo, installed)
    dev-libs/openssl:0[-bindist] required by (net-dns/bind-9.12.3_p1:0/0::gentoo, ebuild scheduled for merge)
    dev-libs/openssl:0= required by (net-misc/openssh-7.9_p1-r2:0/0::gentoo, ebuild scheduled for merge)
    dev-libs/openssl:0 required by (net-nds/openldap-2.4.45:0/0::gentoo, installed)
    >=dev-libs/openssl-1.0.2:0= required by (www-servers/apache-2.4.38:2/2::gentoo, ebuild scheduled for merge)
    dev-libs/openssl:0= required by (dev-perl/Net-SSLeay-1.850.0:0/0::gentoo, ebuild scheduled for merge)
    dev-libs/openssl:0= required by (www-client/elinks-0.13_pre_pre20180225:0/0::gentoo, installed)
    dev-libs/openssl:0= required by (dev-lang/python-3.5.5-r1:3.5/3.5m::gentoo, installed)
    dev-libs/openssl:0 required by (www-servers/apache-2.4.38:2/2::gentoo, ebuild scheduled for merge)
    dev-libs/openssl:0=[static-libs?] (dev-libs/openssl:0=) required by (app-text/mupdf-1.14.0-r2:0/1.14.0::gentoo, installed)
    dev-libs/openssl:0= required by (dev-lang/ruby-2.4.5-r1:2.4/2.4::gentoo, installed)
    dev-libs/openssl:0/0= required by (net-analyzer/nmap-7.70:0/0::gentoo, installed)
    dev-libs/openssl:0= required by (www-client/lynx-2.8.9_p1:0/0::gentoo, installed)
    dev-libs/openssl:0= required by (net-libs/serf-1.3.9:1/1::gentoo, installed)
    dev-libs/openssl:0= required by (net-libs/courier-authlib-0.69.0-r1:0/0::gentoo, ebuild scheduled for merge)
    dev-libs/openssl:0/0= required by (mail-filter/spamassassin-3.4.2-r3:0/0::gentoo, installed)
    dev-libs/openssl:0/0=[-bindist(-)] required by (media-video/makemkv-1.14.2:0/0::gentoo, installed)
    dev-libs/openssl:0= required by (dev-vcs/git-2.20.1:0/0::gentoo, installed)
    >=dev-libs/openssl-1.0.1h-r2:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=dev-libs/openssl-1.0.1h-r2:0=[abi_x86_64(-)]) required by (dev-libs/libevent-2.1.8:0/2.1-6::gentoo, installed)
    dev-libs/openssl:0= required by (mail-mta/sendmail-8.14.9-r1:0/0::gentoo, installed)
    dev-libs/openssl:0 required by (net-nntp/inn-2.5.5-r1:0/0::gentoo, installed)
    dev-libs/openssl:0/0= required by (app-text/mupdf-1.14.0-r2:0/1.14.0::gentoo, installed)
    dev-libs/openssl:0/0= required by (dev-lang/python-3.5.5-r1:3.5/3.5m::gentoo, installed)
    dev-libs/openssl:0= required by (sys-block/mbuffer-20181119:0/0::gentoo, installed)
    >=dev-libs/openssl-1.0.1h-r2:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=dev-libs/openssl-1.0.1h-r2:0=[abi_x86_64(-)]) required by (dev-libs/cyrus-sasl-2.1.27-r1:2/2::gentoo, ebuild scheduled for merge)
    >=dev-libs/openssl-1.0.1h-r2:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=dev-libs/openssl-1.0.1h-r2:0=[abi_x86_64(-)]) required by (app-crypt/mit-krb5-1.16.3:0/0::gentoo, ebuild scheduled for merge)
    dev-libs/openssl:0/0=[-bindist(-)] required by (dev-python/m2crypto-0.31.0:0/0::gentoo, installed)
    >=dev-libs/openssl-1.0.1:0= required by (dev-lang/php-7.3.1:7.3/7.3::gentoo, ebuild scheduled for merge)
    dev-libs/openssl:0[-bindist(-)] required by (dev-python/cryptography-2.4.2:0/0::gentoo, installed)
    >=dev-libs/openssl-0.9.6-r1:0/0= required by (dev-db/postgresql-11.1:11/11::gentoo, installed)
    dev-libs/openssl:0/0= required by (dev-lang/python-2.7.15:2.7/2.7::gentoo, installed)
    dev-libs/openssl:0= required by (net-dialup/ppp-2.4.7-r7:0/2.4.7::gentoo, installed)
    dev-libs/openssl:0= required by (dev-lang/ruby-2.5.3:2.5/2.5::gentoo, installed)
    dev-libs/openssl:0/0=[abi_x86_64(-)] required by (dev-db/mysql-connector-c-6.1.11-r1:0/18::gentoo, installed)
    dev-libs/openssl:0/0= required by (net-dialup/ppp-2.4.7-r7:0/2.4.7::gentoo, installed)
    >=dev-libs/openssl-0.9.6-r1:0= required by (dev-db/postgresql-11.1:11/11::gentoo, installed)
    dev-libs/openssl:0/0= required by (sys-block/mbuffer-20181119:0/0::gentoo, installed)
    dev-libs/openssl:0=[bindist=] (dev-libs/openssl:0=[-bindist]) required by (dev-qt/qtnetwork-5.11.3:5/5.11::gentoo, installed)
    dev-libs/openssl:0= required by (net-ftp/proftpd-1.3.6-r2:0/0::gentoo, installed)
    >=dev-libs/openssl-1.0.2k:0=[bindist=] (>=dev-libs/openssl-1.0.2k:0=[-bindist]) required by (net-wireless/wpa_supplicant-2.7-r1:0/0::gentoo, ebuild scheduled for merge)
    dev-libs/openssl:0= required by (dev-python/cryptography-2.4.2:0/0::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


Script done on 2019-01-29 10:51:16-05:00 [COMMAND_EXIT_CODE="1"]

--
Your life is like a penny.  You're going to lose it.  The question is:
How do
you spend it?

         John Covici wb2una
         [hidden email]