perl-5.18 required…

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

perl-5.18 required…

Alex Efros-4
Hi!

I prefer to use latest CPAN modules, so I've in /etc/portage/package.keywords:

    perl-core/*
    dev-perl/*
    virtual/perl-*

This works fine until today, when I notice several ~arch packages require
perl-5.18 (which I didn't plan to install until it will be marked stable
in portage, and which can't be installed anyway because of several
conflicts). To fix this I've to add into /etc/portage/package.mask:

    # require perl-5.18
    =virtual/perl-ExtUtils-CBuilder-0.280.210
    =virtual/perl-ExtUtils-ParseXS-3.220.0
    =virtual/perl-IO-1.280.0
    =virtual/perl-Perl-OSType-1.3.0
    =virtual/perl-CPAN-2.0.0

Maybe it makes more sense to hardmask such packages in portage, at least
until perl-5.18 will be ready to install without conflicts on ~arch?

--
                        WBR, Alex.

Reply | Threaded
Open this post in threaded view
|

Re: [gentoo-perl] perl-5.18 required…

Kent Fredric

On 6 September 2013 12:11, Alex Efros <[hidden email]> wrote:

    # require perl-5.18
    =virtual/perl-ExtUtils-CBuilder-0.280.210
    =virtual/perl-ExtUtils-ParseXS-3.220.0
    =virtual/perl-IO-1.280.0
    =virtual/perl-Perl-OSType-1.3.0
    =virtual/perl-CPAN-2.0.0


At least in ::gentoo, nothing should be presently pulling in 5.18 in arch~ , and everything that does get pulled in should be filed as a bug, because if its not filed as a bug and fixed now, it will possibly become become a bigger problem when 5.16 becomes the new "arch"/ stable.

Sometimes virtuals get confused and pull in versions of perl instead of pulling in perl-core/* , but this is not one of those times I think.

In the cases above, the problem seems because somebody didn't add perl-core/* to tree when they added virtual/perl-* to tree, and any instance you hit of this, where it is indeed the case that those versions are avialable from CPAN, the corresponding perl-core/* should be in tree.

ie:

   || ( =dev-lang/perl-5.18* ~perl-core/CPAN-${PV} )

If the denormalised version of $PV on exists on CPAN and perl-core/WHATEVER-$PV does not exist, thats a bug, and the respective package should be added to tree.

If the denormalised version does NOT exist on CPAN, then thats a bug , and the virtual/ that implies 5.18 unconditionally in such a case should be bugged as something that should be in the 5.18 mask.



--
Kent

perl -e  "print substr( \"edrgmaM  SPA NOcomil.ic\\@tfrken\", \$_ * 3, 3 ) for ( 9,8,0,7,1,6,5,4,3,2 );"