ruby-sdl 1.8/1.9 Bug

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

ruby-sdl 1.8/1.9 Bug

knasan
Hallo Liste,

ich verwende Funtoo und bin eben auf ein Bug gestoßen.
Im Package dev-ruby/ruby-sdl fehlt die Zuordnung für Ruby 1.9, in meinem
Lokalen Overlay hab ich das gefixt und getestet. Es funktioniert ohne
Probleme mit Ruby1.9.

Jetzt weiß nicht, wohin mit dieser Bugmeldung?!
Hab mir das ebuild unter packages.gentoo.org angesehen und dort ist der
Bug auch vorhanden, deswegen gehe ich davon aus, dass dies ein gentoo
bug ist.

Der Bug ist schnell behoben, im Ebuild muss lediglich die Variable
USE_RUBY um ruby19 erweitert werden.
Im Message Text steht noch dev-ruby/rubysdl was jetzt aber
dev-ruby/ruby-sdl heißt. Dies habe ich auch in mein Ebuild gefixt.

Ich veröffentliche meine Ebuilds zwar online auf Github, aber würde
gerne diesen Bug global gefixt sehen, also wohin mit dem Bug oder Ebuild?

Gruß
Sandy

Reply | Threaded
Open this post in threaded view
|

Re: ruby-sdl 1.8/1.9 Bug

Randolph Maaßen
Am 10. März 2013 09:19 schrieb Sandy Marko Knauer <[hidden email]>:
Hallo Liste,

ich verwende Funtoo und bin eben auf ein Bug gestoßen.
Im Package dev-ruby/ruby-sdl fehlt die Zuordnung für Ruby 1.9, in meinem Lokalen Overlay hab ich das gefixt und getestet. Es funktioniert ohne Probleme mit Ruby1.9.

Jetzt weiß nicht, wohin mit dieser Bugmeldung?!
Hab mir das ebuild unter packages.gentoo.org angesehen und dort ist der Bug auch vorhanden, deswegen gehe ich davon aus, dass dies ein gentoo bug ist.

Der Bug ist schnell behoben, im Ebuild muss lediglich die Variable USE_RUBY um ruby19 erweitert werden.
Im Message Text steht noch dev-ruby/rubysdl was jetzt aber dev-ruby/ruby-sdl heißt. Dies habe ich auch in mein Ebuild gefixt.

Ich veröffentliche meine Ebuilds zwar online auf Github, aber würde gerne diesen Bug global gefixt sehen, also wohin mit dem Bug oder Ebuild?

Gruß
Sandy


HI,

Für alle Fehler in Gentoo:
bugs.gentoo.org

--
Mit freundlichen Grüßen / Best regards
 
Randolph Maaßen

Reply | Threaded
Open this post in threaded view
|

Re: ruby-sdl 1.8/1.9 Bug

knasan
On 03/10/2013 10:02 AM, Randolph Maaßen wrote:

> Am 10. März 2013 09:19 schrieb Sandy Marko Knauer
> <[hidden email] <mailto:[hidden email]>>:
>
>     Hallo Liste,
>
>     ich verwende Funtoo und bin eben auf ein Bug gestoßen.
>     Im Package dev-ruby/ruby-sdl fehlt die Zuordnung für Ruby 1.9, in
>     meinem Lokalen Overlay hab ich das gefixt und getestet. Es
>     funktioniert ohne Probleme mit Ruby1.9.
>
>     Jetzt weiß nicht, wohin mit dieser Bugmeldung?!
>     Hab mir das ebuild unter packages.gentoo.org
>     <http://packages.gentoo.org> angesehen und dort ist der Bug auch
>     vorhanden, deswegen gehe ich davon aus, dass dies ein gentoo bug ist.
>
>     Der Bug ist schnell behoben, im Ebuild muss lediglich die Variable
>     USE_RUBY um ruby19 erweitert werden.
>     Im Message Text steht noch dev-ruby/rubysdl was jetzt aber
>     dev-ruby/ruby-sdl heißt. Dies habe ich auch in mein Ebuild gefixt.
>
>     Ich veröffentliche meine Ebuilds zwar online auf Github, aber
>     würde gerne diesen Bug global gefixt sehen, also wohin mit dem Bug
>     oder Ebuild?
>
>     Gruß
>     Sandy
>
>
> HI,
>
> Für alle Fehler in Gentoo:
> bugs.gentoo.org <http://bugs.gentoo.org>
>
> --
> Mit freundlichen Grüßen / Best regards
> Randolph Maaßen
>
Hi,

im Wiki von funtoo steht.
http://www.funtoo.org/wiki/Reporting_Bugs

"If you feel it is necessary to file a bug with Gentoo, please inform
the Funtoo core team that you are doing so, indicate that you are using
Funtoo Linux in the bug report, also mention the troubleshooting steps
you have performed so far (on Funtoo infrastructure), and add
[hidden email] to the CC field on your bug report so that I can
personally track the status of these bug reports and get involved as
necessary."

Deswegen habe ich mich erst mal eine Email an die Funtoo User Google
Group geschrieben.

Gruß
Sandy