speakup won't compile with kernel 3.1.1 and 2.6.36 isn't available.

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

speakup won't compile with kernel 3.1.1 and 2.6.36 isn't available.

Shane Davidson

Hello all;

I’ve been a Gentoo user for awhile, and installed  a knew VM, using the latest available kernel, 3.1.1.

When speakup attempts to install I get

* ERROR: app-accessibility/speakup-3.1.6_p201011120508 failed (setup phase):

Great, ok, so I further look into it, looks like it wants kernel 2.6.36.

This is no longer available, attempt to compile anything less then 2.6.36 I’m told it requires 2.6.36 kernel.

Also, speakup hasn’t been updated since around this time last year.

So, thoughts, ideas, suggestions for getting this fixed?

Thanks for any assistance.

Shane

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: speakup won't compile with kernel 3.1.1 and 2.6.36 isn't available.

William Hubbs
Hi Shane,

On Tue, Nov 29, 2011 at 08:28:09PM -0500, Shane Davidson wrote:
> I've been a Gentoo user for awhile, and installed  a knew VM, using the
> latest available kernel, 3.1.1.
>
> When speakup attempts to install I get
>
> * ERROR: app-accessibility/speakup-3.1.6_p201011120508 failed (setup phase):

This is because speakup is in the staging drivers in the kernel source
for newer kernels.

You should run make menuconfig, then go to device drivers, staging
drivers, then you will find speakup there.

Let me know if you need any more assistance.

Thanks,

William

attachment0 (205 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: speakup won't compile with kernel 3.1.1 and 2.6.36 isn't available.

Shane Davidson
Hello;
So it's gonna require a recompile of the kernel. This is gonna be fun.
I'll send Gentoo-user a message noting the resolution of the matter.
Thanks for the help.
Shane
-----Original Message-----
From: William Hubbs [mailto:[hidden email]] On Behalf Of William Hubbs
Sent: Tuesday, November 29, 2011 9:29 PM
To: [hidden email]
Subject: Re: [gentoo-accessibility] speakup won't compile with kernel 3.1.1
and 2.6.36 isn't available.

Hi Shane,

On Tue, Nov 29, 2011 at 08:28:09PM -0500, Shane Davidson wrote:
> I've been a Gentoo user for awhile, and installed  a knew VM, using
> the latest available kernel, 3.1.1.
>
> When speakup attempts to install I get
>
> * ERROR: app-accessibility/speakup-3.1.6_p201011120508 failed (setup
phase):

This is because speakup is in the staging drivers in the kernel source for
newer kernels.

You should run make menuconfig, then go to device drivers, staging drivers,
then you will find speakup there.

Let me know if you need any more assistance.

Thanks,

William


Loading...