stav xkeyboard-config

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

stav xkeyboard-config

Pavel Dobes
Zdravim,

ze otravuji s topicem 3/4 roku starym, ale kdyz jsem preinstaloval gentoo, zase mi nefungovala kavesnice a tak jsem si ho v historii vyhledal.

Upgradoval jsem z 0.9 na 1.1 a kdyz zadam:

$ setxkbmap cz -variant qwerty

dostanu

Error loading new keyboard description

Stejne se to chova i pri pouhem

$ setxkbmap cz

Jak se divam do bugzilly, tak to je ale jiny bug. Bohuzel jsem pred jejim prohledanim uz presel na xkbdata z overlaye, ktery funguje bez problemu... Takze nevim, jestli to je ve verzi 1.1 jiz opravene.

Samostatny bug hlasici problem s ceskou klavesnici jsem tam nenasel. Nevim ale jak ho nahlasit, prtoze jsem nepochopil pricinu chovani a muzu pouze suse konstatovat, ze nefunguje to a to (ale to asi stacit nebude) :-/

PaD
--
[hidden email] mailing list

Reply | Threaded
Open this post in threaded view
|

Re: stav xkeyboard-config

Honza Macháček
Pavel Dobes píše:

> Upgradoval jsem z 0.9 na 1.1 a kdyz zadam:
>
> $ setxkbmap cz -variant qwerty
>
> dostanu
>
> Error loading new keyboard description
>
> Stejne se to chova i pri pouhem
>
> $ setxkbmap cz

  V tom bude něco hlubšího, takové problémy jsem u sebe nepozoroval.
  Jenom přepínání virtuálních terminálů mi nefungovalo -- a starý patch
od lidí z Debianu na novou verzi nezabíral. Naštěstí pomohlo, když jsem
se jím dal inspirovat, porovnal jsem data verzí 0.8 a 1.1 a našel jedno
podezřelé místo, kde se v 1.1 narozdíl od 0.8 zacházelo s LALT způsobem,
jaký starý patch odstraňoval pro RALT. Zkusil jsem to opravit ve stylu
onoho patche a zabralo to -- právě jsem to dal na bugzillu na
https://bugs.gentoo.org/show_bug.cgi?id=157837
  Držím palce, jestli to samo o sobě nezabere.
                                                Honza Macháček
--
[hidden email] mailing list

Reply | Threaded
Open this post in threaded view
|

Re: stav xkeyboard-config

Pavel Dobes
On Sun, 07 Oct 2007 20:19:19 +0200
Honza Macháček <[hidden email]> wrote:

> Pavel Dobes píše:
>
> > Upgradoval jsem z 0.9 na 1.1 a kdyz zadam:
> >
> > $ setxkbmap cz -variant qwerty
> >
> > dostanu
> >
> > Error loading new keyboard description
> >
> > Stejne se to chova i pri pouhem
> >
> > $ setxkbmap cz
>
>   V tom bude něco hlubšího, takové problémy jsem u sebe nepozoroval.
>   Jenom přepínání virtuálních terminálů mi nefungovalo -- a starý patch
> od lidí z Debianu na novou verzi nezabíral. Naštěstí pomohlo, když jsem
> se jím dal inspirovat, porovnal jsem data verzí 0.8 a 1.1 a našel jedno
> podezřelé místo, kde se v 1.1 narozdíl od 0.8 zacházelo s LALT způsobem,
> jaký starý patch odstraňoval pro RALT. Zkusil jsem to opravit ve stylu
> onoho patche a zabralo to -- právě jsem to dal na bugzillu na
> https://bugs.gentoo.org/show_bug.cgi?id=157837
>   Držím palce, jestli to samo o sobě nezabere.

Diky vyzkousim, ale asi az o dalsim vikendu. Do te doby jsem rad, ze mi xkbdata funguje.

PaD
--
[hidden email] mailing list