systemd and virtual/udev

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

systemd and virtual/udev

João Matos-2
Dear list,

Shouldn't systemd fulfill virtual/udev?

I'm getting this problem when I try to update my system:

(sys-apps/systemd-206-r3::gentoo, ebuild scheduled for merge) pulled in by
    sys-apps/systemd required by (sys-apps/dbus-1.6.12::gentoo, installed)
    >=sys-apps/systemd-44-r1[pam] required by (sys-auth/pambase-20120417-r2::gentoo, ebuild scheduled for merge)
    sys-apps/systemd required by @selected
    >=sys-apps/systemd-39 required by (media-sound/pulseaudio-4.0::gentoo, installed)
    sys-apps/systemd required by (sys-auth/polkit-0.111-r1::gentoo, ebuild scheduled for merge)
    sys-apps/systemd required by (kde-base/kdm-4.11.0-r1::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-200 required by (sys-power/upower-0.9.21::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-197 required by (sys-fs/udisks-2.1.0::gentoo, ebuild scheduled for merge)

  (sys-fs/udev-206-r3::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/udev-206-r2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_x86_32(-)?,abi_x86_64(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,gudev?,introspection?,kmod?,selinux?,static-libs?] (>=sys-fs/udev-206-r2[abi_x86_64(-),abi_x86_64(-),gudev,introspection,kmod,static-libs]) required by (virtual/udev-206-r2::gentoo, ebuild scheduled for merge)


If I mask sys-fs/udev and eudev the problem persists: can't update the system bcz there is no ebuild to satisfy sys-fs\udev. Is there any recent change that I'm not aware? Did some of you had this problem?

Thank you,


attachment0 (7K) Download Attachment