upgrade to openblas 0.2.20 issues

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

upgrade to openblas 0.2.20 issues

François Bissey-4
Hi all,

A word about the update to openblas 0.2.20 that finally hit the
overlay (thanks to Benda in particular for making the final push).

There have been subtle changes included in this release. Some functions
that were provided by openblas have been removed because they are part
of lapack 3.7.0. I didn’t notice this before this morning.

If you encounter missing symbols for csymv_ or zsymv_ that’s the reason.
What to do?
1) rebuilding lapack-reference first is probably a good idea.
2) just rebuild the affected package and the linking will sort itself out.
For sage-on-gentoo users that means rebuilding cvxopt.
If rebuilding the package doesn’t solve the issue it probably means it doesn’t
link to lapack when it should. In that case report the issue in bugzilla.

Cheers,
François