version of portaudio conflicts with itsself?

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

version of portaudio conflicts with itsself?

tuxic
Hi,

I see this or similiar from time to time:

media-libs/portaudio:0

  (media-libs/portaudio-19.06.00-r2:0/0::gentoo, ebuild scheduled for merge) conflicts with
    <media-libs/portaudio-19.06.00-r2 required by (media-sound/audacity-2.2.2:0/0::gentoo, installed)

looks to me, like portaudion conflicts with itsself.

How can I avoid this in the future?

Cheers!
Meino



Reply | Threaded
Open this post in threaded view
|

Re: version of portaudio conflicts with itsself?

Arve Barsnes
On Sat, 6 Jul 2019 at 01:46, <[hidden email]> wrote:
> I see this or similiar from time to time:
>
> media-libs/portaudio:0
>
>   (media-libs/portaudio-19.06.00-r2:0/0::gentoo, ebuild scheduled for merge) conflicts with
>     <media-libs/portaudio-19.06.00-r2 required by (media-sound/audacity-2.2.2:0/0::gentoo, installed)
>
> looks to me, like portaudion conflicts with itsself.

You're missing the little < sign there.

Portage would like to install portaudio-19.06.00-r2, but audacity
requires a version lower than that. I have the same output on my box,
waiting for an audacity release I guess.

Regards,
Arve

Reply | Threaded
Open this post in threaded view
|

Re: version of portaudio conflicts with itsself?

Andrew Udvare
On 05/07/2019 22:05, Arve Barsnes wrote:
> Portage would like to install portaudio-19.06.00-r2, but audacity
> requires a version lower than that. I have the same output on my box,
> waiting for an audacity release I guess.

I have similar output especially with packages that are slotted like
wine-mono:

[U] app-emulation/wine-mono
     Available versions:
     (4.6.4) 4.6.4
     (4.7.0) (~)4.7.0
     (4.7.1) 4.7.1
     (4.7.3) (~)4.7.3
     (4.7.5) 4.7.5
     (4.8.0) (~)4.8.0
     (4.8.1) (~)4.8.1
     (4.8.3) (~)4.8.3
     (4.9.0) (~)4.9.0

                   Installed versions:  4.7.5(4.7.5)(13:55:46 28/01/19)

                                 Homepage:
https://www.winehq.org/
     Description:         Wine Mono is a replacement for the .NET
runtime and class libraries in Wine


If I run an upgrade this never gets updated. My assumption is that the
Wine ebuild is not requiring >wine-mono:4.7.5.


signature.asc (849 bytes) Download Attachment