virtual/udev problem with emerge

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

virtual/udev problem with emerge

Gmail

Hi, i'm using systemd without virtual/udev installed, but when i try
to update system an error message blocks emerge:

emerge: there are no ebuilds built with USE flags to satisfy
">=virtual/udev-208[gudev]".
!!! One of the following packages is required to complete your request:
- virtual/udev-215::gentoo (Missing IUSE: gudev)
(dependency required by "sys-fs/udisks-2.1.3::gentoo" [installed])
(dependency required by "gnome-base/gvfs-1.22.3::gentoo[udisks]"
[installed])
(dependency required by "media-sound/sound-juicer-3.14.0::gentoo"
[ebuild])
(dependency required by
"gnome-base/gnome-extra-apps-3.14.0-r1::gentoo" [ebuild])
(dependency required by "gnome-base/gnome-3.12.0::gentoo" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

Reply | Threaded
Open this post in threaded view
|

Re: virtual/udev problem with emerge

Duncan-42
Gmail posted on Wed, 10 Jun 2015 18:23:23 +0200 as excerpted:

> Hi, i'm using systemd without virtual/udev installed, but when i try to
> update system an error message blocks emerge:
>
> emerge: there are no ebuilds built with USE flags to satisfy
> ">=virtual/udev-208[gudev]".
> !!! One of the following packages is required to complete your request:
> - virtual/udev-215::gentoo (Missing IUSE: gudev)
> (dependency required by "sys-fs/udisks-2.1.3::gentoo" [installed])
> (dependency required by [... ultimately gnome, in @world]

See this entry in the virtual/udev changelog:

*udev-215 (29 Jul 2014)

  29 Jul 2014; Samuli Suominen <[hidden email]> +udev-215.ebuild:
  New virtual version wrt #518416 for package managers with no proper
  in-place dependency handling.


If you visit that bug, you'll see a rather similar error message.  The
technical problem is static vs. dynamic deps, tho that's a rather longer
and hairier debate than you're likely to be interested in.  (See the
gentoo-dev list from about that period or shortly thereafter if you /are/
interested in the hairy details.)

The fix, short version, is that your version of udisks is outdated.  
2.1.3 isn't in the tree any longer, it's now 2.1.4, and 2.1.4 doesn't
have the dep on virtual/udev[gudev], as it has been replaced with a
straight virtual/udev dep, plus a virtual/libgudev:= (subslot-based) dep.

So update udisks.  Note that you may have to install both the udev and
libgudev virtuals (and possibly some other packages) at the same time as
you update udisks, in ordered to have all the deps satified at the same
time, since otherwise the older version of some package or another might
block updating the one's you're trying to update together.

If you use emerge's --deep option when you use --update (particularly if
used with --newuse), it tends to catch and automatically handle many but
not all of these situations.  Sometimes you have to manually remerge
another package that does /not/ have an update waiting, at the same time.

Of course that's just solving the problem for udisks.  It's possible that
once you have it set to upgrade at the same time, you'll run into the
same problem with another package, and will have to add it as well.  
That's the reason for the "and possibly some other packages"
parenthetical above.

--
Duncan - List replies preferred.   No HTML msgs.
"Every nonfree program has a lord, a master --
and if you use the program, he is your master."  Richard Stallman